Update to 6.1.2
This commit is contained in:
parent
69d06fe675
commit
2612e2ec91
@ -1,99 +0,0 @@
|
||||
From: Jan Ekström <jeebjp@gmail.com>
|
||||
Date: Wed, 14 Feb 2024 20:40:54 +0000 (+0200)
|
||||
Subject: {avcodec,tests}: rename the bundled Mesa AV1 vulkan video headers
|
||||
X-Git-Url: http://git.ffmpeg.org/gitweb/ffmpeg.git/commitdiff_plain/fef22c87ada4517441701e6e61e062c9f4399c8e
|
||||
|
||||
{avcodec,tests}: rename the bundled Mesa AV1 vulkan video headers
|
||||
|
||||
This together with adjusting the inclusion define allows for the
|
||||
build to not fail with latest Vulkan-Headers that contain the
|
||||
stabilized Vulkan AV1 decoding definitions.
|
||||
|
||||
Compilation fails currently as the AV1 header is getting included
|
||||
via hwcontext_vulkan.h -> <vulkan/vulkan.h> -> vulkan_core.h, which
|
||||
finally includes vk_video/vulkan_video_codec_av1std.h and the decode
|
||||
header, leading to the bundled header to never defining anything
|
||||
due to the inclusion define being the same.
|
||||
|
||||
This fix is imperfect, as it leads to additional re-definition
|
||||
warnings for things such as
|
||||
VK_STD_VULKAN_VIDEO_CODEC_AV1_DECODE_SPEC_VERSION. , but it is
|
||||
not clear how to otherwise have the bundled version trump the
|
||||
actually standardized one for a short-term compilation fix.
|
||||
|
||||
(cherry picked from commit e06ce6d2b45edac4a2df04f304e18d4727417d24)
|
||||
---
|
||||
|
||||
diff --git a/libavcodec/Makefile b/libavcodec/Makefile
|
||||
index ec57e53e30..eb25707ef5 100644
|
||||
--- a/libavcodec/Makefile
|
||||
+++ b/libavcodec/Makefile
|
||||
@@ -1284,7 +1284,7 @@ SKIPHEADERS += %_tablegen.h \
|
||||
aacenc_quantization.h \
|
||||
aacenc_quantization_misc.h \
|
||||
bitstream_template.h \
|
||||
- vulkan_video_codec_av1std.h \
|
||||
+ vulkan_video_codec_av1std_mesa.h \
|
||||
$(ARCH)/vpx_arith.h \
|
||||
|
||||
SKIPHEADERS-$(CONFIG_AMF) += amfenc.h
|
||||
@@ -1306,7 +1306,7 @@ SKIPHEADERS-$(CONFIG_XVMC) += xvmc.h
|
||||
SKIPHEADERS-$(CONFIG_VAAPI) += vaapi_decode.h vaapi_hevc.h vaapi_encode.h
|
||||
SKIPHEADERS-$(CONFIG_VDPAU) += vdpau.h vdpau_internal.h
|
||||
SKIPHEADERS-$(CONFIG_VIDEOTOOLBOX) += videotoolbox.h vt_internal.h
|
||||
-SKIPHEADERS-$(CONFIG_VULKAN) += vulkan.h vulkan_video.h vulkan_decode.h vulkan_video_codec_av1std_decode.h
|
||||
+SKIPHEADERS-$(CONFIG_VULKAN) += vulkan.h vulkan_video.h vulkan_decode.h vulkan_video_codec_av1std_decode_mesa.h
|
||||
SKIPHEADERS-$(CONFIG_V4L2_M2M) += v4l2_buffers.h v4l2_context.h v4l2_m2m.h
|
||||
SKIPHEADERS-$(CONFIG_ZLIB) += zlib_wrapper.h
|
||||
|
||||
diff --git a/libavcodec/vulkan_video.h b/libavcodec/vulkan_video.h
|
||||
index b28e3fe0bd..51f44dd543 100644
|
||||
--- a/libavcodec/vulkan_video.h
|
||||
+++ b/libavcodec/vulkan_video.h
|
||||
@@ -23,8 +23,8 @@
|
||||
#include "vulkan.h"
|
||||
|
||||
#include <vk_video/vulkan_video_codecs_common.h>
|
||||
-#include "vulkan_video_codec_av1std.h"
|
||||
-#include "vulkan_video_codec_av1std_decode.h"
|
||||
+#include "vulkan_video_codec_av1std_mesa.h"
|
||||
+#include "vulkan_video_codec_av1std_decode_mesa.h"
|
||||
|
||||
#define CODEC_VER_MAJ(ver) (ver >> 22)
|
||||
#define CODEC_VER_MIN(ver) ((ver >> 12) & ((1 << 10) - 1))
|
||||
diff --git a/libavcodec/vulkan_video_codec_av1std_decode.h b/libavcodec/vulkan_video_codec_av1std_decode_mesa.h
|
||||
similarity index 89%
|
||||
rename from libavcodec/vulkan_video_codec_av1std_decode.h
|
||||
rename to libavcodec/vulkan_video_codec_av1std_decode_mesa.h
|
||||
index a697c00593..e2f37b4e6e 100644
|
||||
--- a/libavcodec/vulkan_video_codec_av1std_decode.h
|
||||
+++ b/libavcodec/vulkan_video_codec_av1std_decode_mesa.h
|
||||
@@ -14,8 +14,8 @@
|
||||
* limitations under the License.
|
||||
*/
|
||||
|
||||
-#ifndef VULKAN_VIDEO_CODEC_AV1STD_DECODE_H_
|
||||
-#define VULKAN_VIDEO_CODEC_AV1STD_DECODE_H_ 1
|
||||
+#ifndef VULKAN_VIDEO_CODEC_AV1STD_DECODE_MESA_H_
|
||||
+#define VULKAN_VIDEO_CODEC_AV1STD_DECODE_MESA_H_ 1
|
||||
|
||||
/*
|
||||
** This header is NOT YET generated from the Khronos Vulkan XML API Registry.
|
||||
diff --git a/libavcodec/vulkan_video_codec_av1std.h b/libavcodec/vulkan_video_codec_av1std_mesa.h
|
||||
similarity index 99%
|
||||
rename from libavcodec/vulkan_video_codec_av1std.h
|
||||
rename to libavcodec/vulkan_video_codec_av1std_mesa.h
|
||||
index c46236c457..c91589eee2 100644
|
||||
--- a/libavcodec/vulkan_video_codec_av1std.h
|
||||
+++ b/libavcodec/vulkan_video_codec_av1std_mesa.h
|
||||
@@ -14,8 +14,8 @@
|
||||
* limitations under the License.
|
||||
*/
|
||||
|
||||
-#ifndef VULKAN_VIDEO_CODEC_AV1STD_H_
|
||||
-#define VULKAN_VIDEO_CODEC_AV1STD_H_ 1
|
||||
+#ifndef VULKAN_VIDEO_CODEC_AV1STD_MESA_H_
|
||||
+#define VULKAN_VIDEO_CODEC_AV1STD_MESA_H_ 1
|
||||
|
||||
/*
|
||||
** This header is NOT YET generated from the Khronos Vulkan XML API Registry.
|
@ -99,8 +99,8 @@
|
||||
Name: ffmpeg
|
||||
%global pkg_name %{name}%{?pkg_suffix}
|
||||
|
||||
Version: 6.1.1
|
||||
Release: 19%{?dist}
|
||||
Version: 6.1.2
|
||||
Release: 1%{?dist}
|
||||
Summary: A complete solution to record, convert and stream audio and video
|
||||
License: GPL-3.0-or-later
|
||||
URL: https://ffmpeg.org/
|
||||
@ -130,8 +130,6 @@ Patch4: 0001-lavc-libopenh264-Drop-openh264-runtime-version-check.patch
|
||||
Patch5: ffmpeg-c99.patch
|
||||
# Fix build with gcc14 (-Wint-conversion, -Wincompatible-pointer-types)
|
||||
Patch6: ffmpeg-gcc14.patch
|
||||
# Fix build with Vulkan headers >= 1.3.280.0
|
||||
Patch7: ffmpeg-vulkan.patch
|
||||
# Backport fix for CVE-2023-49528
|
||||
Patch8: https://git.ffmpeg.org/gitweb/ffmpeg.git/patch/2d9ed64859c9887d0504cd71dbd5b2c15e14251a#/ffmpeg-CVE-2023-49528.patch
|
||||
# Fixes for Mesa 24.0.6+ / 24.1.4+ VA-API
|
||||
@ -883,6 +881,9 @@ rm -rf %{buildroot}%{_datadir}/%{name}/examples
|
||||
%{_mandir}/man3/libswscale.3*
|
||||
|
||||
%changelog
|
||||
* Sat Aug 24 2024 Fabio Valentini <decathorpe@gmail.com> - 6.1.2-1
|
||||
- Update to 6.1.2
|
||||
|
||||
* Sat Jul 20 2024 Neal Gompa <ngompa@fedoraproject.org> - 6.1.1-19
|
||||
- Backport fixes for Mesa 24.0.6+ / 21.1.4+ changes for VA-API
|
||||
|
||||
|
@ -1816,9 +1816,9 @@ libavcodec/vulkan_av1.c
|
||||
libavcodec/vulkan_decode.c
|
||||
libavcodec/vulkan_decode.h
|
||||
libavcodec/vulkan_video.c
|
||||
libavcodec/vulkan_video_codec_av1std_decode_mesa.h
|
||||
libavcodec/vulkan_video_codec_av1std_mesa.h
|
||||
libavcodec/vulkan_video.h
|
||||
libavcodec/vulkan_video_codec_av1std.h
|
||||
libavcodec/vulkan_video_codec_av1std_decode.h
|
||||
libavcodec/vvc.h
|
||||
libavcodec/vvc_mp4toannexb_bsf.c
|
||||
libavcodec/vvc_parser.c
|
||||
|
4
sources
4
sources
@ -1,4 +1,4 @@
|
||||
SHA512 (ffmpeg-free-6.1.1.tar.xz) = f7ca7901b7affa45fd6016b7ac2d7f843f89ad7f813c6f37228d184842aa55167429585e172d3da61ca1ef64818d563199faa7d06295eea1fd829696d28fa044
|
||||
SHA512 (ffmpeg-6.1.1.tar.xz.asc) = 0e10c1f560bab0812d759d286656593dea5940f02bb52d88d9ba7f10b12b9cc3d7aa2a41c5f7a45b319069e04dce22dc1286b3c1ba685b35cd6d04cd81c5a0f5
|
||||
SHA512 (ffmpeg-free-6.1.2.tar.xz) = edaa836c69b0ec2f484a4fd9b49dab97f76e7c6451449f8db8f81f04558974d850b725e3affc36f9790c206a049e42b710f54bb8fd7e4da00ec80ebce6a13e5f
|
||||
SHA512 (ffmpeg-6.1.2.tar.xz.asc) = a26dba1f4870b964080b45f8468f5ce3591eb6aa69be426bf4afbe5a60c3cbd0fe5056dc86ca7bb817c04ae30d39160cb7773772a9a2123ae7f095b18a6d7050
|
||||
SHA512 (ffmpeg-dlopen-headers.tar.xz) = 97e6986fc2bb9dfa4516135a76b04d27ceb52ff96f0af21a6169919aeefefb4d2e2e24a771959689cdbec385f5d71614ba661223c67c0e94089a6dd823a30099
|
||||
SHA512 (ffmpeg.keyring) = 9b36506835db36f776b7ddb53ad6fa9e915e6ca2f9c7cfebe8eb45513e1036a985283590a840ca313a111bf35dc3731f68885aaafb1fb7011ec433cc119e5165
|
||||
|
Loading…
Reference in New Issue
Block a user