Update patches for 4.88

This commit is contained in:
David Woodhouse 2016-12-25 21:20:08 +00:00
parent abf48374cf
commit 4d3a8b6fe3
4 changed files with 35 additions and 44 deletions

View File

@ -1,7 +1,5 @@
diff --git a/src/configure.default b/src/configure.default --- a/src/configure.default.spamd 2016-12-25 21:06:57.453758443 +0000
index 531435b..374c51d 100644 +++ b/src/configure.default 2016-12-25 21:07:49.940188407 +0000
--- a/src/configure.default
+++ b/src/configure.default
@@ -109,6 +109,7 @@ hostlist relay_from_hosts = localhost @@ -109,6 +109,7 @@ hostlist relay_from_hosts = localhost
acl_smtp_rcpt = acl_check_rcpt acl_smtp_rcpt = acl_check_rcpt
@ -29,9 +27,9 @@ index 531435b..374c51d 100644
require verify = sender require verify = sender
@@ -533,27 +535,63 @@ acl_check_data: @@ -535,27 +537,63 @@ acl_check_data:
# got $max_received_linelength
deny condition = ${if > {$max_received_linelength}{998}} condition = ${if > {$max_received_linelength}{998}}
+ # Put simple tests first. A good one is to check for the presence of a + # Put simple tests first. A good one is to check for the presence of a
+ # Message-Id: header, which RFC2822 says SHOULD be present. Some broken + # Message-Id: header, which RFC2822 says SHOULD be present. Some broken
@ -52,17 +50,17 @@ index 531435b..374c51d 100644
- # Add headers to a message if it is judged to be spam. Before enabling this, - # Add headers to a message if it is judged to be spam. Before enabling this,
- # you must install SpamAssassin. You may also need to set the spamd_address - # you must install SpamAssassin. You may also need to set the spamd_address
- # option above. - # option above.
+ # Bypass SpamAssassin checks if the message is too large. - #
#
- # warn spam = nobody - # warn spam = nobody
- # add_header = X-Spam_score: $spam_score\n\ - # add_header = X-Spam_score: $spam_score\n\
- # X-Spam_score_int: $spam_score_int\n\ - # X-Spam_score_int: $spam_score_int\n\
- # X-Spam_bar: $spam_bar\n\ - # X-Spam_bar: $spam_bar\n\
- # X-Spam_report: $spam_report - # X-Spam_report: $spam_report
+ # Bypass SpamAssassin checks if the message is too large.
+ #
+ # accept condition = ${if >={$message_size}{100000} {1}} + # accept condition = ${if >={$message_size}{100000} {1}}
+ # add_header = X-Spam-Note: SpamAssassin run bypassed due to message size + # add_header = X-Spam-Note: SpamAssassin run bypassed due to message size
+
- # Accept the message.
+ # Run SpamAssassin, but allow for it to fail or time out. Add a warning message + # Run SpamAssassin, but allow for it to fail or time out. Add a warning message
+ # and accept the mail if that happens. Add an X-Spam-Flag: header if the SA + # and accept the mail if that happens. Add an X-Spam-Flag: header if the SA
+ # score exceeds the SA system threshold. + # score exceeds the SA system threshold.
@ -78,7 +76,8 @@ index 531435b..374c51d 100644
+ # + #
+ # warn add_header = X-Spam-Score: $spam_score ($spam_bar)\n\ + # warn add_header = X-Spam-Score: $spam_score ($spam_bar)\n\
+ # X-Spam-Report: $spam_report + # X-Spam-Report: $spam_report
+
- # Accept the message.
+ # And reject if the SpamAssassin score is greater than ten + # And reject if the SpamAssassin score is greater than ten
+ # + #
+ # deny condition = ${if >{$spam_score_int}{100} {1}} + # deny condition = ${if >{$spam_score_int}{100} {1}}

View File

@ -1,8 +1,8 @@
diff --git a/scripts/Configure-Makefile b/scripts/Configure-Makefile diff --git a/src/scripts/Configure-Makefile b/src/scripts/Configure-Makefile
index 4aa7d76..3a5263c 100755 index 3e486a6..6c4afec 100755
--- a/scripts/Configure-Makefile --- a/scripts/Configure-Makefile
+++ b/scripts/Configure-Makefile +++ b/scripts/Configure-Makefile
@@ -253,7 +253,7 @@ if [ "${EXIM_PERL}" != "" ] ; then @@ -269,7 +269,7 @@ if [ "${EXIM_PERL}" != "" ] ; then
mv $mft $mftt mv $mft $mftt
echo "PERL_CC=`$PERL_COMMAND -MConfig -e 'print $Config{cc}'`" >>$mft echo "PERL_CC=`$PERL_COMMAND -MConfig -e 'print $Config{cc}'`" >>$mft
@ -11,8 +11,8 @@ index 4aa7d76..3a5263c 100755
echo "PERL_LIBS=`$PERL_COMMAND -MExtUtils::Embed -e ldopts`" >>$mft echo "PERL_LIBS=`$PERL_COMMAND -MExtUtils::Embed -e ldopts`" >>$mft
echo "" >>$mft echo "" >>$mft
cat $mftt >> $mft cat $mftt >> $mft
diff --git a/src/EDITME b/src/EDITME diff --git a/src/src/EDITME b/src/src/EDITME
index d852103..bbb7527 100644 index 6929346..5a08197 100644
--- a/src/EDITME --- a/src/EDITME
+++ b/src/EDITME +++ b/src/EDITME
@@ -98,7 +98,7 @@ @@ -98,7 +98,7 @@
@ -105,24 +105,16 @@ index d852103..bbb7527 100644
# LOOKUP_WHOSON=yes # LOOKUP_WHOSON=yes
# These two settings are obsolete; all three lookups are compiled when # These two settings are obsolete; all three lookups are compiled when
@@ -390,14 +392,14 @@ EXIM_MONITOR=eximon.bin @@ -390,7 +392,7 @@ EXIM_MONITOR=eximon.bin
# and the MIME ACL. Please read the documentation to learn more about these # and the MIME ACL. Please read the documentation to learn more about these
# features. # features.
-# WITH_CONTENT_SCAN=yes -# WITH_CONTENT_SCAN=yes
+WITH_CONTENT_SCAN=yes +WITH_CONTENT_SCAN=yes
# If you want to use the deprecated "demime" condition in the DATA ACL,
# uncomment the line below. Doing so will also explicitly turn on the
# WITH_CONTENT_SCAN option. If possible, use the MIME ACL instead of
# the "demime" condition.
-# WITH_OLD_DEMIME=yes
+WITH_OLD_DEMIME=yes
#------------------------------------------------------------------------------ #------------------------------------------------------------------------------
# If you're using ClamAV and are backporting fixes to an old version, instead # If you're using ClamAV and are backporting fixes to an old version, instead
@@ -573,7 +575,7 @@ FIXED_NEVER_USERS=root @@ -577,7 +579,7 @@ FIXED_NEVER_USERS=root
# CONFIGURE_OWNER setting, to specify a configuration file which is listed in # CONFIGURE_OWNER setting, to specify a configuration file which is listed in
# the TRUSTED_CONFIG_LIST file, then root privileges are not dropped by Exim. # the TRUSTED_CONFIG_LIST file, then root privileges are not dropped by Exim.
@ -131,7 +123,7 @@ index d852103..bbb7527 100644
#------------------------------------------------------------------------------ #------------------------------------------------------------------------------
@@ -618,16 +620,14 @@ FIXED_NEVER_USERS=root @@ -622,16 +624,14 @@ FIXED_NEVER_USERS=root
# included in the Exim binary. You will then need to set up the run time # included in the Exim binary. You will then need to set up the run time
# configuration to make use of the mechanism(s) selected. # configuration to make use of the mechanism(s) selected.
@ -156,7 +148,7 @@ index d852103..bbb7527 100644
#------------------------------------------------------------------------------ #------------------------------------------------------------------------------
@@ -648,7 +648,7 @@ FIXED_NEVER_USERS=root @@ -652,7 +652,7 @@ FIXED_NEVER_USERS=root
# one that is set in the headers_charset option. The default setting is # one that is set in the headers_charset option. The default setting is
# defined by this setting: # defined by this setting:
@ -165,7 +157,7 @@ index d852103..bbb7527 100644
# If you are going to make use of $header_xxx expansions in your configuration # If you are going to make use of $header_xxx expansions in your configuration
# file, or if your users are going to use them in filter files, and the normal # file, or if your users are going to use them in filter files, and the normal
@@ -668,7 +668,7 @@ HEADERS_CHARSET="ISO-8859-1" @@ -672,7 +672,7 @@ HEADERS_CHARSET="ISO-8859-1"
# the Sieve filter support. For those OS where iconv() is known to be installed # the Sieve filter support. For those OS where iconv() is known to be installed
# as standard, the file in OS/Makefile-xxxx contains # as standard, the file in OS/Makefile-xxxx contains
# #
@ -174,7 +166,7 @@ index d852103..bbb7527 100644
# #
# If you are not using one of those systems, but have installed iconv(), you # If you are not using one of those systems, but have installed iconv(), you
# need to uncomment that line above. In some cases, you may find that iconv() # need to uncomment that line above. In some cases, you may find that iconv()
@@ -730,11 +730,11 @@ HEADERS_CHARSET="ISO-8859-1" @@ -734,11 +734,11 @@ HEADERS_CHARSET="ISO-8859-1"
# leave these settings commented out. # leave these settings commented out.
# This setting is required for any TLS support (either OpenSSL or GnuTLS) # This setting is required for any TLS support (either OpenSSL or GnuTLS)
@ -189,7 +181,7 @@ index d852103..bbb7527 100644
# Uncomment the first and either the second or the third of these if you # Uncomment the first and either the second or the third of these if you
# are using GnuTLS. If you have pkg-config, then the second, else the third. # are using GnuTLS. If you have pkg-config, then the second, else the third.
@@ -799,7 +799,7 @@ HEADERS_CHARSET="ISO-8859-1" @@ -807,7 +807,7 @@ HEADERS_CHARSET="ISO-8859-1"
# Once you have done this, "make install" will build the info files and # Once you have done this, "make install" will build the info files and
# install them in the directory you have defined. # install them in the directory you have defined.
@ -198,7 +190,7 @@ index d852103..bbb7527 100644
#------------------------------------------------------------------------------ #------------------------------------------------------------------------------
@@ -812,7 +812,7 @@ HEADERS_CHARSET="ISO-8859-1" @@ -820,7 +820,7 @@ HEADERS_CHARSET="ISO-8859-1"
# %s. This will be replaced by one of the strings "main", "panic", or "reject" # %s. This will be replaced by one of the strings "main", "panic", or "reject"
# to form the final file names. Some installations may want something like this: # to form the final file names. Some installations may want something like this:
@ -207,7 +199,7 @@ index d852103..bbb7527 100644
# which results in files with names /var/log/exim_mainlog, etc. The directory # which results in files with names /var/log/exim_mainlog, etc. The directory
# in which the log files are placed must exist; Exim does not try to create # in which the log files are placed must exist; Exim does not try to create
@@ -884,7 +884,7 @@ ZCAT_COMMAND=/usr/bin/zcat @@ -892,7 +892,7 @@ ZCAT_COMMAND=/usr/bin/zcat
# (version 5.004 or later) installed, set EXIM_PERL to perl.o. Using embedded # (version 5.004 or later) installed, set EXIM_PERL to perl.o. Using embedded
# Perl costs quite a lot of resources. Only do this if you really need it. # Perl costs quite a lot of resources. Only do this if you really need it.
@ -216,7 +208,7 @@ index d852103..bbb7527 100644
#------------------------------------------------------------------------------ #------------------------------------------------------------------------------
@@ -894,7 +894,7 @@ ZCAT_COMMAND=/usr/bin/zcat @@ -902,7 +902,7 @@ ZCAT_COMMAND=/usr/bin/zcat
# that the local_scan API is made available by the linker. You may also need # that the local_scan API is made available by the linker. You may also need
# to add -ldl to EXTRALIBS so that dlopen() is available to Exim. # to add -ldl to EXTRALIBS so that dlopen() is available to Exim.
@ -225,7 +217,7 @@ index d852103..bbb7527 100644
#------------------------------------------------------------------------------ #------------------------------------------------------------------------------
@@ -904,7 +904,7 @@ ZCAT_COMMAND=/usr/bin/zcat @@ -912,7 +912,7 @@ ZCAT_COMMAND=/usr/bin/zcat
# support, which is intended for use in conjunction with the SMTP AUTH # support, which is intended for use in conjunction with the SMTP AUTH
# facilities, is included only when requested by the following setting: # facilities, is included only when requested by the following setting:
@ -234,7 +226,7 @@ index d852103..bbb7527 100644
# You probably need to add -lpam to EXTRALIBS, and in some releases of # You probably need to add -lpam to EXTRALIBS, and in some releases of
# GNU/Linux -ldl is also needed. # GNU/Linux -ldl is also needed.
@@ -998,7 +998,7 @@ ZCAT_COMMAND=/usr/bin/zcat @@ -1006,7 +1006,7 @@ ZCAT_COMMAND=/usr/bin/zcat
# group. Once you have installed saslauthd, you should arrange for it to be # group. Once you have installed saslauthd, you should arrange for it to be
# started by root at boot time. # started by root at boot time.
@ -243,7 +235,7 @@ index d852103..bbb7527 100644
#------------------------------------------------------------------------------ #------------------------------------------------------------------------------
@@ -1011,9 +1011,9 @@ ZCAT_COMMAND=/usr/bin/zcat @@ -1019,9 +1019,9 @@ ZCAT_COMMAND=/usr/bin/zcat
# You may well also have to specify a local "include" file and an additional # You may well also have to specify a local "include" file and an additional
# library for TCP wrappers, so you probably need something like this: # library for TCP wrappers, so you probably need something like this:
# #
@ -256,7 +248,7 @@ index d852103..bbb7527 100644
# #
# but of course there may need to be other things in CFLAGS and EXTRALIBS_EXIM # but of course there may need to be other things in CFLAGS and EXTRALIBS_EXIM
# as well. # as well.
@@ -1065,7 +1065,7 @@ SYSTEM_ALIASES_FILE=/etc/aliases @@ -1073,7 +1073,7 @@ SYSTEM_ALIASES_FILE=/etc/aliases
# is "yes", as well as supporting line editing, a history of input lines in the # is "yes", as well as supporting line editing, a history of input lines in the
# current run is maintained. # current run is maintained.
@ -265,7 +257,7 @@ index d852103..bbb7527 100644
# You may need to add -ldl to EXTRALIBS when you set USE_READLINE=yes. # You may need to add -ldl to EXTRALIBS when you set USE_READLINE=yes.
# Note that this option adds to the size of the Exim binary, because the # Note that this option adds to the size of the Exim binary, because the
@@ -1075,7 +1075,7 @@ SYSTEM_ALIASES_FILE=/etc/aliases @@ -1083,7 +1083,7 @@ SYSTEM_ALIASES_FILE=/etc/aliases
#------------------------------------------------------------------------------ #------------------------------------------------------------------------------
# Uncomment this setting to include IPv6 support. # Uncomment this setting to include IPv6 support.
@ -274,7 +266,7 @@ index d852103..bbb7527 100644
############################################################################### ###############################################################################
# THINGS YOU ALMOST NEVER NEED TO MENTION # # THINGS YOU ALMOST NEVER NEED TO MENTION #
@@ -1096,13 +1096,13 @@ SYSTEM_ALIASES_FILE=/etc/aliases @@ -1104,13 +1104,13 @@ SYSTEM_ALIASES_FILE=/etc/aliases
# haven't got Perl, Exim will still build and run; you just won't be able to # haven't got Perl, Exim will still build and run; you just won't be able to
# use those utilities. # use those utilities.
@ -295,7 +287,7 @@ index d852103..bbb7527 100644
#------------------------------------------------------------------------------ #------------------------------------------------------------------------------
@@ -1304,7 +1304,7 @@ EXIM_TMPDIR="/tmp" @@ -1312,7 +1312,7 @@ EXIM_TMPDIR="/tmp"
# (process id) to a file so that it can easily be identified. The path of the # (process id) to a file so that it can easily be identified. The path of the
# file can be specified here. Some installations may want something like this: # file can be specified here. Some installations may want something like this:

View File

@ -47,7 +47,7 @@ Source25: exim-gen-cert
Source26: clamd.exim.service Source26: clamd.exim.service
Patch4: exim-4.87-rhl.patch Patch4: exim-4.87-rhl.patch
Patch6: exim-4.87-config.patch Patch6: exim-4.88-config.patch
Patch8: exim-4.82-libdir.patch Patch8: exim-4.82-libdir.patch
Patch12: exim-4.87-cyrus.patch Patch12: exim-4.87-cyrus.patch
Patch13: exim-4.87-pamconfig.patch Patch13: exim-4.87-pamconfig.patch

View File

@ -1 +1 @@
SHA512 (exim-4.88.tar.bz2) = ea094bf703628c201de119fc5f09539475e52158e935f8f2a9e4138c4a1bfe885017145c3cc5e22aa9087b195091955c69385ebf1ea0baec64ed5c1b8e3b1caf SHA512 (exim-4.87.1.tar.bz2) = bdb0a0507a8ad63abe49026250bd8206f6993cc08a01e640f8076f8accc57a33b16c336196351bf5cb124f1a435b140f908b4d6707ce0efb8d305764cf156e6b