New version

Resolves: rhbz#1615158
Dropped dynlookup-config patch (merged into config patch)
Dropped dec64table-read-fix patch (already upstream)
De-fuzzified patches
This commit is contained in:
Jaroslav Škarvada 2018-08-22 16:11:00 +02:00
parent 3206e7c0eb
commit 3afb1c1273
13 changed files with 84 additions and 106 deletions

View File

@ -1,26 +0,0 @@
diff --git a/src/EDITME b/src/EDITME
index ce2b047..ad06440 100644
--- a/src/EDITME
+++ b/src/EDITME
@@ -311,15 +311,17 @@ LOOKUP_DSEARCH=yes
# LOOKUP_IBASE=yes
LOOKUP_LDAP=yes
LDAP_LIB_TYPE=OPENLDAP2
-LOOKUP_INCLUDE=-I/usr/include/mysql
-LOOKUP_LIBS=-lldap -llber -lsqlite3 -L/usr/$(_lib)/mysql -lmysqlclient -lpq
-LOOKUP_MYSQL=yes
+LOOKUP_LIBS=-lldap -llber -lsqlite3
+LOOKUP_INCLUDE=-L/usr/$(_lib)/mysql -I/usr/include/mysql
+LOOKUP_MYSQL_LIBS=-lmysqlclient
+LOOKUP_PGSQL_LIBS=-lpq
+LOOKUP_MYSQL=2
# LOOKUP_MYSQL_PC=mariadb
LOOKUP_NIS=yes
LOOKUP_NISPLUS=yes
# LOOKUP_ORACLE=yes
LOOKUP_PASSWD=yes
-LOOKUP_PGSQL=yes
+LOOKUP_PGSQL=2
# LOOKUP_REDIS=yes
LOOKUP_SQLITE=yes
# LOOKUP_WHOSON=yes

View File

@ -1,8 +1,8 @@
diff --git a/src/configure.default b/src/configure.default
index 2cce34b..50e9236 100644
index 7d26076..ce3b3b0 100644
--- a/src/configure.default
+++ b/src/configure.default
@@ -727,7 +727,7 @@ userforward:
@@ -733,7 +733,7 @@ userforward:
# local_part_suffix = +* : -*
# local_part_suffix_optional
file = $home/.forward

View File

@ -1,8 +1,8 @@
diff --git a/scripts/Configure-Makefile b/scripts/Configure-Makefile
index 2af1927..e461505 100755
index 7e0bf38..c97ccec 100755
--- a/scripts/Configure-Makefile
+++ b/scripts/Configure-Makefile
@@ -296,7 +296,7 @@ if [ "${EXIM_PERL}" != "" ] ; then
@@ -297,7 +297,7 @@ if [ "${EXIM_PERL}" != "" ] ; then
mv $mft $mftt
echo "PERL_CC=`$PERL_COMMAND -MConfig -e 'print $Config{cc}'`" >>$mft
@ -12,7 +12,7 @@ index 2af1927..e461505 100755
echo "" >>$mft
cat $mftt >> $mft
diff --git a/src/EDITME b/src/EDITME
index 72e26ce..ef6a2d4 100644
index bd5151d..3ffc3a0 100644
--- a/src/EDITME
+++ b/src/EDITME
@@ -98,7 +98,7 @@
@ -73,7 +73,7 @@ index 72e26ce..ef6a2d4 100644
#------------------------------------------------------------------------------
@@ -306,20 +306,22 @@ LOOKUP_DBM=yes
@@ -306,20 +306,23 @@ LOOKUP_DBM=yes
LOOKUP_LSEARCH=yes
LOOKUP_DNSDB=yes
@ -84,21 +84,23 @@ index 72e26ce..ef6a2d4 100644
# LOOKUP_IBASE=yes
-# LOOKUP_LDAP=yes
-# LOOKUP_MYSQL=yes
-# LOOKUP_MYSQL_PC=mariadb
-# LOOKUP_NIS=yes
-# LOOKUP_NISPLUS=yes
+LOOKUP_LDAP=yes
+LDAP_LIB_TYPE=OPENLDAP2
+LOOKUP_INCLUDE=-I/usr/include/mysql
+LOOKUP_LIBS=-lldap -llber -lsqlite3 -L/usr/$(_lib)/mysql -lmysqlclient -lpq
+LOOKUP_MYSQL=yes
# LOOKUP_MYSQL_PC=mariadb
-# LOOKUP_NIS=yes
-# LOOKUP_NISPLUS=yes
+LOOKUP_MYSQL=2
+#LOOKUP_MYSQL_PC=mariadb
+LOOKUP_NIS=yes
+LOOKUP_NISPLUS=yes
# LOOKUP_ORACLE=yes
-# LOOKUP_PASSWD=yes
-# LOOKUP_PGSQL=yes
+LOOKUP_PASSWD=yes
+LOOKUP_PGSQL=yes
+LOOKUP_PGSQL=2
+LOOKUP_PGSQL_LIBS=-lpq
# LOOKUP_REDIS=yes
-# LOOKUP_SQLITE=yes
-# LOOKUP_SQLITE_PC=sqlite3
@ -106,16 +108,16 @@ index 72e26ce..ef6a2d4 100644
# LOOKUP_WHOSON=yes
# These two settings are obsolete; all three lookups are compiled when
@@ -396,7 +398,7 @@ EXIM_MONITOR=eximon.bin
@@ -402,7 +405,7 @@ EXIM_MONITOR=eximon.bin
# and the MIME ACL. Please read the documentation to learn more about these
# features.
-# WITH_CONTENT_SCAN=yes
+WITH_CONTENT_SCAN=yes
#------------------------------------------------------------------------------
# If you're using ClamAV and are backporting fixes to an old version, instead
@@ -584,7 +586,7 @@ FIXED_NEVER_USERS=root
# If you have content scanning you may wish to only include some of the scanner
# interfaces. Uncomment any of these lines to remove that code.
@@ -590,7 +593,7 @@ FIXED_NEVER_USERS=root
# CONFIGURE_OWNER setting, to specify a configuration file which is listed in
# the TRUSTED_CONFIG_LIST file, then root privileges are not dropped by Exim.
@ -124,7 +126,7 @@ index 72e26ce..ef6a2d4 100644
#------------------------------------------------------------------------------
@@ -629,17 +631,14 @@ FIXED_NEVER_USERS=root
@@ -635,17 +638,14 @@ FIXED_NEVER_USERS=root
# included in the Exim binary. You will then need to set up the run time
# configuration to make use of the mechanism(s) selected.
@ -150,7 +152,7 @@ index 72e26ce..ef6a2d4 100644
# Heimdal through 1.5 required pkg-config 'heimdal-gssapi'; Heimdal 7.1
# requires multiple pkg-config files to work with Exim, so the second example
@@ -663,7 +662,7 @@ FIXED_NEVER_USERS=root
@@ -669,7 +669,7 @@ FIXED_NEVER_USERS=root
# one that is set in the headers_charset option. The default setting is
# defined by this setting:
@ -159,7 +161,7 @@ index 72e26ce..ef6a2d4 100644
# If you are going to make use of $header_xxx expansions in your configuration
# file, or if your users are going to use them in filter files, and the normal
@@ -683,7 +682,7 @@ HEADERS_CHARSET="ISO-8859-1"
@@ -689,7 +689,7 @@ HEADERS_CHARSET="ISO-8859-1"
# the Sieve filter support. For those OS where iconv() is known to be installed
# as standard, the file in OS/Makefile-xxxx contains
#
@ -168,7 +170,7 @@ index 72e26ce..ef6a2d4 100644
#
# If you are not using one of those systems, but have installed iconv(), you
# need to uncomment that line above. In some cases, you may find that iconv()
@@ -752,11 +751,11 @@ HEADERS_CHARSET="ISO-8859-1"
@@ -758,11 +758,11 @@ HEADERS_CHARSET="ISO-8859-1"
# leave these settings commented out.
# This setting is required for any TLS support (either OpenSSL or GnuTLS)
@ -183,7 +185,7 @@ index 72e26ce..ef6a2d4 100644
# Uncomment the first and either the second or the third of these if you
# are using GnuTLS. If you have pkg-config, then the second, else the third.
@@ -825,7 +824,7 @@ HEADERS_CHARSET="ISO-8859-1"
@@ -834,7 +834,7 @@ HEADERS_CHARSET="ISO-8859-1"
# Once you have done this, "make install" will build the info files and
# install them in the directory you have defined.
@ -192,7 +194,7 @@ index 72e26ce..ef6a2d4 100644
#------------------------------------------------------------------------------
@@ -838,7 +837,7 @@ HEADERS_CHARSET="ISO-8859-1"
@@ -847,7 +847,7 @@ HEADERS_CHARSET="ISO-8859-1"
# %s. This will be replaced by one of the strings "main", "panic", or "reject"
# to form the final file names. Some installations may want something like this:
@ -201,7 +203,7 @@ index 72e26ce..ef6a2d4 100644
# which results in files with names /var/log/exim_mainlog, etc. The directory
# in which the log files are placed must exist; Exim does not try to create
@@ -910,7 +909,7 @@ ZCAT_COMMAND=/usr/bin/zcat
@@ -919,7 +919,7 @@ ZCAT_COMMAND=/usr/bin/zcat
# (version 5.004 or later) installed, set EXIM_PERL to perl.o. Using embedded
# Perl costs quite a lot of resources. Only do this if you really need it.
@ -210,7 +212,7 @@ index 72e26ce..ef6a2d4 100644
#------------------------------------------------------------------------------
@@ -920,7 +919,7 @@ ZCAT_COMMAND=/usr/bin/zcat
@@ -929,7 +929,7 @@ ZCAT_COMMAND=/usr/bin/zcat
# that the local_scan API is made available by the linker. You may also need
# to add -ldl to EXTRALIBS so that dlopen() is available to Exim.
@ -219,7 +221,7 @@ index 72e26ce..ef6a2d4 100644
#------------------------------------------------------------------------------
@@ -930,7 +929,7 @@ ZCAT_COMMAND=/usr/bin/zcat
@@ -939,7 +939,7 @@ ZCAT_COMMAND=/usr/bin/zcat
# support, which is intended for use in conjunction with the SMTP AUTH
# facilities, is included only when requested by the following setting:
@ -228,7 +230,7 @@ index 72e26ce..ef6a2d4 100644
# You probably need to add -lpam to EXTRALIBS, and in some releases of
# GNU/Linux -ldl is also needed.
@@ -1028,7 +1027,7 @@ ZCAT_COMMAND=/usr/bin/zcat
@@ -1047,7 +1047,7 @@ ZCAT_COMMAND=/usr/bin/zcat
# group. Once you have installed saslauthd, you should arrange for it to be
# started by root at boot time.
@ -237,7 +239,7 @@ index 72e26ce..ef6a2d4 100644
#------------------------------------------------------------------------------
@@ -1042,8 +1041,8 @@ ZCAT_COMMAND=/usr/bin/zcat
@@ -1061,8 +1061,8 @@ ZCAT_COMMAND=/usr/bin/zcat
# library for TCP wrappers, so you probably need something like this:
#
# USE_TCP_WRAPPERS=yes
@ -248,7 +250,7 @@ index 72e26ce..ef6a2d4 100644
#
# but of course there may need to be other things in CFLAGS and EXTRALIBS_EXIM
# as well.
@@ -1095,7 +1094,7 @@ SYSTEM_ALIASES_FILE=/etc/aliases
@@ -1114,7 +1114,7 @@ SYSTEM_ALIASES_FILE=/etc/aliases
# is "yes", as well as supporting line editing, a history of input lines in the
# current run is maintained.
@ -257,7 +259,7 @@ index 72e26ce..ef6a2d4 100644
# You may need to add -ldl to EXTRALIBS when you set USE_READLINE=yes.
# Note that this option adds to the size of the Exim binary, because the
@@ -1112,7 +1111,7 @@ SYSTEM_ALIASES_FILE=/etc/aliases
@@ -1131,7 +1131,7 @@ SYSTEM_ALIASES_FILE=/etc/aliases
#------------------------------------------------------------------------------
# Uncomment this setting to include IPv6 support.
@ -266,7 +268,7 @@ index 72e26ce..ef6a2d4 100644
###############################################################################
# THINGS YOU ALMOST NEVER NEED TO MENTION #
@@ -1133,13 +1132,13 @@ SYSTEM_ALIASES_FILE=/etc/aliases
@@ -1152,13 +1152,13 @@ SYSTEM_ALIASES_FILE=/etc/aliases
# haven't got Perl, Exim will still build and run; you just won't be able to
# use those utilities.
@ -287,7 +289,7 @@ index 72e26ce..ef6a2d4 100644
#------------------------------------------------------------------------------
@@ -1341,7 +1340,7 @@ EXIM_TMPDIR="/tmp"
@@ -1360,7 +1360,7 @@ EXIM_TMPDIR="/tmp"
# (process id) to a file so that it can easily be identified. The path of the
# file can be specified here. Some installations may want something like this:

View File

@ -1,8 +1,8 @@
diff --git a/src/configure.default b/src/configure.default
index 562d0be..1138335 100644
index 78e44d2..ae50b15 100644
--- a/src/configure.default
+++ b/src/configure.default
@@ -768,6 +768,16 @@ address_reply:
@@ -774,6 +774,16 @@ address_reply:
driver = autoreply

View File

@ -1,11 +1,12 @@
diff --git a/src/EDITME b/src/EDITME
index 0bd97f1..ce2b047 100644
index 4cd3b4d..1b79e71 100644
--- a/src/EDITME
+++ b/src/EDITME
@@ -809,6 +809,20 @@ TLS_LIBS=-lssl -lcrypto
@@ -817,6 +817,20 @@ TLS_LIBS=-lssl -lcrypto
# specified in INCLUDE.
#------------------------------------------------------------------------------
+#------------------------------------------------------------------------------
+# On systems which support dynamic loading of shared libraries, Exim can
+# load a local_scan function specified in its config file instead of having
+# to be recompiled with the desired local_scan function. For a full
@ -19,15 +20,14 @@ index 0bd97f1..ce2b047 100644
+
+LFLAGS=-rdynamic -ldl -pie
+
+#------------------------------------------------------------------------------
#------------------------------------------------------------------------------
# The default distribution of Exim contains only the plain text form of the
# documentation. Other forms are available separately. If you want to install
# the documentation in "info" format, first fetch the Texinfo documentation
diff --git a/src/config.h.defaults b/src/config.h.defaults
index 4750523..e3943a8 100644
index ce478d5..6ce0d45 100644
--- a/src/config.h.defaults
+++ b/src/config.h.defaults
@@ -31,6 +31,8 @@ Do not put spaces between # and the 'define'.
@@ -32,6 +32,8 @@ Do not put spaces between # and the 'define'.
#define AUTH_VARS 3
@ -37,7 +37,7 @@ index 4750523..e3943a8 100644
#define CONFIGURE_FILE
diff --git a/src/globals.c b/src/globals.c
index 5df84bd..74724fd 100644
index 7d18b38..438c993 100644
--- a/src/globals.c
+++ b/src/globals.c
@@ -167,6 +167,10 @@ uschar *tls_verify_hosts = NULL;
@ -52,7 +52,7 @@ index 5df84bd..74724fd 100644
/* Per Recipient Data Response variables */
BOOL prdr_enable = FALSE;
diff --git a/src/globals.h b/src/globals.h
index 37d4cad..2b313e0 100644
index da1230b..b9f0155 100644
--- a/src/globals.h
+++ b/src/globals.h
@@ -126,6 +126,11 @@ extern uschar *tls_try_verify_hosts; /* Optional client verification */
@ -251,7 +251,7 @@ index 3500047..8599172 100644
+
/* End of local_scan.c */
diff --git a/src/readconf.c b/src/readconf.c
index 8d5f38c..73095be 100644
index cbbef6e..da3421a 100644
--- a/src/readconf.c
+++ b/src/readconf.c
@@ -195,6 +195,9 @@ static optionlist optionlist_config[] = {

View File

@ -1,5 +1,5 @@
diff --git a/src/configure.default b/src/configure.default
index 72675be..30ffc8c 100644
index f1260cf..05e9371 100644
--- a/src/configure.default
+++ b/src/configure.default
@@ -107,6 +107,7 @@ hostlist relay_from_hosts = localhost
@ -72,7 +72,7 @@ index 72675be..30ffc8c 100644
# At this point, the address has passed all the checks that have been
# configured, so we accept it unconditionally.
@@ -549,6 +582,12 @@ acl_check_data:
@@ -555,6 +588,12 @@ acl_check_data:
# deny condition = ${if !def:h_Message-ID: {1}}
# message = RFC2822 says that all mail SHOULD have a Message-ID header.\n\
# Most messages without it are spam, so your mail has been rejected.
@ -85,7 +85,7 @@ index 72675be..30ffc8c 100644
# Deny if the message contains a virus. Before enabling this check, you
# must install a virus scanner and set the av_scanner option above.
@@ -583,8 +622,30 @@ acl_check_data:
@@ -589,8 +628,30 @@ acl_check_data:
# message = Your message scored $spam_score SpamAssassin point. Report follows:\n\
# $spam_report

View File

@ -1,5 +1,5 @@
diff --git a/src/configure.default b/src/configure.default
index 1138335..0675b40 100644
index ae50b15..6966ad3 100644
--- a/src/configure.default
+++ b/src/configure.default
@@ -142,7 +142,7 @@ acl_smtp_data = acl_check_data
@ -58,7 +58,7 @@ index 1138335..0675b40 100644
# The settings below cause Exim to make RFC 1413 (ident) callbacks
# for all incoming SMTP calls. You can limit the hosts to which these
@@ -847,7 +865,7 @@ begin authenticators
@@ -853,7 +871,7 @@ begin authenticators
# driver = plaintext
# server_set_id = $auth2
# server_prompts = :
@ -67,7 +67,7 @@ index 1138335..0675b40 100644
# server_advertise_condition = ${if def:tls_in_cipher }
# LOGIN authentication has traditional prompts and responses. There is no
@@ -859,7 +877,7 @@ begin authenticators
@@ -865,7 +883,7 @@ begin authenticators
# driver = plaintext
# server_set_id = $auth1
# server_prompts = <| Username: | Password:

View File

@ -1,8 +1,8 @@
diff --git a/src/configure.default b/src/configure.default
index 8b4575c..2cce34b 100644
index dd5bfeb..7d26076 100644
--- a/src/configure.default
+++ b/src/configure.default
@@ -735,6 +735,12 @@ userforward:
@@ -741,6 +741,12 @@ userforward:
pipe_transport = address_pipe
reply_transport = address_reply
@ -15,7 +15,7 @@ index 8b4575c..2cce34b 100644
# This router matches local user mailboxes. If the router fails, the error
# message is "Unknown user".
@@ -776,6 +782,16 @@ remote_smtp:
@@ -782,6 +788,16 @@ remote_smtp:
driver = smtp
message_size_limit = ${if > {$max_received_linelength}{998} {1}{0}}

View File

@ -1,8 +1,8 @@
diff --git a/src/configure.default b/src/configure.default
index 1dc9b91..562d0be 100644
index 79bbc8c..78e44d2 100644
--- a/src/configure.default
+++ b/src/configure.default
@@ -633,7 +633,7 @@ system_aliases:
@@ -639,7 +639,7 @@ system_aliases:
driver = redirect
allow_fail
allow_defer
@ -11,7 +11,7 @@ index 1dc9b91..562d0be 100644
# user = exim
file_transport = address_file
pipe_transport = address_pipe
@@ -734,8 +734,8 @@ local_delivery:
@@ -740,8 +740,8 @@ local_delivery:
delivery_date_add
envelope_to_add
return_path_add

View File

@ -1,8 +1,8 @@
diff --git a/src/configure.default b/src/configure.default
index 30ffc8c..b955c6e 100644
index 05e9371..5e61818 100644
--- a/src/configure.default
+++ b/src/configure.default
@@ -843,6 +843,15 @@ remote_smtp:
@@ -849,6 +849,15 @@ remote_smtp:
driver = smtp
message_size_limit = ${if > {$max_received_linelength}{998} {1}{0}}
@ -18,7 +18,7 @@ index 30ffc8c..b955c6e 100644
# This transport invokes procmail to deliver mail
procmail:
driver = pipe
@@ -951,6 +960,21 @@ begin rewrite
@@ -957,6 +966,21 @@ begin rewrite
# AUTHENTICATION CONFIGURATION #
######################################################################
@ -40,7 +40,7 @@ index 30ffc8c..b955c6e 100644
# The following authenticators support plaintext username/password
# authentication using the standard PLAIN mechanism and the traditional
# but non-standard LOGIN mechanism, with Exim acting as the server.
@@ -966,7 +990,7 @@ begin rewrite
@@ -972,7 +996,7 @@ begin rewrite
# The default RCPT ACL checks for successful authentication, and will accept
# messages from authenticated users from anywhere on the Internet.

View File

@ -1,5 +1,5 @@
diff --git a/src/configure.default b/src/configure.default
index 0675b40..8b4575c 100644
index 6966ad3..dd5bfeb 100644
--- a/src/configure.default
+++ b/src/configure.default
@@ -109,6 +109,7 @@ hostlist relay_from_hosts = localhost
@ -29,9 +29,9 @@ index 0675b40..8b4575c 100644
require verify = sender
@@ -538,27 +540,63 @@ acl_check_data:
got $max_received_linelength
condition = ${if > {$max_received_linelength}{998}}
@@ -544,27 +546,63 @@ acl_check_data:
message = header syntax
log_message = header syntax ($acl_verify_message)
+ # Put simple tests first. A good one is to check for the presence of a
+ # Message-Id: header, which RFC2822 says SHOULD be present. Some broken

View File

@ -14,8 +14,8 @@
Summary: The exim mail transfer agent
Name: exim
Version: 4.90.1
Release: 3%{?dist}
Version: 4.91
Release: 1%{?dist}
License: GPLv2+
Url: http://www.exim.org/
Group: System Environment/Daemons
@ -52,23 +52,20 @@ Source25: exim-gen-cert
Source26: clamd.exim.service
%endif
Patch4: exim-4.90.1-rhl.patch
Patch6: exim-4.90.1-config.patch
Patch4: exim-4.91-rhl.patch
Patch6: exim-4.91-config.patch
Patch8: exim-4.82-libdir.patch
Patch12: exim-4.90.1-cyrus.patch
Patch13: exim-4.90.1-pamconfig.patch
Patch14: exim-4.90.1-spamdconf.patch
Patch18: exim-4.90.1-dlopen-localscan.patch
Patch19: exim-4.90.1-procmail.patch
Patch20: exim-4.90.1-allow-filter.patch
Patch12: exim-4.91-cyrus.patch
Patch13: exim-4.91-pamconfig.patch
Patch14: exim-4.91-spamdconf.patch
Patch18: exim-4.91-dlopen-localscan.patch
Patch19: exim-4.91-procmail.patch
Patch20: exim-4.91-allow-filter.patch
Patch21: exim-4.87-localhost-is-local.patch
Patch22: exim-4.90.1-greylist-conf.patch
Patch23: exim-4.90.1-smarthost-config.patch
Patch25: exim-4.90.1-dynlookup-config.patch
Patch22: exim-4.91-greylist-conf.patch
Patch23: exim-4.91-smarthost-config.patch
Patch26: exim-4.85-pic.patch
Patch27: exim-4.90.1-environment.patch
# Backported from upstream
Patch28: exim-4.90.1-dec64table-read-fix.patch
Requires: /etc/pki/tls/certs /etc/pki/tls/private
Requires: /etc/aliases
@ -224,10 +221,8 @@ greylisting unconditional.
%patch21 -p1 -b .localhost
%patch22 -p1 -b .grey
%patch23 -p1 -b .smarthost
%patch25 -p1 -b .dynconfig
%patch26 -p1 -b .fpic
%patch27 -p1 -b .environment
%patch28 -p1 -b .dec64table-read-fix
cp src/EDITME Local/Makefile
sed -i 's@^# LOOKUP_MODULE_DIR=.*@LOOKUP_MODULE_DIR=%{_libdir}/exim/%{version}-%{release}/lookups@' Local/Makefile
@ -620,6 +615,13 @@ test "$1" = 0 || %{_initrddir}/clamd.exim condrestart >/dev/null 2>&1 || :
%{_sysconfdir}/cron.daily/greylist-tidy.sh
%changelog
* Mon Aug 20 2018 Jaroslav Škarvada <jskarvad@redhat.com> - 4.91-1
- New version
Resolves: rhbz#1615158
- Dropped dynlookup-config patch (merged into config patch)
- Dropped dec64table-read-fix patch (already upstream)
- De-fuzzified patches
* Wed Mar 14 2018 Jaroslav Škarvada <jskarvad@redhat.com> - 4.90.1-3
- Fixed dec64table OOB read in b64decode

View File

@ -1,2 +1,2 @@
SHA512 (sa-exim-4.2.tar.gz) = 2c1839c4d897bf65d19c754bbc9dc0674276ccad4a564c639591396afc23f1456decceec94817f62ee9b688f5d6d90436d3d47c869e04a69c955b1376c9fbd7b
SHA512 (exim-4.90.1.tar.xz) = b4830a2e03023b2bafc9e62535f467bb61b0f1398b6b3af0a7ef6f49e6cba60a9496e6762d0898b7ac1c2823db8cf96ed9f37e26b05809b4ba01725d9e72b806
SHA512 (exim-4.91.tar.xz) = 35b34dda8dd0f27c0429e6eb8409756ecd3cf9e535bac421d696b1560db0ff3bf4cd0e4a00bc0b7e32137d31bb5de20776c7c1830ec125aa36b5c4376b0c71a2