Add minimal support for riscv64

Signed-off-by: David Abdurachmanov <davidlt@rivosinc.com>
This commit is contained in:
David Abdurachmanov 2023-04-28 16:58:23 +03:00
parent 73eb0d0a95
commit 6b30bd26f8
Signed by: davidlt
GPG Key ID: 8B7F1DA0E2C9FDBB
2 changed files with 117 additions and 1 deletions

View File

@ -0,0 +1,112 @@
From 353286ad47b73fc2d2b790fff8df4782595e1242 Mon Sep 17 00:00:00 2001
From: rpm-build <rpm-build>
Date: Mon, 28 Jan 2019 08:49:23 +0000
Subject: [PATCH] Add minimal support for RISC-V 64-bit (riscv64)
Signed-off-by: rpm-build <rpm-build>
---
src/Makefile.am | 2 +-
src/Makefile.in | 7 ++++---
src/arch-riscv64.c | 38 ++++++++++++++++++++++++++++++++++++++
3 files changed, 43 insertions(+), 4 deletions(-)
create mode 100644 src/arch-riscv64.c
diff --git a/src/Makefile.am b/src/Makefile.am
index a4c65f2..28ea4a6 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -13,7 +13,7 @@ bin_PROGRAMS = execstack
arch_SOURCES = arch-i386.c arch-alpha.c arch-ppc.c arch-ppc64.c \
arch-sparc.c arch-sparc64.c arch-x86_64.c arch-mips.c \
arch-s390.c arch-s390x.c arch-arm.c arch-sh.c arch-ia64.c \
- arch-aarch64.c
+ arch-aarch64.c arch-riscv64.c
common_SOURCES = checksum.c data.c dso.c dwarf2.c dwarf2.h fptr.c fptr.h \
hashtab.c hashtab.h mdebug.c prelink.h stabs.c crc32.c
prelink_SOURCES = cache.c conflict.c cxx.c doit.c exec.c execle_open.c get.c \
diff --git a/src/Makefile.in b/src/Makefile.in
index 863dc83..9a9f555 100644
--- a/src/Makefile.in
+++ b/src/Makefile.in
@@ -108,7 +108,7 @@ bin_PROGRAMS = execstack
arch_SOURCES = arch-i386.c arch-alpha.c arch-ppc.c arch-ppc64.c \
arch-sparc.c arch-sparc64.c arch-x86_64.c arch-mips.c \
arch-s390.c arch-s390x.c arch-arm.c arch-sh.c arch-ia64.c \
- arch-aarch64.c
+ arch-aarch64.c arch-riscv64.c
common_SOURCES = checksum.c data.c dso.c dwarf2.c dwarf2.h fptr.c fptr.h \
hashtab.c hashtab.h mdebug.c prelink.h stabs.c crc32.c
@@ -141,7 +141,7 @@ am__objects_2 = arch-i386.$(OBJEXT) arch-alpha.$(OBJEXT) \
arch-sparc64.$(OBJEXT) arch-x86_64.$(OBJEXT) \
arch-mips.$(OBJEXT) arch-s390.$(OBJEXT) arch-s390x.$(OBJEXT) \
arch-arm.$(OBJEXT) arch-sh.$(OBJEXT) arch-ia64.$(OBJEXT) \
- arch-aarch64.$(OBJEXT)
+ arch-aarch64.$(OBJEXT) arch-riscv64.$(OBJEXT)
am_execstack_OBJECTS = execstack.$(OBJEXT) $(am__objects_1) \
$(am__objects_2)
execstack_OBJECTS = $(am_execstack_OBJECTS)
@@ -169,7 +169,7 @@ am__depfiles_maybe = depfiles
@AMDEP_TRUE@ ./$(DEPDIR)/arch-ppc.Po ./$(DEPDIR)/arch-ppc64.Po \
@AMDEP_TRUE@ ./$(DEPDIR)/arch-s390.Po ./$(DEPDIR)/arch-s390x.Po \
@AMDEP_TRUE@ ./$(DEPDIR)/arch-sh.Po ./$(DEPDIR)/arch-sparc.Po \
-@AMDEP_TRUE@ ./$(DEPDIR)/arch-sparc64.Po \
+@AMDEP_TRUE@ ./$(DEPDIR)/arch-sparc64.Po ./$(DEPDIR)/arch-riscv64.Po \
@AMDEP_TRUE@ ./$(DEPDIR)/arch-x86_64.Po ./$(DEPDIR)/cache.Po \
@AMDEP_TRUE@ ./$(DEPDIR)/canonicalize.Po ./$(DEPDIR)/checksum.Po \
@AMDEP_TRUE@ ./$(DEPDIR)/conflict.Po ./$(DEPDIR)/crc32.Po \
@@ -291,6 +291,7 @@ distclean-compile:
@AMDEP_TRUE@@am__include@ @am__quote@./$(DEPDIR)/arch-sparc.Po@am__quote@
@AMDEP_TRUE@@am__include@ @am__quote@./$(DEPDIR)/arch-sparc64.Po@am__quote@
@AMDEP_TRUE@@am__include@ @am__quote@./$(DEPDIR)/arch-x86_64.Po@am__quote@
+@AMDEP_TRUE@@am__include@ @am__quote@./$(DEPDIR)/arch-riscv64.Po@am__quote@
@AMDEP_TRUE@@am__include@ @am__quote@./$(DEPDIR)/cache.Po@am__quote@
@AMDEP_TRUE@@am__include@ @am__quote@./$(DEPDIR)/canonicalize.Po@am__quote@
@AMDEP_TRUE@@am__include@ @am__quote@./$(DEPDIR)/checksum.Po@am__quote@
diff --git a/src/arch-riscv64.c b/src/arch-riscv64.c
new file mode 100644
index 0000000..ceecc0f
--- /dev/null
+++ b/src/arch-riscv64.c
@@ -0,0 +1,38 @@
+/* Copyright (C) 2019 David Abdurachmanov
+ Written by David Abdurachmanov <david.abdurachmanov@gmail.com>, 2019.
+
+ This program is free software; you can redistribute it and/or modify
+ it under the terms of the GNU General Public License as published by
+ the Free Software Foundation; either version 2, or (at your option)
+ any later version.
+
+ This program is distributed in the hope that it will be useful,
+ but WITHOUT ANY WARRANTY; without even the implied warranty of
+ MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+ GNU General Public License for more details.
+
+ You should have received a copy of the GNU General Public License
+ along with this program; if not, write to the Free Software Foundation,
+ Inc., 59 Temple Place - Suite 330, Boston, MA 02111-1307, USA. */
+
+#include <config.h>
+#include <assert.h>
+#include <errno.h>
+#include <fcntl.h>
+#include <stdio.h>
+#include <string.h>
+#include <locale.h>
+#include <error.h>
+#include <argp.h>
+#include <stdlib.h>
+
+#include "prelink.h"
+
+PL_ARCH = {
+ .name = "RISCV64",
+ .class = ELFCLASS64,
+ .machine = EM_RISCV,
+ .alternate_machine = { EM_NONE },
+ .max_page_size = 0x1000,
+ .page_size = 0x1000
+};
--
2.20.1

View File

@ -1,6 +1,6 @@
Name: execstack
Version: 0.5.0
Release: 25%{?dist}
Release: 25.0.riscv64%{?dist}
Summary: Utility to set/clear/query executable stack bit
%global commit 4c79120bcdbde0616f592458ccde7035e92ca3d8
@ -12,6 +12,7 @@ Source0: https://github.com/keszybz/prelink/archive/%{commit}.tar.gz#/prelink-%{
Patch0: Add-PL_ARCH-for-AArch64.patch
Patch1: execstack-configure-c99.patch
Patch2: 0001-Add-minimal-support-for-RISC-V-64-bit-riscv64.patch
BuildRequires: gcc
BuildRequires: gcc-c++
@ -59,6 +60,9 @@ install -Dm0644 doc/execstack.8 %{buildroot}%{_mandir}/man8/execstack.8
%{_mandir}/man8/execstack.8.*
%changelog
* Fri Apr 28 2023 David Abdurachmanov <davidlt@rivosinc.com> - 0.5.0-25.0.riscv64
- Add minimal support for riscv64
* Thu Jan 19 2023 Fedora Release Engineering <releng@fedoraproject.org> - 0.5.0-25
- Rebuilt for https://fedoraproject.org/wiki/Fedora_38_Mass_Rebuild