Update to 40.0
This commit is contained in:
parent
0999f65685
commit
eb43449f3b
1
.gitignore
vendored
1
.gitignore
vendored
@ -96,3 +96,4 @@ evince-3.0.0.tar.bz2
|
||||
/evince-3.38.0.tar.xz
|
||||
/evince-3.39.1.tar.xz
|
||||
/evince-3.39.2.tar.xz
|
||||
/evince-40.0.tar.xz
|
||||
|
@ -1,39 +0,0 @@
|
||||
From e56653558be1cb8ab2411437bd411f5c1812d0aa Mon Sep 17 00:00:00 2001
|
||||
From: Marek Kasik <mkasik@redhat.com>
|
||||
Date: Wed, 3 Mar 2021 17:15:58 +0100
|
||||
Subject: [PATCH] window: Set page cache size with correct type
|
||||
|
||||
ev_view_set_page_cache_size() accepts gsize as its second parameter
|
||||
but guint was passed in. This reduced maximal cache size considerably
|
||||
as its size is 4 bytes.
|
||||
Retyping the multiplication by "1024 * 1024" to gsize increases maximal
|
||||
configurable cache size beyond 4 GiB.
|
||||
---
|
||||
shell/ev-window.c | 4 ++--
|
||||
1 file changed, 2 insertions(+), 2 deletions(-)
|
||||
|
||||
diff --git a/shell/ev-window.c b/shell/ev-window.c
|
||||
index ba282e18..077d577d 100644
|
||||
--- a/shell/ev-window.c
|
||||
+++ b/shell/ev-window.c
|
||||
@@ -1554,7 +1554,7 @@ page_cache_size_changed (GSettings *settings,
|
||||
|
||||
page_cache_mb = g_settings_get_uint (settings, GS_PAGE_CACHE_SIZE);
|
||||
ev_view_set_page_cache_size (EV_VIEW (priv->view),
|
||||
- page_cache_mb * 1024 * 1024);
|
||||
+ (gsize) page_cache_mb * 1024 * 1024);
|
||||
}
|
||||
|
||||
static void
|
||||
@@ -7636,7 +7636,7 @@ ev_window_init (EvWindow *ev_window)
|
||||
page_cache_mb = g_settings_get_uint (ev_window_ensure_settings (ev_window),
|
||||
GS_PAGE_CACHE_SIZE);
|
||||
ev_view_set_page_cache_size (EV_VIEW (priv->view),
|
||||
- page_cache_mb * 1024 * 1024);
|
||||
+ (gsize) page_cache_mb * 1024 * 1024);
|
||||
allow_links_change_zoom = g_settings_get_boolean (ev_window_ensure_settings (ev_window),
|
||||
GS_ALLOW_LINKS_CHANGE_ZOOM);
|
||||
ev_view_set_allow_links_change_zoom (EV_VIEW (priv->view),
|
||||
--
|
||||
2.30.1
|
||||
|
13
evince.spec
13
evince.spec
@ -5,15 +5,17 @@
|
||||
%global synctex_version 1.19
|
||||
|
||||
Name: evince
|
||||
Version: 3.39.2
|
||||
Release: 2%{?dist}
|
||||
Version: 40.0
|
||||
Release: 1%{?dist}
|
||||
Summary: Document viewer
|
||||
|
||||
License: GPLv2+ and GPLv3+ and LGPLv2+ and MIT and Afmparse
|
||||
URL: https://wiki.gnome.org/Apps/Evince
|
||||
Source0: https://download.gnome.org/sources/%{name}/3.39/%{name}-%{version}.tar.xz
|
||||
Source0: https://download.gnome.org/sources/%{name}/40/%{name}-%{version}.tar.xz
|
||||
|
||||
Patch0: 0001-window-Set-page-cache-size-with-correct-type.patch
|
||||
# Avoid changing soname
|
||||
# https://gitlab.gnome.org/GNOME/evince/-/merge_requests/332
|
||||
Patch0: soname.patch
|
||||
|
||||
BuildRequires: gcc-c++
|
||||
BuildRequires: gcc
|
||||
@ -258,6 +260,9 @@ desktop-file-validate $RPM_BUILD_ROOT%{_datadir}/applications/org.gnome.Evince-p
|
||||
%{_mandir}/man1/evince-thumbnailer.1*
|
||||
|
||||
%changelog
|
||||
* Fri Mar 26 2021 Kalev Lember <klember@redhat.com> - 40.0-1
|
||||
- Update to 40.0
|
||||
|
||||
* Wed Mar 03 2021 Marek Kasik <mkasik@redhat.com> - 3.39.2-2
|
||||
- Set page cache size with correct type
|
||||
- Resolves: #1458845
|
||||
|
66
soname.patch
Normal file
66
soname.patch
Normal file
@ -0,0 +1,66 @@
|
||||
From ca4b7aaff690095971de96370317fdf1bcd3af8f Mon Sep 17 00:00:00 2001
|
||||
From: Kalev Lember <klember@redhat.com>
|
||||
Date: Fri, 26 Mar 2021 14:48:51 +0100
|
||||
Subject: [PATCH] Avoid changing soname
|
||||
|
||||
Bumping the major version to 40 in commit
|
||||
288be740b5bbb59757db5038ab435ceb7a334dcf inadvertently changed the
|
||||
soname for shared libevdocument and libevview.
|
||||
|
||||
Fix this by making the soname calculation independent from the project
|
||||
version as the library ABI hasn't actually changed.
|
||||
---
|
||||
libdocument/meson.build | 2 +-
|
||||
libview/meson.build | 2 +-
|
||||
meson.build | 4 ++--
|
||||
3 files changed, 4 insertions(+), 4 deletions(-)
|
||||
|
||||
diff --git a/libdocument/meson.build b/libdocument/meson.build
|
||||
index 74fe2fb1..e09de7fc 100644
|
||||
--- a/libdocument/meson.build
|
||||
+++ b/libdocument/meson.build
|
||||
@@ -138,7 +138,7 @@ cflags = [
|
||||
]
|
||||
|
||||
libevdocument = shared_library(
|
||||
- 'evdocument' + ev_major_version.to_string(),
|
||||
+ 'evdocument3',
|
||||
version: ev_document_version,
|
||||
sources: sources + enum_sources + [version_header],
|
||||
include_directories: top_inc,
|
||||
diff --git a/libview/meson.build b/libview/meson.build
|
||||
index 20179aff..74c86d51 100644
|
||||
--- a/libview/meson.build
|
||||
+++ b/libview/meson.build
|
||||
@@ -82,7 +82,7 @@ if enable_multimedia
|
||||
endif
|
||||
|
||||
libevview = shared_library(
|
||||
- 'evview' + ev_major_version.to_string(),
|
||||
+ 'evview3',
|
||||
version: ev_view_version,
|
||||
sources: sources + marshal_sources + enum_sources,
|
||||
include_directories: top_inc,
|
||||
diff --git a/meson.build b/meson.build
|
||||
index 1ed37e96..cafb9023 100644
|
||||
--- a/meson.build
|
||||
+++ b/meson.build
|
||||
@@ -43,13 +43,13 @@ ev_document_version = '@0@.@1@.@2@'.format(ev_document_current, ev_document_revi
|
||||
ev_document_current_minus_age = ev_document_current - ev_document_age
|
||||
|
||||
# Libtool version of the view library
|
||||
-ev_view_current = ev_major_version
|
||||
+ev_view_current = 3
|
||||
ev_view_revision = 0
|
||||
ev_view_age = 0
|
||||
ev_view_version = '@0@.@1@.@2@'.format(ev_view_current, ev_view_revision, ev_view_age)
|
||||
ev_view_current_minus_age = ev_view_current - ev_view_age
|
||||
|
||||
-ev_api_version = '@0@.0'.format(ev_major_version)
|
||||
+ev_api_version = '3.0'
|
||||
|
||||
ev_include_subdir = join_paths(ev_name, ev_api_version)
|
||||
|
||||
--
|
||||
2.30.2
|
||||
|
2
sources
2
sources
@ -1 +1 @@
|
||||
SHA512 (evince-3.39.2.tar.xz) = 978322943d53a8b6687e0823b5f87d6d3bc706931eecf677a78a1ef0919ecc3ee67485eb3d829f993b2560ffa41253bc63514bed390ce36686feabab97f1262e
|
||||
SHA512 (evince-40.0.tar.xz) = 995693e4a6e1a3bb31e1d4f3538dc53519102a5a6afa58ba61454a1e2ca582df26bd368876210fce6fab8ff4e218305644fa7a7a88c99e1a1ca5bda8d8f1ece2
|
||||
|
Loading…
Reference in New Issue
Block a user