Update to 3.24.0
This commit is contained in:
parent
2ba5fb704f
commit
b466d7087b
1
.gitignore
vendored
1
.gitignore
vendored
@ -63,3 +63,4 @@ evince-3.0.0.tar.bz2
|
|||||||
/evince-3.21.92.tar.xz
|
/evince-3.21.92.tar.xz
|
||||||
/evince-3.22.0.tar.xz
|
/evince-3.22.0.tar.xz
|
||||||
/evince-3.22.1.tar.xz
|
/evince-3.22.1.tar.xz
|
||||||
|
/evince-3.24.0.tar.xz
|
||||||
|
@ -1,33 +0,0 @@
|
|||||||
From 15e7b658315d0a9254e5c2ff7fcc1a15a15dceef Mon Sep 17 00:00:00 2001
|
|
||||||
From: =?UTF-8?q?Caol=C3=A1n=20McNamara?= <caolanm@redhat.com>
|
|
||||||
Date: Fri, 9 Dec 2016 12:09:02 +0000
|
|
||||||
Subject: [PATCH] gnome#692552 don't complain about inability to copy metadata
|
|
||||||
|
|
||||||
related rhbz#1022649
|
|
||||||
|
|
||||||
nautilus just takes the view that copying metadata is a "nice to have",
|
|
||||||
but if it doesn't work it's not a hard error so just do that
|
|
||||||
---
|
|
||||||
libview/ev-jobs.c | 6 ++++--
|
|
||||||
1 file changed, 4 insertions(+), 2 deletions(-)
|
|
||||||
|
|
||||||
diff --git a/libview/ev-jobs.c b/libview/ev-jobs.c
|
|
||||||
index dea5aa4..f24808b 100644
|
|
||||||
--- a/libview/ev-jobs.c
|
|
||||||
+++ b/libview/ev-jobs.c
|
|
||||||
@@ -1574,8 +1574,10 @@ ev_job_save_run (EvJob *job)
|
|
||||||
ev_tmp_uri_unlink (local_uri);
|
|
||||||
|
|
||||||
/* Copy the metadata from the original file */
|
|
||||||
- if (!error)
|
|
||||||
- ev_file_copy_metadata (job_save->document_uri, job_save->uri, &error);
|
|
||||||
+ if (!error) {
|
|
||||||
+ /* Ignore errors here. Failure to copy metadata is not a hard error */
|
|
||||||
+ ev_file_copy_metadata (job_save->document_uri, job_save->uri, NULL);
|
|
||||||
+ }
|
|
||||||
|
|
||||||
if (error) {
|
|
||||||
ev_job_failed_from_error (job, error);
|
|
||||||
--
|
|
||||||
2.9.3
|
|
||||||
|
|
11
evince.spec
11
evince.spec
@ -4,17 +4,15 @@
|
|||||||
%global gxps_version 0.2.1
|
%global gxps_version 0.2.1
|
||||||
|
|
||||||
Name: evince
|
Name: evince
|
||||||
Version: 3.22.1
|
Version: 3.24.0
|
||||||
Release: 6%{?dist}
|
Release: 1%{?dist}
|
||||||
Summary: Document viewer
|
Summary: Document viewer
|
||||||
|
|
||||||
License: GPLv2+ and GPLv3+ and LGPLv2+ and MIT and Afmparse
|
License: GPLv2+ and GPLv3+ and LGPLv2+ and MIT and Afmparse
|
||||||
URL: https://wiki.gnome.org/Apps/Evince
|
URL: https://wiki.gnome.org/Apps/Evince
|
||||||
Source0: https://download.gnome.org/sources/%{name}/3.22/%{name}-%{version}.tar.xz
|
Source0: https://download.gnome.org/sources/%{name}/3.24/%{name}-%{version}.tar.xz
|
||||||
|
|
||||||
Patch0: evince-3.21.4-NPNVToolKit.patch
|
Patch0: evince-3.21.4-NPNVToolKit.patch
|
||||||
#https://bugzilla.gnome.org/show_bug.cgi?id=692552
|
|
||||||
Patch1: 0001-gnome-692552-don-t-complain-about-inability-to-copy-.patch
|
|
||||||
#https://bugzilla.gnome.org/show_bug.cgi?id=777082
|
#https://bugzilla.gnome.org/show_bug.cgi?id=777082
|
||||||
Patch2: 0001-Resolves-rhbz-1404656-crash-on-opening-second-evince.patch
|
Patch2: 0001-Resolves-rhbz-1404656-crash-on-opening-second-evince.patch
|
||||||
#https://bugzilla.gnome.org/show_bug.cgi?id=766749
|
#https://bugzilla.gnome.org/show_bug.cgi?id=766749
|
||||||
@ -267,6 +265,9 @@ glib-compile-schemas %{_datadir}/glib-2.0/schemas >&/dev/null ||:
|
|||||||
%{_libdir}/mozilla/plugins/libevbrowserplugin.so
|
%{_libdir}/mozilla/plugins/libevbrowserplugin.so
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Tue Mar 21 2017 Kalev Lember <klember@redhat.com> - 3.24.0-1
|
||||||
|
- Update to 3.24.0
|
||||||
|
|
||||||
* Fri Feb 10 2017 Fedora Release Engineering <releng@fedoraproject.org> - 3.22.1-6
|
* Fri Feb 10 2017 Fedora Release Engineering <releng@fedoraproject.org> - 3.22.1-6
|
||||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_26_Mass_Rebuild
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_26_Mass_Rebuild
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user