parent
6f9ee2dac2
commit
b2576a436b
24
0001-find-sidebar-Fix-memory-leak.patch
Normal file
24
0001-find-sidebar-Fix-memory-leak.patch
Normal file
@ -0,0 +1,24 @@
|
|||||||
|
From 26e52726991f3eb7dac90470ff88dc000348b1f3 Mon Sep 17 00:00:00 2001
|
||||||
|
From: Carlos Garcia Campos <carlosgc@gnome.org>
|
||||||
|
Date: Sun, 10 Aug 2014 13:05:56 +0200
|
||||||
|
Subject: [PATCH] find-sidebar: Fix memory leak
|
||||||
|
|
||||||
|
---
|
||||||
|
shell/ev-find-sidebar.c | 1 +
|
||||||
|
1 file changed, 1 insertion(+)
|
||||||
|
|
||||||
|
diff --git a/shell/ev-find-sidebar.c b/shell/ev-find-sidebar.c
|
||||||
|
index 0f7a336..c9882e3 100644
|
||||||
|
--- a/shell/ev-find-sidebar.c
|
||||||
|
+++ b/shell/ev-find-sidebar.c
|
||||||
|
@@ -402,6 +402,7 @@ process_matches_idle (EvFindSidebar *sidebar)
|
||||||
|
|
||||||
|
page = ev_document_get_page (document, current_page);
|
||||||
|
page_text = get_page_text (document, page, &areas, &n_areas);
|
||||||
|
+ g_object_unref (page);
|
||||||
|
if (!page_text)
|
||||||
|
continue;
|
||||||
|
|
||||||
|
--
|
||||||
|
2.1.0
|
||||||
|
|
10
evince.spec
10
evince.spec
@ -5,7 +5,7 @@
|
|||||||
|
|
||||||
Name: evince
|
Name: evince
|
||||||
Version: 3.10.3
|
Version: 3.10.3
|
||||||
Release: 1%{?dist}
|
Release: 2%{?dist}
|
||||||
Summary: Document viewer
|
Summary: Document viewer
|
||||||
|
|
||||||
License: GPLv2+ and GPLv3+ and LGPLv2+ and MIT and Afmparse
|
License: GPLv2+ and GPLv3+ and LGPLv2+ and MIT and Afmparse
|
||||||
@ -13,6 +13,9 @@ Group: Applications/Publishing
|
|||||||
URL: http://projects.gnome.org/evince/
|
URL: http://projects.gnome.org/evince/
|
||||||
Source0: http://download.gnome.org/sources/%{name}/3.10/%{name}-%{version}.tar.xz
|
Source0: http://download.gnome.org/sources/%{name}/3.10/%{name}-%{version}.tar.xz
|
||||||
|
|
||||||
|
# https://bugzilla.redhat.com/show_bug.cgi?id=1147619
|
||||||
|
Patch0: 0001-find-sidebar-Fix-memory-leak.patch
|
||||||
|
|
||||||
BuildRequires: gtk3-devel
|
BuildRequires: gtk3-devel
|
||||||
BuildRequires: glib2-devel >= %{glib2_version}
|
BuildRequires: glib2-devel >= %{glib2_version}
|
||||||
BuildRequires: poppler-glib-devel >= %{poppler_version}
|
BuildRequires: poppler-glib-devel >= %{poppler_version}
|
||||||
@ -106,6 +109,7 @@ It adds an additional tab called "Document" to the file properties dialog.
|
|||||||
|
|
||||||
%prep
|
%prep
|
||||||
%setup -q
|
%setup -q
|
||||||
|
%patch0 -p1 -b .search-leak
|
||||||
|
|
||||||
%build
|
%build
|
||||||
./autogen.sh
|
./autogen.sh
|
||||||
@ -216,6 +220,10 @@ glib-compile-schemas %{_datadir}/glib-2.0/schemas >&/dev/null ||:
|
|||||||
%{_libdir}/nautilus/extensions-3.0/libevince-properties-page.so
|
%{_libdir}/nautilus/extensions-3.0/libevince-properties-page.so
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Tue Nov 18 2014 Marek Kasik <mkasik@redhat.com> - 3.10.3-2
|
||||||
|
- Fix a memory leak in find-sidebar
|
||||||
|
- Resolves: #1147619
|
||||||
|
|
||||||
* Mon Nov 18 2013 Marek Kasik <mkasik@redhat.com> - 3.10.3-1
|
* Mon Nov 18 2013 Marek Kasik <mkasik@redhat.com> - 3.10.3-1
|
||||||
- Update to 3.10.3
|
- Update to 3.10.3
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user