parent
50afed4a2d
commit
6c3b2d2773
43
evince-3.24.2-media-player-keys.patch
Normal file
43
evince-3.24.2-media-player-keys.patch
Normal file
@ -0,0 +1,43 @@
|
|||||||
|
diff --git a/shell/ev-media-player-keys.c b/shell/ev-media-player-keys.c
|
||||||
|
index a0075edc..63a1344c 100644
|
||||||
|
--- a/shell/ev-media-player-keys.c
|
||||||
|
+++ b/shell/ev-media-player-keys.c
|
||||||
|
@@ -41,8 +41,9 @@ struct _EvMediaPlayerKeys
|
||||||
|
{
|
||||||
|
GObject parent;
|
||||||
|
|
||||||
|
- GDBusProxy *proxy;
|
||||||
|
- gboolean has_name_owner;
|
||||||
|
+ GDBusProxy *proxy;
|
||||||
|
+ gboolean has_name_owner;
|
||||||
|
+ GCancellable *service_appearance_cancellable;
|
||||||
|
};
|
||||||
|
|
||||||
|
struct _EvMediaPlayerKeysClass
|
||||||
|
@@ -187,13 +188,15 @@ mediakeys_service_appeared_cb (GObject *source_object,
|
||||||
|
static void
|
||||||
|
ev_media_player_keys_init (EvMediaPlayerKeys *keys)
|
||||||
|
{
|
||||||
|
+ keys->service_appearance_cancellable = g_cancellable_new ();
|
||||||
|
+
|
||||||
|
g_dbus_proxy_new_for_bus (G_BUS_TYPE_SESSION,
|
||||||
|
G_DBUS_PROXY_FLAGS_DO_NOT_LOAD_PROPERTIES,
|
||||||
|
NULL,
|
||||||
|
SD_NAME,
|
||||||
|
SD_OBJECT_PATH,
|
||||||
|
SD_INTERFACE,
|
||||||
|
- NULL,
|
||||||
|
+ keys->service_appearance_cancellable,
|
||||||
|
mediakeys_service_appeared_cb,
|
||||||
|
keys);
|
||||||
|
}
|
||||||
|
@@ -212,6 +215,9 @@ ev_media_player_keys_finalize (GObject *object)
|
||||||
|
{
|
||||||
|
EvMediaPlayerKeys *keys = EV_MEDIA_PLAYER_KEYS (object);
|
||||||
|
|
||||||
|
+ g_cancellable_cancel (keys->service_appearance_cancellable);
|
||||||
|
+ g_object_unref (keys->service_appearance_cancellable);
|
||||||
|
+
|
||||||
|
if (keys->proxy != NULL) {
|
||||||
|
ev_media_player_keys_release_keys (keys);
|
||||||
|
g_object_unref (keys->proxy);
|
16
evince.spec
16
evince.spec
@ -5,7 +5,7 @@
|
|||||||
|
|
||||||
Name: evince
|
Name: evince
|
||||||
Version: 3.24.2
|
Version: 3.24.2
|
||||||
Release: 2%{?dist}
|
Release: 3%{?dist}
|
||||||
Summary: Document viewer
|
Summary: Document viewer
|
||||||
|
|
||||||
License: GPLv2+ and GPLv3+ and LGPLv2+ and MIT and Afmparse
|
License: GPLv2+ and GPLv3+ and LGPLv2+ and MIT and Afmparse
|
||||||
@ -13,15 +13,17 @@ URL: https://wiki.gnome.org/Apps/Evince
|
|||||||
Source0: https://download.gnome.org/sources/%{name}/3.24/%{name}-%{version}.tar.xz
|
Source0: https://download.gnome.org/sources/%{name}/3.24/%{name}-%{version}.tar.xz
|
||||||
|
|
||||||
Patch0: evince-3.21.4-NPNVToolKit.patch
|
Patch0: evince-3.21.4-NPNVToolKit.patch
|
||||||
#https://bugzilla.gnome.org/show_bug.cgi?id=777082
|
# https://bugzilla.gnome.org/show_bug.cgi?id=777082
|
||||||
Patch2: 0001-Resolves-rhbz-1404656-crash-on-opening-second-evince.patch
|
Patch2: 0001-Resolves-rhbz-1404656-crash-on-opening-second-evince.patch
|
||||||
#https://bugzilla.gnome.org/show_bug.cgi?id=766749
|
# https://bugzilla.gnome.org/show_bug.cgi?id=766749
|
||||||
Patch3: 0001-Resolves-deb-762530-rhbz-1061177-add-man-pages.patch
|
Patch3: 0001-Resolves-deb-762530-rhbz-1061177-add-man-pages.patch
|
||||||
Patch4: 0001-Resolves-rhbz-1358249-page-up-down.patch
|
Patch4: 0001-Resolves-rhbz-1358249-page-up-down.patch
|
||||||
#https://bugzilla.redhat.com/show_bug.cgi?id=1468488
|
# https://bugzilla.redhat.com/show_bug.cgi?id=1468488
|
||||||
Patch5: evince-libarchive-gnome-3-24.patch
|
Patch5: evince-libarchive-gnome-3-24.patch
|
||||||
#https://bugzilla.gnome.org/show_bug.cgi?id=784947
|
# https://bugzilla.gnome.org/show_bug.cgi?id=784947
|
||||||
Patch6: 0001-dvi-Mitigate-command-injection-attacks-by-quoting-fi.patch
|
Patch6: 0001-dvi-Mitigate-command-injection-attacks-by-quoting-fi.patch
|
||||||
|
# https://bugzilla.redhat.com/show_bug.cgi?id=1359507
|
||||||
|
Patch7: evince-3.24.2-media-player-keys.patch
|
||||||
|
|
||||||
BuildRequires: pkgconfig(adwaita-icon-theme)
|
BuildRequires: pkgconfig(adwaita-icon-theme)
|
||||||
BuildRequires: pkgconfig(gio-unix-2.0) >= %{glib2_version}
|
BuildRequires: pkgconfig(gio-unix-2.0) >= %{glib2_version}
|
||||||
@ -268,6 +270,10 @@ glib-compile-schemas %{_datadir}/glib-2.0/schemas >&/dev/null ||:
|
|||||||
%{_libdir}/mozilla/plugins/libevbrowserplugin.so
|
%{_libdir}/mozilla/plugins/libevbrowserplugin.so
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Wed May 9 2018 Marek Kasik <mkasik@redhat.com> - 3.24.2-3
|
||||||
|
- Fix crash in EvMediaPlayerKeys
|
||||||
|
- Resolves: #1359507
|
||||||
|
|
||||||
* Wed Dec 06 2017 Caolán McNamara <caolanm@redhat.com> - 3.24.2-2
|
* Wed Dec 06 2017 Caolán McNamara <caolanm@redhat.com> - 3.24.2-2
|
||||||
- Resolves: rhbz#1521212 CVE-2017-1000159
|
- Resolves: rhbz#1521212 CVE-2017-1000159
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user