- Update required versions of libraries
- Remove unused patches
This commit is contained in:
parent
d109813853
commit
56f747a30f
@ -1,36 +0,0 @@
|
||||
--- shell/ev-window.c 2008-09-12 14:11:56.000000000 +0200
|
||||
+++ shell/ev-window.c 2008-09-12 17:07:00.000000000 +0200
|
||||
@@ -2283,8 +2283,6 @@ ev_window_print_send (EvWindow *windo
|
||||
|
||||
gtk_print_settings_set_page_ranges (settings, NULL, 0);
|
||||
gtk_print_settings_set_print_pages (settings, GTK_PRINT_PAGES_ALL);
|
||||
- if (capabilities & EV_FILE_EXPORTER_CAN_COPIES)
|
||||
- gtk_print_settings_set_n_copies (settings, 1);
|
||||
if (capabilities & EV_FILE_EXPORTER_CAN_PAGE_SET)
|
||||
gtk_print_settings_set_page_set (settings, GTK_PAGE_SET_ALL);
|
||||
if (capabilities & EV_FILE_EXPORTER_CAN_SCALE)
|
||||
@@ -2371,7 +2369,6 @@ ev_window_print_dialog_response_cb (GtkD
|
||||
EvPrintRange *ranges = NULL;
|
||||
EvPrintPageSet page_set;
|
||||
gint n_ranges = 0;
|
||||
- gint copies;
|
||||
gint pages_per_sheet;
|
||||
gboolean collate;
|
||||
gboolean reverse;
|
||||
@@ -2477,7 +2474,6 @@ ev_window_print_dialog_response_cb (GtkD
|
||||
|
||||
pages_per_sheet = gtk_print_settings_get_number_up (window->priv->print_settings);
|
||||
|
||||
- copies = gtk_print_settings_get_n_copies (window->priv->print_settings);
|
||||
collate = gtk_print_settings_get_collate (window->priv->print_settings);
|
||||
reverse = gtk_print_settings_get_reverse (window->priv->print_settings);
|
||||
|
||||
@@ -2487,7 +2483,7 @@ ev_window_print_dialog_response_cb (GtkD
|
||||
ranges, n_ranges,
|
||||
page_set,
|
||||
pages_per_sheet,
|
||||
- copies, collate,
|
||||
+ 1, collate,
|
||||
reverse);
|
||||
|
||||
g_signal_connect (window->priv->print_job, "finished",
|
@ -1,21 +0,0 @@
|
||||
diff -up evince-2.23.4/shell/ev-window.c.print-error evince-2.23.4/shell/ev-window.c
|
||||
--- evince-2.23.4/shell/ev-window.c.print-error 2008-06-16 16:10:20.000000000 -0400
|
||||
+++ evince-2.23.4/shell/ev-window.c 2008-07-17 16:34:31.000000000 -0400
|
||||
@@ -2244,6 +2244,8 @@ ev_window_print_finished (GtkPrintJob *p
|
||||
if (error) {
|
||||
GtkWidget *dialog;
|
||||
|
||||
+ GDK_THREADS_ENTER ();
|
||||
+
|
||||
dialog = gtk_message_dialog_new (GTK_WINDOW (window),
|
||||
GTK_DIALOG_MODAL,
|
||||
GTK_MESSAGE_ERROR,
|
||||
@@ -2254,6 +2256,8 @@ ev_window_print_finished (GtkPrintJob *p
|
||||
|
||||
gtk_dialog_run (GTK_DIALOG (dialog));
|
||||
gtk_widget_destroy (dialog);
|
||||
+
|
||||
+ GDK_THREADS_LEAVE ();
|
||||
} else {
|
||||
/* If printed successfully, save print settings */
|
||||
ev_application_set_print_settings (EV_APP,
|
@ -1,14 +0,0 @@
|
||||
diff -up evince-2.29.5/configure.ac.libs evince-2.29.5/configure.ac
|
||||
--- evince-2.29.5/configure.ac.libs 2010-02-14 00:26:26.130364459 -0500
|
||||
+++ evince-2.29.5/configure.ac 2010-02-14 00:41:06.780365386 -0500
|
||||
@@ -167,7 +167,9 @@ case "$with_platform" in
|
||||
;;
|
||||
esac
|
||||
|
||||
-PKG_CHECK_MODULES([SHELL_CORE],[libxml-2.0 >= $LIBXML_REQUIRED gtk+-2.0 >= $GTK_REQUIRED gio-2.0 >= $GLIB_REQUIRED gthread-2.0 $SHELL_PLATFORM_PKGS])
|
||||
+PKG_CHECK_MODULES([SHELL_CORE],[libxml-2.0 >= $LIBXML_REQUIRED gtk+-2.0 >= $GTK_REQUIRED gio-2.0 >= $GLIB_REQUIRED gthread-2.0 $SHELL_PLATFORM_PKGS x11])
|
||||
+
|
||||
+SHELL_CORE_LIBS="$SHELL_CORE_LIBS -lm"
|
||||
|
||||
# *********
|
||||
# SM client
|
15
evince.spec
15
evince.spec
@ -1,20 +1,18 @@
|
||||
%global poppler_version 0.10.1
|
||||
%global glib2_version 2.15.0
|
||||
%global poppler_version 0.12.0
|
||||
%global glib2_version 2.18.0
|
||||
%global gtk2_version 2.20.0
|
||||
%global dbus_version 0.60
|
||||
%global dbus_version 0.70
|
||||
%global theme_version 2.17.1
|
||||
|
||||
Name: evince
|
||||
Version: 2.30.0
|
||||
Release: 4%{?dist}
|
||||
Release: 5%{?dist}
|
||||
Summary: Document viewer
|
||||
|
||||
License: GPLv2+ and GFDL
|
||||
Group: Applications/Publishing
|
||||
URL: http://projects.gnome.org/evince/
|
||||
Source0: http://download.gnome.org/sources/%{name}/2.30/%{name}-%{version}.tar.bz2
|
||||
# http://bugzilla.gnome.org/show_bug.cgi?id=455759
|
||||
# Patch1: duplex-copies.patch
|
||||
# https://bugzilla.redhat.com/show_bug.cgi?id=562648
|
||||
Patch2: evince-t1font-mapping.patch
|
||||
Patch3: evince-deprecated-functions.patch
|
||||
@ -114,7 +112,6 @@ adds an additional tab called "Document" to the file properties dialog.
|
||||
|
||||
%prep
|
||||
%setup -q
|
||||
# %patch1 -p0 -b .duplex-copies
|
||||
%patch2 -p1 -b .t1font-map
|
||||
%patch3 -p1 -b .deprecated
|
||||
|
||||
@ -240,6 +237,10 @@ gtk-update-icon-cache %{_datadir}/icons/hicolor >&/dev/null || :
|
||||
%{_libdir}/nautilus/extensions-2.0/libevince-properties-page.so
|
||||
|
||||
%changelog
|
||||
* Fri Apr 2 2010 Marek Kasik <mkasik@redhat.com> - 2.30.0-5
|
||||
- Update required versions of libraries
|
||||
- Remove unused patches
|
||||
|
||||
* Thu Apr 1 2010 Christoph Wickert <cwickert@fedoraproject.org> - 2.30.0-4
|
||||
- Update scriptlets
|
||||
- Make build verbose
|
||||
|
Loading…
Reference in New Issue
Block a user