Update to 3.25.4
This commit is contained in:
parent
a593d59779
commit
3e8eedfcfd
1
.gitignore
vendored
1
.gitignore
vendored
@ -64,3 +64,4 @@ evince-3.0.0.tar.bz2
|
||||
/evince-3.22.0.tar.xz
|
||||
/evince-3.22.1.tar.xz
|
||||
/evince-3.24.0.tar.xz
|
||||
/evince-3.25.4.tar.xz
|
||||
|
@ -1,77 +0,0 @@
|
||||
From ca83dd9054abdaae93308f27bdf927e050230027 Mon Sep 17 00:00:00 2001
|
||||
From: =?UTF-8?q?Caol=C3=A1n=20McNamara?= <caolanm@redhat.com>
|
||||
Date: Tue, 10 Jan 2017 12:04:58 +0000
|
||||
Subject: [PATCH] Resolves: rhbz#1404656 crash on opening second evince window
|
||||
|
||||
e.g.
|
||||
|
||||
export G_SLICE=always-malloc
|
||||
open https://www.antennahouse.com/XSLsample/pdf/sample-link_1.pdf
|
||||
right click on the first link and open in new window
|
||||
close the new window
|
||||
repeat
|
||||
crash
|
||||
|
||||
This is similar to https://bugzilla.gnome.org/show_bug.cgi?id=726812
|
||||
---
|
||||
shell/ev-window.c | 34 ++++++++++++++++++++++++----------
|
||||
1 file changed, 24 insertions(+), 10 deletions(-)
|
||||
|
||||
diff --git a/shell/ev-window.c b/shell/ev-window.c
|
||||
index 11f2fd5..a648ed7 100644
|
||||
--- a/shell/ev-window.c
|
||||
+++ b/shell/ev-window.c
|
||||
@@ -6666,10 +6666,32 @@ _gtk_css_provider_load_from_resource (GtkCssProvider *provider,
|
||||
}
|
||||
|
||||
static void
|
||||
+ev_window_init_css (void)
|
||||
+{
|
||||
+ static gsize initialization_value = 0;
|
||||
+
|
||||
+ if (g_once_init_enter (&initialization_value)) {
|
||||
+ GtkCssProvider *css_provider;
|
||||
+ GError *error = NULL;
|
||||
+
|
||||
+ css_provider = gtk_css_provider_new ();
|
||||
+ _gtk_css_provider_load_from_resource (css_provider,
|
||||
+ "/org/gnome/evince/ui/evince.css",
|
||||
+ &error);
|
||||
+ g_assert_no_error (error);
|
||||
+ gtk_style_context_add_provider_for_screen (gdk_screen_get_default (),
|
||||
+ GTK_STYLE_PROVIDER (css_provider),
|
||||
+ GTK_STYLE_PROVIDER_PRIORITY_APPLICATION);
|
||||
+ g_object_unref (css_provider);
|
||||
+
|
||||
+ g_once_init_leave (&initialization_value, 1);
|
||||
+ }
|
||||
+}
|
||||
+
|
||||
+static void
|
||||
ev_window_init (EvWindow *ev_window)
|
||||
{
|
||||
GtkBuilder *builder;
|
||||
- GtkCssProvider *css_provider;
|
||||
GError *error = NULL;
|
||||
GtkWidget *sidebar_widget;
|
||||
GtkWidget *overlay;
|
||||
@@ -6748,15 +6770,7 @@ ev_window_init (EvWindow *ev_window)
|
||||
actions, G_N_ELEMENTS (actions),
|
||||
ev_window);
|
||||
|
||||
- css_provider = gtk_css_provider_new ();
|
||||
- _gtk_css_provider_load_from_resource (css_provider,
|
||||
- "/org/gnome/evince/ui/evince.css",
|
||||
- &error);
|
||||
- g_assert_no_error (error);
|
||||
- gtk_style_context_add_provider_for_screen (gtk_widget_get_screen (GTK_WIDGET (ev_window)),
|
||||
- GTK_STYLE_PROVIDER (css_provider),
|
||||
- GTK_STYLE_PROVIDER_PRIORITY_APPLICATION);
|
||||
- g_object_unref (css_provider);
|
||||
+ ev_window_init_css ();
|
||||
|
||||
ev_window->priv->recent_manager = gtk_recent_manager_get_default ();
|
||||
|
||||
--
|
||||
2.9.3
|
||||
|
@ -1,82 +0,0 @@
|
||||
From 6480c7039bdf7e8f15f7d1415460db255910c40b Mon Sep 17 00:00:00 2001
|
||||
From: =?UTF-8?q?Nelson=20Ben=C3=ADtez=20Le=C3=B3n?=
|
||||
<nbenitezl+gnome@gmail.com>
|
||||
Date: Sun, 28 May 2017 22:35:05 +0500
|
||||
Subject: [PATCH] sidebar-thumbnails: fix clunky scrolling
|
||||
|
||||
Caused by GtkIconView doing an invalidate and relayout of *all*
|
||||
items in the view anytime we update model data in any indiviual
|
||||
item (which happens with all the items that are getting in and out
|
||||
of the scrolling area while we scroll). This caused GtkIconView to
|
||||
machine-gunned us with "size-allocate" signals, a signal we were
|
||||
using to update thumbnails when the sidebar is resized.
|
||||
|
||||
Fixed by connecting to the GtkTreeModel "row-changed" signal before
|
||||
GtkIconView does it, and stop emission from there.
|
||||
|
||||
As we don't depend now on "size-allocate" signals to show thumbnails
|
||||
while we scroll, just queue a draw on the icon view when a
|
||||
thumbnail finish rendering.
|
||||
|
||||
Thanks Jose Aliste for first spotting the problem.
|
||||
|
||||
https://bugzilla.gnome.org/show_bug.cgi?id=691448
|
||||
---
|
||||
shell/ev-sidebar-thumbnails.c | 24 ++++++++++++++++++++++++
|
||||
1 file changed, 24 insertions(+)
|
||||
|
||||
diff --git a/shell/ev-sidebar-thumbnails.c b/shell/ev-sidebar-thumbnails.c
|
||||
index 253eabf..c22e92e 100644
|
||||
--- a/shell/ev-sidebar-thumbnails.c
|
||||
+++ b/shell/ev-sidebar-thumbnails.c
|
||||
@@ -802,9 +802,26 @@ ev_sidebar_thumbnails_device_scale_factor_changed_cb (EvSidebarThumbnails *sideb
|
||||
}
|
||||
|
||||
static void
|
||||
+ev_sidebar_thumbnails_row_changed (GtkTreeModel *model,
|
||||
+ GtkTreePath *path,
|
||||
+ GtkTreeIter *iter,
|
||||
+ gpointer data)
|
||||
+{
|
||||
+ guint signal_id;
|
||||
+
|
||||
+ signal_id = GPOINTER_TO_UINT (data);
|
||||
+
|
||||
+ /* PREVENT GtkIconView "row-changed" handler to be reached, as it will
|
||||
+ * perform a full invalidate and relayout of all items, See bug:
|
||||
+ * https://bugzilla.gnome.org/show_bug.cgi?id=691448#c9 */
|
||||
+ g_signal_stop_emission (model, signal_id, 0);
|
||||
+}
|
||||
+
|
||||
+static void
|
||||
ev_sidebar_thumbnails_init (EvSidebarThumbnails *ev_sidebar_thumbnails)
|
||||
{
|
||||
EvSidebarThumbnailsPrivate *priv;
|
||||
+ guint signal_id;
|
||||
|
||||
priv = ev_sidebar_thumbnails->priv = EV_SIDEBAR_THUMBNAILS_GET_PRIVATE (ev_sidebar_thumbnails);
|
||||
|
||||
@@ -814,6 +831,11 @@ ev_sidebar_thumbnails_init (EvSidebarThumbnails *ev_sidebar_thumbnails)
|
||||
G_TYPE_BOOLEAN,
|
||||
EV_TYPE_JOB_THUMBNAIL);
|
||||
|
||||
+ signal_id = g_signal_lookup ("row-changed", GTK_TYPE_TREE_MODEL);
|
||||
+ g_signal_connect (GTK_TREE_MODEL (priv->list_store), "row-changed",
|
||||
+ G_CALLBACK (ev_sidebar_thumbnails_row_changed),
|
||||
+ GUINT_TO_POINTER (signal_id));
|
||||
+
|
||||
priv->swindow = gtk_scrolled_window_new (NULL, NULL);
|
||||
|
||||
gtk_scrolled_window_set_policy (GTK_SCROLLED_WINDOW (priv->swindow),
|
||||
@@ -962,6 +984,8 @@ thumbnail_job_completed_callback (EvJobThumbnail *job,
|
||||
COLUMN_JOB, NULL,
|
||||
-1);
|
||||
cairo_surface_destroy (surface);
|
||||
+
|
||||
+ gtk_widget_queue_draw (priv->icon_view);
|
||||
}
|
||||
|
||||
static void
|
||||
--
|
||||
2.9.3
|
||||
|
File diff suppressed because it is too large
Load Diff
13
evince.spec
13
evince.spec
@ -4,24 +4,20 @@
|
||||
%global gxps_version 0.2.1
|
||||
|
||||
Name: evince
|
||||
Version: 3.24.0
|
||||
Release: 4%{?dist}
|
||||
Version: 3.25.4
|
||||
Release: 1%{?dist}
|
||||
Summary: Document viewer
|
||||
|
||||
License: GPLv2+ and GPLv3+ and LGPLv2+ and MIT and Afmparse
|
||||
URL: https://wiki.gnome.org/Apps/Evince
|
||||
Source0: https://download.gnome.org/sources/%{name}/3.24/%{name}-%{version}.tar.xz
|
||||
Source0: https://download.gnome.org/sources/%{name}/3.25/%{name}-%{version}.tar.xz
|
||||
|
||||
Patch0: evince-3.21.4-NPNVToolKit.patch
|
||||
#https://bugzilla.gnome.org/show_bug.cgi?id=777082
|
||||
Patch2: 0001-Resolves-rhbz-1404656-crash-on-opening-second-evince.patch
|
||||
#https://bugzilla.gnome.org/show_bug.cgi?id=766749
|
||||
Patch3: 0001-Resolves-deb-762530-rhbz-1061177-add-man-pages.patch
|
||||
Patch4: 0001-Resolves-rhbz-1358249-page-up-down.patch
|
||||
Patch5: 0001-sidebar-thumbnails-fix-clunky-scrolling.patch
|
||||
Patch6: 0001-Revert-Bump-poppler-requirements-to-0.33.0.patch
|
||||
# https://bugzilla.redhat.com/show_bug.cgi?id=1468488
|
||||
Patch7: evince-libarchive-gnome-3-24.patch
|
||||
|
||||
BuildRequires: pkgconfig(adwaita-icon-theme)
|
||||
BuildRequires: pkgconfig(gio-unix-2.0) >= %{glib2_version}
|
||||
@ -269,6 +265,9 @@ glib-compile-schemas %{_datadir}/glib-2.0/schemas >&/dev/null ||:
|
||||
%{_libdir}/mozilla/plugins/libevbrowserplugin.so
|
||||
|
||||
%changelog
|
||||
* Thu Jul 27 2017 Kalev Lember <klember@redhat.com> - 3.25.4-1
|
||||
- Update to 3.25.4
|
||||
|
||||
* Wed Jul 26 2017 Fedora Release Engineering <releng@fedoraproject.org> - 3.24.0-4
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_27_Mass_Rebuild
|
||||
|
||||
|
2
sources
2
sources
@ -1 +1 @@
|
||||
SHA512 (evince-3.24.0.tar.xz) = b793c44b2976abe58461adfdb0b1874af8d6bafaf9b80a851d94b776f9d50f6a81774bcb5b35cd59a9ad3afeea9a8b88018aa85d670373c7c2fa9617407a09c4
|
||||
SHA512 (evince-3.25.4.tar.xz) = d0d72eeeb935c36ce9185c2ecff763c20926ce12b10565108ff927bd973758754a48ceda99ee1d4e6f27d5abd42e7224a3cce3721263c35e2fc135ea4b026fc9
|
||||
|
Loading…
Reference in New Issue
Block a user