erlang/otp-0003-Fix-for-dlopening-libGL-and-libGLU.patch
Hans Ulrich Niedermann 696873c554 Update erlang.spec and otp-00*.patch without numbers
Update erlang.spec and otp-00*.patch without patch numbers. Those
created too much useless changes in the git history.
2011-01-31 16:27:55 +01:00

29 lines
947 B
Diff

From 576c399f2226f8bdf6ae6f94038d204d5f8693c9 Mon Sep 17 00:00:00 2001
From: Peter Lemenkov <lemenkov@gmail.com>
Date: Fri, 16 Apr 2010 21:13:47 +0400
Subject: [PATCH] Fix for dlopening libGL and libGLU
Signed-off-by: Peter Lemenkov <lemenkov@gmail.com>
---
lib/wx/c_src/egl_impl.cpp | 4 ++--
1 files changed, 2 insertions(+), 2 deletions(-)
diff --git a/lib/wx/c_src/egl_impl.cpp b/lib/wx/c_src/egl_impl.cpp
index e2dbbb7..56e560f 100644
--- a/lib/wx/c_src/egl_impl.cpp
+++ b/lib/wx/c_src/egl_impl.cpp
@@ -70,8 +70,8 @@ typedef char DL_CHAR;
# define OPENGL_LIB "/System/Library/Frameworks/OpenGL.framework/Versions/A/Libraries/libGL.dylib"
# define OPENGLU_LIB "/System/Library/Frameworks/OpenGL.framework/Versions/A/Libraries/libGLU.dylib"
# else
-# define OPENGL_LIB "libGL.so"
-# define OPENGLU_LIB "libGLU.so"
+# define OPENGL_LIB "libGL.so.1"
+# define OPENGLU_LIB "libGLU.so.1"
# endif
#endif
extern "C" {
--
1.7.3.5