erlang/erlang-configure-c99.patch

90 lines
2.2 KiB
Diff

Configure changes to adjust to stricter C99 compilers: Avoid
implicit function declarations, and define main as returning int.
Submitted upstream: <https://github.com/erlang/otp/pull/6504>
diff --git a/erts/configure b/erts/configure
index 815428caaf61c914..7d057e69ae5e3a93 100755
--- a/erts/configure
+++ b/erts/configure
@@ -20529,6 +20529,9 @@ else $as_nop
#ifdef HAVE_MALLOC_H
# include <malloc.h>
#endif
+#ifdef HAVE_UNISTD_H
+# include <unistd.h>
+#endif
#if defined(HAVE_END_SYMBOL)
extern char end;
#elif defined(HAVE__END_SYMBOL)
@@ -24437,10 +24440,13 @@ else $as_nop
/* end confdefs.h. */
#include <poll.h>
-main()
+#ifdef HAVE_FCNTL_H
+#include <fcntl.h>
+#endif
+int main()
{
#ifdef _POLL_EMUL_H_
- exit(1); /* Implemented using select() -- fail */
+ return 1; /* Implemented using select() -- fail */
#else
struct pollfd fds[1];
int fd;
@@ -24449,9 +24455,9 @@ main()
fds[0].events = POLLIN;
fds[0].revents = 0;
if (poll(fds, 1, 0) < 0 || (fds[0].revents & POLLNVAL) != 0) {
- exit(1); /* Does not work for devices -- fail */
+ return 1; /* Does not work for devices -- fail */
}
- exit(0);
+ return 0;
#endif
}
diff --git a/erts/configure.ac b/erts/configure.ac
index ab2ee78acdca211e..f658b66e3c0e508a 100644
--- a/erts/configure.ac
+++ b/erts/configure.ac
@@ -2436,6 +2436,9 @@ AC_CACHE_CHECK([if __after_morecore_hook can track malloc()s core memory use],
#ifdef HAVE_MALLOC_H
# include <malloc.h>
#endif
+#ifdef HAVE_UNISTD_H
+# include <unistd.h>
+#endif
#if defined(HAVE_END_SYMBOL)
extern char end;
#elif defined(HAVE__END_SYMBOL)
@@ -3033,10 +3036,13 @@ poll_works=no
AC_RUN_IFELSE([AC_LANG_SOURCE([[
#include <poll.h>
-main()
+#ifdef HAVE_FCNTL_H
+#include <fcntl.h>
+#endif
+int main()
{
#ifdef _POLL_EMUL_H_
- exit(1); /* Implemented using select() -- fail */
+ return 1; /* Implemented using select() -- fail */
#else
struct pollfd fds[1];
int fd;
@@ -3045,9 +3051,9 @@ main()
fds[0].events = POLLIN;
fds[0].revents = 0;
if (poll(fds, 1, 0) < 0 || (fds[0].revents & POLLNVAL) != 0) {
- exit(1); /* Does not work for devices -- fail */
+ return 1; /* Does not work for devices -- fail */
}
- exit(0);
+ return 0;
#endif
}
]])],[poll_works=yes],[poll_works=no],[