9433160c6b
Signed-off-by: Peter Lemenkov <lemenkov@gmail.com>
56 lines
1.6 KiB
Diff
56 lines
1.6 KiB
Diff
From 5d52142fcfa2b4a776f80592ae0033e17628adb7 Mon Sep 17 00:00:00 2001
|
|
From: Peter Lemenkov <lemenkov@gmail.com>
|
|
Date: Sat, 19 Jun 2010 10:25:29 +0400
|
|
Subject: [PATCH 09/12] Do not install *.bat files on non-win32 machines
|
|
|
|
Signed-off-by: Peter Lemenkov <lemenkov@gmail.com>
|
|
---
|
|
lib/observer/src/Makefile | 8 ++++++--
|
|
lib/webtool/priv/Makefile | 8 ++++++--
|
|
2 files changed, 12 insertions(+), 4 deletions(-)
|
|
|
|
diff --git a/lib/observer/src/Makefile b/lib/observer/src/Makefile
|
|
index dde1ea1..fe5eba1 100644
|
|
--- a/lib/observer/src/Makefile
|
|
+++ b/lib/observer/src/Makefile
|
|
@@ -56,11 +56,15 @@ TARGET_FILES= $(MODULES:%=$(EBIN)/%.$(EMULATOR)) $(APP_TARGET) $(APPUP_TARGET)
|
|
PRIVDIR= ../priv
|
|
WEBTOOLFILES= $(PRIVDIR)/crashdump_viewer.tool
|
|
BINDIR= $(PRIVDIR)/bin
|
|
+ifeq ($(findstring win32,$(TARGET)),win32)
|
|
+WIN32_EXECUTABLES= $(BINDIR)/etop.bat $(BINDIR)/getop.bat
|
|
+else
|
|
+WIN32_EXECUTABLES=
|
|
+endif
|
|
EXECUTABLES= \
|
|
$(BINDIR)/etop \
|
|
$(BINDIR)/getop \
|
|
- $(BINDIR)/etop.bat \
|
|
- $(BINDIR)/getop.bat
|
|
+ $(WIN32_EXECUTABLES)
|
|
CDVDIR= $(PRIVDIR)/crashdump_viewer
|
|
GIF_FILES= \
|
|
$(CDVDIR)/collapsd.gif \
|
|
diff --git a/lib/webtool/priv/Makefile b/lib/webtool/priv/Makefile
|
|
index 56ab772..c29e912 100644
|
|
--- a/lib/webtool/priv/Makefile
|
|
+++ b/lib/webtool/priv/Makefile
|
|
@@ -39,8 +39,12 @@ HTDOCS_FILES = root/doc/index.html \
|
|
root/doc/tool_management.html \
|
|
root/doc/start_info.html
|
|
|
|
-SCRIPTS = bin/start_webtool \
|
|
- bin/start_webtool.bat
|
|
+ifeq ($(findstring win32,$(TARGET)),win32)
|
|
+WIN32_SCRIPTS= bin/start.bat
|
|
+else
|
|
+WIN32_SCRIPTS=
|
|
+endif
|
|
+SCRIPTS = bin/start_webtool $(WIN32_SCRIPTS)
|
|
|
|
# ----------------------------------------------------
|
|
# FLAGS
|
|
--
|
|
1.7.2.3
|
|
|