Erlang ver. 24.3.3
Signed-off-by: Peter Lemenkov <lemenkov@gmail.com>
This commit is contained in:
parent
abc6dfa759
commit
f92c4b5b4c
11
erlang.spec
11
erlang.spec
@ -63,8 +63,8 @@
|
||||
|
||||
|
||||
Name: erlang
|
||||
Version: 24.2.2
|
||||
Release: 2%{?dist}
|
||||
Version: 24.3.3
|
||||
Release: 1%{?dist}
|
||||
Summary: General-purpose programming language and runtime environment
|
||||
|
||||
License: ASL 2.0
|
||||
@ -104,7 +104,7 @@ Patch6: otp-0006-Do-not-install-erlang-sources.patch
|
||||
Patch7: otp-0007-Add-extra-search-directory.patch
|
||||
Patch8: otp-0008-Avoid-forking-sed-to-get-basename.patch
|
||||
Patch9: otp-0009-Load-man-pages-from-system-wide-directory.patch
|
||||
Patch10: otp-0010-Allow-openssl-3.0.0-FIPS-compilation.patch
|
||||
Patch10: otp-0010-Revert-crypto-Temporarily-disable-FIPS-for-cryptolib.patch
|
||||
# end of autogenerated patch tag list
|
||||
|
||||
BuildRequires: gcc
|
||||
@ -294,7 +294,6 @@ Diameter (RFC 3588) library
|
||||
Summary: Erlang documentation
|
||||
BuildRequires: fop
|
||||
BuildRequires: libxslt
|
||||
BuildArch: noarch
|
||||
|
||||
%description doc
|
||||
Documentation for Erlang.
|
||||
@ -1909,6 +1908,10 @@ useradd -r -g epmd -d /dev/null -s /sbin/nologin \
|
||||
|
||||
|
||||
%changelog
|
||||
* Tue Mar 29 2022 Peter Lemenkov <lemenkov@gmail.com> - 24.3.3-1
|
||||
- Ver. 24.3.3
|
||||
- Doc sub-package no longermarked as noarch (contains links to _libdir)
|
||||
|
||||
* Mon Mar 28 2022 John Eckersberg <jeckersb@redhat.com> - 24.2.2-2
|
||||
- Keep documentation chunks in the code path (rhbz#2068758)
|
||||
|
||||
|
@ -5,10 +5,10 @@ Subject: [PATCH] Remove rpath
|
||||
Signed-off-by: Peter Lemenkov <lemenkov@gmail.com>
|
||||
|
||||
diff --git a/lib/crypto/c_src/Makefile.in b/lib/crypto/c_src/Makefile.in
|
||||
index 8ad5c7889e..041bcf7e06 100644
|
||||
index 4478ed7d9c..3224c705e6 100644
|
||||
--- a/lib/crypto/c_src/Makefile.in
|
||||
+++ b/lib/crypto/c_src/Makefile.in
|
||||
@@ -139,7 +139,7 @@ endif
|
||||
@@ -145,7 +145,7 @@ endif
|
||||
endif
|
||||
|
||||
ifeq ($(DYNAMIC_OR_WIN_CRYPTO_LIB),yes)
|
||||
|
@ -14,7 +14,7 @@ https://bugzilla.redhat.com/818419
|
||||
Signed-off-by: Peter Lemenkov <lemenkov@gmail.com>
|
||||
|
||||
diff --git a/lib/asn1/c_src/Makefile b/lib/asn1/c_src/Makefile
|
||||
index cb606fd74e..48a7c2f4f1 100644
|
||||
index 8fb3360f83..5fb080f206 100644
|
||||
--- a/lib/asn1/c_src/Makefile
|
||||
+++ b/lib/asn1/c_src/Makefile
|
||||
@@ -136,8 +136,6 @@ include $(ERL_TOP)/make/otp_release_targets.mk
|
||||
@ -27,11 +27,11 @@ index cb606fd74e..48a7c2f4f1 100644
|
||||
release_docs_spec:
|
||||
|
||||
diff --git a/lib/erl_interface/src/Makefile.in b/lib/erl_interface/src/Makefile.in
|
||||
index 56fdaa608e..25764ce50d 100644
|
||||
index 92459f6223..d2c7b7f765 100644
|
||||
--- a/lib/erl_interface/src/Makefile.in
|
||||
+++ b/lib/erl_interface/src/Makefile.in
|
||||
@@ -690,13 +690,11 @@ release: opt
|
||||
$(INSTALL_DATA) $(OBJ_TARGETS) "$(RELEASE_PATH)/usr/lib"
|
||||
@@ -709,13 +709,11 @@ ifeq (@DYNAMIC_LIB@, yes)
|
||||
endif
|
||||
$(INSTALL_PROGRAM) $(EXE_TARGETS) "$(RELSYSDIR)/bin"
|
||||
$(INSTALL_DATA) $(EXTRA) "$(RELSYSDIR)/src"
|
||||
- $(INSTALL_DATA) connect/*.[ch] "$(RELSYSDIR)/src/connect"
|
||||
@ -63,7 +63,7 @@ index cd409fa54f..c65e817385 100644
|
||||
endif
|
||||
|
||||
diff --git a/lib/odbc/c_src/Makefile.in b/lib/odbc/c_src/Makefile.in
|
||||
index 3c16e7e294..82fe1492ef 100644
|
||||
index d1b26743a6..cf8faae1f5 100644
|
||||
--- a/lib/odbc/c_src/Makefile.in
|
||||
+++ b/lib/odbc/c_src/Makefile.in
|
||||
@@ -129,11 +129,8 @@ include $(ERL_TOP)/make/otp_release_targets.mk
|
||||
|
@ -5,7 +5,7 @@ Subject: [PATCH] Do not install Java sources
|
||||
Signed-off-by: Peter Lemenkov <lemenkov@gmail.com>
|
||||
|
||||
diff --git a/lib/jinterface/java_src/com/ericsson/otp/erlang/Makefile b/lib/jinterface/java_src/com/ericsson/otp/erlang/Makefile
|
||||
index bcbb206db6..1451378b35 100644
|
||||
index e42fd9468d..35deacbcf3 100644
|
||||
--- a/lib/jinterface/java_src/com/ericsson/otp/erlang/Makefile
|
||||
+++ b/lib/jinterface/java_src/com/ericsson/otp/erlang/Makefile
|
||||
@@ -123,8 +123,6 @@ release release_docs release_tests release_html:
|
||||
|
@ -6,7 +6,7 @@ Subject: [PATCH] Do not install nteventlog and related doc-files on non-win32
|
||||
Signed-off-by: Peter Lemenkov <lemenkov@gmail.com>
|
||||
|
||||
diff --git a/lib/os_mon/doc/src/Makefile b/lib/os_mon/doc/src/Makefile
|
||||
index d16f2b4831..c5b721f995 100644
|
||||
index 8e3882bfdc..ea999cf9c7 100644
|
||||
--- a/lib/os_mon/doc/src/Makefile
|
||||
+++ b/lib/os_mon/doc/src/Makefile
|
||||
@@ -31,11 +31,16 @@ APPLICATION=os_mon
|
||||
@ -28,7 +28,7 @@ index d16f2b4831..c5b721f995 100644
|
||||
XML_REF6_FILES = os_mon_app.xml
|
||||
|
||||
diff --git a/lib/os_mon/src/Makefile b/lib/os_mon/src/Makefile
|
||||
index 98c5ced068..e2f4d5a090 100644
|
||||
index 48a896265b..afb67c1793 100644
|
||||
--- a/lib/os_mon/src/Makefile
|
||||
+++ b/lib/os_mon/src/Makefile
|
||||
@@ -34,7 +34,13 @@ RELSYSDIR = $(RELEASE_PATH)/lib/os_mon-$(VSN)
|
||||
|
@ -397,7 +397,7 @@ index 7ca59495ed..a52ade2fe3 100644
|
||||
$(INSTALL_DATA) $(EXT_HRL_FILES) "$(RELSYSDIR)/include"
|
||||
$(INSTALL_DIR) "$(RELSYSDIR)/ebin"
|
||||
diff --git a/lib/os_mon/src/Makefile b/lib/os_mon/src/Makefile
|
||||
index e2f4d5a090..57f21a145b 100644
|
||||
index afb67c1793..ec6acf1fce 100644
|
||||
--- a/lib/os_mon/src/Makefile
|
||||
+++ b/lib/os_mon/src/Makefile
|
||||
@@ -105,7 +105,6 @@ include $(ERL_TOP)/make/otp_release_targets.mk
|
||||
@ -437,7 +437,7 @@ index 1fef168463..e5411b903b 100644
|
||||
$(INSTALL_DATA) $(TARGET_FILES) "$(RELSYSDIR)/ebin"
|
||||
|
||||
diff --git a/lib/public_key/src/Makefile b/lib/public_key/src/Makefile
|
||||
index 76bdffe089..fc5e4dfa8e 100644
|
||||
index e27f02eea9..dec54a8414 100644
|
||||
--- a/lib/public_key/src/Makefile
|
||||
+++ b/lib/public_key/src/Makefile
|
||||
@@ -110,8 +110,6 @@ $(APPUP_TARGET): $(APPUP_SRC) ../vsn.mk
|
||||
@ -553,7 +553,7 @@ index eca2d949d2..4c234caf88 100644
|
||||
$(INSTALL_DATA) $(TARGET_FILES) "$(RELSYSDIR)/ebin"
|
||||
# $(INSTALL_DIR) "$(RELSYSDIR)/include"
|
||||
diff --git a/lib/ssh/src/Makefile b/lib/ssh/src/Makefile
|
||||
index 88126f6289..831cd1d938 100644
|
||||
index cc3cfe9e96..9f3cd694f5 100644
|
||||
--- a/lib/ssh/src/Makefile
|
||||
+++ b/lib/ssh/src/Makefile
|
||||
@@ -182,7 +182,7 @@ include $(ERL_TOP)/make/otp_release_targets.mk
|
||||
@ -566,7 +566,7 @@ index 88126f6289..831cd1d938 100644
|
||||
$(INSTALL_DATA) $(BEHAVIOUR_TARGET_FILES) $(TARGET_FILES) $(APP_TARGET) \
|
||||
$(APPUP_TARGET) "$(RELSYSDIR)/ebin"
|
||||
diff --git a/lib/ssl/src/Makefile b/lib/ssl/src/Makefile
|
||||
index c8d0d6f12f..92471ac30e 100644
|
||||
index 1e55bb497d..1cf3cbf5ee 100644
|
||||
--- a/lib/ssl/src/Makefile
|
||||
+++ b/lib/ssl/src/Makefile
|
||||
@@ -211,7 +211,7 @@ include $(ERL_TOP)/make/otp_release_targets.mk
|
||||
@ -604,7 +604,7 @@ index af6a472f3d..6796810ac2 100644
|
||||
$(INSTALL_DATA) $(INCLUDE_DELIVERABLES) "$(RELSYSDIR)/include"
|
||||
|
||||
diff --git a/lib/tftp/src/Makefile b/lib/tftp/src/Makefile
|
||||
index 029bd731bd..85c633b4f0 100644
|
||||
index 4ece9ffe28..da95babcea 100644
|
||||
--- a/lib/tftp/src/Makefile
|
||||
+++ b/lib/tftp/src/Makefile
|
||||
@@ -101,7 +101,7 @@ include $(ERL_TOP)/make/otp_release_targets.mk
|
||||
|
@ -1,75 +0,0 @@
|
||||
From: Michele Baldessari <michele@acksyn.org>
|
||||
Date: Tue, 28 Sep 2021 17:26:16 +0200
|
||||
Subject: [PATCH] Allow openssl-3.0.0 FIPS compilation
|
||||
|
||||
Openssl 3.0.0 dropped support for the old way of adding fips
|
||||
and in particular it dropped support for FIPS_mode() and
|
||||
FIPS_mode_set().
|
||||
|
||||
In RHEL9, openssl-3.0.0 ships a compat macro for FIPS_mode(), so
|
||||
this change focuses on replacing FIPS_mode_set()
|
||||
|
||||
Compiled erlang-erts-24.1-1.el9.x86_64 with this patch and then tested as follows:
|
||||
A. Booted the system with fips enabled:
|
||||
[root@rhel9 ~]# fips-mode-setup --check
|
||||
FIPS mode is enabled.
|
||||
|
||||
B. Set up a fips config file:
|
||||
cat > fips.config<<EOF
|
||||
[{crypto, [{fips_mode, true}]}]
|
||||
.
|
||||
EOF
|
||||
|
||||
C. Ran the following:
|
||||
$ erl -config fips
|
||||
1> crypto:info_fips().
|
||||
not_enabled
|
||||
2> crypto:enable_fips_mode(true).
|
||||
true
|
||||
3> crypto:info_fips().
|
||||
enabled
|
||||
|
||||
D. Verified that the ciphers when using fips are a subset of the usual
|
||||
ciphers:
|
||||
|
||||
4> crypto:supports().
|
||||
[{hashs,[sha,sha224,sha256,sha384,sha512,sha3_224,sha3_256,
|
||||
sha3_384,sha3_512,blake2b,blake2s]},
|
||||
{ciphers,[aes_cbc,aes_ccm,aes_cfb128,aes_cfb8,aes_ctr,
|
||||
aes_ecb,aes_gcm,des_ede3_cfb,aes_128_cbc,aes_192_cbc,
|
||||
aes_256_cbc,aes_128_cfb128,aes_192_cfb128,aes_256_cfb128,
|
||||
aes_128_cfb8,aes_192_cfb8,aes_256_cfb8,aes_128_ecb,
|
||||
aes_192_ecb,aes_256_ecb,aes_256_gcm,aes_256_ccm,aes_192_gcm,
|
||||
aes_192_ccm,aes_128_gcm|...]},
|
||||
{public_keys,[rsa,dss,dh,ecdsa,ecdh]},
|
||||
{macs,[cmac,hmac,poly1305]},
|
||||
{curves,[]},
|
||||
{rsa_opts,[rsa_pkcs1_pss_padding,rsa_pss_saltlen,
|
||||
rsa_mgf1_md,rsa_pkcs1_oaep_padding,rsa_oaep_label,
|
||||
rsa_oaep_md,signature_md,rsa_pkcs1_padding,rsa_x931_padding,
|
||||
rsa_no_padding]}]
|
||||
|
||||
Note that we could probably just have patched out the FIPS_mode_set()
|
||||
calls as FIPS gets enforced on the system. The automatism is going to
|
||||
come with a version of openssl that is later than > openssl-3.0.0-2.
|
||||
|
||||
Co-Authored-By: John Eckersberg <jeckersb@redhat.com>
|
||||
Co-Authored-By: Damien Ciabrini <dciabrin@redhat.com>
|
||||
|
||||
[1] https://wiki.openssl.org/index.php/OpenSSL_3.0#Upgrading_from_the_OpenSSL_2.0_FIPS_Object_Module
|
||||
|
||||
diff --git a/lib/crypto/c_src/openssl_config.h b/lib/crypto/c_src/openssl_config.h
|
||||
index 49627f17e7..1d12174e3e 100644
|
||||
--- a/lib/crypto/c_src/openssl_config.h
|
||||
+++ b/lib/crypto/c_src/openssl_config.h
|
||||
@@ -438,6 +438,10 @@ do { \
|
||||
# undef FIPS_SUPPORT
|
||||
#endif
|
||||
|
||||
+#if defined(FIPS_SUPPORT) \
|
||||
+ && OPENSSL_VERSION_NUMBER >= (PACKED_OPENSSL_VERSION_PLAIN(3,0,0) & ~0xff)
|
||||
+#define FIPS_mode_set(fips_mode) EVP_default_properties_enable_fips(NULL, fips_mode)
|
||||
+#endif
|
||||
|
||||
/* This is not the final FIPS adaptation for 3.0, just making it compilable */
|
||||
#if OPENSSL_VERSION_NUMBER >= PACKED_OPENSSL_VERSION_PLAIN(3,0,0)
|
@ -0,0 +1,23 @@
|
||||
From: Peter Lemenkov <lemenkov@gmail.com>
|
||||
Date: Tue, 29 Mar 2022 19:38:13 +0200
|
||||
Subject: [PATCH] Revert "crypto: Temporarily disable FIPS for cryptolib ver
|
||||
3.0 and above"
|
||||
|
||||
This reverts commit 6bb9c51e900fe8fb5a88bd2498f6e5a92f94ed8d.
|
||||
|
||||
diff --git a/lib/crypto/c_src/openssl_config.h b/lib/crypto/c_src/openssl_config.h
|
||||
index 647ab25ad4..ab681183a3 100644
|
||||
--- a/lib/crypto/c_src/openssl_config.h
|
||||
+++ b/lib/crypto/c_src/openssl_config.h
|
||||
@@ -452,11 +452,6 @@ do { \
|
||||
# undef FIPS_SUPPORT
|
||||
#endif
|
||||
|
||||
-/* Disable FIPS for 3.0 temporaryly until the support is added */
|
||||
-#if defined(FIPS_SUPPORT) && \
|
||||
- defined(HAS_3_0_API)
|
||||
-# undef FIPS_SUPPORT
|
||||
-#endif
|
||||
|
||||
#if defined(FIPS_SUPPORT) && \
|
||||
defined(HAS_3_0_API)
|
2
sources
2
sources
@ -1 +1 @@
|
||||
SHA512 (otp-OTP-24.2.2.tar.gz) = 791bd9cc299168d4a209bcdc797a9671a39d03924dc18c9e0520393adf4eb54922c48eecde44601bde55b4fa80b91e0eddbfc486c5f45a611da60b47c63208c7
|
||||
SHA512 (otp-OTP-24.3.3.tar.gz) = 5e8ce0ebd50c1c67ca29ce9405fc18f5461793b20a1732418bc8fac404078044deb72526682aab92ee3e737bc9dc9e94e6be162a088e2cb7cc68c14b1d76454e
|
||||
|
Loading…
x
Reference in New Issue
Block a user