*** empty log message ***
This commit is contained in:
parent
e76567c03b
commit
da518fa068
@ -1,6 +1,6 @@
|
|||||||
Name: erlang
|
Name: erlang
|
||||||
Version: R10B
|
Version: R10B
|
||||||
Release: 8.1%{?dist}
|
Release: 8.2%{?dist}
|
||||||
Summary: General-purpose programming language and runtime environment
|
Summary: General-purpose programming language and runtime environment
|
||||||
|
|
||||||
Group: Development/Languages
|
Group: Development/Languages
|
||||||
@ -12,6 +12,7 @@ Source2: http://www.erlang.org/download/otp_doc_man_R10B-8.tar.gz
|
|||||||
Patch: otp-links.patch
|
Patch: otp-links.patch
|
||||||
Patch1: otp-install.patch
|
Patch1: otp-install.patch
|
||||||
Patch2: otp-rpath.patch
|
Patch2: otp-rpath.patch
|
||||||
|
Patch3: otp-glibc24.patch
|
||||||
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
|
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
|
||||||
|
|
||||||
BuildRequires: ncurses-devel, openssl-devel, flex, unixODBC-devel
|
BuildRequires: ncurses-devel, openssl-devel, flex, unixODBC-devel
|
||||||
@ -40,6 +41,7 @@ Documentation for Erlang.
|
|||||||
%patch -p1
|
%patch -p1
|
||||||
%patch1 -p1
|
%patch1 -p1
|
||||||
%patch2 -p1
|
%patch2 -p1
|
||||||
|
%patch3 -p1
|
||||||
|
|
||||||
|
|
||||||
%build
|
%build
|
||||||
@ -93,6 +95,9 @@ rm -rf $RPM_BUILD_ROOT
|
|||||||
|
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Sat Oct 29 2005 Gerard Milmeister <gemi@bluewin.ch> - R10B-8.2
|
||||||
|
- updated rpath patch
|
||||||
|
|
||||||
* Sat Oct 29 2005 Gerard Milmeister <gemi@bluewin.ch> - R10B-8.1
|
* Sat Oct 29 2005 Gerard Milmeister <gemi@bluewin.ch> - R10B-8.1
|
||||||
- New Version R10B-8
|
- New Version R10B-8
|
||||||
|
|
||||||
|
@ -1,16 +1,16 @@
|
|||||||
--- otp_src_R10B-3/lib/crypto/c_src/Makefile.in.rpath 2005-02-13 15:22:29.208560819 +0100
|
--- otp_src_R10B-8/lib/crypto/c_src/Makefile.in.rpath 2005-10-29 22:50:59.000000000 +0200
|
||||||
+++ otp_src_R10B-3/lib/crypto/c_src/Makefile.in 2005-02-13 15:22:50.852106461 +0100
|
+++ otp_src_R10B-8/lib/crypto/c_src/Makefile.in 2005-10-29 22:51:23.000000000 +0200
|
||||||
@@ -79,7 +79,7 @@
|
@@ -79,7 +79,7 @@
|
||||||
ifeq ($(HOST_OS),)
|
ifeq ($(HOST_OS),)
|
||||||
HOST_OS := $(shell $(ERL_TOP)/erts/autoconf/config.guess)
|
HOST_OS := $(shell $(ERL_TOP)/erts/autoconf/config.guess)
|
||||||
endif
|
endif
|
||||||
-LD_R_FLAG=@DED_LD_FLAG_RUNTIME_LIBRARY_PATH@
|
-LD_R_FLAG=@DED_LD_FLAG_RUNTIME_LIBRARY_PATH@
|
||||||
+LD_R_FLAG=
|
+LD_R_FLAG=
|
||||||
ifeq ($(findstring @,$(LD_R_FLAG)),@)
|
ifeq ($(strip $(LD_R_FLAG)),)
|
||||||
# Old erts configure used which hasn't replaced
|
LD_R_OPT =
|
||||||
# @DED_LD_FLAG_RUNTIME_LIBRARY_PATH@; we try our best here instead...
|
else
|
||||||
--- otp_src_R10B-3/lib/crypto/priv/Makefile.rpath 2005-02-13 14:46:15.043814168 +0100
|
--- otp_src_R10B-8/lib/crypto/priv/Makefile.rpath 2005-10-29 22:52:01.000000000 +0200
|
||||||
+++ otp_src_R10B-3/lib/crypto/priv/Makefile 2005-02-13 14:46:48.575467543 +0100
|
+++ otp_src_R10B-8/lib/crypto/priv/Makefile 2005-10-29 22:52:32.000000000 +0200
|
||||||
@@ -60,7 +60,7 @@
|
@@ -60,7 +60,7 @@
|
||||||
# ----------------------------------------------------
|
# ----------------------------------------------------
|
||||||
|
|
||||||
@ -20,25 +20,17 @@
|
|||||||
-o $@ $^ -lcrypto
|
-o $@ $^ -lcrypto
|
||||||
|
|
||||||
$(DLL_DRIVER): $(OBJS)
|
$(DLL_DRIVER): $(OBJS)
|
||||||
--- otp_src_R10B-3/lib/ssh/c_src/Makefile.in.rpath 2005-02-13 15:23:13.516486079 +0100
|
--- otp_src_R10B-8/lib/ssl/c_src/Makefile.in.rpath 2005-10-29 22:53:15.000000000 +0200
|
||||||
+++ otp_src_R10B-3/lib/ssh/c_src/Makefile.in 2005-02-13 15:23:25.130630385 +0100
|
+++ otp_src_R10B-8/lib/ssl/c_src/Makefile.in 2005-10-29 22:53:50.000000000 +0200
|
||||||
@@ -75,7 +75,7 @@
|
@@ -104,9 +104,9 @@
|
||||||
|
CC_R_FLAG =
|
||||||
else
|
else
|
||||||
DYN_DRIVER = $(LIBDIR)/ssh_crypto_drv.so
|
ifeq ($(findstring osf,$(TARGET)),osf) # osf1: -Wl,-rpath,
|
||||||
|
-CC_R_FLAG = -Wl,-rpath,
|
||||||
|
+CC_R_FLAG =
|
||||||
|
else # Default: -Wl,-R
|
||||||
|
-CC_R_FLAG = -Wl,-R
|
||||||
|
+CC_R_FLAG =
|
||||||
|
endif
|
||||||
endif
|
endif
|
||||||
-LD_R_FLAG=@DED_LD_FLAG_RUNTIME_LIBRARY_PATH@
|
|
||||||
+LD_R_FLAG=
|
|
||||||
ifeq ($(findstring @,$(LD_R_FLAG)),@)
|
|
||||||
# Old erts configure used which hasn't replaced
|
|
||||||
# @DED_LD_FLAG_RUNTIME_LIBRARY_PATH@; we try our best here instead...
|
|
||||||
--- otp_src_R10B-3/erts/configure.rpath 2005-02-13 14:44:11.498507144 +0100
|
|
||||||
+++ otp_src_R10B-3/erts/configure 2005-02-13 14:44:55.858437414 +0100
|
|
||||||
@@ -1231,7 +1231,7 @@
|
|
||||||
CFLAGS="$CFLAGS $extra_flags"
|
|
||||||
DEBUG_CFLAGS="-g $extra_flags"
|
|
||||||
|
|
||||||
-CFLAG_RUNTIME_LIBRARY_PATH="-Wl,-R"
|
|
||||||
+CFLAG_RUNTIME_LIBRARY_PATH=""
|
|
||||||
case $host_os in
|
|
||||||
darwin*)
|
|
||||||
CFLAG_RUNTIME_LIBRARY_PATH=
|
|
||||||
|
Loading…
Reference in New Issue
Block a user