Erlang ver. 24.0-rc3
Signed-off-by: Peter Lemenkov <lemenkov@gmail.com>
This commit is contained in:
parent
d8da3b9c78
commit
d813106634
@ -61,7 +61,7 @@
|
||||
|
||||
Name: erlang
|
||||
Version: 24.0
|
||||
Release: 0.1.rc2%{?dist}
|
||||
Release: 0.2.rc3%{?dist}
|
||||
Summary: General-purpose programming language and runtime environment
|
||||
|
||||
License: ASL 2.0
|
||||
@ -69,7 +69,7 @@ URL: https://www.erlang.org
|
||||
%if ! (0%{?rhel} && 0%{?rhel} <= 6)
|
||||
VCS: scm:git:https://github.com/erlang/otp
|
||||
%endif
|
||||
Source0: https://github.com/erlang/otp/archive/OTP-%{version}-rc2/otp-OTP-%{version}-rc2.tar.gz
|
||||
Source0: https://github.com/erlang/otp/archive/OTP-%{version}-rc3/otp-OTP-%{version}-rc3.tar.gz
|
||||
Source5: epmd.service
|
||||
Source6: epmd.socket
|
||||
Source7: epmd@.service
|
||||
@ -1897,6 +1897,9 @@ useradd -r -g epmd -d /dev/null -s /sbin/nologin \
|
||||
|
||||
|
||||
%changelog
|
||||
* Wed Apr 21 2021 Peter Lemenkov <lemenkov@gmail.com> - 24.0-0.2.rc3
|
||||
- Ver. 24.0-rc3
|
||||
|
||||
* Sat Apr 3 2021 Peter Lemenkov <lemenkov@gmail.com> - 24.0-0.1.rc2
|
||||
- Ver. 24.0-rc2
|
||||
- Removed hipe
|
||||
|
@ -27,10 +27,10 @@ index cb606fd74e..48a7c2f4f1 100644
|
||||
release_docs_spec:
|
||||
|
||||
diff --git a/lib/erl_interface/src/Makefile.in b/lib/erl_interface/src/Makefile.in
|
||||
index 061fd05a1d..498b7d1370 100644
|
||||
index 56fdaa608e..ff2490ed85 100644
|
||||
--- a/lib/erl_interface/src/Makefile.in
|
||||
+++ b/lib/erl_interface/src/Makefile.in
|
||||
@@ -691,13 +691,12 @@ release: opt
|
||||
@@ -690,13 +690,12 @@ release: opt
|
||||
$(INSTALL_DATA) $(OBJ_TARGETS) "$(RELEASE_PATH)/usr/lib"
|
||||
$(INSTALL_PROGRAM) $(EXE_TARGETS) "$(RELSYSDIR)/bin"
|
||||
$(INSTALL_DATA) $(EXTRA) "$(RELSYSDIR)/src"
|
||||
|
@ -553,10 +553,10 @@ index 51318b5c66..d4015d71f4 100644
|
||||
$(INSTALL_DATA) $(TARGET_FILES) "$(RELSYSDIR)/ebin"
|
||||
# $(INSTALL_DIR) "$(RELSYSDIR)/include"
|
||||
diff --git a/lib/ssh/src/Makefile b/lib/ssh/src/Makefile
|
||||
index 4f4b55f5c5..ee966e3eed 100644
|
||||
index 517a6611c4..b348d1cfb8 100644
|
||||
--- a/lib/ssh/src/Makefile
|
||||
+++ b/lib/ssh/src/Makefile
|
||||
@@ -165,7 +165,7 @@ include $(ERL_TOP)/make/otp_release_targets.mk
|
||||
@@ -182,7 +182,7 @@ include $(ERL_TOP)/make/otp_release_targets.mk
|
||||
|
||||
release_spec: opt
|
||||
$(INSTALL_DIR) "$(RELSYSDIR)/src"
|
||||
|
@ -7,10 +7,10 @@ Patch allows one to use standard man path with erl -man command.
|
||||
as required by Debian policy.)
|
||||
|
||||
diff --git a/erts/etc/common/erlexec.c b/erts/etc/common/erlexec.c
|
||||
index 0efacd67a1..777079301c 100644
|
||||
index 06182c25ce..b41ae3a90a 100644
|
||||
--- a/erts/etc/common/erlexec.c
|
||||
+++ b/erts/etc/common/erlexec.c
|
||||
@@ -720,8 +720,10 @@ int main(int argc, char **argv)
|
||||
@@ -722,8 +722,10 @@ int main(int argc, char **argv)
|
||||
error("-man not supported on Windows");
|
||||
#else
|
||||
argv[i] = "man";
|
||||
|
2
sources
2
sources
@ -1 +1 @@
|
||||
SHA512 (otp-OTP-24.0-rc2.tar.gz) = 10a658388f6cf2abd70cadbc4e6e0d6547afaa4ba9afdb85431fd7d2e50ded19000472533f54f690e7b0adc747382cfa5af7533fbb9e1ee58c992c03b37d1144
|
||||
SHA512 (otp-OTP-24.0-rc3.tar.gz) = bcc4946fafd6fcc0a29d75f8a0168d9db523bec279aaaf4ec3c4b2eb058c6ff6e38459847acf13b7b9327ebbb2c1ea9b28c164e728a004459d89a3e43bf1ea0c
|
||||
|
Loading…
Reference in New Issue
Block a user