Erlang ver. 26.2.2

Signed-off-by: Peter Lemenkov <lemenkov@gmail.com>
This commit is contained in:
Peter Lemenkov 2024-02-12 18:32:42 +01:00
parent 31296f6a24
commit d2e9015f83
4 changed files with 14 additions and 11 deletions

View File

@ -68,8 +68,8 @@
Name: erlang
Version: 26.2.1
Release: 3%{?dist}
Version: 26.2.2
Release: 1%{?dist}
Summary: General-purpose programming language and runtime environment
License: ASL 2.0
@ -1969,6 +1969,9 @@ useradd -r -g epmd -d /dev/null -s /sbin/nologin \
%changelog
* Mon Feb 12 2024 Peter Lemenkov <lemenkov@gmail.com> - 26.2.2-1
- Ver. 26.2.2
* Wed Jan 24 2024 Fedora Release Engineering <releng@fedoraproject.org> - 26.2.1-3
- Rebuilt for https://fedoraproject.org/wiki/Fedora_40_Mass_Rebuild

View File

@ -6,7 +6,7 @@ Subject: [PATCH] configure.ac: C99 fix for
#include <unistd.h> for the sbrk function if the header is available.
diff --git a/erts/configure b/erts/configure
index a09c84ff09..478ebaa206 100755
index 8d2083aa48..93e4ae295d 100755
--- a/erts/configure
+++ b/erts/configure
@@ -20890,6 +20890,9 @@ else $as_nop
@ -20,7 +20,7 @@ index a09c84ff09..478ebaa206 100755
extern char end;
#elif defined(HAVE__END_SYMBOL)
diff --git a/erts/configure.ac b/erts/configure.ac
index 540cc4b3cb..0d4d9377ef 100644
index c591393fcd..5d5793518f 100644
--- a/erts/configure.ac
+++ b/erts/configure.ac
@@ -2449,6 +2449,9 @@ AC_CACHE_CHECK([if __after_morecore_hook can track malloc()s core memory use],

View File

@ -7,10 +7,10 @@ Return from main instead of calling exit, so that no function
declaration is needed.
diff --git a/erts/configure b/erts/configure
index 478ebaa206..549b53546c 100755
index 93e4ae295d..bdff51a401 100755
--- a/erts/configure
+++ b/erts/configure
@@ -24821,10 +24821,13 @@ else $as_nop
@@ -24837,10 +24837,13 @@ else $as_nop
/* end confdefs.h. */
#include <poll.h>
@ -26,7 +26,7 @@ index 478ebaa206..549b53546c 100755
#else
struct pollfd fds[1];
int fd;
@@ -24833,9 +24836,9 @@ main()
@@ -24849,9 +24852,9 @@ main()
fds[0].events = POLLIN;
fds[0].revents = 0;
if (poll(fds, 1, 0) < 0 || (fds[0].revents & POLLNVAL) != 0) {
@ -39,10 +39,10 @@ index 478ebaa206..549b53546c 100755
}
diff --git a/erts/configure.ac b/erts/configure.ac
index 0d4d9377ef..296a72bacc 100644
index 5d5793518f..d08cf9569c 100644
--- a/erts/configure.ac
+++ b/erts/configure.ac
@@ -3068,10 +3068,13 @@ poll_works=no
@@ -3083,10 +3083,13 @@ poll_works=no
AC_RUN_IFELSE([AC_LANG_SOURCE([[
#include <poll.h>
@ -58,7 +58,7 @@ index 0d4d9377ef..296a72bacc 100644
#else
struct pollfd fds[1];
int fd;
@@ -3080,9 +3083,9 @@ main()
@@ -3095,9 +3098,9 @@ main()
fds[0].events = POLLIN;
fds[0].revents = 0;
if (poll(fds, 1, 0) < 0 || (fds[0].revents & POLLNVAL) != 0) {

View File

@ -1 +1 @@
SHA512 (otp-OTP-26.2.1.tar.gz) = f4fa0d11ecbd99ca5ef4421abb78ef2aba8ea0f8d19e4aed991c2afcc42bb057a37ae34a416b050fd7ed8ca39ba7cc8b3619ff371bc09f56dfd5b523988a8f8c
SHA512 (otp-OTP-26.2.2.tar.gz) = 27d89f4ee1c7beccd27348ad0d5d9650cda58614f3c278b0a7cf062bf4efc91bd1c7aecfff55b934c57f69cb30c41ead89b94625616817acb2e5910b95bc80fd