Update to upstream maintenance release R14B02
This includes removal of the HUGE (and thus difficult to maintain) patch removing the info files, and replaces them with a one-liner using find.
This commit is contained in:
parent
5ca337e585
commit
d00ca992bf
24
erlang.spec
24
erlang.spec
@ -1,6 +1,6 @@
|
||||
%global upstream_ver R14B
|
||||
# Do NOT change %%{upstream_rel} unless UPSTREAM has actually changed it!
|
||||
%global upstream_rel 01
|
||||
%global upstream_rel 02
|
||||
#global upstream_rel %{nil}
|
||||
# Use %%{nil} for %%{upstream_rel} for tracking source like otp_src_R14B.tar.gz,
|
||||
# and 01 %%{upstream_rel} for tracking source like otp_src_R14B01.tar.gz.
|
||||
@ -17,7 +17,7 @@
|
||||
|
||||
Name: erlang
|
||||
Version: %{upstream_ver}
|
||||
Release: %{upstream_rel_for_rpm}.5%{?dist}
|
||||
Release: %{upstream_rel_for_rpm}.1%{?dist}
|
||||
Summary: General-purpose programming language and runtime environment
|
||||
|
||||
Group: Development/Languages
|
||||
@ -29,6 +29,7 @@ Source1: http://erlang.org/download/otp_doc_html_%{upstream_ver}%{upstream_rel}.
|
||||
Source2: http://erlang.org/download/otp_doc_man_%{upstream_ver}%{upstream_rel}.tar.gz
|
||||
%endif
|
||||
|
||||
|
||||
# For the source of the Fedora specific patches, see the respective
|
||||
# branch at https://github.com/lemenkov/otp
|
||||
#
|
||||
@ -41,7 +42,7 @@ Source2: http://erlang.org/download/otp_doc_man_%{upstream_ver}%{upstream_rel}.t
|
||||
# to get yourself a copy of the Erlang/OTP source code with the
|
||||
# Fedora specific patches from Peter Lemenkov and Hans Ulrich Niedermann.
|
||||
# Then run something like
|
||||
# $ ./otp-get-patches.sh /path/to/otp OTP_R14B01 ndim/fedora-R14B01
|
||||
# $ ./otp-get-patches.sh /path/to/otp OTP_R14B02 ndim/fedora-R14B02
|
||||
# for some semi-automatic patch update assistance.
|
||||
#
|
||||
# start of autogenerated patch tag list
|
||||
@ -61,8 +62,8 @@ Patch4: otp-0004-Do-not-install-C-sources.patch
|
||||
# Do not install Java sources
|
||||
Patch5: otp-0005-Do-not-install-Java-sources.patch
|
||||
# Fedora specific patch
|
||||
# Do not install info files - they are almost empty and useless
|
||||
Patch6: otp-0006-Do-not-install-info-files-they-are-almost-empty-and-.patch
|
||||
# Fix install dir typo for snmp man3
|
||||
Patch6: otp-0006-Fix-install-dir-typo-for-snmp-man3.patch
|
||||
# Fedora specific patch
|
||||
# Do not install nteventlog and related doc-files on non-win32 systems
|
||||
Patch7: otp-0007-Do-not-install-nteventlog-and-related-doc-files-on-n.patch
|
||||
@ -79,11 +80,8 @@ Patch10: otp-0010-Do-not-install-erlang-sources.patch
|
||||
# Ugly workaround for java-1.5.0-gcj which doesn't support UNICODE fully
|
||||
Patch11: otp-0011-Ugly-workaround-for-java-1.5.0-gcj-which-doesn-t-sup.patch
|
||||
# Fedora specific patch
|
||||
# Remove strange name field in efile_drv.c as it upsets -D_FORTIFY_SOURCE
|
||||
Patch12: otp-0012-Remove-strange-name-field-in-efile_drv.c-as-it-upset.patch
|
||||
# Fedora specific patch
|
||||
# Remove rpath from esock_ssl
|
||||
Patch13: otp-0013-Remove-rpath-from-esock_ssl.patch
|
||||
Patch12: otp-0012-Remove-rpath-from-esock_ssl.patch
|
||||
# end of autogenerated patch tag list
|
||||
|
||||
# BuildRoot not strictly needed since F10, but keep it for spec file robustness
|
||||
@ -975,7 +973,7 @@ Erlang mode for XEmacs (source lisp files).
|
||||
%patch3 -p1 -b .Fix_for_dlopening_libGL_and_libGLU
|
||||
%patch4 -p1 -b .Do_not_install_C_sources
|
||||
%patch5 -p1 -b .Do_not_install_Java_sources
|
||||
%patch6 -p1 -b .Do_not_install_info_files_they_are_almost_empty_and_
|
||||
%patch6 -p1 -b .Fix_install_dir_typo_for_snmp_man3
|
||||
%patch7 -p1 -b .Do_not_install_nteventlog_and_related_doc_files_on_n
|
||||
%patch8 -p1 -b .Do_not_install_bat_files_on_non_win32_machines
|
||||
%patch9 -p1 -b .Do_not_install_VxWorks_specific_docs
|
||||
@ -985,8 +983,7 @@ Erlang mode for XEmacs (source lisp files).
|
||||
%patch11 -p1 -b .Ugly_workaround_for_java_1_5_0_gcj_which_doesn_t_sup
|
||||
%endif
|
||||
%endif
|
||||
%patch12 -p1 -b .Remove_strange_name_field_in_efile_drv_c_as_it_upset
|
||||
%patch13 -p1 -b .Remove_rpath_from_esock_ssl
|
||||
%patch12 -p1 -b .Remove_rpath_from_esock_ssl
|
||||
# end of autogenerated prep patch list
|
||||
|
||||
# remove shipped zlib sources
|
||||
@ -1102,6 +1099,9 @@ env ERL_LIBS="$RPM_BUILD_ROOT%{_libdir}/erlang/lib" make DESTDIR=$RPM_BUILD_ROOT
|
||||
%endif
|
||||
%endif
|
||||
|
||||
# Do not install info files - they are almost empty and useless
|
||||
find $RPM_BUILD_ROOT%{_libdir}/erlang -type f -name info -exec rm -f {} \;
|
||||
|
||||
# fix 0775 permission on some directories
|
||||
find $RPM_BUILD_ROOT%{_libdir}/erlang/lib/ssl-*/examples/ -type d -perm 0775 | xargs chmod 755
|
||||
find $RPM_BUILD_ROOT%{_libdir}/erlang/lib/kernel-*/examples/uds_dist -type d -perm 0775 | xargs chmod 755
|
||||
|
File diff suppressed because it is too large
Load Diff
22
otp-0006-Fix-install-dir-typo-for-snmp-man3.patch
Normal file
22
otp-0006-Fix-install-dir-typo-for-snmp-man3.patch
Normal file
@ -0,0 +1,22 @@
|
||||
From: Hans Ulrich Niedermann <hun@n-dimensional.de>
|
||||
Date: Mon, 21 Mar 2011 15:53:14 +0100
|
||||
Subject: [PATCH] Fix install dir typo for snmp man3
|
||||
|
||||
This is an obvious thing that should be fixed upstream.
|
||||
---
|
||||
lib/snmp/doc/src/Makefile | 2 +-
|
||||
1 files changed, 1 insertions(+), 1 deletions(-)
|
||||
|
||||
diff --git a/lib/snmp/doc/src/Makefile b/lib/snmp/doc/src/Makefile
|
||||
index 35ed63e..30fabc1 100644
|
||||
--- a/lib/snmp/doc/src/Makefile
|
||||
+++ b/lib/snmp/doc/src/Makefile
|
||||
@@ -286,7 +286,7 @@ release_docs_spec: docs
|
||||
$(INSTALL_DATA) $(INFO_FILE) $(RELSYSDIR)
|
||||
$(INSTALL_DIR) $(RELEASE_PATH)/man/man1
|
||||
$(INSTALL_DATA) $(MAN1_FILES) $(RELEASE_PATH)/man/man1
|
||||
- $(INSTALL_DIR) $(RELEASE_PATH)/man/man
|
||||
+ $(INSTALL_DIR) $(RELEASE_PATH)/man/man3
|
||||
$(INSTALL_DATA) $(MAN3_FILES) $(RELEASE_PATH)/man/man3
|
||||
$(INSTALL_DIR) $(RELEASE_PATH)/man/man6
|
||||
$(INSTALL_DATA) $(MAN6_FILES) $(RELEASE_PATH)/man/man6
|
@ -9,7 +9,7 @@ Signed-off-by: Peter Lemenkov <lemenkov@gmail.com>
|
||||
2 files changed, 16 insertions(+), 2 deletions(-)
|
||||
|
||||
diff --git a/lib/os_mon/doc/src/Makefile b/lib/os_mon/doc/src/Makefile
|
||||
index 8d75df9..95f0101 100644
|
||||
index c976574..6267378 100644
|
||||
--- a/lib/os_mon/doc/src/Makefile
|
||||
+++ b/lib/os_mon/doc/src/Makefile
|
||||
@@ -35,12 +35,17 @@ RELSYSDIR = $(RELEASE_PATH)/lib/$(APPLICATION)-$(VSN)
|
||||
|
@ -1,37 +1,40 @@
|
||||
From: Peter Lemenkov <lemenkov@gmail.com>
|
||||
Date: Sat, 19 Jun 2010 10:25:29 +0400
|
||||
From: Hans Ulrich Niedermann <hun@n-dimensional.de>
|
||||
Date: Mon, 21 Mar 2011 14:27:45 +0100
|
||||
Subject: [PATCH] Do not install *.bat files on non-win32 machines
|
||||
|
||||
Signed-off-by: Peter Lemenkov <lemenkov@gmail.com>
|
||||
Signed-off-by: Hans Ulrich Niedermann <hun@n-dimensional.de>
|
||||
---
|
||||
lib/observer/src/Makefile | 8 ++++++--
|
||||
lib/observer/src/Makefile | 9 ++++++---
|
||||
lib/webtool/priv/Makefile | 8 ++++++--
|
||||
2 files changed, 12 insertions(+), 4 deletions(-)
|
||||
2 files changed, 12 insertions(+), 5 deletions(-)
|
||||
|
||||
diff --git a/lib/observer/src/Makefile b/lib/observer/src/Makefile
|
||||
index b4eb518..353daef 100644
|
||||
index 2d06cb6..3875b62 100644
|
||||
--- a/lib/observer/src/Makefile
|
||||
+++ b/lib/observer/src/Makefile
|
||||
@@ -56,11 +56,15 @@ TARGET_FILES= $(MODULES:%=$(EBIN)/%.$(EMULATOR)) $(APP_TARGET) $(APPUP_TARGET)
|
||||
@@ -56,13 +56,16 @@ TARGET_FILES= $(MODULES:%=$(EBIN)/%.$(EMULATOR)) $(APP_TARGET) $(APPUP_TARGET)
|
||||
PRIVDIR= ../priv
|
||||
WEBTOOLFILES= $(PRIVDIR)/crashdump_viewer.tool
|
||||
BINDIR= $(PRIVDIR)/bin
|
||||
+ifeq ($(findstring win32,$(TARGET)),win32)
|
||||
+WIN32_EXECUTABLES= $(BINDIR)/etop.bat $(BINDIR)/getop.bat
|
||||
+WIN32_EXECUTABLES= $(BINDIR)/etop.bat $(BINDIR)/getop.bat $(BINDIR)/cdv.bat
|
||||
+else
|
||||
+WIN32_EXECUTABLES=
|
||||
+endif
|
||||
EXECUTABLES= \
|
||||
$(BINDIR)/etop \
|
||||
$(BINDIR)/getop \
|
||||
$(BINDIR)/cdv \
|
||||
- $(BINDIR)/etop.bat \
|
||||
- $(BINDIR)/getop.bat
|
||||
- $(BINDIR)/getop.bat \
|
||||
- $(BINDIR)/cdv.bat
|
||||
+ $(WIN32_EXECUTABLES)
|
||||
CDVDIR= $(PRIVDIR)/crashdump_viewer
|
||||
GIF_FILES= \
|
||||
$(CDVDIR)/collapsd.gif \
|
||||
diff --git a/lib/webtool/priv/Makefile b/lib/webtool/priv/Makefile
|
||||
index 56ab772..c29e912 100644
|
||||
index 56ab772..6e1c660 100644
|
||||
--- a/lib/webtool/priv/Makefile
|
||||
+++ b/lib/webtool/priv/Makefile
|
||||
@@ -39,8 +39,12 @@ HTDOCS_FILES = root/doc/index.html \
|
||||
@ -41,7 +44,7 @@ index 56ab772..c29e912 100644
|
||||
-SCRIPTS = bin/start_webtool \
|
||||
- bin/start_webtool.bat
|
||||
+ifeq ($(findstring win32,$(TARGET)),win32)
|
||||
+WIN32_SCRIPTS= bin/start.bat
|
||||
+WIN32_SCRIPTS= bin/start_webtool.bat
|
||||
+else
|
||||
+WIN32_SCRIPTS=
|
||||
+endif
|
||||
|
@ -8,7 +8,7 @@ Signed-off-by: Peter Lemenkov <lemenkov@gmail.com>
|
||||
1 files changed, 0 insertions(+), 1 deletions(-)
|
||||
|
||||
diff --git a/erts/doc/src/Makefile b/erts/doc/src/Makefile
|
||||
index be99288..4bb07c4 100644
|
||||
index 6578923..44206fd 100644
|
||||
--- a/erts/doc/src/Makefile
|
||||
+++ b/erts/doc/src/Makefile
|
||||
@@ -46,7 +46,6 @@ XML_REF1_FILES = epmd.xml \
|
||||
|
@ -1,8 +1,9 @@
|
||||
From: Peter Lemenkov <lemenkov@gmail.com>
|
||||
Date: Sat, 19 Jun 2010 13:21:10 +0400
|
||||
From: Hans Ulrich Niedermann <hun@n-dimensional.de>
|
||||
Date: Mon, 21 Mar 2011 15:41:49 +0100
|
||||
Subject: [PATCH] Do not install erlang sources
|
||||
|
||||
Signed-off-by: Peter Lemenkov <lemenkov@gmail.com>
|
||||
Signed-off-by: Hans Ulrich Niedermann <hun@n-dimensional.de>
|
||||
---
|
||||
erts/preloaded/src/Makefile | 2 --
|
||||
lib/appmon/src/Makefile | 2 +-
|
||||
@ -74,11 +75,11 @@ Signed-off-by: Peter Lemenkov <lemenkov@gmail.com>
|
||||
lib/toolbar/src/Makefile | 2 +-
|
||||
lib/tools/src/Makefile | 2 +-
|
||||
lib/tv/src/Makefile | 2 +-
|
||||
lib/typer/src/Makefile | 2 +-
|
||||
lib/typer/src/Makefile | 2 --
|
||||
lib/webtool/src/Makefile | 2 --
|
||||
lib/wx/src/Makefile | 4 ++--
|
||||
lib/xmerl/src/Makefile | 4 +---
|
||||
74 files changed, 58 insertions(+), 99 deletions(-)
|
||||
74 files changed, 57 insertions(+), 100 deletions(-)
|
||||
|
||||
diff --git a/erts/preloaded/src/Makefile b/erts/preloaded/src/Makefile
|
||||
index 1456388..81db627 100644
|
||||
@ -120,10 +121,10 @@ index 2733cde..42a674e 100644
|
||||
$(INSTALL_DATA) $(EXAMPLES) $(RELSYSDIR)/examples
|
||||
|
||||
diff --git a/lib/common_test/src/Makefile b/lib/common_test/src/Makefile
|
||||
index 027667e..ff6a319 100644
|
||||
index 84b122b..5c01656 100644
|
||||
--- a/lib/common_test/src/Makefile
|
||||
+++ b/lib/common_test/src/Makefile
|
||||
@@ -130,7 +130,7 @@ include $(ERL_TOP)/make/otp_release_targets.mk
|
||||
@@ -132,7 +132,7 @@ include $(ERL_TOP)/make/otp_release_targets.mk
|
||||
|
||||
release_spec: opt
|
||||
$(INSTALL_DIR) $(RELSYSDIR)/src
|
||||
@ -133,10 +134,10 @@ index 027667e..ff6a319 100644
|
||||
$(INSTALL_DATA) $(TARGET_FILES) $(RELSYSDIR)/ebin
|
||||
$(INSTALL_DIR) $(RELSYSDIR)/include
|
||||
diff --git a/lib/compiler/src/Makefile b/lib/compiler/src/Makefile
|
||||
index 0f6d2f6..9ee17e5 100644
|
||||
index 1238d11..93747f6 100644
|
||||
--- a/lib/compiler/src/Makefile
|
||||
+++ b/lib/compiler/src/Makefile
|
||||
@@ -160,8 +160,8 @@ include $(ERL_TOP)/make/otp_release_targets.mk
|
||||
@@ -162,8 +162,8 @@ include $(ERL_TOP)/make/otp_release_targets.mk
|
||||
|
||||
release_spec: opt
|
||||
$(INSTALL_DIR) $(RELSYSDIR)/src
|
||||
@ -148,10 +149,10 @@ index 0f6d2f6..9ee17e5 100644
|
||||
$(INSTALL_DATA) $(INSTALL_FILES) $(RELSYSDIR)/ebin
|
||||
|
||||
diff --git a/lib/cosEvent/src/Makefile b/lib/cosEvent/src/Makefile
|
||||
index ba6e2b1..50a73d9 100644
|
||||
index a62d47c..66ce6d9 100644
|
||||
--- a/lib/cosEvent/src/Makefile
|
||||
+++ b/lib/cosEvent/src/Makefile
|
||||
@@ -199,7 +199,7 @@ release_spec: opt
|
||||
@@ -200,7 +200,7 @@ release_spec: opt
|
||||
$(INSTALL_DIR) $(RELSYSDIR)/ebin
|
||||
$(INSTALL_DATA) $(TARGET_FILES) $(APP_TARGET) $(APPUP_TARGET) $(RELSYSDIR)/ebin
|
||||
$(INSTALL_DIR) $(RELSYSDIR)/src
|
||||
@ -161,10 +162,10 @@ index ba6e2b1..50a73d9 100644
|
||||
$(INSTALL_DATA) $(GEN_HRL_FILES) $(RELSYSDIR)/include
|
||||
|
||||
diff --git a/lib/cosEventDomain/src/Makefile b/lib/cosEventDomain/src/Makefile
|
||||
index 884c8f1..9c36cc1 100644
|
||||
index 56a67cd..19933c9 100644
|
||||
--- a/lib/cosEventDomain/src/Makefile
|
||||
+++ b/lib/cosEventDomain/src/Makefile
|
||||
@@ -165,7 +165,7 @@ release_spec: opt
|
||||
@@ -166,7 +166,7 @@ release_spec: opt
|
||||
$(INSTALL_DIR) $(RELSYSDIR)/ebin
|
||||
$(INSTALL_DATA) $(TARGET_FILES) $(APP_TARGET) $(APPUP_TARGET) $(RELSYSDIR)/ebin
|
||||
$(INSTALL_DIR) $(RELSYSDIR)/src
|
||||
@ -295,10 +296,10 @@ index e8a07a5..d0ac3a9 100644
|
||||
$(INSTALL_DATA) $(TARGET_FILES) $(APP_TARGET) $(APPUP_TARGET) $(RELSYSDIR)/ebin
|
||||
|
||||
diff --git a/lib/edoc/src/Makefile b/lib/edoc/src/Makefile
|
||||
index ca95c4c..56a7745 100644
|
||||
index 9c5a9d3..5de4e3d 100644
|
||||
--- a/lib/edoc/src/Makefile
|
||||
+++ b/lib/edoc/src/Makefile
|
||||
@@ -87,7 +87,7 @@ release_spec: opt
|
||||
@@ -88,7 +88,7 @@ release_spec: opt
|
||||
$(INSTALL_DIR) $(RELSYSDIR)/ebin
|
||||
$(INSTALL_DATA) $(OBJECTS) $(RELSYSDIR)/ebin
|
||||
$(INSTALL_DIR) $(RELSYSDIR)/src
|
||||
@ -499,10 +500,10 @@ index aaf3cfb..0236a49 100644
|
||||
$(INSTALL_DATA) $(TARGET_FILES) $(RELSYSDIR)/ebin
|
||||
|
||||
diff --git a/lib/inets/src/http_server/Makefile b/lib/inets/src/http_server/Makefile
|
||||
index bdd8c5e..64d971f 100644
|
||||
index 55cc68d..78e46ae 100644
|
||||
--- a/lib/inets/src/http_server/Makefile
|
||||
+++ b/lib/inets/src/http_server/Makefile
|
||||
@@ -126,7 +126,7 @@ include $(ERL_TOP)/make/otp_release_targets.mk
|
||||
@@ -123,7 +123,7 @@ include $(ERL_TOP)/make/otp_release_targets.mk
|
||||
release_spec: opt
|
||||
$(INSTALL_DIR) $(RELSYSDIR)/src
|
||||
$(INSTALL_DIR) $(RELSYSDIR)/src/http_server
|
||||
@ -512,18 +513,18 @@ index bdd8c5e..64d971f 100644
|
||||
$(INSTALL_DATA) $(TARGET_FILES) $(RELSYSDIR)/ebin
|
||||
|
||||
diff --git a/lib/inets/src/inets_app/Makefile b/lib/inets/src/inets_app/Makefile
|
||||
index 4632ff3..6014db2 100644
|
||||
index 20e2291..a4e4763 100644
|
||||
--- a/lib/inets/src/inets_app/Makefile
|
||||
+++ b/lib/inets/src/inets_app/Makefile
|
||||
@@ -110,7 +110,7 @@ include $(ERL_TOP)/make/otp_release_targets.mk
|
||||
@@ -111,7 +111,7 @@ include $(ERL_TOP)/make/otp_release_targets.mk
|
||||
release_spec: opt
|
||||
$(INSTALL_DIR) $(RELSYSDIR)/src
|
||||
$(INSTALL_DIR) $(RELSYSDIR)/src/inets_app
|
||||
- $(INSTALL_DATA) $(HRL_FILES) $(ERL_FILES) $(RELSYSDIR)/src/inets_app
|
||||
+ $(INSTALL_DATA) $(HRL_FILES) $(RELSYSDIR)/src/inets_app
|
||||
- $(INSTALL_DATA) $(INTERNAL_HRL_FILES) $(ERL_FILES) $(RELSYSDIR)/src/inets_app
|
||||
+ $(INSTALL_DATA) $(INTERNAL_HRL_FILES) $(RELSYSDIR)/src/inets_app
|
||||
$(INSTALL_DIR) $(RELSYSDIR)/include
|
||||
$(INSTALL_DATA) $(EXTERNAL_HRL_FILES) $(RELSYSDIR)/include
|
||||
$(INSTALL_DIR) $(RELSYSDIR)/ebin
|
||||
$(INSTALL_DATA) $(TARGET_FILES) $(RELSYSDIR)/ebin
|
||||
|
||||
diff --git a/lib/inets/src/tftp/Makefile b/lib/inets/src/tftp/Makefile
|
||||
index 759b70c..9e4f769 100644
|
||||
--- a/lib/inets/src/tftp/Makefile
|
||||
@ -666,10 +667,10 @@ index e032f56..e357187 100644
|
||||
$(INSTALL_DATA) $(TARGET_FILES) $(RELSYSDIR)/ebin
|
||||
|
||||
diff --git a/lib/observer/src/Makefile b/lib/observer/src/Makefile
|
||||
index 353daef..c61d157 100644
|
||||
index 3875b62..cebfbab 100644
|
||||
--- a/lib/observer/src/Makefile
|
||||
+++ b/lib/observer/src/Makefile
|
||||
@@ -113,7 +113,6 @@ include $(ERL_TOP)/make/otp_release_targets.mk
|
||||
@@ -114,7 +114,6 @@ include $(ERL_TOP)/make/otp_release_targets.mk
|
||||
|
||||
release_spec: opt
|
||||
$(INSTALL_DIR) $(RELSYSDIR)/src
|
||||
@ -783,7 +784,7 @@ index e573e57..bdbced1 100644
|
||||
$(INSTALL_DATA) $(TARGET_FILES) $(TARGET_TOOLBOX_FILES) $(RELSYSDIR)/ebin
|
||||
|
||||
diff --git a/lib/public_key/src/Makefile b/lib/public_key/src/Makefile
|
||||
index 51f4053..6179e0a 100644
|
||||
index b042b0c..947009c 100644
|
||||
--- a/lib/public_key/src/Makefile
|
||||
+++ b/lib/public_key/src/Makefile
|
||||
@@ -46,8 +46,6 @@ MODULES = \
|
||||
@ -869,18 +870,18 @@ index d89eb4e..2adf916 100644
|
||||
$(INSTALL_DATA) $(TARGET_FILES) $(APP_TARGET) $(APPUP_TARGET) \
|
||||
$(RELSYSDIR)/ebin
|
||||
diff --git a/lib/snmp/src/compile/Makefile b/lib/snmp/src/compile/Makefile
|
||||
index 4be60e1..df7ed2d 100644
|
||||
index 0ceaf27..872611d 100644
|
||||
--- a/lib/snmp/src/compile/Makefile
|
||||
+++ b/lib/snmp/src/compile/Makefile
|
||||
@@ -115,7 +115,7 @@ include $(ERL_TOP)/make/otp_release_targets.mk
|
||||
@@ -123,7 +123,7 @@ include $(ERL_TOP)/make/otp_release_targets.mk
|
||||
release_spec: opt
|
||||
$(INSTALL_DIR) $(RELSYSDIR)/src
|
||||
$(INSTALL_DIR) $(RELSYSDIR)/src/compiler
|
||||
- $(INSTALL_DATA) $(PARSER_SRC) $(ERL_FILES) $(INTERNAL_HRL_FILES) $(RELSYSDIR)/src/compiler
|
||||
- $(INSTALL_DATA) $(ESCRIPT_SRC) $(PARSER_SRC) $(ERL_FILES) $(INTERNAL_HRL_FILES) $(RELSYSDIR)/src/compiler
|
||||
+ $(INSTALL_DATA) $(INTERNAL_HRL_FILES) $(RELSYSDIR)/src/compiler
|
||||
$(INSTALL_DIR) $(RELSYSDIR)/ebin
|
||||
$(INSTALL_DATA) $(TARGET_FILES) $(RELSYSDIR)/ebin
|
||||
|
||||
$(INSTALL_DIR) $(RELSYSDIR)/bin
|
||||
diff --git a/lib/snmp/src/manager/Makefile b/lib/snmp/src/manager/Makefile
|
||||
index c1d5703..568530d 100644
|
||||
--- a/lib/snmp/src/manager/Makefile
|
||||
@ -959,10 +960,10 @@ index 50369e6..12c6db4 100644
|
||||
release_docs_spec:
|
||||
|
||||
diff --git a/lib/test_server/src/Makefile b/lib/test_server/src/Makefile
|
||||
index 3dca551..217129b 100644
|
||||
index 63a585d..4855056 100644
|
||||
--- a/lib/test_server/src/Makefile
|
||||
+++ b/lib/test_server/src/Makefile
|
||||
@@ -125,7 +125,6 @@ include $(ERL_TOP)/make/otp_release_targets.mk
|
||||
@@ -126,7 +126,6 @@ include $(ERL_TOP)/make/otp_release_targets.mk
|
||||
|
||||
release_spec: opt
|
||||
$(INSTALL_DIR) $(RELSYSDIR)/src
|
||||
@ -1010,18 +1011,18 @@ index 457b9d3..1d2c97c 100644
|
||||
$(INSTALL_DATA) $(TARGET_FILES) $(RELSYSDIR)/ebin
|
||||
|
||||
diff --git a/lib/typer/src/Makefile b/lib/typer/src/Makefile
|
||||
index 9c9ef61..db92881 100644
|
||||
index 620b3eb..67c266f 100644
|
||||
--- a/lib/typer/src/Makefile
|
||||
+++ b/lib/typer/src/Makefile
|
||||
@@ -113,7 +113,7 @@ include $(ERL_TOP)/make/otp_release_targets.mk
|
||||
@@ -102,8 +102,6 @@ include $(ERL_TOP)/make/otp_release_targets.mk
|
||||
|
||||
release_spec: opt
|
||||
$(INSTALL_DIR) $(RELSYSDIR)/src
|
||||
- $(INSTALL_DATA) $(ERL_FILES) $(HRL_FILES) $(YRL_FILES) \
|
||||
+ $(INSTALL_DATA) $(HRL_FILES) \
|
||||
$(RELSYSDIR)/src
|
||||
- $(RELSYSDIR)/src
|
||||
$(INSTALL_DIR) $(RELSYSDIR)/ebin
|
||||
$(INSTALL_DATA) $(INSTALL_FILES) $(RELSYSDIR)/ebin
|
||||
|
||||
diff --git a/lib/webtool/src/Makefile b/lib/webtool/src/Makefile
|
||||
index 62845cd..841cf11 100644
|
||||
--- a/lib/webtool/src/Makefile
|
||||
|
@ -1,38 +0,0 @@
|
||||
From: Patrik Nyblom <pan@erlang.org>
|
||||
Date: Wed, 12 Jan 2011 15:41:46 +0100
|
||||
Subject: [PATCH] Remove strange name field in efile_drv.c as it upsets -D_FORTIFY_SOURCE
|
||||
|
||||
---
|
||||
erts/emulator/drivers/common/efile_drv.c | 5 ++---
|
||||
1 files changed, 2 insertions(+), 3 deletions(-)
|
||||
|
||||
diff --git a/erts/emulator/drivers/common/efile_drv.c b/erts/emulator/drivers/common/efile_drv.c
|
||||
index 786fa7d..6449c6f 100644
|
||||
--- a/erts/emulator/drivers/common/efile_drv.c
|
||||
+++ b/erts/emulator/drivers/common/efile_drv.c
|
||||
@@ -385,7 +385,6 @@ struct t_data
|
||||
ErlDrvBinary *binp;
|
||||
int size;
|
||||
int offset;
|
||||
- char name[1];
|
||||
} read_file;
|
||||
struct {
|
||||
struct t_readdir_buf *first_buf;
|
||||
@@ -1117,7 +1116,7 @@ static void invoke_read_file(void *data)
|
||||
Sint64 size;
|
||||
|
||||
if (! (d->result_ok =
|
||||
- efile_openfile(&d->errInfo, d->c.read_file.name,
|
||||
+ efile_openfile(&d->errInfo, d->b,
|
||||
EFILE_MODE_READ, &fd, &size))) {
|
||||
goto done;
|
||||
}
|
||||
@@ -3071,7 +3070,7 @@ file_outputv(ErlDrvData e, ErlIOVec *ev) {
|
||||
d->command = command;
|
||||
d->reply = !0;
|
||||
/* Copy name */
|
||||
- FILENAME_COPY(d->c.read_file.name, filename);
|
||||
+ FILENAME_COPY(d->b, filename);
|
||||
d->c.read_file.binp = NULL;
|
||||
d->invoke = invoke_read_file;
|
||||
d->free = free_read_file;
|
@ -1,6 +1,6 @@
|
||||
#!/bin/bash
|
||||
# Usage:
|
||||
# ./otp-get-patches.sh /path/to/otp OTP_R14B01 fedora-R14B01
|
||||
# ./otp-get-patches.sh /path/to/otp OTP_R14B02 fedora-R14B02
|
||||
#
|
||||
# otp-get-patches.sh - update erlang.spec and otp-00*.patch files
|
||||
#
|
||||
|
Loading…
Reference in New Issue
Block a user