Ver. R13B-04
This commit is contained in:
parent
dbc24bbcea
commit
b1e63e1152
@ -1,3 +1,3 @@
|
||||
otp_src_R13B01.tar.gz
|
||||
otp_doc_html_R13B01.tar.gz
|
||||
otp_doc_man_R13B01.tar.gz
|
||||
otp_doc_html_R13B04.tar.gz
|
||||
otp_doc_man_R13B04.tar.gz
|
||||
otp_src_R13B04.tar.gz
|
||||
|
56
erlang.spec
56
erlang.spec
@ -1,9 +1,9 @@
|
||||
%define ver R13B
|
||||
%define rel 01
|
||||
%define rel 04
|
||||
|
||||
Name: erlang
|
||||
Version: %{ver}
|
||||
Release: %{rel}.3%{?dist}
|
||||
Release: %{rel}.1%{?dist}
|
||||
Summary: General-purpose programming language and runtime environment
|
||||
|
||||
Group: Development/Languages
|
||||
@ -12,21 +12,23 @@ URL: http://www.erlang.org
|
||||
Source: http://www.erlang.org/download/otp_src_%{ver}%{rel}.tar.gz
|
||||
Source1: http://www.erlang.org/download/otp_doc_html_%{ver}%{rel}.tar.gz
|
||||
Source2: http://www.erlang.org/download/otp_doc_man_%{ver}%{rel}.tar.gz
|
||||
# TODO this patch needs rebase against current tree
|
||||
Patch0: otp-links.patch
|
||||
Patch1: otp-install.patch
|
||||
Patch2: otp-rpath.patch
|
||||
Patch1: otp-0001-Do-not-format-man-pages.patch
|
||||
Patch2: otp-0002-Remove-rpath.patch
|
||||
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
|
||||
|
||||
BuildRequires: ncurses-devel
|
||||
BuildRequires: openssl-devel
|
||||
BuildRequires: zlib-devel
|
||||
BuildRequires: unixODBC-devel
|
||||
BuildRequires: wxGTK-devel
|
||||
BuildRequires: tcl-devel
|
||||
BuildRequires: tk-devel
|
||||
BuildRequires: gd-devel
|
||||
BuildRequires: java-1.6.0-openjdk-devel
|
||||
BuildRequires: flex
|
||||
BuildRequires: m4
|
||||
BuildRequires: fop
|
||||
|
||||
Requires: tk
|
||||
|
||||
@ -47,28 +49,18 @@ Documentation for Erlang.
|
||||
|
||||
%prep
|
||||
%setup -q -n otp_src_%{ver}%{rel}
|
||||
%patch0 -p1 -b .links
|
||||
%patch1 -p1 -b .install
|
||||
%patch1 -p1 -b .do_not_format_manpages
|
||||
%patch2 -p1 -b .rpath
|
||||
|
||||
# enable dynamic linking for ssl
|
||||
sed -i 's|SSL_DYNAMIC_ONLY=no|SSL_DYNAMIC_ONLY=yes|' erts/configure
|
||||
#sed -i 's|^LD.*=.*|LD = gcc -shared|' lib/common_test/c_src/Makefile
|
||||
# fix for newer glibc version
|
||||
sed -i 's|__GLIBC_MINOR__ <= 7|__GLIBC_MINOR__ <= 8|' erts/emulator/hipe/hipe_x86_signal.c
|
||||
# use gcc -shared instead of ld
|
||||
#sed -i 's|@RX_LD@|gcc -shared|' lib/common_test/c_src/Makefile.in
|
||||
#sed -i 's|@RX_LDFLAGS@||' lib/common_test/c_src/Makefile.in
|
||||
|
||||
# remove shipped zlib sources
|
||||
rm -f erts/emulator/zlib/*.[ch]
|
||||
|
||||
|
||||
%build
|
||||
%ifarch sparcv9 sparc64
|
||||
CFLAGS="$RPM_OPT_FLAGS -mcpu=ultrasparc -fno-strict-aliasing" ./configure --prefix=%{_prefix} --exec-prefix=%{_prefix} --bindir=%{_bindir} --libdir=%{_libdir}
|
||||
CFLAGS="$RPM_OPT_FLAGS -mcpu=ultrasparc -fno-strict-aliasing" %configure --enable-shared-zlib
|
||||
%else
|
||||
CFLAGS="$RPM_OPT_FLAGS -fno-strict-aliasing" ./configure --prefix=%{_prefix} --exec-prefix=%{_prefix} --bindir=%{_bindir} --libdir=%{_libdir}
|
||||
CFLAGS="$RPM_OPT_FLAGS -fno-strict-aliasing" %configure --enable-shared-zlib
|
||||
%endif
|
||||
chmod -R u+w .
|
||||
make
|
||||
|
||||
|
||||
@ -101,6 +93,12 @@ done
|
||||
cd $RPM_BUILD_ROOT/%{_libdir}/erlang
|
||||
sed -i "s|$RPM_BUILD_ROOT||" erts*/bin/{erl,start} releases/RELEASES bin/{erl,start}
|
||||
|
||||
# remove unneeded *.erl sources
|
||||
find $RPM_BUILD_ROOT/%{_libdir}/erlang/lib -maxdepth 2 -type d -name *src -exec rm -rf {} \;
|
||||
|
||||
# fixed permisson for wx library
|
||||
chmod 755 $RPM_BUILD_ROOT/%{_libdir}/erlang/lib/wx-*/priv/*/wxe_driver.so
|
||||
|
||||
|
||||
%clean
|
||||
rm -rf $RPM_BUILD_ROOT
|
||||
@ -108,7 +106,7 @@ rm -rf $RPM_BUILD_ROOT
|
||||
|
||||
%files
|
||||
%defattr(-,root,root)
|
||||
%doc AUTHORS EPLICENCE README
|
||||
%doc AUTHORS EPLICENCE README.md
|
||||
%{_bindir}/*
|
||||
%{_libdir}/erlang
|
||||
|
||||
@ -123,8 +121,20 @@ rm -rf $RPM_BUILD_ROOT
|
||||
|
||||
|
||||
%changelog
|
||||
* Wed Dec 09 2009 Kevin Kofler <Kevin@tigcc.ticalc.org> - R13B-01.3
|
||||
- rebuild with fixed GCC, fixes couchdb crash (#527370)
|
||||
* Sat Feb 13 2010 Peter Lemenkov <lemenkov@gmail.com> - R13B-04.1
|
||||
- New release R13B-04
|
||||
- Since now we're using %%configure instead of ./configure
|
||||
- Removed no longer needed fix for newer glibc version
|
||||
- Dropped %%patch3 (applied upstream)
|
||||
- Rebased patches
|
||||
- Added BR fop for rebuilding of docs
|
||||
- Use system-wide zlib instead of shipped one
|
||||
- Dropped BR gd-devel
|
||||
- Removed unneeded sources (should be fixed upstream)
|
||||
- Fixed permission for wx driver (should be fixed upstream)
|
||||
|
||||
* Thu Oct 22 2009 Lubomir Rintel (Good Data) <lubo.rintel@gooddata.com> - R13B-02-1
|
||||
- Update to R13B-02 (patched for what's released as 02-1 by upstream)
|
||||
|
||||
* Tue Aug 25 2009 Tomas Mraz <tmraz@redhat.com> - R13B-01.2
|
||||
- rebuilt with new openssl
|
||||
|
1
import.log
Normal file
1
import.log
Normal file
@ -0,0 +1 @@
|
||||
erlang-R13B-04_1_fc12:F-12:erlang-R13B-04.1.fc12.src.rpm:1268837646
|
32
otp-0001-Do-not-format-man-pages.patch
Normal file
32
otp-0001-Do-not-format-man-pages.patch
Normal file
@ -0,0 +1,32 @@
|
||||
From 80fd602b5cd9f4aaa7b6bd95e174708e27601db5 Mon Sep 17 00:00:00 2001
|
||||
From: Peter Lemenkov <lemenkov@gmail.com>
|
||||
Date: Thu, 25 Feb 2010 16:45:28 +0300
|
||||
Subject: [PATCH 1/2] Do not format man-pages
|
||||
|
||||
Signed-off-by: Peter Lemenkov <lemenkov@gmail.com>
|
||||
---
|
||||
erts/etc/unix/Install.src | 10 ----------
|
||||
1 files changed, 0 insertions(+), 10 deletions(-)
|
||||
|
||||
diff --git a/erts/etc/unix/Install.src b/erts/etc/unix/Install.src
|
||||
index 83f9690..d26137d 100644
|
||||
--- a/erts/etc/unix/Install.src
|
||||
+++ b/erts/etc/unix/Install.src
|
||||
@@ -139,14 +139,4 @@ cp -p ../releases/%I_SYSTEM_VSN%/start_*.boot .
|
||||
cp -p $Name.boot start.boot
|
||||
cp -p ../releases/%I_SYSTEM_VSN%/$Name.script start.script
|
||||
|
||||
-#
|
||||
-# Fixing the man pages
|
||||
-#
|
||||
-
|
||||
-if [ -d $ERL_ROOT/man ]
|
||||
-then
|
||||
- cd $ERL_ROOT
|
||||
- ./misc/format_man_pages $ERL_ROOT
|
||||
-fi
|
||||
-
|
||||
exit 0
|
||||
--
|
||||
1.6.2.5
|
||||
|
72
otp-0002-Remove-rpath.patch
Normal file
72
otp-0002-Remove-rpath.patch
Normal file
@ -0,0 +1,72 @@
|
||||
From 2e10f728feb56ea96b2832999a8c34f1f19646bc Mon Sep 17 00:00:00 2001
|
||||
From: Peter Lemenkov <lemenkov@gmail.com>
|
||||
Date: Thu, 25 Feb 2010 16:57:43 +0300
|
||||
Subject: [PATCH 2/2] Remove rpath
|
||||
|
||||
Signed-off-by: Peter Lemenkov <lemenkov@gmail.com>
|
||||
---
|
||||
lib/crypto/c_src/Makefile.in | 2 +-
|
||||
lib/crypto/priv/Makefile | 2 +-
|
||||
lib/ssl/c_src/Makefile.in | 6 +++---
|
||||
3 files changed, 5 insertions(+), 5 deletions(-)
|
||||
|
||||
diff --git a/lib/crypto/c_src/Makefile.in b/lib/crypto/c_src/Makefile.in
|
||||
index 18040a3..b169930 100644
|
||||
--- a/lib/crypto/c_src/Makefile.in
|
||||
+++ b/lib/crypto/c_src/Makefile.in
|
||||
@@ -83,7 +83,7 @@ endif
|
||||
DYNAMIC_CRYPTO_LIB=@SSL_DYNAMIC_ONLY@
|
||||
|
||||
ifeq ($(DYNAMIC_CRYPTO_LIB),yes)
|
||||
-SSL_DED_LD_RUNTIME_LIBRARY_PATH = @SSL_DED_LD_RUNTIME_LIBRARY_PATH@
|
||||
+SSL_DED_LD_RUNTIME_LIBRARY_PATH =
|
||||
CRYPTO_LINK_LIB=$(SSL_DED_LD_RUNTIME_LIBRARY_PATH) -L$(SSL_LIBDIR) -lcrypto
|
||||
else
|
||||
SSL_DED_LD_RUNTIME_LIBRARY_PATH=
|
||||
diff --git a/lib/crypto/priv/Makefile b/lib/crypto/priv/Makefile
|
||||
index b8acdac..2c2989a 100644
|
||||
--- a/lib/crypto/priv/Makefile
|
||||
+++ b/lib/crypto/priv/Makefile
|
||||
@@ -60,7 +60,7 @@ OBJS = $(OBJDIR)/crypto_drv.o
|
||||
# ----------------------------------------------------
|
||||
|
||||
$(SO_DRIVER): $(OBJS)
|
||||
- $(SO_LD) $(SO_LDFLAGS) -L$(SO_SSL_LIBDIR) -Wl,-R$(SO_SSL_LIBDIR) \
|
||||
+ $(SO_LD) $(SO_LDFLAGS) -L$(SO_SSL_LIBDIR) \
|
||||
-o $@ $^ -lcrypto
|
||||
|
||||
$(DLL_DRIVER): $(OBJS)
|
||||
diff --git a/lib/ssl/c_src/Makefile.in b/lib/ssl/c_src/Makefile.in
|
||||
index 49a209f..5e6c74e 100644
|
||||
--- a/lib/ssl/c_src/Makefile.in
|
||||
+++ b/lib/ssl/c_src/Makefile.in
|
||||
@@ -105,7 +105,7 @@ else
|
||||
SSL_MAKEFILE =
|
||||
endif
|
||||
|
||||
-CC_R_FLAG=@CFLAG_RUNTIME_LIBRARY_PATH@
|
||||
+CC_R_FLAG=
|
||||
|
||||
ifeq ($(findstring @,$(CC_R_FLAG)),@)
|
||||
# Old erts configure used which hasn't replaced @CFLAG_RUNTIME_LIBRARY_PATH@;
|
||||
@@ -117,7 +117,7 @@ else
|
||||
ifeq ($(findstring osf,$(TARGET)),osf) # osf1: -Wl,-rpath,
|
||||
CC_R_FLAG = -Wl,-rpath,
|
||||
else # Default: -Wl,-R
|
||||
-CC_R_FLAG = -Wl,-R
|
||||
+CC_R_FLAG =
|
||||
endif
|
||||
endif
|
||||
endif
|
||||
@@ -125,7 +125,7 @@ endif
|
||||
ifeq ($(strip $(CC_R_FLAG)),)
|
||||
CC_R_OPT =
|
||||
else
|
||||
-CC_R_OPT = $(CC_R_FLAG)$(SSL_LIBDIR)
|
||||
+CC_R_OPT =
|
||||
endif
|
||||
|
||||
SSL_CC_RUNTIME_LIBRARY_PATH=@SSL_CC_RUNTIME_LIBRARY_PATH@
|
||||
--
|
||||
1.6.2.5
|
||||
|
@ -1,29 +0,0 @@
|
||||
--- otp_src_R9C-0/erts/etc/unix/Install.src.install 2003-10-17 12:52:14.000000000 +0200
|
||||
+++ otp_src_R9C-0/erts/etc/unix/Install.src 2003-10-17 14:26:49.000000000 +0200
|
||||
@@ -84,7 +84,7 @@
|
||||
/bin/rm -f epmd
|
||||
fi
|
||||
|
||||
-ln -s $ERL_ROOT/erts-%I_VSN%/bin/epmd epmd
|
||||
+ln -s ../erts-%I_VSN%/bin/epmd epmd
|
||||
|
||||
cp -p $ERL_ROOT/erts-%I_VSN%/bin/run_erl .
|
||||
cp -p $ERL_ROOT/erts-%I_VSN%/bin/to_erl .
|
||||
@@ -145,16 +145,4 @@
|
||||
(ranlib $library) > /dev/null 2>&1
|
||||
done
|
||||
fi
|
||||
-
|
||||
-
|
||||
-#
|
||||
-# Fixing the man pages
|
||||
-#
|
||||
-
|
||||
-if [ -d $ERL_ROOT/man ]
|
||||
-then
|
||||
- cd $ERL_ROOT
|
||||
- ./misc/format_man_pages $ERL_ROOT
|
||||
-fi
|
||||
-
|
||||
-
|
||||
+exit 0
|
@ -1,11 +0,0 @@
|
||||
diff -up otp_src_R12B-0/lib/orber/c_src/setsockaddr_in.c.null otp_src_R12B-0/lib/orber/c_src/setsockaddr_in.c
|
||||
--- otp_src_R12B-0/lib/orber/c_src/setsockaddr_in.c.null 2008-02-23 13:46:52.000000000 +0100
|
||||
+++ otp_src_R12B-0/lib/orber/c_src/setsockaddr_in.c 2008-02-23 13:47:15.000000000 +0100
|
||||
@@ -17,6 +17,7 @@
|
||||
* $Id$
|
||||
*
|
||||
*/
|
||||
+#include <stdlib.h>
|
||||
#include "inet.h"
|
||||
|
||||
#ifdef HAVE_CONFIG_H
|
@ -1,48 +0,0 @@
|
||||
diff -urNp otp_src_R12B-5.orig/lib/crypto/c_src/Makefile.in otp_src_R12B-5/lib/crypto/c_src/Makefile.in
|
||||
--- otp_src_R12B-5.orig/lib/crypto/c_src/Makefile.in 2009-04-21 18:38:46.000000000 +0530
|
||||
+++ otp_src_R12B-5/lib/crypto/c_src/Makefile.in 2009-04-21 18:51:34.000000000 +0530
|
||||
@@ -80,7 +80,7 @@ ifeq ($(HOST_OS),)
|
||||
HOST_OS := $(shell $(ERL_TOP)/erts/autoconf/config.guess)
|
||||
endif
|
||||
DYNAMIC_CRYPTO_LIB=@SSL_DYNAMIC_ONLY@
|
||||
-LD_R_FLAG=@DED_LD_FLAG_RUNTIME_LIBRARY_PATH@
|
||||
+LD_R_FLAG=
|
||||
ifeq ($(strip $(LD_R_FLAG)),)
|
||||
LD_R_OPT =
|
||||
else
|
||||
diff -urNp otp_src_R12B-5.orig/lib/crypto/priv/Makefile otp_src_R12B-5/lib/crypto/priv/Makefile
|
||||
--- otp_src_R12B-5.orig/lib/crypto/priv/Makefile 2009-04-21 18:38:46.000000000 +0530
|
||||
+++ otp_src_R12B-5/lib/crypto/priv/Makefile 2009-04-21 18:52:56.000000000 +0530
|
||||
@@ -60,7 +60,7 @@ OBJS = $(OBJDIR)/crypto_drv.o
|
||||
# ----------------------------------------------------
|
||||
|
||||
$(SO_DRIVER): $(OBJS)
|
||||
- $(SO_LD) $(SO_LDFLAGS) -L$(SO_SSL_LIBDIR) -Wl,-R$(SO_SSL_LIBDIR) \
|
||||
+ $(SO_LD) $(SO_LDFLAGS) -L$(SO_SSL_LIBDIR) \
|
||||
-o $@ $^ -lcrypto
|
||||
|
||||
$(DLL_DRIVER): $(OBJS)
|
||||
diff -urNp otp_src_R12B-5.orig/lib/ssl/c_src/Makefile.in otp_src_R12B-5/lib/ssl/c_src/Makefile.in
|
||||
--- otp_src_R12B-5.orig/lib/ssl/c_src/Makefile.in 2009-04-21 18:38:47.000000000 +0530
|
||||
+++ otp_src_R12B-5/lib/ssl/c_src/Makefile.in 2009-04-21 19:58:29.000000000 +0530
|
||||
@@ -104,7 +104,7 @@ else
|
||||
SSL_MAKEFILE =
|
||||
endif
|
||||
|
||||
-CC_R_FLAG=@CFLAG_RUNTIME_LIBRARY_PATH@
|
||||
+CC_R_FLAG=
|
||||
ifeq ($(findstring @,$(CC_R_FLAG)),@)
|
||||
# Old erts configure used which hasn't replaced @CFLAG_RUNTIME_LIBRARY_PATH@;
|
||||
# we try our best here instead...
|
||||
@@ -113,9 +113,9 @@ ifeq ($(findstring darwin,$(TARGET)),dar
|
||||
CC_R_FLAG =
|
||||
else
|
||||
ifeq ($(findstring osf,$(TARGET)),osf) # osf1: -Wl,-rpath,
|
||||
-CC_R_FLAG = -Wl,-rpath,
|
||||
+CC_R_FLAG =
|
||||
else # Default: -Wl,-R
|
||||
-CC_R_FLAG = -Wl,-R
|
||||
+CC_R_FLAG =
|
||||
endif
|
||||
endif
|
||||
endif
|
@ -1,24 +0,0 @@
|
||||
diff -up otp_src_R12B-4/lib/ssl/c_src/Makefile.in.sslrpath otp_src_R12B-4/lib/ssl/c_src/Makefile.in
|
||||
--- otp_src_R12B-4/lib/ssl/c_src/Makefile.in.sslrpath 2008-10-26 00:00:37.000000000 +0200
|
||||
+++ otp_src_R12B-4/lib/ssl/c_src/Makefile.in 2008-10-26 00:01:09.000000000 +0200
|
||||
@@ -102,7 +102,7 @@ else
|
||||
SSL_MAKEFILE =
|
||||
endif
|
||||
|
||||
-CC_R_FLAG=@CFLAG_RUNTIME_LIBRARY_PATH@
|
||||
+CC_R_FLAG=
|
||||
ifeq ($(findstring @,$(CC_R_FLAG)),@)
|
||||
# Old erts configure used which hasn't replaced @CFLAG_RUNTIME_LIBRARY_PATH@;
|
||||
# we try our best here instead...
|
||||
@@ -111,9 +111,9 @@ ifeq ($(findstring darwin,$(TARGET)),dar
|
||||
CC_R_FLAG =
|
||||
else
|
||||
ifeq ($(findstring osf,$(TARGET)),osf) # osf1: -Wl,-rpath,
|
||||
-CC_R_FLAG = -Wl,-rpath,
|
||||
+CC_R_FLAG =
|
||||
else # Default: -Wl,-R
|
||||
-CC_R_FLAG = -Wl,-R
|
||||
+CC_R_FLAG =
|
||||
endif
|
||||
endif
|
||||
endif
|
6
sources
6
sources
@ -1,3 +1,3 @@
|
||||
b3db581de6c13e1ec93d74e54a7b4231 otp_src_R13B01.tar.gz
|
||||
42cb55bbfa5dc071fd56034615072f7a otp_doc_html_R13B01.tar.gz
|
||||
fa8f96159bd9a88aa2fb9e4d79d7affe otp_doc_man_R13B01.tar.gz
|
||||
d69ce51bfabbdd0808461d86dfc95689 otp_doc_html_R13B04.tar.gz
|
||||
681aaef70affc64743f4e8c0675034af otp_doc_man_R13B04.tar.gz
|
||||
ca6da4921e438891967900aa6a084341 otp_src_R13B04.tar.gz
|
||||
|
Loading…
x
Reference in New Issue
Block a user