Signed-off-by: Peter Lemenkov <lemenkov@gmail.com>
This commit is contained in:
Peter Lemenkov 2012-12-21 18:43:38 +04:00
parent 171e3c16ac
commit ab89e306e4
4 changed files with 25 additions and 19 deletions

4
.gitignore vendored
View File

@ -23,3 +23,7 @@ otp_src_R14A.tar.gz
/otp_doc_html_R15B02.tar.gz
/otp_doc_man_R15B02.tar.gz
/otp_src_R15B02.tar.gz
/otp_doc_html_R15B03-1.tar.gz
/otp_doc_man_R15B03-1.tar.gz
/otp_src_R15B03-1.readme
/otp_src_R15B03-1.tar.gz

View File

@ -1,6 +1,6 @@
%global upstream_ver R15B
# Do NOT change %%{upstream_rel} unless UPSTREAM has actually changed it!
%global upstream_rel 02
%global upstream_rel 03
#%%global upstream_rel %%{nil}
# Use %%{nil} for %%{upstream_rel} for tracking source like otp_src_R14B.tar.gz,
# and 01 %%{upstream_rel} for tracking source like otp_src_R14B01.tar.gz.
@ -31,11 +31,12 @@ Summary: General-purpose programming language and runtime environment
Group: Development/Languages
License: ERPL
URL: http://www.erlang.org
Source0: http://www.erlang.org/download/otp_src_%{upstream_ver}%{upstream_rel}.tar.gz
Source0: http://www.erlang.org/download/otp_src_%{upstream_ver}%{upstream_rel}-1.tar.gz
%if %{use_prebuilt_docs}
Source1: http://erlang.org/download/otp_doc_html_%{upstream_ver}%{upstream_rel}.tar.gz
Source2: http://erlang.org/download/otp_doc_man_%{upstream_ver}%{upstream_rel}.tar.gz
Source1: http://erlang.org/download/otp_doc_html_%{upstream_ver}%{upstream_rel}-1.tar.gz
Source2: http://erlang.org/download/otp_doc_man_%{upstream_ver}%{upstream_rel}-1.tar.gz
%endif
Source4: http://www.erlang.org/download/otp_src_%{upstream_ver}%{upstream_rel}-1.readme
# For the source of the Fedora specific patches, see the respective
@ -1028,8 +1029,9 @@ CFLAGS="$RPM_OPT_FLAGS -mcpu=ultrasparc -fno-strict-aliasing" %configure --enabl
CFLAGS="$RPM_OPT_FLAGS -fno-strict-aliasing" %configure --enable-shared-zlib
%endif
# remove pre-built stuff
make clean
# FIXME remove pre-built BEAM files
# some of them are required for compilation
#find ./lib -type f -name "*.beam" -delete
# GNU Emacs/XEmacs related stuff
erlang_tools_vsn="$(sed -n 's/TOOLS_VSN = //p' lib/tools/vsn.mk)"
@ -1405,6 +1407,8 @@ rm -rf $RPM_BUILD_ROOT
%{_libdir}/erlang/man/man1/diameter_compile.*
%{_libdir}/erlang/man/man3/diameter.*
%{_libdir}/erlang/man/man3/diameter_app.*
%{_libdir}/erlang/man/man3/diameter_codec.*
%{_libdir}/erlang/man/man3/diameter_make.*
%{_libdir}/erlang/man/man3/diameter_sctp.*
%{_libdir}/erlang/man/man3/diameter_tcp.*
%{_libdir}/erlang/man/man3/diameter_transport.*
@ -2334,6 +2338,9 @@ rm -rf $RPM_BUILD_ROOT
%changelog
* Fri Dec 21 2012 Peter Lemenkov <lemenkov@gmail.com> - R15B-03.1
- Ver. R15B03 (actually R15B03-1)
* Mon Sep 10 2012 Peter Lemenkov <lemenkov@gmail.com> - R15B-02.1
- Ver. R15B02

View File

@ -125,10 +125,10 @@ index 4bd49aa..b6d4880 100644
$(INSTALL_DATA) $(EXAMPLES) "$(RELSYSDIR)/examples"
diff --git a/lib/common_test/src/Makefile b/lib/common_test/src/Makefile
index f7dce19..ee75f6e 100644
index dd2923e..246d30a 100644
--- a/lib/common_test/src/Makefile
+++ b/lib/common_test/src/Makefile
@@ -138,7 +138,7 @@ include $(ERL_TOP)/make/otp_release_targets.mk
@@ -139,7 +139,7 @@ include $(ERL_TOP)/make/otp_release_targets.mk
release_spec: opt
$(INSTALL_DIR) "$(RELSYSDIR)/src"
@ -288,10 +288,10 @@ index 63cc1c9..af956d9 100644
$(INSTALL_DIR) "$(RELSYSDIR)/ebin"
$(INSTALL_DATA) $(INSTALL_FILES) "$(RELSYSDIR)/ebin"
diff --git a/lib/diameter/src/Makefile b/lib/diameter/src/Makefile
index 99c3432..d79b3af 100644
index 060659b..5e91d0f 100644
--- a/lib/diameter/src/Makefile
+++ b/lib/diameter/src/Makefile
@@ -231,11 +231,8 @@ release_spec: opt
@@ -222,11 +222,8 @@ release_spec: opt
$(MAKE) $(EXAMPLE_DIRS:%/=release_examples_%)
$(TARGET_DIRS:%/=release_src_%): release_src_%:

13
sources
View File

@ -1,9 +1,4 @@
80553f4730b04aad4c9994590bad3fe6 otp_doc_html_R15B.tar.gz
9738da523737712a9db87db0dee05338 otp_doc_man_R15B.tar.gz
dd6c2a4807551b4a8a536067bde31d73 otp_src_R15B.tar.gz
7569cae680eecd64e7e5d952be788ee5 otp_doc_html_R15B01.tar.gz
d87412c2a1e6005bbe29dfe642a9ca20 otp_doc_man_R15B01.tar.gz
f12d00f6e62b36ad027d6c0c08905fad otp_src_R15B01.tar.gz
36d91f123204f4c71a464985b1b2a375 otp_doc_html_R15B02.tar.gz
974020ba533242fca759a7f5eaf628e5 otp_doc_man_R15B02.tar.gz
ccbe5e032a2afe2390de8913bfe737a1 otp_src_R15B02.tar.gz
18ba57d24085a77c01bf05f5bc0e6fb5 otp_doc_html_R15B03-1.tar.gz
1d7ace92e8cf41abbee1dba8192b7d5f otp_doc_man_R15B03-1.tar.gz
f299c8af6f54e4b767fbba100b18acf2 otp_src_R15B03-1.readme
eccd1e6dda6132993555e088005019f2 otp_src_R15B03-1.tar.gz