auto-import erlang-R10B-6.3 on branch devel from erlang-R10B-6.3.src.rpm

This commit is contained in:
Gérard Milmeister 2005-09-06 15:14:36 +00:00
parent 5303bc7c6c
commit 8d9a918bf3
6 changed files with 209 additions and 0 deletions

View File

@ -0,0 +1,3 @@
otp_doc_html_R10B-6.tar.gz
otp_doc_man_R10B-6.tar.gz
otp_src_R10B-6.tar.gz

113
erlang.spec Normal file
View File

@ -0,0 +1,113 @@
Name: erlang
Version: R10B
Release: 6.3
Summary: General-purpose programming language and runtime environment
Group: Development/Languages
License: Erlang Public License
URL: http://www.erlang.org
Source: http://www.erlang.org/download/otp_src_R10B-6.tar.gz
Source1: http://www.erlang.org/download/otp_doc_html_R10B-6.tar.gz
Source2: http://www.erlang.org/download/otp_doc_man_R10B-6.tar.gz
Patch: otp-links.patch
Patch1: otp-install.patch
Patch2: otp-rpath.patch
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
BuildRequires: ncurses-devel, openssl-devel, flex, unixODBC-devel
%description
Erlang is a general-purpose programming language and runtime
environment. Erlang has built-in support for concurrency, distribution
and fault tolerance. Erlang is used in several large telecommunication
systems from Ericsson.
%package doc
Summary: Erlang documentation
Group: Development/Languages
%description doc
Documentation for Erlang.
%prep
%setup -q -n otp_src_R10B-6
%patch -p1
%patch1 -p1
%patch2 -p1
%build
./configure --prefix=%{_prefix} --exec-prefix=%{_prefix} --bindir=%{_bindir} --libdir=%{_libdir}
chmod -R u+w .
make
%install
rm -rf $RPM_BUILD_ROOT
make INSTALL_PREFIX=$RPM_BUILD_ROOT install
# clean up
find $RPM_BUILD_ROOT%{_libdir}/erlang -perm 0775 | xargs chmod 755
find $RPM_BUILD_ROOT%{_libdir}/erlang -name Makefile | xargs chmod 644
find $RPM_BUILD_ROOT%{_libdir}/erlang -name \*.bat | xargs rm -f
find $RPM_BUILD_ROOT%{_libdir}/erlang -name index.txt.old | xargs rm -f
# doc
mkdir -p erlang_doc
tar -C erlang_doc -zxf %{SOURCE1}
tar -C $RPM_BUILD_ROOT/%{_libdir}/erlang -zxf %{SOURCE2}
# make links to binaries
mkdir -p $RPM_BUILD_ROOT/%{_bindir}
cd $RPM_BUILD_ROOT/%{_bindir}
for file in erl erlc
do
ln -sf ../%{_lib}/erlang/bin/$file .
done
%clean
rm -rf $RPM_BUILD_ROOT
%files
%defattr(-,root,root)
%doc AUTHORS EPLICENCE README
%{_bindir}/*
%{_libdir}/erlang
%files doc
%defattr(-,root,root)
%doc erlang_doc/*
%post
%{_libdir}/erlang/Install -minimal %{_libdir}/erlang > /dev/null
%changelog
* Tue Sep 6 2005 Gerard Milmeister <gemi@bluewin.ch> - R10B-6.3
- Remove perl BuildRequires
* Tue Aug 30 2005 Gerard Milmeister <gemi@bluewin.ch> - R10B-6.2
- change /usr/lib to %%{_libdir}
- redirect output in %%post to /dev/null
- add unixODBC-devel to BuildRequires
- split doc off to erlang-doc package
* Sat Jun 25 2005 Gerard Milmeister <gemi@bluewin.ch> - R10B-6.1
- New Version R10B-6
* Sun Feb 13 2005 Gerard Milmeister <gemi@bluewin.ch> - R10B-3.1
- New Version R10B-3
* Mon Dec 27 2004 Gerard Milmeister <gemi@bluewin.ch> - 0:R10B-2-0.fdr.1
- New Version R10B-2
* Wed Oct 6 2004 Gerard Milmeister <gemi@bluewin.ch> - 0:R10B-0.fdr.1
- New Version R10B
* Thu Oct 16 2003 Gerard Milmeister <gemi@bluewin.ch> - 0:R9B-1.fdr.1
- First Fedora release

29
otp-install.patch Normal file
View File

@ -0,0 +1,29 @@
--- otp_src_R9C-0/erts/etc/unix/Install.src.install 2003-10-17 12:52:14.000000000 +0200
+++ otp_src_R9C-0/erts/etc/unix/Install.src 2003-10-17 14:26:49.000000000 +0200
@@ -84,7 +84,7 @@
/bin/rm -f epmd
fi
-ln -s $ERL_ROOT/erts-%I_VSN%/bin/epmd epmd
+ln -s ../erts-%I_VSN%/bin/epmd epmd
cp -p $ERL_ROOT/erts-%I_VSN%/bin/run_erl .
cp -p $ERL_ROOT/erts-%I_VSN%/bin/to_erl .
@@ -145,16 +145,4 @@
(ranlib $library) > /dev/null 2>&1
done
fi
-
-
-#
-# Fixing the man pages
-#
-
-if [ -d $ERL_ROOT/man ]
-then
- cd $ERL_ROOT
- ./misc/format_man_pages $ERL_ROOT
-fi
-
-
+exit 0

17
otp-links.patch Normal file
View File

@ -0,0 +1,17 @@
--- otp_src_R9C-0/Makefile.in.links 2003-10-17 12:49:41.000000000 +0200
+++ otp_src_R9C-0/Makefile.in 2003-10-17 12:50:07.000000000 +0200
@@ -505,14 +505,6 @@
# Erlang base public files
#
install.bin:
- rm -f $(BINDIR)/erl $(BINDIR)/erlc \
- $(BINDIR)/ecc $(BINDIR)/elink $(BINDIR)/ear $(BINDIR)/escript
- ${LN_S} $(ERLANG_BINDIR)/erl $(BINDIR)/erl
- ${LN_S} $(ERLANG_BINDIR)/erlc $(BINDIR)/erlc
- ${LN_S} $(ERLANG_BINDIR)/ecc $(BINDIR)/ecc
- ${LN_S} $(ERLANG_BINDIR)/elink $(BINDIR)/elink
- ${LN_S} $(ERLANG_BINDIR)/ear $(BINDIR)/ear
- ${LN_S} $(ERLANG_BINDIR)/escript $(BINDIR)/escript
#
# Directories needed before we can install

44
otp-rpath.patch Normal file
View File

@ -0,0 +1,44 @@
--- otp_src_R10B-3/lib/crypto/c_src/Makefile.in.rpath 2005-02-13 15:22:29.208560819 +0100
+++ otp_src_R10B-3/lib/crypto/c_src/Makefile.in 2005-02-13 15:22:50.852106461 +0100
@@ -79,7 +79,7 @@
ifeq ($(HOST_OS),)
HOST_OS := $(shell $(ERL_TOP)/erts/autoconf/config.guess)
endif
-LD_R_FLAG=@DED_LD_FLAG_RUNTIME_LIBRARY_PATH@
+LD_R_FLAG=
ifeq ($(findstring @,$(LD_R_FLAG)),@)
# Old erts configure used which hasn't replaced
# @DED_LD_FLAG_RUNTIME_LIBRARY_PATH@; we try our best here instead...
--- otp_src_R10B-3/lib/crypto/priv/Makefile.rpath 2005-02-13 14:46:15.043814168 +0100
+++ otp_src_R10B-3/lib/crypto/priv/Makefile 2005-02-13 14:46:48.575467543 +0100
@@ -60,7 +60,7 @@
# ----------------------------------------------------
$(SO_DRIVER): $(OBJS)
- $(SO_LD) $(SO_LDFLAGS) -L$(SO_SSL_LIBDIR) -Wl,-R$(SO_SSL_LIBDIR) \
+ $(SO_LD) $(SO_LDFLAGS) -L$(SO_SSL_LIBDIR) \
-o $@ $^ -lcrypto
$(DLL_DRIVER): $(OBJS)
--- otp_src_R10B-3/lib/ssh/c_src/Makefile.in.rpath 2005-02-13 15:23:13.516486079 +0100
+++ otp_src_R10B-3/lib/ssh/c_src/Makefile.in 2005-02-13 15:23:25.130630385 +0100
@@ -75,7 +75,7 @@
else
DYN_DRIVER = $(LIBDIR)/ssh_crypto_drv.so
endif
-LD_R_FLAG=@DED_LD_FLAG_RUNTIME_LIBRARY_PATH@
+LD_R_FLAG=
ifeq ($(findstring @,$(LD_R_FLAG)),@)
# Old erts configure used which hasn't replaced
# @DED_LD_FLAG_RUNTIME_LIBRARY_PATH@; we try our best here instead...
--- otp_src_R10B-3/erts/configure.rpath 2005-02-13 14:44:11.498507144 +0100
+++ otp_src_R10B-3/erts/configure 2005-02-13 14:44:55.858437414 +0100
@@ -1231,7 +1231,7 @@
CFLAGS="$CFLAGS $extra_flags"
DEBUG_CFLAGS="-g $extra_flags"
-CFLAG_RUNTIME_LIBRARY_PATH="-Wl,-R"
+CFLAG_RUNTIME_LIBRARY_PATH=""
case $host_os in
darwin*)
CFLAG_RUNTIME_LIBRARY_PATH=

View File

@ -0,0 +1,3 @@
9f50340fd1c25af5d5a6fcf9f14b2e49 otp_doc_html_R10B-6.tar.gz
0243d2ff01fb2bac03115bcbe2284b20 otp_doc_man_R10B-6.tar.gz
6463f70b40e2a6c3587e54653add8414 otp_src_R10B-6.tar.gz