Ver. 19.2

Signed-off-by: Peter Lemenkov <lemenkov@gmail.com>
This commit is contained in:
Peter Lemenkov 2017-01-11 19:39:49 +03:00
parent d8d49b5b3e
commit 8bed1fa73a
6 changed files with 17 additions and 98 deletions

1
.gitignore vendored
View File

@ -76,3 +76,4 @@ otp_src_R14A.tar.gz
/otp-OTP-19.1.4.tar.gz
/otp-OTP-19.1.5.tar.gz
/otp-OTP-19.1.6.tar.gz
/otp-OTP-19.2.tar.gz

View File

@ -65,8 +65,8 @@
Name: erlang
Version: 19.1.6
Release: 2%{?dist}
Version: 19.2
Release: 1%{?dist}
Summary: General-purpose programming language and runtime environment
Group: Development/Languages
@ -116,12 +116,6 @@ Patch5: otp-0005-Do-not-install-nteventlog-and-related-doc-files-on-n.patch
# Fedora specific patch
# Do not install erlang sources
Patch6: otp-0006-Do-not-install-erlang-sources.patch
# Fedora specific patch
# erts: Fix correct link flags for hipe_mkliterals
Patch7: otp-0007-erts-Fix-correct-link-flags-for-hipe_mkliterals.patch
# Fedora specific patch
# erts: Disable -fPIE for HiPE on x86_64
Patch8: otp-0008-erts-Disable-fPIE-for-HiPE-on-x86_64.patch
# end of autogenerated patch tag list
BuildRequires: flex
@ -363,7 +357,7 @@ Orber OMG Transaction Service.
%package crypto
Summary: Cryptographical support
Group: Development/Languages
BuildRequires: openssl-devel
BuildRequires: pkgconfig(openssl) < 1.1.0
Requires: %{name}-erts%{?_isa} = %{version}-%{release}
Requires: %{name}-kernel%{?_isa} = %{version}-%{release}
Requires: %{name}-stdlib%{?_isa} = %{version}-%{release}
@ -932,8 +926,6 @@ Provides support for XML 1.0.
%patch4 -p1 -b .Do_not_install_Java_sources
%patch5 -p1 -b .Do_not_install_nteventlog_and_related_doc_files_on_n
%patch6 -p1 -b .Do_not_install_erlang_sources
%patch7 -p1 -b .erts_Fix_correct_link_flags_for_hipe_mkliterals
%patch8 -p1 -b .erts_Disable_fPIE_for_HiPE_on_x86_64
# end of autogenerated prep patch list
# FIXME we should come up with a better solution
@ -1008,7 +1000,7 @@ cat > xemacs-erlang-init.el << EOF
EOF
mkdir xemacs-erlang
cp lib/tools/emacs/*.el xemacs-erlang/
rm -f xemacs-erlang/erlang-flymake.el xemacs-erlang/erlang-test.el
rm -f xemacs-erlang/erlang-flymake.el xemacs-erlang/erlang-test.el xemacs-erlang/erldoc.el xemacs-erlang/erlang-edoc.el
pushd xemacs-erlang
%{_xemacs_bytecompile} *.el
popd
@ -2129,6 +2121,7 @@ useradd -r -g epmd -d /tmp -s /sbin/nologin \
%{_libdir}/erlang/man/man3/wxDirDialog.*
%{_libdir}/erlang/man/man3/wxDirPickerCtrl.*
%{_libdir}/erlang/man/man3/wxDisplayChangedEvent.*
%{_libdir}/erlang/man/man3/wxDropFilesEvent.*
%{_libdir}/erlang/man/man3/wxEraseEvent.*
%{_libdir}/erlang/man/man3/wxEvent.*
%{_libdir}/erlang/man/man3/wxEvtHandler.*
@ -2318,6 +2311,9 @@ useradd -r -g epmd -d /tmp -s /sbin/nologin \
%changelog
* Wed Jan 11 2017 Peter Lemenkov <lemenkov@gmail.com> - 19.2-1
- Ver. 19.2
* Wed Nov 23 2016 Peter Lemenkov <lemenkov@gmail.com> - 19.1.6-2
- Fix HiPE by disabling -fpie
- Fix dialyzer generation

View File

@ -34,10 +34,10 @@ index 38cf2d4..d4bb398 100644
$(INSTALL_DATA) $(EXAMPLES) "$(RELSYSDIR)/examples"
diff --git a/lib/common_test/src/Makefile b/lib/common_test/src/Makefile
index 0f9e044..5039444 100644
index 9d75199..b96a112 100644
--- a/lib/common_test/src/Makefile
+++ b/lib/common_test/src/Makefile
@@ -151,7 +151,7 @@ include $(ERL_TOP)/make/otp_release_targets.mk
@@ -152,7 +152,7 @@ include $(ERL_TOP)/make/otp_release_targets.mk
release_spec: opt
$(INSTALL_DIR) "$(RELSYSDIR)/src"
@ -634,10 +634,10 @@ index 08a00e6..a21ffb3 100644
$(INSTALL_DATA) $(TARGET_FILES) "$(RELSYSDIR)/ebin"
diff --git a/lib/observer/src/Makefile b/lib/observer/src/Makefile
index dd7831f..1d5c505 100644
index ff2bcbd..4973158 100644
--- a/lib/observer/src/Makefile
+++ b/lib/observer/src/Makefile
@@ -153,7 +153,6 @@ include $(ERL_TOP)/make/otp_release_targets.mk
@@ -149,7 +149,6 @@ include $(ERL_TOP)/make/otp_release_targets.mk
release_spec: opt
$(INSTALL_DIR) "$(RELSYSDIR)/src"
@ -868,7 +868,7 @@ index adc2c48..89ce954 100644
$(INSTALL_DATA) $(TARGET_FILES) "$(RELSYSDIR)/ebin"
# $(INSTALL_DIR) "$(RELSYSDIR)/include"
diff --git a/lib/ssh/src/Makefile b/lib/ssh/src/Makefile
index 69d5a47..c79ffd1 100644
index 7ab6f22..b57da4a 100644
--- a/lib/ssh/src/Makefile
+++ b/lib/ssh/src/Makefile
@@ -136,7 +136,7 @@ include $(ERL_TOP)/make/otp_release_targets.mk
@ -881,10 +881,10 @@ index 69d5a47..c79ffd1 100644
$(INSTALL_DATA) $(BEHAVIOUR_TARGET_FILES) $(TARGET_FILES) $(APP_TARGET) \
$(APPUP_TARGET) "$(RELSYSDIR)/ebin"
diff --git a/lib/ssl/src/Makefile b/lib/ssl/src/Makefile
index b625db0..9172486 100644
index 3dda1a3..a1e3c7c 100644
--- a/lib/ssl/src/Makefile
+++ b/lib/ssl/src/Makefile
@@ -143,7 +143,7 @@ include $(ERL_TOP)/make/otp_release_targets.mk
@@ -146,7 +146,7 @@ include $(ERL_TOP)/make/otp_release_targets.mk
release_spec: opt
$(INSTALL_DIR) "$(RELSYSDIR)/src"

View File

@ -1,45 +0,0 @@
From: Sverker Eriksson <sverker@erlang.org>
Date: Wed, 9 Nov 2016 16:52:23 +0100
Subject: [PATCH] erts: Fix correct link flags for hipe_mkliterals
and no need for $(INCLUDED).
diff --git a/erts/emulator/Makefile.in b/erts/emulator/Makefile.in
index e026020..8772bef 100644
--- a/erts/emulator/Makefile.in
+++ b/erts/emulator/Makefile.in
@@ -49,6 +49,7 @@ CREATE_DIRS=
LDFLAGS=@LDFLAGS@
ARFLAGS=rc
OMIT_OMIT_FP=no
+TYPE_LIBS=
DIRTY_SCHEDULER_SUPPORT=@DIRTY_SCHEDULER_SUPPORT@
NEW_PURGE_STRATEGY=@NEW_PURGE_STRATEGY@
@@ -90,7 +91,7 @@ PURIFY =
TYPEMARKER = .gcov
TYPE_FLAGS = $(DEBUG_CFLAGS) -DERTS_GCOV -DNO_JUMP_TABLE -fprofile-arcs -ftest-coverage -O0 -DERTS_CAN_INLINE=0 -DERTS_INLINE=
ifneq ($(findstring solaris,$(TARGET)),solaris)
-LIBS += -lgcov
+TYPE_LIBS = -lgcov
endif
ENABLE_ALLOC_TYPE_VARS += debug
else
@@ -146,6 +147,8 @@ endif
endif
endif
+LIBS += $(TYPE_LIBS)
+
comma:=,
space:=
space+=
@@ -931,7 +934,7 @@ $(OBJDIR)/%.o: hipe/%.c
$(V_CC) $(subst O2,O3, $(CFLAGS)) $(INCLUDES) -c $< -o $@
$(BINDIR)/hipe_mkliterals$(TF_MARKER): $(OBJDIR)/hipe_mkliterals.o
- $(ld_verbose)$(CC) $(CFLAGS) $(INCLUDES) -o $@ $<
+ $(ld_verbose)$(CC) $(LDFLAGS) -o $@ $< $(TYPE_LIBS)
$(OBJDIR)/hipe_mkliterals.o: $(HIPE_ASM) $(TTF_DIR)/erl_alloc_types.h $(DTRACE_HEADERS) \
$(TTF_DIR)/OPCODES-GENERATED $(TARGET)/TABLES-GENERATED

View File

@ -1,33 +0,0 @@
From: Sverker Eriksson <sverker@erlang.org>
Date: Tue, 8 Nov 2016 16:52:32 +0100
Subject: [PATCH] erts: Disable -fPIE for HiPE on x86_64
diff --git a/erts/configure.in b/erts/configure.in
index 7455516..7489f8a 100644
--- a/erts/configure.in
+++ b/erts/configure.in
@@ -2778,6 +2778,23 @@ if test "$cross_compiling" != "yes" && test X${enable_hipe} != Xno; then
fi
fi
+dnl Check to disable -fPIE and friends for HiPE on amd64
+if test X${enable_hipe} = Xyes && test X$ARCH = Xamd64; then
+ AC_TRY_COMPILE(, [#if defined(__pie__) || defined(__PIE__)
+ #error -fPIE is enabled by default
+ #endif],
+ [AC_MSG_NOTICE([No -fPIE enabled by default])],
+ [AC_MSG_WARN([Security feature -fPIE will be disabled for HiPE])
+ STATIC_CFLAGS="-fno-PIE $STATIC_CFLAGS"
+ saved_LDFLAGS=$LDFLAGS
+ LDFLAGS="-no-pie $LDFLAGS"
+ AC_TRY_LINK(,, [],
+ [AC_MSG_WARN([Linked does not accept option -no-pie])
+ LDFLAGS=$saved_LDFLAGS])])
+
+fi
+
+
if test X${enable_fp_exceptions} = Xauto ; then
case $host_os in
*linux*)

View File

@ -1 +1 @@
2a69d8aa3b9312cea9b3b0813eead2bf otp-OTP-19.1.6.tar.gz
SHA512 (otp-OTP-19.2.tar.gz) = 8ad0fb2958bb35620e666522e09290f4fa4302c57e0bca7fc97abc77f8ec7401b73d8d346eef076e30a218683b182b275f8ecc3601a1048faa0e37aa544f3db9