Ver. R12B-1

This commit is contained in:
Peter Lemenkov 2008-03-27 19:00:29 +00:00
parent 04e99ff8cb
commit 6f361b1c0d
6 changed files with 34 additions and 66 deletions

View File

@ -1,3 +1,3 @@
otp_src_R11B-2.tar.gz
otp_doc_html_R11B-2.tar.gz
otp_doc_man_R11B-2.tar.gz
otp_doc_html_R12B-1.tar.gz
otp_doc_man_R12B-1.tar.gz
otp_src_R12B-1.tar.gz

View File

@ -1,20 +1,20 @@
Name: erlang
Version: R11B
Release: 2.3%{?dist}
Version: R12B
Release: 1.0%{?dist}
Summary: General-purpose programming language and runtime environment
Group: Development/Languages
License: Erlang Public License
URL: http://www.erlang.org
Source: http://www.erlang.org/download/otp_src_R11B-2.tar.gz
Source1: http://www.erlang.org/download/otp_doc_html_R11B-2.tar.gz
Source2: http://www.erlang.org/download/otp_doc_man_R11B-2.tar.gz
Source: http://www.erlang.org/download/otp_src_R12B-1.tar.gz
Source1: http://www.erlang.org/download/otp_doc_html_R12B-1.tar.gz
Source2: http://www.erlang.org/download/otp_doc_man_R12B-1.tar.gz
Patch0: otp-links.patch
Patch1: otp-install.patch
Patch2: otp-rpath.patch
Patch3: otp-sslrpath.patch
Patch4: otp-glibc25.patch
Patch5: otp-run_erl.patch
Patch6: otp-ssl_missing_libs.patch
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
BuildRequires: ncurses-devel
@ -44,13 +44,13 @@ Documentation for Erlang.
%prep
%setup -q -n otp_src_R11B-2
%setup -q -n otp_src_R12B-1
%patch0 -p1 -b .links
%patch1 -p1 -b .install
%patch2 -p1 -b .rpath
%patch3 -p1 -b .sslrpath
%patch4 -p1 -b .glibc25
%patch5 -p1 -b .run_erl
%patch5 -p0 -b .run_erl
%patch6 -p0 -b .keyutils
%build
@ -108,6 +108,9 @@ rm -rf $RPM_BUILD_ROOT
%changelog
* Wed Mar 26 2008 Peter Lemenkov <lemenkov@gmail.com> - R12B-1.0
- Ver. R12B-1
* Sun Dec 31 2006 Gerard Milmeister <gemi@bluewin.ch> - R11B-2.3
- remove buildroot from installed files

View File

@ -1,11 +0,0 @@
--- otp_src_R11B-2/erts/emulator/hipe/hipe_x86_signal.c.glibc25 2006-12-30 23:57:04.000000000 +0100
+++ otp_src_R11B-2/erts/emulator/hipe/hipe_x86_signal.c 2006-12-30 23:57:36.000000000 +0100
@@ -34,7 +34,7 @@
#endif
#include "hipe_signal.h"
-#if __GLIBC__ == 2 && (__GLIBC_MINOR__ == 3 || __GLIBC_MINOR__ == 4)
+#if __GLIBC__ == 2 && (__GLIBC_MINOR__ == 3 || __GLIBC_MINOR__ == 4 || __GLIBC_MINOR__ == 5)
/* See comment below for glibc 2.2. */
#ifndef __USE_GNU
#define __USE_GNU /* to un-hide RTLD_NEXT */

View File

@ -1,46 +1,11 @@
--- otp_src_R10B-10/erts/etc/unix/run_erl.c.bak 2006-05-03 15:54:19.000000000 +0200
+++ otp_src_R10B-10/erts/etc/unix/run_erl.c 2006-05-03 15:57:36.000000000 +0200
@@ -42,6 +42,8 @@
#include <dirent.h>
#include <termios.h>
#include <time.h>
+#include <pty.h>
+#include <utmp.h>
#if !defined(NO_SYSLOG)
#include <syslog.h>
#endif
@@ -803,6 +805,7 @@
static int open_pty_master(char **ptyslave)
{
int mfd;
+ int sfd;
char *major, *minor;
static char majorchars[] = "pqrstuvwxyzabcdePQRSTUVWXYZABCDE";
@@ -818,6 +821,15 @@
/* http://www.xcf.berkeley.edu/~ali/K0D/UNIX/PTY/code/upty.h.html */
{
+ static char ttyname[] = " ";
+ if (0 == openpty(&mfd, &sfd, ttyname, NULL, NULL)) {
+ close(sfd);
+ *ptyslave = ttyname;
+ return mfd;
+ }
+ }
+
+ {
/* New style devpts or devfs /dev/pty/{m,s}{0,1....} */
static char ptyname[] = "/dev/pty/mX";
--- otp_src_R10B-10/erts/etc/common/Makefile.in.orig 2006-05-03 17:08:53.000000000 +0200
+++ otp_src_R10B-10/erts/etc/common/Makefile.in 2006-05-03 17:10:18.000000000 +0200
@@ -241,7 +241,7 @@
--- erts/etc/common/Makefile.in.orig 2008-03-27 13:11:52.000000000 +0300
+++ erts/etc/common/Makefile.in 2008-03-27 13:13:23.000000000 +0300
@@ -298,7 +298,7 @@
$(PURIFY) $(LD) $(LDFLAGS) $(ENTRY_LDFLAGS) -o $@ $(OBJDIR)/inet_gethost.o $(ENTRY_OBJ) $(LIBS)
$(BINDIR)/run_erl: $(OBJDIR)/run_erl.o
- $(LD) $(LDFLAGS) -o $@ $(OBJDIR)/run_erl.o
+ $(LD) $(LDFLAGS) -lutil -o $@ $(OBJDIR)/run_erl.o
- $(LD) $(LDFLAGS) -o $@ $(OBJDIR)/run_erl.o $(LIBS)
+ $(LD) $(LDFLAGS) -o $@ $(OBJDIR)/run_erl.o $(LIBS) -lutil
$(OBJDIR)/run_erl.o: ../unix/run_erl.c
$(CC) $(CFLAGS) -o $@ -c ../unix/run_erl.c

View File

@ -0,0 +1,11 @@
--- lib/ssl/c_src/Makefile.in 2008-03-27 13:43:04.000000000 +0300
+++ lib/ssl/c_src/Makefile.in 2008-03-27 14:03:27.000000000 +0300
@@ -38,7 +38,7 @@
CC = @CC@
LD = @LD@
SHELL = /bin/sh
-LIBS = @LIBS@
+LIBS = @LIBS@ -lkeyutils -lselinux
PLAIN_CFLAGS = @CFLAGS@
# ----------------------------------------------------

View File

@ -1,3 +1,3 @@
7d7cca1d2f392a8a317cb4c0bd904726 otp_src_R11B-2.tar.gz
e2c45ced77ec63b9b1dd95c8f5396f7d otp_doc_html_R11B-2.tar.gz
c81023f591c1bace836de3aa874f3c2a otp_doc_man_R11B-2.tar.gz
3dd8aee17fcbd3e5fda7313208fce6ac otp_doc_html_R12B-1.tar.gz
96da62bcfb40e5d3ec2945bb2b050024 otp_doc_man_R12B-1.tar.gz
6de3630b446e9c2150edfe01e383c917 otp_src_R12B-1.tar.gz