Erlang ver. 23.0-rc2
Signed-off-by: Peter Lemenkov <lemenkov@gmail.com>
This commit is contained in:
parent
a27b5d77d2
commit
68c6fc718d
44
erlang.spec
44
erlang.spec
@ -65,8 +65,8 @@
|
||||
|
||||
|
||||
Name: erlang
|
||||
Version: 22.3.2
|
||||
Release: 1%{?dist}
|
||||
Version: 23.0
|
||||
Release: 0.1.rc2%{?dist}
|
||||
Summary: General-purpose programming language and runtime environment
|
||||
|
||||
License: ASL 2.0
|
||||
@ -74,7 +74,8 @@ URL: https://www.erlang.org
|
||||
%if ! (0%{?rhel} && 0%{?rhel} <= 6)
|
||||
VCS: scm:git:https://github.com/erlang/otp
|
||||
%endif
|
||||
Source0: https://github.com/erlang/otp/archive/OTP-%{version}/otp-OTP-%{version}.tar.gz
|
||||
#Source0: https://github.com/erlang/otp/archive/OTP-%{version}/otp-OTP-%{version}.tar.gz
|
||||
Source0: https://github.com/erlang/otp/archive/OTP-%{version}-rc2/otp-OTP-%{version}-rc2.tar.gz
|
||||
Source5: epmd.service
|
||||
Source6: epmd.socket
|
||||
Source7: epmd@.service
|
||||
@ -106,7 +107,6 @@ Patch6: otp-0006-Do-not-install-erlang-sources.patch
|
||||
Patch7: otp-0007-Add-extra-search-directory.patch
|
||||
Patch8: otp-0008-Avoid-forking-sed-to-get-basename.patch
|
||||
Patch9: otp-0009-Load-man-pages-from-system-wide-directory.patch
|
||||
Patch10: otp-0010-erl_child_setup-reduce-number-of-calls-to-close.patch
|
||||
# end of autogenerated patch tag list
|
||||
|
||||
BuildRequires: gcc
|
||||
@ -712,17 +712,16 @@ Provides support for XML 1.0.
|
||||
### END OF AUTOGENERATED LIST ###
|
||||
|
||||
%prep
|
||||
%autosetup -p1 -n otp-OTP-%{version}
|
||||
%autosetup -p1 -n otp-OTP-%{version}-rc2
|
||||
|
||||
# FIXME we should come up with a better solution
|
||||
# remove shipped zlib sources
|
||||
#rm -f erts/emulator/zlib/*.[ch]
|
||||
|
||||
# Reconfigure everything to apply changes to the autotools templates
|
||||
./otp_build autoconf
|
||||
|
||||
|
||||
%build
|
||||
# Reconfigure everything to apply changes to the autotools templates
|
||||
./otp_build autoconf
|
||||
|
||||
# Set up proper cflags/cxxflags first
|
||||
%ifarch sparcv9 sparc64
|
||||
@ -1017,6 +1016,9 @@ useradd -r -g epmd -d /dev/null -s /sbin/nologin \
|
||||
%files compiler
|
||||
%{_libdir}/erlang/lib/compiler-*/
|
||||
%if %{with doc}
|
||||
%{_mandir}/man3/cerl.*
|
||||
%{_mandir}/man3/cerl_clauses.*
|
||||
%{_mandir}/man3/cerl_trees.*
|
||||
%{_mandir}/man3/compile.*
|
||||
%endif
|
||||
|
||||
@ -1048,8 +1050,8 @@ useradd -r -g epmd -d /dev/null -s /sbin/nologin \
|
||||
%{_libdir}/erlang/erts-*/bin/typer
|
||||
%{_libdir}/erlang/lib/dialyzer-*/
|
||||
%if %{with doc}
|
||||
%{_mandir}/man1/typer.*
|
||||
%{_mandir}/man3/dialyzer.*
|
||||
%{_mandir}/man3/typer.*
|
||||
%endif
|
||||
%endif # __with_wxwidgets
|
||||
|
||||
@ -1107,13 +1109,14 @@ useradd -r -g epmd -d /dev/null -s /sbin/nologin \
|
||||
%{_mandir}/man1/erl_call.*
|
||||
%{_mandir}/man3/ei.*
|
||||
%{_mandir}/man3/ei_connect.*
|
||||
%{_mandir}/man3/erl_connect.*
|
||||
%{_mandir}/man3/erl_error.*
|
||||
%{_mandir}/man3/erl_eterm.*
|
||||
%{_mandir}/man3/erl_format.*
|
||||
%{_mandir}/man3/erl_global.*
|
||||
%{_mandir}/man3/erl_malloc.*
|
||||
%{_mandir}/man3/erl_marshal.*
|
||||
%{_mandir}/man3/ei_global.*
|
||||
#%%{_mandir}/man3/erl_connect.*
|
||||
#%%{_mandir}/man3/erl_error.*
|
||||
#%%{_mandir}/man3/erl_eterm.*
|
||||
#%%{_mandir}/man3/erl_format.*
|
||||
#%%{_mandir}/man3/erl_global.*
|
||||
#%%{_mandir}/man3/erl_malloc.*
|
||||
#%%{_mandir}/man3/erl_marshal.*
|
||||
%{_mandir}/man3/registry.*
|
||||
%endif
|
||||
|
||||
@ -1165,6 +1168,7 @@ useradd -r -g epmd -d /dev/null -s /sbin/nologin \
|
||||
%{_libdir}/erlang/erts-*/bin/start.src
|
||||
%{_libdir}/erlang/erts-*/bin/start_erl.src
|
||||
%{_libdir}/erlang/erts-*/bin/to_erl
|
||||
%{_libdir}/erlang/erts-*/bin/yielding_c_fun
|
||||
%{_libdir}/erlang/erts-*/include
|
||||
%{_libdir}/erlang/erts-*/lib/
|
||||
%{_libdir}/erlang/erts-*/src/
|
||||
@ -1296,6 +1300,7 @@ useradd -r -g epmd -d /dev/null -s /sbin/nologin \
|
||||
%dir %{_javadir}/%{name}/
|
||||
%{_javadir}/%{name}/OtpErlang.jar
|
||||
%{_libdir}/erlang/lib/jinterface-*/
|
||||
%{_mandir}/man3/jinterface.*
|
||||
%endif # __with_java
|
||||
|
||||
%files kernel
|
||||
@ -1313,6 +1318,7 @@ useradd -r -g epmd -d /dev/null -s /sbin/nologin \
|
||||
%{_mandir}/man3/erl_epmd.*
|
||||
%{_mandir}/man3/erl_prim_loader_stub.*
|
||||
%{_mandir}/man3/erlang_stub.*
|
||||
%{_mandir}/man3/erpc.*
|
||||
%{_mandir}/man3/error_handler.*
|
||||
%{_mandir}/man3/error_logger.*
|
||||
%{_mandir}/man3/file.*
|
||||
@ -1333,6 +1339,7 @@ useradd -r -g epmd -d /dev/null -s /sbin/nologin \
|
||||
%{_mandir}/man3/net_adm.*
|
||||
%{_mandir}/man3/net_kernel.*
|
||||
%{_mandir}/man3/os.*
|
||||
%{_mandir}/man3/pg.*
|
||||
%{_mandir}/man3/pg2.*
|
||||
%{_mandir}/man3/rpc.*
|
||||
%{_mandir}/man3/seq_trace.*
|
||||
@ -1533,6 +1540,7 @@ useradd -r -g epmd -d /dev/null -s /sbin/nologin \
|
||||
%{_libdir}/erlang/lib/ssh-*/src
|
||||
%if %{with doc}
|
||||
%{_mandir}/man3/ssh.*
|
||||
%{_mandir}/man3/ssh_agent.*
|
||||
%{_mandir}/man3/ssh_client_channel.*
|
||||
%{_mandir}/man3/ssh_client_key_api.*
|
||||
%{_mandir}/man3/ssh_connection.*
|
||||
@ -1613,6 +1621,7 @@ useradd -r -g epmd -d /dev/null -s /sbin/nologin \
|
||||
%{_mandir}/man3/sets.*
|
||||
%{_mandir}/man3/shell.*
|
||||
%{_mandir}/man3/shell_default.*
|
||||
%{_mandir}/man3/shell_docs.*
|
||||
%{_mandir}/man3/slave.*
|
||||
%{_mandir}/man3/sofs.*
|
||||
%{_mandir}/man3/string.*
|
||||
@ -1943,6 +1952,9 @@ useradd -r -g epmd -d /dev/null -s /sbin/nologin \
|
||||
|
||||
|
||||
%changelog
|
||||
* Sun Apr 19 2020 Peter Lemenkov <lemenkov@gmail.com> - 23.0-0.1.rc2
|
||||
- Ver. 23.0-rc2
|
||||
|
||||
* Thu Apr 9 2020 Peter Lemenkov <lemenkov@gmail.com> - 22.3.2-1
|
||||
- Ver. 22.3.2
|
||||
|
||||
|
@ -6,10 +6,10 @@ Subject: [PATCH] Do not format man-pages and do not install miscellaneous
|
||||
Signed-off-by: Peter Lemenkov <lemenkov@gmail.com>
|
||||
|
||||
diff --git a/erts/etc/common/Makefile.in b/erts/etc/common/Makefile.in
|
||||
index 05d7b5679f..cbac9956bc 100644
|
||||
index ef40341c87..84e6c3cb2f 100644
|
||||
--- a/erts/etc/common/Makefile.in
|
||||
+++ b/erts/etc/common/Makefile.in
|
||||
@@ -504,10 +504,6 @@ endif
|
||||
@@ -501,10 +501,6 @@ endif
|
||||
ifneq ($(INSTALL_TOP_BIN),)
|
||||
$(INSTALL_PROGRAM) $(INSTALL_TOP_BIN) "$(RELEASE_PATH)"
|
||||
endif
|
||||
|
@ -5,10 +5,10 @@ Subject: [PATCH] Remove rpath
|
||||
Signed-off-by: Peter Lemenkov <lemenkov@gmail.com>
|
||||
|
||||
diff --git a/lib/crypto/c_src/Makefile.in b/lib/crypto/c_src/Makefile.in
|
||||
index 129d0a7822..56af1b60bc 100644
|
||||
index d06dc95aa4..c9d5a7064a 100644
|
||||
--- a/lib/crypto/c_src/Makefile.in
|
||||
+++ b/lib/crypto/c_src/Makefile.in
|
||||
@@ -113,7 +113,7 @@ TEST_ENGINE_LIB = $(LIBDIR)/otp_test_engine$(TYPEMARKER).@DED_EXT@
|
||||
@@ -114,7 +114,7 @@ TEST_ENGINE_LIB = $(LIBDIR)/otp_test_engine$(TYPEMARKER).@DED_EXT@
|
||||
DYNAMIC_CRYPTO_LIB=@SSL_DYNAMIC_ONLY@
|
||||
|
||||
ifeq ($(DYNAMIC_CRYPTO_LIB),yes)
|
||||
|
@ -27,10 +27,10 @@ index 1f714df357..95835d6ed2 100644
|
||||
release_docs_spec:
|
||||
|
||||
diff --git a/lib/crypto/c_src/Makefile.in b/lib/crypto/c_src/Makefile.in
|
||||
index 56af1b60bc..141168d3f8 100644
|
||||
index c9d5a7064a..5f2dfb8e02 100644
|
||||
--- a/lib/crypto/c_src/Makefile.in
|
||||
+++ b/lib/crypto/c_src/Makefile.in
|
||||
@@ -222,16 +222,11 @@ docs:
|
||||
@@ -223,16 +223,11 @@ docs:
|
||||
include $(ERL_TOP)/make/otp_release_targets.mk
|
||||
|
||||
release_spec: opt
|
||||
@ -48,10 +48,10 @@ index 56af1b60bc..141168d3f8 100644
|
||||
|
||||
release_docs_spec:
|
||||
diff --git a/lib/erl_interface/src/Makefile.in b/lib/erl_interface/src/Makefile.in
|
||||
index ba0164ea51..9ccbbee1b3 100644
|
||||
index 55827ce097..e01ab3ef36 100644
|
||||
--- a/lib/erl_interface/src/Makefile.in
|
||||
+++ b/lib/erl_interface/src/Makefile.in
|
||||
@@ -848,14 +848,14 @@ ifneq ($(EXE_TARGETS),)
|
||||
@@ -748,14 +748,13 @@ ifneq ($(EXE_TARGETS),)
|
||||
$(INSTALL_PROGRAM) $(EXE_TARGETS) "$(RELSYSDIR)/bin"
|
||||
endif
|
||||
$(INSTALL_DATA) $(EXTRA) "$(RELSYSDIR)/src"
|
||||
@ -61,7 +61,7 @@ index ba0164ea51..9ccbbee1b3 100644
|
||||
- $(INSTALL_DATA) epmd/*.[ch] "$(RELSYSDIR)/src/epmd"
|
||||
- $(INSTALL_DATA) misc/*.[ch] "$(RELSYSDIR)/src/misc"
|
||||
- $(INSTALL_DATA) registry/*.[ch] "$(RELSYSDIR)/src/registry"
|
||||
- $(INSTALL_DATA) legacy/*.[ch] "$(RELSYSDIR)/src/legacy"
|
||||
- $(INSTALL_DATA) global/*.[ch] "$(RELSYSDIR)/src/global"
|
||||
- $(INSTALL_DATA) prog/*.[ch] "$(RELSYSDIR)/src/prog"
|
||||
+ $(INSTALL_DATA) connect/*.h "$(RELSYSDIR)/src/connect"
|
||||
+ $(INSTALL_DATA) decode/*.h "$(RELSYSDIR)/src/decode"
|
||||
@ -69,7 +69,6 @@ index ba0164ea51..9ccbbee1b3 100644
|
||||
+ $(INSTALL_DATA) epmd/*.h "$(RELSYSDIR)/src/epmd"
|
||||
+ $(INSTALL_DATA) misc/*.h "$(RELSYSDIR)/src/misc"
|
||||
+ $(INSTALL_DATA) registry/*.h "$(RELSYSDIR)/src/registry"
|
||||
+ $(INSTALL_DATA) legacy/*.h "$(RELSYSDIR)/src/legacy"
|
||||
+ $(INSTALL_DATA) prog/*.h "$(RELSYSDIR)/src/prog"
|
||||
|
||||
release_docs:
|
||||
@ -88,7 +87,7 @@ index cd409fa54f..c65e817385 100644
|
||||
endif
|
||||
|
||||
diff --git a/lib/odbc/c_src/Makefile.in b/lib/odbc/c_src/Makefile.in
|
||||
index 294d832797..173f660f26 100644
|
||||
index 3c16e7e294..82fe1492ef 100644
|
||||
--- a/lib/odbc/c_src/Makefile.in
|
||||
+++ b/lib/odbc/c_src/Makefile.in
|
||||
@@ -129,11 +129,8 @@ include $(ERL_TOP)/make/otp_release_targets.mk
|
||||
@ -117,10 +116,10 @@ index 27b156a2c9..f11ff303b6 100644
|
||||
$(INSTALL_PROGRAM) $(TARGET_FILES) "$(RELSYSDIR)/priv/bin"
|
||||
|
||||
diff --git a/lib/tools/c_src/Makefile.in b/lib/tools/c_src/Makefile.in
|
||||
index 0cd760b137..b2d7cf94c9 100644
|
||||
index 8e13571786..ae18ef3cf4 100644
|
||||
--- a/lib/tools/c_src/Makefile.in
|
||||
+++ b/lib/tools/c_src/Makefile.in
|
||||
@@ -189,8 +189,6 @@ include ../vsn.mk
|
||||
@@ -188,8 +188,6 @@ include ../vsn.mk
|
||||
RELSYSDIR = $(RELEASE_PATH)/lib/tools-$(TOOLS_VSN)
|
||||
|
||||
release_spec: all
|
||||
|
@ -5,10 +5,10 @@ Subject: [PATCH] Do not install Java sources
|
||||
Signed-off-by: Peter Lemenkov <lemenkov@gmail.com>
|
||||
|
||||
diff --git a/lib/jinterface/java_src/com/ericsson/otp/erlang/Makefile b/lib/jinterface/java_src/com/ericsson/otp/erlang/Makefile
|
||||
index ee616f3d7e..fdd28e79b3 100644
|
||||
index bcbb206db6..1451378b35 100644
|
||||
--- a/lib/jinterface/java_src/com/ericsson/otp/erlang/Makefile
|
||||
+++ b/lib/jinterface/java_src/com/ericsson/otp/erlang/Makefile
|
||||
@@ -120,8 +120,6 @@ release release_docs release_tests release_html:
|
||||
@@ -123,8 +123,6 @@ release release_docs release_tests release_html:
|
||||
$(V_at)$(MAKE) $(MFLAGS) RELEASE_PATH="$(RELEASE_PATH)" $(TARGET_MAKEFILE) $@_spec
|
||||
|
||||
release_spec: opt
|
||||
|
@ -6,10 +6,10 @@ Subject: [PATCH] Do not install nteventlog and related doc-files on non-win32
|
||||
Signed-off-by: Peter Lemenkov <lemenkov@gmail.com>
|
||||
|
||||
diff --git a/lib/os_mon/doc/src/Makefile b/lib/os_mon/doc/src/Makefile
|
||||
index 8e9a4c333c..33b32b09b9 100644
|
||||
index d16f2b4831..c5b721f995 100644
|
||||
--- a/lib/os_mon/doc/src/Makefile
|
||||
+++ b/lib/os_mon/doc/src/Makefile
|
||||
@@ -36,11 +36,16 @@ RELSYSDIR = $(RELEASE_PATH)/lib/$(APPLICATION)-$(VSN)
|
||||
@@ -31,11 +31,16 @@ APPLICATION=os_mon
|
||||
# Target Specs
|
||||
# ----------------------------------------------------
|
||||
XML_APPLICATION_FILES = ref_man.xml
|
||||
@ -28,20 +28,20 @@ index 8e9a4c333c..33b32b09b9 100644
|
||||
XML_REF6_FILES = os_mon_app.xml
|
||||
|
||||
diff --git a/lib/os_mon/src/Makefile b/lib/os_mon/src/Makefile
|
||||
index 923a31f290..5963351b0f 100644
|
||||
index 98c5ced068..e2f4d5a090 100644
|
||||
--- a/lib/os_mon/src/Makefile
|
||||
+++ b/lib/os_mon/src/Makefile
|
||||
@@ -34,7 +34,13 @@ RELSYSDIR = $(RELEASE_PATH)/lib/os_mon-$(VSN)
|
||||
# ----------------------------------------------------
|
||||
# Target Specs
|
||||
# ----------------------------------------------------
|
||||
-MODULES= disksup memsup cpu_sup os_mon os_sup os_mon_sysinfo nteventlog
|
||||
-MODULES= disksup memsup cpu_sup os_mon os_mon_mib os_sup os_mon_sysinfo nteventlog
|
||||
+ifeq ($(findstring win32,$(TARGET)),win32)
|
||||
+NTEVENTLOG=nteventlog
|
||||
+else
|
||||
+NTEVENTLOG=
|
||||
+endif
|
||||
+MODULES= disksup memsup cpu_sup os_mon os_sup os_mon_sysinfo \
|
||||
+MODULES= disksup memsup cpu_sup os_mon os_mon_mib os_sup os_mon_sysinfo \
|
||||
+ $(NTEVENTLOG)
|
||||
|
||||
INCLUDE=../include
|
||||
|
@ -21,10 +21,10 @@ index d2153f23e1..1eb33a5922 100644
|
||||
$(INSTALL_DATA) $(STATIC_TARGET_FILES) $(APP_TARGET) "$(RELSYSDIR)/ebin"
|
||||
|
||||
diff --git a/lib/asn1/src/Makefile b/lib/asn1/src/Makefile
|
||||
index a6ff72898c..35d4530f32 100644
|
||||
index 1c3bdfcaa8..8c2e6c9fbc 100644
|
||||
--- a/lib/asn1/src/Makefile
|
||||
+++ b/lib/asn1/src/Makefile
|
||||
@@ -155,7 +155,7 @@ release_spec: opt
|
||||
@@ -154,7 +154,7 @@ release_spec: opt
|
||||
$(INSTALL_DIR) "$(RELSYSDIR)/ebin"
|
||||
$(INSTALL_DATA) $(TARGET_FILES) $(APP_TARGET) $(APPUP_TARGET) "$(RELSYSDIR)/ebin"
|
||||
$(INSTALL_DIR) "$(RELSYSDIR)/src"
|
||||
@ -63,10 +63,10 @@ index f015064b39..57f96d2929 100644
|
||||
$(INSTALL_SCRIPT) $(PROGRAMS) "$(RELEASE_PATH)/test_server"
|
||||
|
||||
diff --git a/lib/compiler/src/Makefile b/lib/compiler/src/Makefile
|
||||
index e42032c3ae..501ed4d3d6 100644
|
||||
index b1531ac985..dbcfe0042c 100644
|
||||
--- a/lib/compiler/src/Makefile
|
||||
+++ b/lib/compiler/src/Makefile
|
||||
@@ -179,8 +179,8 @@ include $(ERL_TOP)/make/otp_release_targets.mk
|
||||
@@ -184,8 +184,8 @@ include $(ERL_TOP)/make/otp_release_targets.mk
|
||||
|
||||
release_spec: opt
|
||||
$(INSTALL_DIR) "$(RELSYSDIR)/src"
|
||||
@ -104,10 +104,10 @@ index 118cb6b758..86722d8767 100644
|
||||
$(INSTALL_DATA) $(TARGET_FILES) $(TARGET_TOOLBOX_FILES) "$(RELSYSDIR)/ebin"
|
||||
|
||||
diff --git a/lib/dialyzer/src/Makefile b/lib/dialyzer/src/Makefile
|
||||
index bddd761705..f0c2e7c35b 100644
|
||||
index 1f5b308c7d..1f728c56d6 100644
|
||||
--- a/lib/dialyzer/src/Makefile
|
||||
+++ b/lib/dialyzer/src/Makefile
|
||||
@@ -160,7 +160,7 @@ include $(ERL_TOP)/make/otp_release_targets.mk
|
||||
@@ -161,7 +161,7 @@ include $(ERL_TOP)/make/otp_release_targets.mk
|
||||
|
||||
release_spec: opt
|
||||
$(INSTALL_DIR) "$(RELSYSDIR)/src"
|
||||
@ -117,10 +117,10 @@ index bddd761705..f0c2e7c35b 100644
|
||||
$(INSTALL_DIR) "$(RELSYSDIR)/ebin"
|
||||
$(INSTALL_DATA) $(INSTALL_FILES) "$(RELSYSDIR)/ebin"
|
||||
diff --git a/lib/diameter/src/Makefile b/lib/diameter/src/Makefile
|
||||
index d6854cfd27..fab5f3dec3 100644
|
||||
index 36e8fefd4c..d3a10890ce 100644
|
||||
--- a/lib/diameter/src/Makefile
|
||||
+++ b/lib/diameter/src/Makefile
|
||||
@@ -257,11 +257,8 @@ release_spec: opt
|
||||
@@ -263,11 +263,8 @@ release_spec: opt
|
||||
$(MAKE) $(EXAMPLE_DIRS:%/=release_examples_%)
|
||||
|
||||
$(TARGET_DIRS:%/=release_src_%): release_src_%:
|
||||
@ -168,10 +168,10 @@ index b79a537424..d0b231e5fc 100644
|
||||
release_docs_spec:
|
||||
|
||||
diff --git a/lib/erl_docgen/src/Makefile b/lib/erl_docgen/src/Makefile
|
||||
index 82d051e9bb..950fdbe177 100644
|
||||
index 4c6f542ebb..d0cd6d8f68 100644
|
||||
--- a/lib/erl_docgen/src/Makefile
|
||||
+++ b/lib/erl_docgen/src/Makefile
|
||||
@@ -90,8 +90,6 @@ $(APPUP_TARGET): $(APPUP_SRC) ../vsn.mk
|
||||
@@ -91,8 +91,6 @@ $(APPUP_TARGET): $(APPUP_SRC) ../vsn.mk
|
||||
include $(ERL_TOP)/make/otp_release_targets.mk
|
||||
|
||||
release_spec: opt
|
||||
@ -343,10 +343,10 @@ index 8248e37c44..1f1b23184b 100644
|
||||
$(INSTALL_DATA) $(TARGET_FILES) "$(RELSYSDIR)/ebin"
|
||||
|
||||
diff --git a/lib/inets/src/http_server/Makefile b/lib/inets/src/http_server/Makefile
|
||||
index 9848fd4b35..387475febb 100644
|
||||
index da9549406f..eaa14b628f 100644
|
||||
--- a/lib/inets/src/http_server/Makefile
|
||||
+++ b/lib/inets/src/http_server/Makefile
|
||||
@@ -136,7 +136,7 @@ include $(ERL_TOP)/make/otp_release_targets.mk
|
||||
@@ -134,7 +134,7 @@ include $(ERL_TOP)/make/otp_release_targets.mk
|
||||
release_spec: opt
|
||||
$(INSTALL_DIR) "$(RELSYSDIR)/src"
|
||||
$(INSTALL_DIR) "$(RELSYSDIR)/src/http_server"
|
||||
@ -369,10 +369,10 @@ index ec1ae70305..88c084ef58 100644
|
||||
$(INSTALL_DATA) $(EXTERNAL_HRL_FILES) "$(RELSYSDIR)/include"
|
||||
$(INSTALL_DIR) "$(RELSYSDIR)/ebin"
|
||||
diff --git a/lib/kernel/src/Makefile b/lib/kernel/src/Makefile
|
||||
index 2d2b84c206..9d67cb0c01 100644
|
||||
index 07f4f2304c..9c8913a5c1 100644
|
||||
--- a/lib/kernel/src/Makefile
|
||||
+++ b/lib/kernel/src/Makefile
|
||||
@@ -231,7 +231,6 @@ include $(ERL_TOP)/make/otp_release_targets.mk
|
||||
@@ -235,7 +235,6 @@ include $(ERL_TOP)/make/otp_release_targets.mk
|
||||
|
||||
release_spec: opt
|
||||
$(INSTALL_DIR) "$(RELSYSDIR)/src"
|
||||
@ -394,10 +394,10 @@ index ab45548099..5c7a7f0be9 100644
|
||||
$(INSTALL_DATA) $(EXTERNAL_HRL_FILES) "$(RELSYSDIR)/include"
|
||||
|
||||
diff --git a/lib/megaco/src/binary/Makefile b/lib/megaco/src/binary/Makefile
|
||||
index b9643669f6..5b5a4cf482 100644
|
||||
index 7fc90fd6d5..6ad086ed01 100644
|
||||
--- a/lib/megaco/src/binary/Makefile
|
||||
+++ b/lib/megaco/src/binary/Makefile
|
||||
@@ -176,7 +176,7 @@ release_spec: opt
|
||||
@@ -177,7 +177,7 @@ release_spec: opt
|
||||
$(INSTALL_DATA) $(TARGET_FILES) "$(RELSYSDIR)/ebin"
|
||||
$(INSTALL_DIR) "$(RELSYSDIR)/src"
|
||||
$(INSTALL_DIR) "$(RELSYSDIR)/src/binary"
|
||||
@ -445,10 +445,10 @@ index d07db3fa4b..7f421d24cc 100644
|
||||
|
||||
release_docs_spec:
|
||||
diff --git a/lib/megaco/src/text/Makefile b/lib/megaco/src/text/Makefile
|
||||
index 8e7e82b276..2a118d24e3 100644
|
||||
index 3dd24b1df7..836e163499 100644
|
||||
--- a/lib/megaco/src/text/Makefile
|
||||
+++ b/lib/megaco/src/text/Makefile
|
||||
@@ -135,7 +135,7 @@ release_spec: opt
|
||||
@@ -131,7 +131,7 @@ release_spec: opt
|
||||
$(INSTALL_DATA) $(BEAM_TARGET_FILES) "$(RELSYSDIR)/ebin"
|
||||
$(INSTALL_DIR) "$(RELSYSDIR)/src"
|
||||
$(INSTALL_DIR) "$(RELSYSDIR)/src/text"
|
||||
@ -471,10 +471,10 @@ index 028a63e98e..9e11e9bfb2 100644
|
||||
|
||||
release_docs_spec:
|
||||
diff --git a/lib/mnesia/src/Makefile b/lib/mnesia/src/Makefile
|
||||
index 7d316df263..60fdefb5d0 100644
|
||||
index 90e8780754..1a13d764b3 100644
|
||||
--- a/lib/mnesia/src/Makefile
|
||||
+++ b/lib/mnesia/src/Makefile
|
||||
@@ -134,7 +134,7 @@ include $(ERL_TOP)/make/otp_release_targets.mk
|
||||
@@ -135,7 +135,7 @@ include $(ERL_TOP)/make/otp_release_targets.mk
|
||||
|
||||
release_spec: opt
|
||||
$(INSTALL_DIR) "$(RELSYSDIR)/src"
|
||||
@ -509,7 +509,7 @@ index 7ca59495ed..a52ade2fe3 100644
|
||||
$(INSTALL_DATA) $(EXT_HRL_FILES) "$(RELSYSDIR)/include"
|
||||
$(INSTALL_DIR) "$(RELSYSDIR)/ebin"
|
||||
diff --git a/lib/os_mon/src/Makefile b/lib/os_mon/src/Makefile
|
||||
index 5963351b0f..22c41137d0 100644
|
||||
index e2f4d5a090..57f21a145b 100644
|
||||
--- a/lib/os_mon/src/Makefile
|
||||
+++ b/lib/os_mon/src/Makefile
|
||||
@@ -105,7 +105,6 @@ include $(ERL_TOP)/make/otp_release_targets.mk
|
||||
@ -665,10 +665,10 @@ index adc2c4858f..89ce954e99 100644
|
||||
$(INSTALL_DATA) $(TARGET_FILES) "$(RELSYSDIR)/ebin"
|
||||
# $(INSTALL_DIR) "$(RELSYSDIR)/include"
|
||||
diff --git a/lib/ssh/src/Makefile b/lib/ssh/src/Makefile
|
||||
index 2b96020678..3e692d25b2 100644
|
||||
index 4985774f4c..afd93dc922 100644
|
||||
--- a/lib/ssh/src/Makefile
|
||||
+++ b/lib/ssh/src/Makefile
|
||||
@@ -148,7 +148,7 @@ include $(ERL_TOP)/make/otp_release_targets.mk
|
||||
@@ -153,7 +153,7 @@ include $(ERL_TOP)/make/otp_release_targets.mk
|
||||
|
||||
release_spec: opt
|
||||
$(INSTALL_DIR) "$(RELSYSDIR)/src"
|
||||
@ -678,10 +678,10 @@ index 2b96020678..3e692d25b2 100644
|
||||
$(INSTALL_DATA) $(BEHAVIOUR_TARGET_FILES) $(TARGET_FILES) $(APP_TARGET) \
|
||||
$(APPUP_TARGET) "$(RELSYSDIR)/ebin"
|
||||
diff --git a/lib/ssl/src/Makefile b/lib/ssl/src/Makefile
|
||||
index 03c39b4722..4a8fc58a18 100644
|
||||
index 0b99cdde52..7ffa86b1fc 100644
|
||||
--- a/lib/ssl/src/Makefile
|
||||
+++ b/lib/ssl/src/Makefile
|
||||
@@ -190,7 +190,7 @@ include $(ERL_TOP)/make/otp_release_targets.mk
|
||||
@@ -196,7 +196,7 @@ include $(ERL_TOP)/make/otp_release_targets.mk
|
||||
|
||||
release_spec: opt
|
||||
$(INSTALL_DIR) "$(RELSYSDIR)/src"
|
||||
@ -691,10 +691,10 @@ index 03c39b4722..4a8fc58a18 100644
|
||||
$(INSTALL_DATA) $(BEHAVIOUR_TARGET_FILES) $(TARGET_FILES) $(APP_TARGET) \
|
||||
$(APPUP_TARGET) "$(RELSYSDIR)/ebin"
|
||||
diff --git a/lib/stdlib/src/Makefile b/lib/stdlib/src/Makefile
|
||||
index 9d8a5f98f9..e5afdcfa27 100644
|
||||
index e3e0c9c03d..ff9bad32ab 100644
|
||||
--- a/lib/stdlib/src/Makefile
|
||||
+++ b/lib/stdlib/src/Makefile
|
||||
@@ -216,7 +216,6 @@ include $(ERL_TOP)/make/otp_release_targets.mk
|
||||
@@ -223,7 +223,6 @@ include $(ERL_TOP)/make/otp_release_targets.mk
|
||||
|
||||
release_spec: opt
|
||||
$(INSTALL_DIR) "$(RELSYSDIR)/src"
|
||||
|
@ -5,7 +5,7 @@ Subject: [PATCH] Add extra search directory
|
||||
Signed-off-by: Peter Lemenkov <lemenkov@gmail.com>
|
||||
|
||||
diff --git a/lib/kernel/src/code_server.erl b/lib/kernel/src/code_server.erl
|
||||
index 126de66d13..ad926ea1da 100644
|
||||
index 4c4823eb38..de0ab149fb 100644
|
||||
--- a/lib/kernel/src/code_server.erl
|
||||
+++ b/lib/kernel/src/code_server.erl
|
||||
@@ -79,11 +79,17 @@ init(Ref, Parent, [Root,Mode]) ->
|
||||
|
@ -7,10 +7,10 @@ Patch allows one to use standard man path with erl -man command.
|
||||
as required by Debian policy.)
|
||||
|
||||
diff --git a/erts/etc/common/erlexec.c b/erts/etc/common/erlexec.c
|
||||
index 681a4c1299..034f7902ae 100644
|
||||
index 890a5b381a..9f84a16353 100644
|
||||
--- a/erts/etc/common/erlexec.c
|
||||
+++ b/erts/etc/common/erlexec.c
|
||||
@@ -719,8 +719,10 @@ int main(int argc, char **argv)
|
||||
@@ -721,8 +721,10 @@ int main(int argc, char **argv)
|
||||
error("-man not supported on Windows");
|
||||
#else
|
||||
argv[i] = "man";
|
||||
|
@ -1,57 +0,0 @@
|
||||
From: John Eckersberg <jeckersb@redhat.com>
|
||||
Date: Fri, 11 Oct 2019 13:06:20 -0400
|
||||
Subject: [PATCH] erl_child_setup: reduce number of calls to close()
|
||||
|
||||
On systems without closefrom(), such as Linux, iterating over all
|
||||
possible file descriptors and calling close() for each is inefficient.
|
||||
This is markedly so when the maximum number of file descriptors has
|
||||
been tuned to a large number.
|
||||
|
||||
Instead, walk the open descriptors under /dev/fd and close only those
|
||||
which are open.
|
||||
|
||||
diff --git a/erts/emulator/sys/unix/erl_child_setup.c b/erts/emulator/sys/unix/erl_child_setup.c
|
||||
index 129861ebd5..7ddd753136 100644
|
||||
--- a/erts/emulator/sys/unix/erl_child_setup.c
|
||||
+++ b/erts/emulator/sys/unix/erl_child_setup.c
|
||||
@@ -411,6 +411,7 @@ main(int argc, char *argv[])
|
||||
int uds_fd = 3, max_fd = 3;
|
||||
#ifndef HAVE_CLOSEFROM
|
||||
int i;
|
||||
+ DIR *dir;
|
||||
#endif
|
||||
struct sigaction sa;
|
||||
|
||||
@@ -426,11 +427,29 @@ main(int argc, char *argv[])
|
||||
#if defined(HAVE_CLOSEFROM)
|
||||
closefrom(4);
|
||||
#else
|
||||
- for (i = 4; i < max_files; i++)
|
||||
+ dir = opendir("/dev/fd");
|
||||
+ if (dir == NULL) { /* /dev/fd not available */
|
||||
+ for (i = 4; i < max_files; i++)
|
||||
#if defined(__ANDROID__)
|
||||
- if (i != system_properties_fd())
|
||||
+ if (i != system_properties_fd())
|
||||
#endif
|
||||
- (void) close(i);
|
||||
+ (void) close(i);
|
||||
+ } else {
|
||||
+ /* Iterate over fds obtained from /dev/fd */
|
||||
+ struct dirent *entry;
|
||||
+ int dir_fd = dirfd(dir);
|
||||
+
|
||||
+ while ((entry = readdir(dir)) != NULL) {
|
||||
+ i = atoi(entry->d_name);
|
||||
+#if defined(__ANDROID__)
|
||||
+ if (i != system_properties_fd())
|
||||
+#endif
|
||||
+ if (i >= 4 && i != dir_fd)
|
||||
+ (void) close(i);
|
||||
+ }
|
||||
+
|
||||
+ closedir(dir);
|
||||
+ }
|
||||
#endif
|
||||
|
||||
if (pipe(sigchld_pipe) < 0) {
|
2
sources
2
sources
@ -1 +1 @@
|
||||
SHA512 (otp-OTP-22.3.2.tar.gz) = 02333fed57394012834452aff38d9a3340c52b109b14e444b6e7975ac3a65485de1deda6ae6c732a28f75ca2518000de576f70497118306699e35af5f249a0d1
|
||||
SHA512 (otp-OTP-23.0-rc2.tar.gz) = 38c68e9731814911a867bb663802fb6b290d892097c1f834c5fad33c0f202c34a9237025d189553bcf8775cdf2e960072fad65d89dedb90ced7c34e13ee45c6f
|
||||
|
Loading…
Reference in New Issue
Block a user