Ver. R14B04
Signed-off-by: Peter Lemenkov <lemenkov@gmail.com>
This commit is contained in:
parent
c18217b725
commit
64bbd25ff7
3
.gitignore
vendored
3
.gitignore
vendored
@ -11,3 +11,6 @@ otp_src_R14A.tar.gz
|
||||
/otp_src_R14B03.tar.gz
|
||||
/otp_doc_html_R14B03.tar.gz
|
||||
/otp_doc_man_R14B03.tar.gz
|
||||
/otp_src_R14B04.tar.gz
|
||||
/otp_doc_html_R14B04.tar.gz
|
||||
/otp_doc_man_R14B04.tar.gz
|
||||
|
37
erlang.spec
37
erlang.spec
@ -1,6 +1,6 @@
|
||||
%global upstream_ver R14B
|
||||
# Do NOT change %%{upstream_rel} unless UPSTREAM has actually changed it!
|
||||
%global upstream_rel 03
|
||||
%global upstream_rel 04
|
||||
#global upstream_rel %{nil}
|
||||
# Use %%{nil} for %%{upstream_rel} for tracking source like otp_src_R14B.tar.gz,
|
||||
# and 01 %%{upstream_rel} for tracking source like otp_src_R14B01.tar.gz.
|
||||
@ -25,7 +25,7 @@
|
||||
|
||||
Name: erlang
|
||||
Version: %{upstream_ver}
|
||||
Release: %{upstream_rel_for_rpm}.3%{?dist}
|
||||
Release: %{upstream_rel_for_rpm}.1%{?dist}
|
||||
Summary: General-purpose programming language and runtime environment
|
||||
|
||||
Group: Development/Languages
|
||||
@ -70,26 +70,20 @@ Patch4: otp-0004-Do-not-install-C-sources.patch
|
||||
# Do not install Java sources
|
||||
Patch5: otp-0005-Do-not-install-Java-sources.patch
|
||||
# Fedora specific patch
|
||||
# Fix install dir typo for snmp man3
|
||||
Patch6: otp-0006-Fix-install-dir-typo-for-snmp-man3.patch
|
||||
# Fedora specific patch
|
||||
# Do not install nteventlog and related doc-files on non-win32
|
||||
Patch7: otp-0007-Do-not-install-nteventlog-and-related-doc-files-on-n.patch
|
||||
# Fedora specific patch
|
||||
# Do not install *.bat files on non-win32 machines
|
||||
Patch8: otp-0008-Do-not-install-.bat-files-on-non-win32-machines.patch
|
||||
Patch6: otp-0006-Do-not-install-nteventlog-and-related-doc-files-on-n.patch
|
||||
# Fedora specific patch
|
||||
# Do not install VxWorks-specific docs
|
||||
Patch9: otp-0009-Do-not-install-VxWorks-specific-docs.patch
|
||||
Patch7: otp-0007-Do-not-install-VxWorks-specific-docs.patch
|
||||
# Fedora specific patch
|
||||
# Do not install erlang sources
|
||||
Patch10: otp-0010-Do-not-install-erlang-sources.patch
|
||||
Patch8: otp-0008-Do-not-install-erlang-sources.patch
|
||||
# Required only for el5, el6 on PowerPC
|
||||
# Ugly workaround for java-1.5.0-gcj which doesn't support
|
||||
Patch11: otp-0011-Ugly-workaround-for-java-1.5.0-gcj-which-doesn-t-sup.patch
|
||||
Patch9: otp-0009-Ugly-workaround-for-java-1.5.0-gcj-which-doesn-t-sup.patch
|
||||
# Fedora specific patch
|
||||
# Remove rpath from esock_ssl
|
||||
Patch12: otp-0012-Remove-rpath-from-esock_ssl.patch
|
||||
Patch10: otp-0010-Remove-rpath-from-esock_ssl.patch
|
||||
# end of autogenerated patch tag list
|
||||
|
||||
# BuildRoot not strictly needed since F10, but keep it for spec file robustness
|
||||
@ -131,6 +125,7 @@ Requires: erlang-cosTransactions%{?_isa} = %{version}-%{release}
|
||||
Requires: erlang-crypto%{?_isa} = %{version}-%{release}
|
||||
Requires: erlang-debugger%{?_isa} = %{version}-%{release}
|
||||
Requires: erlang-dialyzer%{?_isa} = %{version}-%{release}
|
||||
Requires: erlang-diameter%{?_isa} = %{version}-%{release}
|
||||
Requires: erlang-docbuilder%{?_isa} = %{version}-%{release}
|
||||
Requires: erlang-edoc%{?_isa} = %{version}-%{release}
|
||||
Requires: erlang-erl_docgen%{?_isa} = %{version}-%{release}
|
||||
@ -999,17 +994,15 @@ Erlang mode for XEmacs (source lisp files).
|
||||
%patch3 -p1 -b .Fix_for_dlopening_libGL_and_libGLU
|
||||
%patch4 -p1 -b .Do_not_install_C_sources
|
||||
%patch5 -p1 -b .Do_not_install_Java_sources
|
||||
%patch6 -p1 -b .Fix_install_dir_typo_for_snmp_man3
|
||||
%patch7 -p1 -b .Do_not_install_nteventlog_and_related_doc_files_on_n
|
||||
%patch8 -p1 -b .Do_not_install_bat_files_on_non_win32_machines
|
||||
%patch9 -p1 -b .Do_not_install_VxWorks_specific_docs
|
||||
%patch10 -p1 -b .Do_not_install_erlang_sources
|
||||
%patch6 -p1 -b .Do_not_install_nteventlog_and_related_doc_files_on_n
|
||||
%patch7 -p1 -b .Do_not_install_VxWorks_specific_docs
|
||||
%patch8 -p1 -b .Do_not_install_erlang_sources
|
||||
%if 0%{?el4}%{?el5}%{?el6}
|
||||
%ifnarch %{ix86} x86_64
|
||||
%patch11 -p1 -b .Ugly_workaround_for_java_1_5_0_gcj_which_doesn_t_sup
|
||||
%patch9 -p1 -b .Ugly_workaround_for_java_1_5_0_gcj_which_doesn_t_sup
|
||||
%endif
|
||||
%endif
|
||||
%patch12 -p1 -b .Remove_rpath_from_esock_ssl
|
||||
%patch10 -p1 -b .Remove_rpath_from_esock_ssl
|
||||
# end of autogenerated prep patch list
|
||||
|
||||
# remove shipped zlib sources
|
||||
@ -2243,6 +2236,7 @@ rm -rf $RPM_BUILD_ROOT
|
||||
%{_libdir}/erlang/man/man3/wxListCtrl.*
|
||||
%{_libdir}/erlang/man/man3/wxListEvent.*
|
||||
%{_libdir}/erlang/man/man3/wxListItem.*
|
||||
%{_libdir}/erlang/man/man3/wxListItemAttr.*
|
||||
%{_libdir}/erlang/man/man3/wxListView.*
|
||||
%{_libdir}/erlang/man/man3/wxLogNull.*
|
||||
%{_libdir}/erlang/man/man3/wxMask.*
|
||||
@ -2384,6 +2378,9 @@ rm -rf $RPM_BUILD_ROOT
|
||||
|
||||
|
||||
%changelog
|
||||
* Sun Aug 07 2011 Peter Lemenkov <lemenkov@gmail.com> - R14B-04.1
|
||||
- Ver. R14B04
|
||||
|
||||
* Sun Aug 07 2011 Peter Lemenkov <lemenkov@gmail.com> - R14B-03.3
|
||||
- Use prebuilt docs on EL-[56] also
|
||||
|
||||
|
@ -10,16 +10,16 @@ Signed-off-by: Peter Lemenkov <lemenkov@gmail.com>
|
||||
3 files changed, 5 insertions(+), 5 deletions(-)
|
||||
|
||||
diff --git a/lib/crypto/c_src/Makefile.in b/lib/crypto/c_src/Makefile.in
|
||||
index 276c84d..586c70e 100644
|
||||
index c2a986c..48ba130 100644
|
||||
--- a/lib/crypto/c_src/Makefile.in
|
||||
+++ b/lib/crypto/c_src/Makefile.in
|
||||
@@ -83,7 +83,7 @@ endif
|
||||
@@ -84,7 +84,7 @@ endif
|
||||
DYNAMIC_CRYPTO_LIB=@SSL_DYNAMIC_ONLY@
|
||||
|
||||
ifeq ($(DYNAMIC_CRYPTO_LIB),yes)
|
||||
-SSL_DED_LD_RUNTIME_LIBRARY_PATH = @SSL_DED_LD_RUNTIME_LIBRARY_PATH@
|
||||
+SSL_DED_LD_RUNTIME_LIBRARY_PATH =
|
||||
CRYPTO_LINK_LIB=$(SSL_DED_LD_RUNTIME_LIBRARY_PATH) -L$(SSL_LIBDIR) -l$(SSL_CRYPTO_LIBNAME)
|
||||
CRYPTO_LINK_LIB=$(SSL_DED_LD_RUNTIME_LIBRARY_PATH) -L$(SSL_LIBDIR) -l$(SSL_CRYPTO_LIBNAME) -l$(SSL_SSL_LIBNAME)
|
||||
else
|
||||
SSL_DED_LD_RUNTIME_LIBRARY_PATH=
|
||||
diff --git a/lib/crypto/priv/Makefile b/lib/crypto/priv/Makefile
|
||||
|
@ -8,7 +8,7 @@ Signed-off-by: Peter Lemenkov <lemenkov@gmail.com>
|
||||
1 files changed, 2 insertions(+), 2 deletions(-)
|
||||
|
||||
diff --git a/lib/wx/c_src/egl_impl.cpp b/lib/wx/c_src/egl_impl.cpp
|
||||
index e2dbbb7..56e560f 100644
|
||||
index 6d873ab..18916c0 100644
|
||||
--- a/lib/wx/c_src/egl_impl.cpp
|
||||
+++ b/lib/wx/c_src/egl_impl.cpp
|
||||
@@ -70,8 +70,8 @@ typedef char DL_CHAR;
|
||||
@ -20,5 +20,5 @@ index e2dbbb7..56e560f 100644
|
||||
+# define OPENGL_LIB "libGL.so.1"
|
||||
+# define OPENGLU_LIB "libGLU.so.1"
|
||||
# endif
|
||||
#endif
|
||||
#endif
|
||||
extern "C" {
|
||||
|
@ -29,10 +29,10 @@ index 9e9cb18..1d73d3c 100644
|
||||
release_docs_spec:
|
||||
|
||||
diff --git a/lib/crypto/c_src/Makefile.in b/lib/crypto/c_src/Makefile.in
|
||||
index 586c70e..e6ab475 100644
|
||||
index 48ba130..553195b 100644
|
||||
--- a/lib/crypto/c_src/Makefile.in
|
||||
+++ b/lib/crypto/c_src/Makefile.in
|
||||
@@ -136,10 +136,7 @@ docs:
|
||||
@@ -137,10 +137,7 @@ docs:
|
||||
include $(ERL_TOP)/make/otp_release_targets.mk
|
||||
|
||||
release_spec: opt
|
||||
|
@ -1,22 +0,0 @@
|
||||
From: Hans Ulrich Niedermann <hun@n-dimensional.de>
|
||||
Date: Mon, 21 Mar 2011 15:53:14 +0100
|
||||
Subject: [PATCH] Fix install dir typo for snmp man3
|
||||
|
||||
This is an obvious thing that should be fixed upstream.
|
||||
---
|
||||
lib/snmp/doc/src/Makefile | 2 +-
|
||||
1 files changed, 1 insertions(+), 1 deletions(-)
|
||||
|
||||
diff --git a/lib/snmp/doc/src/Makefile b/lib/snmp/doc/src/Makefile
|
||||
index 35ed63e..30fabc1 100644
|
||||
--- a/lib/snmp/doc/src/Makefile
|
||||
+++ b/lib/snmp/doc/src/Makefile
|
||||
@@ -286,7 +286,7 @@ release_docs_spec: docs
|
||||
$(INSTALL_DATA) $(INFO_FILE) $(RELSYSDIR)
|
||||
$(INSTALL_DIR) $(RELEASE_PATH)/man/man1
|
||||
$(INSTALL_DATA) $(MAN1_FILES) $(RELEASE_PATH)/man/man1
|
||||
- $(INSTALL_DIR) $(RELEASE_PATH)/man/man
|
||||
+ $(INSTALL_DIR) $(RELEASE_PATH)/man/man3
|
||||
$(INSTALL_DATA) $(MAN3_FILES) $(RELEASE_PATH)/man/man3
|
||||
$(INSTALL_DIR) $(RELEASE_PATH)/man/man6
|
||||
$(INSTALL_DATA) $(MAN6_FILES) $(RELEASE_PATH)/man/man6
|
@ -8,10 +8,10 @@ Signed-off-by: Peter Lemenkov <lemenkov@gmail.com>
|
||||
1 files changed, 0 insertions(+), 1 deletions(-)
|
||||
|
||||
diff --git a/erts/doc/src/Makefile b/erts/doc/src/Makefile
|
||||
index 6578923..44206fd 100644
|
||||
index cfa5527..d18b615 100644
|
||||
--- a/erts/doc/src/Makefile
|
||||
+++ b/erts/doc/src/Makefile
|
||||
@@ -46,7 +46,6 @@ XML_REF1_FILES = epmd.xml \
|
||||
@@ -55,7 +55,6 @@ XML_REF3_EFILES = \
|
||||
XML_REF3_FILES = \
|
||||
driver_entry.xml \
|
||||
erl_nif.xml \
|
@ -1,54 +0,0 @@
|
||||
From: Hans Ulrich Niedermann <hun@n-dimensional.de>
|
||||
Date: Mon, 21 Mar 2011 14:27:45 +0100
|
||||
Subject: [PATCH] Do not install *.bat files on non-win32 machines
|
||||
|
||||
Signed-off-by: Peter Lemenkov <lemenkov@gmail.com>
|
||||
Signed-off-by: Hans Ulrich Niedermann <hun@n-dimensional.de>
|
||||
---
|
||||
lib/observer/src/Makefile | 9 ++++++---
|
||||
lib/webtool/priv/Makefile | 8 ++++++--
|
||||
2 files changed, 12 insertions(+), 5 deletions(-)
|
||||
|
||||
diff --git a/lib/observer/src/Makefile b/lib/observer/src/Makefile
|
||||
index 2d06cb6..3875b62 100644
|
||||
--- a/lib/observer/src/Makefile
|
||||
+++ b/lib/observer/src/Makefile
|
||||
@@ -56,13 +56,16 @@ TARGET_FILES= $(MODULES:%=$(EBIN)/%.$(EMULATOR)) $(APP_TARGET) $(APPUP_TARGET)
|
||||
PRIVDIR= ../priv
|
||||
WEBTOOLFILES= $(PRIVDIR)/crashdump_viewer.tool
|
||||
BINDIR= $(PRIVDIR)/bin
|
||||
+ifeq ($(findstring win32,$(TARGET)),win32)
|
||||
+WIN32_EXECUTABLES= $(BINDIR)/etop.bat $(BINDIR)/getop.bat $(BINDIR)/cdv.bat
|
||||
+else
|
||||
+WIN32_EXECUTABLES=
|
||||
+endif
|
||||
EXECUTABLES= \
|
||||
$(BINDIR)/etop \
|
||||
$(BINDIR)/getop \
|
||||
$(BINDIR)/cdv \
|
||||
- $(BINDIR)/etop.bat \
|
||||
- $(BINDIR)/getop.bat \
|
||||
- $(BINDIR)/cdv.bat
|
||||
+ $(WIN32_EXECUTABLES)
|
||||
CDVDIR= $(PRIVDIR)/crashdump_viewer
|
||||
GIF_FILES= \
|
||||
$(CDVDIR)/collapsd.gif \
|
||||
diff --git a/lib/webtool/priv/Makefile b/lib/webtool/priv/Makefile
|
||||
index 56ab772..6e1c660 100644
|
||||
--- a/lib/webtool/priv/Makefile
|
||||
+++ b/lib/webtool/priv/Makefile
|
||||
@@ -39,8 +39,12 @@ HTDOCS_FILES = root/doc/index.html \
|
||||
root/doc/tool_management.html \
|
||||
root/doc/start_info.html
|
||||
|
||||
-SCRIPTS = bin/start_webtool \
|
||||
- bin/start_webtool.bat
|
||||
+ifeq ($(findstring win32,$(TARGET)),win32)
|
||||
+WIN32_SCRIPTS= bin/start_webtool.bat
|
||||
+else
|
||||
+WIN32_SCRIPTS=
|
||||
+endif
|
||||
+SCRIPTS = bin/start_webtool $(WIN32_SCRIPTS)
|
||||
|
||||
# ----------------------------------------------------
|
||||
# FLAGS
|
@ -287,10 +287,10 @@ index 810f86d..f3f2b22 100644
|
||||
$(INSTALL_DIR) $(RELSYSDIR)/ebin
|
||||
$(INSTALL_DATA) $(INSTALL_FILES) $(RELSYSDIR)/ebin
|
||||
diff --git a/lib/diameter/src/app/Makefile b/lib/diameter/src/app/Makefile
|
||||
index 6de220d..322fb78 100644
|
||||
index a75c70d..ba3d10e 100644
|
||||
--- a/lib/diameter/src/app/Makefile
|
||||
+++ b/lib/diameter/src/app/Makefile
|
||||
@@ -169,7 +169,6 @@ release_spec: opt
|
||||
@@ -177,7 +177,6 @@ release_spec: opt
|
||||
$(INSTALL_DIR) $(RELSYSDIR)/examples
|
||||
$(INSTALL_SCRIPT) $(ESCRIPT_FILES) $(RELSYSDIR)/bin
|
||||
$(INSTALL_DATA) $(TARGET_FILES) $(RELSYSDIR)/ebin
|
||||
@ -299,10 +299,10 @@ index 6de220d..322fb78 100644
|
||||
$(INSTALL_DATA) $(INTERNAL_HRL_FILES) $(RELSYSDIR)/src/app
|
||||
$(INSTALL_DATA) $(EXTERNAL_HRL_FILES) $(SPEC_HRL_FILES) $(RELSYSDIR)/include
|
||||
diff --git a/lib/diameter/src/compiler/Makefile b/lib/diameter/src/compiler/Makefile
|
||||
index 3ab7606..119a032 100644
|
||||
index 779013b..edc7a3d 100644
|
||||
--- a/lib/diameter/src/compiler/Makefile
|
||||
+++ b/lib/diameter/src/compiler/Makefile
|
||||
@@ -117,7 +117,7 @@ release_spec: opt
|
||||
@@ -107,7 +107,7 @@ release_spec: opt
|
||||
$(INSTALL_DATA) $(TARGET_FILES) $(RELSYSDIR)/ebin
|
||||
$(INSTALL_DIR) $(RELSYSDIR)/src
|
||||
$(INSTALL_DIR) $(RELSYSDIR)/src/compiler
|
||||
@ -338,7 +338,7 @@ index e8a07a5..d0ac3a9 100644
|
||||
$(INSTALL_DATA) $(TARGET_FILES) $(APP_TARGET) $(APPUP_TARGET) $(RELSYSDIR)/ebin
|
||||
|
||||
diff --git a/lib/edoc/src/Makefile b/lib/edoc/src/Makefile
|
||||
index 9c5a9d3..5de4e3d 100644
|
||||
index fcb0b61..2082ca6 100644
|
||||
--- a/lib/edoc/src/Makefile
|
||||
+++ b/lib/edoc/src/Makefile
|
||||
@@ -88,7 +88,7 @@ release_spec: opt
|
||||
@ -709,10 +709,10 @@ index 64b6478..5cf0fe2 100644
|
||||
|
||||
release_docs_spec:
|
||||
diff --git a/lib/mnesia/src/Makefile b/lib/mnesia/src/Makefile
|
||||
index e032f56..e357187 100644
|
||||
index 1c8ec54..cc00b60 100644
|
||||
--- a/lib/mnesia/src/Makefile
|
||||
+++ b/lib/mnesia/src/Makefile
|
||||
@@ -131,7 +131,7 @@ include $(ERL_TOP)/make/otp_release_targets.mk
|
||||
@@ -133,7 +133,7 @@ include $(ERL_TOP)/make/otp_release_targets.mk
|
||||
|
||||
release_spec: opt
|
||||
$(INSTALL_DIR) $(RELSYSDIR)/src
|
||||
@ -925,17 +925,17 @@ index d89eb4e..2adf916 100644
|
||||
$(INSTALL_DATA) $(TARGET_FILES) $(APP_TARGET) $(APPUP_TARGET) \
|
||||
$(RELSYSDIR)/ebin
|
||||
diff --git a/lib/snmp/src/compile/Makefile b/lib/snmp/src/compile/Makefile
|
||||
index 0ceaf27..872611d 100644
|
||||
index 627af6f..af185bf 100644
|
||||
--- a/lib/snmp/src/compile/Makefile
|
||||
+++ b/lib/snmp/src/compile/Makefile
|
||||
@@ -123,7 +123,7 @@ include $(ERL_TOP)/make/otp_release_targets.mk
|
||||
@@ -122,7 +122,7 @@ include $(ERL_TOP)/make/otp_release_targets.mk
|
||||
release_spec: opt
|
||||
$(INSTALL_DIR) $(RELSYSDIR)/src
|
||||
$(INSTALL_DIR) $(RELSYSDIR)/src/compiler
|
||||
- $(INSTALL_DATA) $(ESCRIPT_SRC) $(PARSER_SRC) $(ERL_FILES) $(INTERNAL_HRL_FILES) $(RELSYSDIR)/src/compiler
|
||||
+ $(INSTALL_DATA) $(INTERNAL_HRL_FILES) $(RELSYSDIR)/src/compiler
|
||||
$(INSTALL_DIR) $(RELSYSDIR)/ebin
|
||||
$(INSTALL_DATA) $(TARGET_FILES) $(RELSYSDIR)/ebin
|
||||
$(INSTALL_DATA) $(EBIN_FILES) $(RELSYSDIR)/ebin
|
||||
$(INSTALL_DIR) $(RELSYSDIR)/bin
|
||||
diff --git a/lib/snmp/src/manager/Makefile b/lib/snmp/src/manager/Makefile
|
||||
index c1d5703..568530d 100644
|
@ -1,92 +0,0 @@
|
||||
#!/bin/bash
|
||||
# Usage:
|
||||
# ./otp-get-patches.sh /path/to/otp OTP_R14B02 fedora-R14B02
|
||||
#
|
||||
# otp-get-patches.sh - update erlang.spec and otp-00*.patch files
|
||||
#
|
||||
# otp-get-patches.sh updates the erlang.spec and otp-00*.patch
|
||||
# files in the git index. After an otp-get-patches.sh run, you
|
||||
# will need to review the stage git changes, possibly adapt the
|
||||
# Release: and %changelog parts of erlang spec, and can then
|
||||
# "git commit" everything.
|
||||
#
|
||||
# Caution: Leave the four special comment lines untouched in the
|
||||
# spec file, as otp-get-patches.sh requires them and will only
|
||||
# touch erlang.spec between the respective start/end pair:
|
||||
#
|
||||
# # start of autogenerated patch tag list
|
||||
# # end of autogenerated patch tag list
|
||||
# # start of autogenerated prep patch list
|
||||
# # end of autogenerated prep patch list
|
||||
#
|
||||
# The following special comment lines in the git commit messages
|
||||
# will be interpreted:
|
||||
#
|
||||
# Fedora-Spec-Comment: This patch only applies to EL6 builds
|
||||
# Fedora-Spec-Before: %if 0%?el6}
|
||||
# Fedora-Spec-After: %endif
|
||||
#
|
||||
# If there is no "Fedora-Spec-Comment:" line, we will use
|
||||
# "Fedora specific patch".
|
||||
|
||||
# Command line parsing
|
||||
otp_dir="${1:?'Fatal: otp git repo dir required'}"
|
||||
otp_upstream="${2:?'Fatal: git ref to upstream release required'}"
|
||||
otp_fedora="${3:?'Fatal: git ref to branch with fedora patches required'}"
|
||||
|
||||
# Setup
|
||||
set -e
|
||||
# set -x
|
||||
tmpdir="$(mktemp -d --tmpdir="$PWD")"
|
||||
|
||||
# Generate patch files
|
||||
pushd "$otp_dir"
|
||||
git format-patch -N -o "$tmpdir" "${otp_upstream}..${otp_fedora}" > "$tmpdir/patch-list.txt"
|
||||
popd
|
||||
|
||||
test -s "$tmpdir/patch-list.txt"
|
||||
|
||||
# Process patch files
|
||||
echo "# start of autogenerated patch tag list" > "$tmpdir/patch-list-tags.txt"
|
||||
echo "# start of autogenerated prep patch list" > "$tmpdir/patch-list-prep.txt"
|
||||
n=1
|
||||
while read patch
|
||||
do
|
||||
otppatch="$(dirname "$patch")/otp-$(basename "$patch")"
|
||||
${SED-sed} -e '1d' -e '/^-- $/,$d' "$patch" > "$otppatch"
|
||||
rm -f "$patch"
|
||||
comment="$(sed -n 's/^Fedora-Spec-Comment:\s*//p' "$otppatch")"
|
||||
if test "x$comment" = "x"; then comment="Fedora specific patch"; fi
|
||||
echo "# ${comment}" >> "$tmpdir/patch-list-tags.txt"
|
||||
echo "# $(sed -n 's/^Subject: \[PATCH\] //p' "$otppatch")" >> "$tmpdir/patch-list-tags.txt"
|
||||
echo "Patch$n: $(basename "$otppatch")" >> "$tmpdir/patch-list-tags.txt"
|
||||
base="$(basename "$patch" ".patch" | sed 's/^00[0-9][0-9]-//')"
|
||||
backupext=".$(echo -n "$base" | tr -c -s '[:alnum:]' '_')"
|
||||
sed -n 's/^Fedora-Spec-Before:\s*//p' "$otppatch" >> "$tmpdir/patch-list-prep.txt"
|
||||
echo "%patch$n -p1 -b ${backupext}" >> "$tmpdir/patch-list-prep.txt"
|
||||
sed -n 's/^Fedora-Spec-After:\s*//p' "$otppatch" >> "$tmpdir/patch-list-prep.txt"
|
||||
n=$(($n + 1))
|
||||
done < "$tmpdir/patch-list.txt"
|
||||
echo "# end of autogenerated patch tag list" >> "$tmpdir/patch-list-tags.txt"
|
||||
echo "# end of autogenerated prep patch list" >> "$tmpdir/patch-list-prep.txt"
|
||||
|
||||
# Create updated spec file
|
||||
specfile="erlang.spec"
|
||||
newspec1="${tmpdir}/${specfile}.new1"
|
||||
newspec2="${tmpdir}/${specfile}.new2"
|
||||
sed '/^# start of autogenerated patch tag list$/,$d' "$specfile" > "$newspec1"
|
||||
cat "$tmpdir/patch-list-tags.txt" >> "$newspec1"
|
||||
sed '1,/^# end of autogenerated patch tag list/d' "$specfile" >> "$newspec1"
|
||||
sed '/^# start of autogenerated prep patch list$/,$d' "$newspec1" > "$newspec2"
|
||||
cat "$tmpdir/patch-list-prep.txt" >> "$newspec2"
|
||||
sed '1,/^# end of autogenerated prep patch list/d' "$newspec1" >> "$newspec2"
|
||||
|
||||
# Actually put all changes into git index
|
||||
git rm -f otp-00*.patch
|
||||
mv "$tmpdir/otp-00"*.patch .
|
||||
git add otp-00*.patch
|
||||
mv -f "$newspec2" "$specfile"
|
||||
git add "$specfile"
|
||||
|
||||
rm -rf "$tmpdir"
|
||||
# End of file.
|
6
sources
6
sources
@ -1,3 +1,3 @@
|
||||
c9033bc35dbe4631dd2d14a6183b966a otp_doc_html_R14B03.tar.gz
|
||||
357f54b174bb29d41fee97c063a47e8f otp_doc_man_R14B03.tar.gz
|
||||
7979e662d11476b97c462feb7c132fb7 otp_src_R14B03.tar.gz
|
||||
4b469729f103f52702bfb1fb24529dc0 otp_src_R14B04.tar.gz
|
||||
2a440aa8c1242dd0c79785d69f0d97ca otp_doc_html_R14B04.tar.gz
|
||||
f31e72518daae4007f595c0b224dd59f otp_doc_man_R14B04.tar.gz
|
||||
|
Loading…
Reference in New Issue
Block a user