Erlang ver. 22.0.7

Signed-off-by: Peter Lemenkov <lemenkov@gmail.com>
This commit is contained in:
Peter Lemenkov 2019-07-16 15:16:12 +02:00
parent 4ed5ede65e
commit 4c0d16ab65
7 changed files with 91 additions and 118 deletions

View File

@ -65,8 +65,8 @@
Name: erlang
Version: 21.3.8.6
Release: 2%{?dist}
Version: 22.0.7
Release: 1%{?dist}
Summary: General-purpose programming language and runtime environment
License: ASL 2.0
@ -134,15 +134,15 @@ BuildRequires: automake
Requires: %{name}-asn1%{?_isa} = %{version}-%{release}
%if %{__with_wxwidgets}
Requires: %{name}-common_test%{?_isa} = %{version}-%{release}
%endif %{__with_wxwidgets}
%endif # __with_wxwidgets
Requires: %{name}-compiler%{?_isa} = %{version}-%{release}
Requires: %{name}-crypto%{?_isa} = %{version}-%{release}
%if %{__with_wxwidgets}
Requires: %{name}-debugger%{?_isa} = %{version}-%{release}
%endif %{__with_wxwidgets}
%endif # __with_wxwidgets
%if %{__with_wxwidgets}
Requires: %{name}-dialyzer%{?_isa} = %{version}-%{release}
%endif %{__with_wxwidgets}
%endif # __with_wxwidgets
Requires: %{name}-diameter%{?_isa} = %{version}-%{release}
Requires: %{name}-edoc%{?_isa} = %{version}-%{release}
Requires: %{name}-eldap%{?_isa} = %{version}-%{release}
@ -151,30 +151,29 @@ Requires: %{name}-erl_interface%{?_isa} = %{version}-%{release}
Requires: %{name}-erts%{?_isa} = %{version}-%{release}
%if %{__with_wxwidgets}
Requires: %{name}-et%{?_isa} = %{version}-%{release}
%endif %{__with_wxwidgets}
%endif # __with_wxwidgets
Requires: %{name}-eunit%{?_isa} = %{version}-%{release}
Requires: %{name}-ftp%{?_isa} = %{version}-%{release}
Requires: %{name}-hipe%{?_isa} = %{version}-%{release}
Requires: %{name}-inets%{?_isa} = %{version}-%{release}
%if %{__with_java}
Requires: %{name}-jinterface%{?_isa} = %{version}-%{release}
%endif %{__with_java}
%endif # __with_java
Requires: %{name}-kernel%{?_isa} = %{version}-%{release}
%if %{__with_wxwidgets}
Requires: %{name}-megaco%{?_isa} = %{version}-%{release}
%endif %{__with_wxwidgets}
%endif # __with_wxwidgets
Requires: %{name}-mnesia%{?_isa} = %{version}-%{release}
%if %{__with_wxwidgets}
Requires: %{name}-observer%{?_isa} = %{version}-%{release}
%endif %{__with_wxwidgets}
%endif # __with_wxwidgets
Requires: %{name}-odbc%{?_isa} = %{version}-%{release}
Requires: %{name}-os_mon%{?_isa} = %{version}-%{release}
Requires: %{name}-otp_mibs%{?_isa} = %{version}-%{release}
Requires: %{name}-parsetools%{?_isa} = %{version}-%{release}
Requires: %{name}-public_key%{?_isa} = %{version}-%{release}
%if %{__with_wxwidgets}
Requires: %{name}-reltool%{?_isa} = %{version}-%{release}
%endif %{__with_wxwidgets}
%endif # __with_wxwidgets
Requires: %{name}-runtime_tools%{?_isa} = %{version}-%{release}
Requires: %{name}-sasl%{?_isa} = %{version}-%{release}
Requires: %{name}-snmp%{?_isa} = %{version}-%{release}
@ -186,7 +185,7 @@ Requires: %{name}-tftp%{?_isa} = %{version}-%{release}
Requires: %{name}-tools%{?_isa} = %{version}-%{release}
%if %{__with_wxwidgets}
Requires: %{name}-wx%{?_isa} = %{version}-%{release}
%endif %{__with_wxwidgets}
%endif # __with_wxwidgets
Requires: %{name}-xmerl%{?_isa} = %{version}-%{release}
%description
@ -228,7 +227,7 @@ Obsoletes: erlang-test_server
%description common_test
A portable framework for automatic testing.
%endif %{__with_wxwidgets}
%endif # __with_wxwidgets
%package compiler
Summary: A byte code compiler for Erlang which produces highly compact code
@ -262,7 +261,7 @@ Requires: %{name}-wx%{?_isa} = %{version}-%{release}
%description debugger
A debugger for debugging and testing of Erlang programs.
%endif %{__with_wxwidgets}
%endif # __with_wxwidgets
%if %{__with_wxwidgets}
%package dialyzer
@ -279,7 +278,7 @@ Obsoletes: erlang-typer
%description dialyzer
A DIscrepancy AnaLYZer for ERlang programs.
%endif %{__with_wxwidgets}
%endif # __with_wxwidgets
%package diameter
Summary: Diameter (RFC 3588) library
@ -368,6 +367,7 @@ Obsoletes: erlang-docbuilder
Obsoletes: erlang-gs
Obsoletes: erlang-inviso
Obsoletes: erlang-ose
Obsoletes: erlang-otp_mibs
# Moved to https://github.com/erlang/percept
Obsoletes: erlang-percept < 20.2.3
Obsoletes: erlang-pman
@ -389,7 +389,7 @@ Requires: %{name}-wx%{?_isa} = %{version}-%{release}
%description et
An event tracer for Erlang programs.
%endif %{__with_wxwidgets}
%endif # __with_wxwidgets
%package eunit
Summary: Support for unit testing
@ -455,7 +455,7 @@ Requires: %{name}-erts%{?_isa} = %{version}-%{release}
%description jinterface
Low level interface to Java.
%endif %{__with_java}
%endif # __with_java
%package kernel
Summary: Main erlang library
@ -480,7 +480,7 @@ Requires: %{name}-stdlib%{?_isa} = %{version}-%{release}
Megaco/H.248 is a protocol for control of elements in a physically
decomposed multimedia gateway, enabling separation of call control
from media conversion.
%endif %{__with_wxwidgets}
%endif # __with_wxwidgets
%package mnesia
Summary: A heavy duty real-time distributed database
@ -504,7 +504,7 @@ Requires: %{name}-wx%{?_isa} = %{version}-%{release}
%description observer
A set of tools for tracing and investigation of distributed systems.
%endif %{__with_wxwidgets}
%endif # __with_wxwidgets
%package odbc
Summary: A library for unixODBC support in Erlang
@ -522,7 +522,6 @@ Summary: A monitor which allows inspection of the underlying operating system
Requires: %{name}-erts%{?_isa} = %{version}-%{release}
Requires: %{name}-kernel%{?_isa} = %{version}-%{release}
Requires: %{name}-mnesia%{?_isa} = %{version}-%{release}
Requires: %{name}-otp_mibs%{?_isa} = %{version}-%{release}
Requires: %{name}-sasl%{?_isa} = %{version}-%{release}
Requires: %{name}-snmp%{?_isa} = %{version}-%{release}
Requires: %{name}-stdlib%{?_isa} = %{version}-%{release}
@ -530,17 +529,6 @@ Requires: %{name}-stdlib%{?_isa} = %{version}-%{release}
%description os_mon
A monitor which allows inspection of the underlying operating system.
%package otp_mibs
Summary: SNMP management information base for Erlang/OTP nodes
Requires: %{name}-erts%{?_isa} = %{version}-%{release}
Requires: %{name}-kernel%{?_isa} = %{version}-%{release}
Requires: %{name}-mnesia%{?_isa} = %{version}-%{release}
Requires: %{name}-snmp%{?_isa} = %{version}-%{release}
Requires: %{name}-stdlib%{?_isa} = %{version}-%{release}
%description otp_mibs
SNMP management information base for Erlang/OTP nodes.
%package parsetools
Summary: A set of parsing and lexical analysis tools
Requires: %{name}-erts%{?_isa} = %{version}-%{release}
@ -578,7 +566,7 @@ between applications. The graphical frontend depicts the
dependencies and enables interactive customization of a
target system. The backend provides a batch interface
for generation of customized target systems.
%endif %{__with_wxwidgets}
%endif # __with_wxwidgets
%package runtime_tools
Summary: A set of tools to include in a production system
@ -710,7 +698,7 @@ Requires: mesa-libGLU
%description wx
A Graphics System used to write platform independent user interfaces.
%endif %{__with_wxwidgets}
%endif # __with_wxwidgets
%package xmerl
Summary: Provides support for XML 1.0
@ -749,7 +737,7 @@ CFLAGS="${ERL_FLAGS}" CXXFLAGS="${ERL_FLAGS}" %configure --enable-shared-zlib --
\
%else
--without-jinterface \
%endif %{__with_java}
%endif # __with_java
%if %{__with_wxwidgets}
--with-wx-config=/usr/bin/wx-config-3.0
%else
@ -761,7 +749,7 @@ CFLAGS="${ERL_FLAGS}" CXXFLAGS="${ERL_FLAGS}" %configure --enable-shared-zlib --
--without-observer \
--without-reltool \
--without-wx
%endif %{__with_wxwidgets}
%endif # __with_wxwidgets
# Remove pre-built BEAM files
make clean
@ -929,7 +917,7 @@ install -m 0755 -d "$RPM_BUILD_ROOT%{_javadir}/%{name}"
jinterface_lib_dir="$(ls -d1 $RPM_BUILD_ROOT%{_libdir}/erlang/lib/jinterface-*/ | sed "s,^$RPM_BUILD_ROOT,,")"
test -d "$RPM_BUILD_ROOT$jinterface_lib_dir"
ln -s "${jinterface_lib_dir}priv/OtpErlang.jar" "$RPM_BUILD_ROOT%{_javadir}/%{name}/"
%endif %{__with_java}
%endif # __with_java
# systemd-related stuff
%if ! (0%{?rhel} && 0%{?rhel} <= 6)
@ -951,7 +939,7 @@ do
rm -f $RPM_BUILD_ROOT/%{_libdir}/erlang/bin/${exe}
rm -f $RPM_BUILD_ROOT/%{_libdir}/erlang/erts-*/bin/${exe}
done
%endif %{__with_wxwidgets}
%endif # __with_wxwidgets
# Provide a place for noarch libs to live.
install -d -p -m 0755 %{buildroot}%{_datadir}/erlang/
@ -1017,7 +1005,7 @@ useradd -r -g epmd -d /dev/null -s /sbin/nologin \
%{_mandir}/man3/unix_telnet.*
%{_mandir}/man6/common_test.*
%endif
%endif %{__with_wxwidgets}
%endif # __with_wxwidgets
%files compiler
%{_libdir}/erlang/lib/compiler-*/
@ -1040,7 +1028,7 @@ useradd -r -g epmd -d /dev/null -s /sbin/nologin \
%{_mandir}/man3/i.*
%{_mandir}/man3/int.*
%endif
%endif %{__with_wxwidgets}
%endif # __with_wxwidgets
%if %{__with_wxwidgets}
%files dialyzer
@ -1056,7 +1044,7 @@ useradd -r -g epmd -d /dev/null -s /sbin/nologin \
%{_mandir}/man3/dialyzer.*
%{_mandir}/man3/typer.*
%endif
%endif %{__with_wxwidgets}
%endif # __with_wxwidgets
%files diameter
%dir %{_libdir}/erlang/lib/diameter-*/
@ -1192,8 +1180,10 @@ useradd -r -g epmd -d /dev/null -s /sbin/nologin \
%{_mandir}/man3/erlang.*
%{_mandir}/man3/erts_alloc.*
%{_mandir}/man3/init.*
%{_mandir}/man3/net.*
%{_mandir}/man3/persistent_term.*
%{_mandir}/man3/scheduler.*
%{_mandir}/man3/socket.*
%{_mandir}/man3/zlib.*
%endif
%{_libdir}/erlang/releases/*
@ -1217,7 +1207,7 @@ useradd -r -g epmd -d /dev/null -s /sbin/nologin \
%{_mandir}/man3/et_selector.*
%{_mandir}/man3/et_viewer.*
%endif
%endif %{__with_wxwidgets}
%endif # __with_wxwidgets
%files eunit
%dir %{_libdir}/erlang/lib/eunit-*/
@ -1235,20 +1225,20 @@ useradd -r -g epmd -d /dev/null -s /sbin/nologin \
%{_libdir}/erlang/lib/diameter-*/examples/
%if %{__with_wxwidgets}
%{_libdir}/erlang/lib/et-*/examples/
%endif %{__with_wxwidgets}
%endif # __with_wxwidgets
%{_libdir}/erlang/lib/eunit-*/examples/
%{_libdir}/erlang/lib/inets-*/examples/
%{_libdir}/erlang/lib/kernel-*/examples/
%if %{__with_wxwidgets}
%{_libdir}/erlang/lib/megaco-*/examples/
%endif %{__with_wxwidgets}
%endif # __with_wxwidgets
%{_libdir}/erlang/lib/mnesia-*/examples/
%if %{__with_wxwidgets}
%{_libdir}/erlang/lib/observer-*/examples/
%endif %{__with_wxwidgets}
%endif # __with_wxwidgets
%if %{__with_wxwidgets}
%{_libdir}/erlang/lib/reltool-*/examples/
%endif %{__with_wxwidgets}
%endif # __with_wxwidgets
%{_libdir}/erlang/lib/runtime_tools-*/examples/
%{_libdir}/erlang/lib/sasl-*/examples/
%{_libdir}/erlang/lib/snmp-*/examples/
@ -1258,7 +1248,7 @@ useradd -r -g epmd -d /dev/null -s /sbin/nologin \
%{_libdir}/erlang/lib/tools-*/examples/
%if %{__with_wxwidgets}
%{_libdir}/erlang/lib/wx-*/examples/
%endif %{__with_wxwidgets}
%endif # __with_wxwidgets
%endif %{__with_examples}
%files ftp
@ -1299,7 +1289,7 @@ useradd -r -g epmd -d /dev/null -s /sbin/nologin \
%dir %{_javadir}/%{name}/
%{_javadir}/%{name}/OtpErlang.jar
%{_libdir}/erlang/lib/jinterface-*/
%endif %{__with_java}
%endif # __with_java
%files kernel
%dir %{_libdir}/erlang/lib/kernel-*/
@ -1368,7 +1358,7 @@ useradd -r -g epmd -d /dev/null -s /sbin/nologin \
%{_mandir}/man3/megaco_udp.*
%{_mandir}/man3/megaco_user.*
%endif
%endif %{__with_wxwidgets}
%endif # __with_wxwidgets
%files mnesia
%dir %{_libdir}/erlang/lib/mnesia-*/
@ -1395,7 +1385,7 @@ useradd -r -g epmd -d /dev/null -s /sbin/nologin \
%{_mandir}/man3/ttb.*
%{_mandir}/man6/observer.*
%endif
%endif %{__with_wxwidgets}
%endif # __with_wxwidgets
%files odbc
%{_libdir}/erlang/lib/odbc-*/
@ -1409,17 +1399,10 @@ useradd -r -g epmd -d /dev/null -s /sbin/nologin \
%{_mandir}/man3/cpu_sup.*
%{_mandir}/man3/disksup.*
%{_mandir}/man3/memsup.*
%{_mandir}/man3/os_mon_mib.*
%{_mandir}/man3/os_sup.*
%{_mandir}/man6/os_mon.*
%endif
%files otp_mibs
%{_libdir}/erlang/lib/otp_mibs-*/
%if %{with doc}
%{_mandir}/man3/otp_mib.*
%endif
%files parsetools
%{_libdir}/erlang/lib/parsetools-*/
%if %{with doc}
@ -1442,7 +1425,7 @@ useradd -r -g epmd -d /dev/null -s /sbin/nologin \
%if %{with doc}
%{_mandir}/man3/reltool.*
%endif
%endif %{__with_wxwidgets}
%endif # __with_wxwidgets
%files runtime_tools
%dir %{_libdir}/erlang/lib/runtime_tools-*/
@ -1937,7 +1920,7 @@ useradd -r -g epmd -d /dev/null -s /sbin/nologin \
%{_mandir}/man3/wx_misc.*
%{_mandir}/man3/wx_object.*
%endif
%endif %{__with_wxwidgets}
%endif # __with_wxwidgets
%files xmerl
%{_libdir}/erlang/lib/xmerl-*/
@ -1953,6 +1936,10 @@ useradd -r -g epmd -d /dev/null -s /sbin/nologin \
%changelog
* Tue Jul 30 2019 Peter Lemenkov <lemenkov@gmail.com> - 22.0.7-1
- Ver. 22.0.7
- Removed otp_mibs application
* Wed Jul 24 2019 Fedora Release Engineering <releng@fedoraproject.org> - 21.3.8.6-2
- Rebuilt for https://fedoraproject.org/wiki/Fedora_31_Mass_Rebuild

View File

@ -5,10 +5,10 @@ Subject: [PATCH] Remove rpath
Signed-off-by: Peter Lemenkov <lemenkov@gmail.com>
diff --git a/lib/crypto/c_src/Makefile.in b/lib/crypto/c_src/Makefile.in
index 31124ba477..a4a6c158cc 100644
index b6a65d7488..cd60549711 100644
--- a/lib/crypto/c_src/Makefile.in
+++ b/lib/crypto/c_src/Makefile.in
@@ -96,7 +96,7 @@ endif
@@ -114,7 +114,7 @@ TEST_ENGINE_LIB = $(LIBDIR)/otp_test_engine$(TYPEMARKER).@DED_EXT@
DYNAMIC_CRYPTO_LIB=@SSL_DYNAMIC_ONLY@
ifeq ($(DYNAMIC_CRYPTO_LIB),yes)

View File

@ -27,10 +27,10 @@ index 1f714df357..95835d6ed2 100644
release_docs_spec:
diff --git a/lib/crypto/c_src/Makefile.in b/lib/crypto/c_src/Makefile.in
index a4a6c158cc..13658302f5 100644
index cd60549711..5be70391d2 100644
--- a/lib/crypto/c_src/Makefile.in
+++ b/lib/crypto/c_src/Makefile.in
@@ -216,16 +216,11 @@ docs:
@@ -223,16 +223,11 @@ docs:
include $(ERL_TOP)/make/otp_release_targets.mk
release_spec: opt
@ -48,10 +48,10 @@ index a4a6c158cc..13658302f5 100644
release_docs_spec:
diff --git a/lib/erl_interface/src/Makefile.in b/lib/erl_interface/src/Makefile.in
index 2c1a8252ae..48973052c8 100644
index 6e0d3476c7..55499fd9d4 100644
--- a/lib/erl_interface/src/Makefile.in
+++ b/lib/erl_interface/src/Makefile.in
@@ -844,14 +844,14 @@ ifneq ($(EXE_TARGETS),)
@@ -848,14 +848,14 @@ ifneq ($(EXE_TARGETS),)
$(INSTALL_PROGRAM) $(EXE_TARGETS) "$(RELSYSDIR)/bin"
endif
$(INSTALL_DATA) $(EXTRA) "$(RELSYSDIR)/src"
@ -75,10 +75,10 @@ index 2c1a8252ae..48973052c8 100644
release_docs:
diff --git a/lib/megaco/src/flex/Makefile.in b/lib/megaco/src/flex/Makefile.in
index c37ad4d702..09bf1efe95 100644
index 26d2ddd44c..753925ed77 100644
--- a/lib/megaco/src/flex/Makefile.in
+++ b/lib/megaco/src/flex/Makefile.in
@@ -271,7 +271,7 @@ release_spec: opt
@@ -251,7 +251,7 @@ release_spec: opt
$(INSTALL_DATA) $(ERL_FILES) $(INTERNAL_HRL_FILES) "$(RELSYSDIR)/src/flex"
$(INSTALL_DATA) $(TARGET_FILES) "$(RELSYSDIR)/ebin"
ifeq ($(ENABLE_MEGACO_FLEX_SCANNER),true)
@ -88,7 +88,7 @@ index c37ad4d702..09bf1efe95 100644
endif
diff --git a/lib/odbc/c_src/Makefile.in b/lib/odbc/c_src/Makefile.in
index 784e73c47e..568c5e4c3e 100644
index 294d832797..173f660f26 100644
--- a/lib/odbc/c_src/Makefile.in
+++ b/lib/odbc/c_src/Makefile.in
@@ -129,11 +129,8 @@ include $(ERL_TOP)/make/otp_release_targets.mk

View File

@ -6,10 +6,10 @@ Subject: [PATCH] Do not install nteventlog and related doc-files on non-win32
Signed-off-by: Peter Lemenkov <lemenkov@gmail.com>
diff --git a/lib/os_mon/doc/src/Makefile b/lib/os_mon/doc/src/Makefile
index 354f8ed26b..12adcfbcf2 100644
index 8e9a4c333c..33b32b09b9 100644
--- a/lib/os_mon/doc/src/Makefile
+++ b/lib/os_mon/doc/src/Makefile
@@ -36,12 +36,17 @@ RELSYSDIR = $(RELEASE_PATH)/lib/$(APPLICATION)-$(VSN)
@@ -36,11 +36,16 @@ RELSYSDIR = $(RELEASE_PATH)/lib/$(APPLICATION)-$(VSN)
# Target Specs
# ----------------------------------------------------
XML_APPLICATION_FILES = ref_man.xml
@ -21,7 +21,6 @@ index 354f8ed26b..12adcfbcf2 100644
XML_REF3_FILES = cpu_sup.xml \
disksup.xml \
memsup.xml \
os_mon_mib.xml \
os_sup.xml \
- nteventlog.xml
+ $(NTEVENTLOG_DOCFILE)
@ -29,25 +28,25 @@ index 354f8ed26b..12adcfbcf2 100644
XML_REF6_FILES = os_mon_app.xml
diff --git a/lib/os_mon/src/Makefile b/lib/os_mon/src/Makefile
index fc2eb22393..e2f4d5a090 100644
index 923a31f290..5963351b0f 100644
--- a/lib/os_mon/src/Makefile
+++ b/lib/os_mon/src/Makefile
@@ -34,8 +34,13 @@ RELSYSDIR = $(RELEASE_PATH)/lib/os_mon-$(VSN)
@@ -34,7 +34,13 @@ RELSYSDIR = $(RELEASE_PATH)/lib/os_mon-$(VSN)
# ----------------------------------------------------
# Target Specs
# ----------------------------------------------------
-MODULES= disksup memsup cpu_sup os_mon os_sup os_mon_sysinfo nteventlog
+ifeq ($(findstring win32,$(TARGET)),win32)
+NTEVENTLOG=nteventlog
+else
+NTEVENTLOG=
+endif
MODULES= disksup memsup cpu_sup os_mon os_mon_mib os_sup os_mon_sysinfo \
- nteventlog
+MODULES= disksup memsup cpu_sup os_mon os_sup os_mon_sysinfo \
+ $(NTEVENTLOG)
INCLUDE=../include
CSRC=../c_src
@@ -79,7 +84,11 @@ docs:
@@ -78,7 +84,11 @@ docs:
# ----------------------------------------------------
$(APP_TARGET): $(APP_SRC) ../vsn.mk

View File

@ -8,10 +8,10 @@ Signed-off-by: Peter Lemenkov <lemenkov@gmail.com>
Signed-off-by: Hans Ulrich Niedermann <hun@n-dimensional.de>
diff --git a/erts/preloaded/src/Makefile b/erts/preloaded/src/Makefile
index e1bd5bc295..a4833521d1 100644
index 27d450c873..d3ea19286e 100644
--- a/erts/preloaded/src/Makefile
+++ b/erts/preloaded/src/Makefile
@@ -94,8 +94,6 @@ $(APP_TARGET): $(APP_SRC) $(ERL_TOP)/erts/vsn.mk
@@ -112,8 +112,6 @@ $(APP_TARGET): $(APP_SRC) $(ERL_TOP)/erts/vsn.mk
include $(ERL_TOP)/make/otp_release_targets.mk
release_spec: $(APP_TARGET)
@ -63,10 +63,10 @@ index f015064b39..57f96d2929 100644
$(INSTALL_SCRIPT) $(PROGRAMS) "$(RELEASE_PATH)/test_server"
diff --git a/lib/compiler/src/Makefile b/lib/compiler/src/Makefile
index 2408c76b48..700e236964 100644
index 87b0d345f2..db0ea47135 100644
--- a/lib/compiler/src/Makefile
+++ b/lib/compiler/src/Makefile
@@ -173,8 +173,8 @@ include $(ERL_TOP)/make/otp_release_targets.mk
@@ -179,8 +179,8 @@ include $(ERL_TOP)/make/otp_release_targets.mk
release_spec: opt
$(INSTALL_DIR) "$(RELSYSDIR)/src"
@ -104,10 +104,10 @@ index 118cb6b758..86722d8767 100644
$(INSTALL_DATA) $(TARGET_FILES) $(TARGET_TOOLBOX_FILES) "$(RELSYSDIR)/ebin"
diff --git a/lib/dialyzer/src/Makefile b/lib/dialyzer/src/Makefile
index fc08e7ca2f..2464a15c3f 100644
index bddd761705..f0c2e7c35b 100644
--- a/lib/dialyzer/src/Makefile
+++ b/lib/dialyzer/src/Makefile
@@ -158,7 +158,7 @@ include $(ERL_TOP)/make/otp_release_targets.mk
@@ -160,7 +160,7 @@ include $(ERL_TOP)/make/otp_release_targets.mk
release_spec: opt
$(INSTALL_DIR) "$(RELSYSDIR)/src"
@ -205,10 +205,10 @@ index 3510d3cc93..9179e9b4c2 100644
$(INSTALL_DIR) "$(RELSYSDIR)/include"
$(INSTALL_DATA) $(INCLUDE_DELIVERABLES) "$(RELSYSDIR)/include"
diff --git a/lib/hipe/cerl/Makefile b/lib/hipe/cerl/Makefile
index f653dce36f..7cc5c06528 100644
index 5c367b5b77..b7a85ba115 100644
--- a/lib/hipe/cerl/Makefile
+++ b/lib/hipe/cerl/Makefile
@@ -102,7 +102,7 @@ include $(ERL_TOP)/make/otp_release_targets.mk
@@ -105,7 +105,7 @@ include $(ERL_TOP)/make/otp_release_targets.mk
release_spec: opt
$(INSTALL_DIR) "$(RELSYSDIR)/cerl"
@ -244,10 +244,10 @@ index b220bc16a0..d4073277be 100644
$(INSTALL_DATA) $(TARGET_FILES) "$(RELSYSDIR)/ebin"
diff --git a/lib/hipe/llvm/Makefile b/lib/hipe/llvm/Makefile
index 817ff67dcd..e50ba5e207 100644
index 9f7a2def6d..def1b4be52 100644
--- a/lib/hipe/llvm/Makefile
+++ b/lib/hipe/llvm/Makefile
@@ -101,7 +101,7 @@ include $(ERL_TOP)/make/otp_release_targets.mk
@@ -104,7 +104,7 @@ include $(ERL_TOP)/make/otp_release_targets.mk
release_spec: opt
$(INSTALL_DIR) $(RELSYSDIR)/llvm
@ -283,10 +283,10 @@ index e5033e444b..74a444b386 100644
$(INSTALL_DATA) $(TARGET_FILES) "$(RELSYSDIR)/ebin"
diff --git a/lib/hipe/rtl/Makefile b/lib/hipe/rtl/Makefile
index becdd0b7d8..da8f66343f 100644
index 0c0f6e24f5..fcffc1f8b5 100644
--- a/lib/hipe/rtl/Makefile
+++ b/lib/hipe/rtl/Makefile
@@ -105,7 +105,7 @@ include $(ERL_TOP)/make/otp_release_targets.mk
@@ -108,7 +108,7 @@ include $(ERL_TOP)/make/otp_release_targets.mk
release_spec: opt
$(INSTALL_DIR) "$(RELSYSDIR)/rtl"
@ -369,10 +369,10 @@ index ec1ae70305..88c084ef58 100644
$(INSTALL_DATA) $(EXTERNAL_HRL_FILES) "$(RELSYSDIR)/include"
$(INSTALL_DIR) "$(RELSYSDIR)/ebin"
diff --git a/lib/kernel/src/Makefile b/lib/kernel/src/Makefile
index 3d1506ea08..728fa64869 100644
index fcb599859b..14f82f9ea4 100644
--- a/lib/kernel/src/Makefile
+++ b/lib/kernel/src/Makefile
@@ -227,7 +227,6 @@ include $(ERL_TOP)/make/otp_release_targets.mk
@@ -228,7 +228,6 @@ include $(ERL_TOP)/make/otp_release_targets.mk
release_spec: opt
$(INSTALL_DIR) "$(RELSYSDIR)/src"
@ -420,10 +420,10 @@ index 869b516b05..fa7d774d84 100644
diff --git a/lib/megaco/src/flex/Makefile.in b/lib/megaco/src/flex/Makefile.in
index 09bf1efe95..b320b2e96f 100644
index 753925ed77..c6b68e225f 100644
--- a/lib/megaco/src/flex/Makefile.in
+++ b/lib/megaco/src/flex/Makefile.in
@@ -268,7 +268,6 @@ release_spec: opt
@@ -248,7 +248,6 @@ release_spec: opt
$(INSTALL_DIR) "$(RELSYSDIR)/src/flex"
$(INSTALL_DIR) "$(RELSYSDIR)/priv/lib"
$(INSTALL_DIR) "$(RELSYSDIR)/include"
@ -509,7 +509,7 @@ index 7ca59495ed..a52ade2fe3 100644
$(INSTALL_DATA) $(EXT_HRL_FILES) "$(RELSYSDIR)/include"
$(INSTALL_DIR) "$(RELSYSDIR)/ebin"
diff --git a/lib/os_mon/src/Makefile b/lib/os_mon/src/Makefile
index e2f4d5a090..57f21a145b 100644
index 5963351b0f..22c41137d0 100644
--- a/lib/os_mon/src/Makefile
+++ b/lib/os_mon/src/Makefile
@@ -105,7 +105,6 @@ include $(ERL_TOP)/make/otp_release_targets.mk
@ -520,19 +520,6 @@ index e2f4d5a090..57f21a145b 100644
$(INSTALL_DATA) $(HRL_FILES) "$(RELSYSDIR)/src"
$(INSTALL_DIR) "$(RELSYSDIR)/ebin"
$(INSTALL_DATA) $(TARGET_FILES) "$(RELSYSDIR)/ebin"
diff --git a/lib/otp_mibs/src/Makefile b/lib/otp_mibs/src/Makefile
index 5c7af39c3f..a85368b4f4 100644
--- a/lib/otp_mibs/src/Makefile
+++ b/lib/otp_mibs/src/Makefile
@@ -96,8 +96,6 @@ $(APPUP_TARGET): $(APPUP_SRC) ../vsn.mk
include $(ERL_TOP)/make/otp_release_targets.mk
release_spec: opt
- $(INSTALL_DIR) "$(RELSYSDIR)/src"
- $(INSTALL_DATA) $(ERL_FILES) "$(RELSYSDIR)/src"
$(INSTALL_DIR) "$(RELSYSDIR)/ebin"
$(INSTALL_DATA) $(TARGETS) "$(RELSYSDIR)/ebin"
diff --git a/lib/parsetools/src/Makefile b/lib/parsetools/src/Makefile
index ba206904ec..281cc8657c 100644
--- a/lib/parsetools/src/Makefile
@ -547,7 +534,7 @@ index ba206904ec..281cc8657c 100644
$(INSTALL_DATA) $(TARGET_FILES) "$(RELSYSDIR)/ebin"
$(INSTALL_DIR) "$(RELSYSDIR)/include"
diff --git a/lib/public_key/asn1/Makefile b/lib/public_key/asn1/Makefile
index 10952106c6..dc07102803 100644
index a920ea87ea..7672ef3470 100644
--- a/lib/public_key/asn1/Makefile
+++ b/lib/public_key/asn1/Makefile
@@ -96,8 +96,8 @@ release_spec: opt
@ -601,10 +588,10 @@ index 76286c5499..d921f9f294 100644
$(INSTALL_DATA) $(HRL_FILES) "$(RELSYSDIR)/include"
$(INSTALL_DIR) "$(RELSYSDIR)/examples"
diff --git a/lib/sasl/src/Makefile b/lib/sasl/src/Makefile
index 7338bdf016..a280225dad 100644
index fd62588f5c..07373bfa78 100644
--- a/lib/sasl/src/Makefile
+++ b/lib/sasl/src/Makefile
@@ -93,7 +93,6 @@ include $(ERL_TOP)/make/otp_release_targets.mk
@@ -97,7 +97,6 @@ include $(ERL_TOP)/make/otp_release_targets.mk
release_spec: opt
$(INSTALL_DIR) "$(RELSYSDIR)/src"
@ -691,10 +678,10 @@ index 6d64a45112..5b1249ca5b 100644
$(INSTALL_DATA) $(BEHAVIOUR_TARGET_FILES) $(TARGET_FILES) $(APP_TARGET) \
$(APPUP_TARGET) "$(RELSYSDIR)/ebin"
diff --git a/lib/ssl/src/Makefile b/lib/ssl/src/Makefile
index 8d1341f594..72ab265200 100644
index 8dc76f2638..3c2f73f5be 100644
--- a/lib/ssl/src/Makefile
+++ b/lib/ssl/src/Makefile
@@ -149,7 +149,7 @@ include $(ERL_TOP)/make/otp_release_targets.mk
@@ -183,7 +183,7 @@ include $(ERL_TOP)/make/otp_release_targets.mk
release_spec: opt
$(INSTALL_DIR) "$(RELSYSDIR)/src"
@ -704,10 +691,10 @@ index 8d1341f594..72ab265200 100644
$(INSTALL_DATA) $(BEHAVIOUR_TARGET_FILES) $(TARGET_FILES) $(APP_TARGET) \
$(APPUP_TARGET) "$(RELSYSDIR)/ebin"
diff --git a/lib/stdlib/src/Makefile b/lib/stdlib/src/Makefile
index c95f7637f7..0f601aefb5 100644
index 86003c953d..69bfbefeb9 100644
--- a/lib/stdlib/src/Makefile
+++ b/lib/stdlib/src/Makefile
@@ -214,7 +214,6 @@ include $(ERL_TOP)/make/otp_release_targets.mk
@@ -216,7 +216,6 @@ include $(ERL_TOP)/make/otp_release_targets.mk
release_spec: opt
$(INSTALL_DIR) "$(RELSYSDIR)/src"
@ -755,7 +742,7 @@ index cc5bee9a8f..7dfa55cb41 100644
$(INSTALL_DATA) $(TARGET_FILES) $(APP_TARGET) $(APPUP_TARGET) \
"$(RELSYSDIR)/ebin"
diff --git a/lib/wx/src/Makefile b/lib/wx/src/Makefile
index 21b45af2c4..a7bf34f4f4 100644
index 52f4008e0a..dc297f1d55 100644
--- a/lib/wx/src/Makefile
+++ b/lib/wx/src/Makefile
@@ -122,9 +122,9 @@ $(EBIN)/%.beam: $(EGEN)/%.erl $(HEADER_FILES)

View File

@ -7,10 +7,10 @@ Patch allows one to use standard man path with erl -man command.
as required by Debian policy.)
diff --git a/erts/etc/common/erlexec.c b/erts/etc/common/erlexec.c
index 23bbb86333..741b492668 100644
index 8203c46a39..631b93a92e 100644
--- a/erts/etc/common/erlexec.c
+++ b/erts/etc/common/erlexec.c
@@ -722,8 +722,10 @@ int main(int argc, char **argv)
@@ -706,8 +706,10 @@ int main(int argc, char **argv)
error("-man not supported on Windows");
#else
argv[i] = "man";

View File

@ -37,7 +37,7 @@ even if a node disconnects.
Signed-off-by: Peter Lemenkov <lemenkov@gmail.com>
diff --git a/lib/kernel/src/net_kernel.erl b/lib/kernel/src/net_kernel.erl
index a9dc77837e..04025cf35b 100644
index 83d3b4b5e1..bebefc2e08 100644
--- a/lib/kernel/src/net_kernel.erl
+++ b/lib/kernel/src/net_kernel.erl
@@ -670,24 +670,16 @@ code_change(_OldVsn, State, _Extra) ->
@ -69,7 +69,7 @@ index a9dc77837e..04025cf35b 100644
%% ------------------------------------------------------------
@@ -1139,35 +1131,10 @@ disconnect_pid(Pid, State) ->
@@ -1147,35 +1139,10 @@ disconnect_pid(Pid, State) ->
%%
%%
%%
@ -108,7 +108,7 @@ index a9dc77837e..04025cf35b 100644
ticker(Kernel, Tick) when is_integer(Tick) ->
process_flag(priority, max),
@@ -1632,15 +1599,14 @@ get_node_info(Node, Key) ->
@@ -1640,15 +1607,14 @@ get_node_info(Node, Key) ->
end.
get_nodes_info() ->