Erlang ver. 23.0
Signed-off-by: Peter Lemenkov <lemenkov@gmail.com>
This commit is contained in:
parent
755939eed8
commit
4a788b08bd
10
erlang.spec
10
erlang.spec
@ -66,7 +66,7 @@
|
||||
|
||||
Name: erlang
|
||||
Version: 23.0
|
||||
Release: 0.2.rc3%{?dist}
|
||||
Release: 1%{?dist}
|
||||
Summary: General-purpose programming language and runtime environment
|
||||
|
||||
License: ASL 2.0
|
||||
@ -74,8 +74,7 @@ URL: https://www.erlang.org
|
||||
%if ! (0%{?rhel} && 0%{?rhel} <= 6)
|
||||
VCS: scm:git:https://github.com/erlang/otp
|
||||
%endif
|
||||
#Source0: https://github.com/erlang/otp/archive/OTP-%{version}/otp-OTP-%{version}.tar.gz
|
||||
Source0: https://github.com/erlang/otp/archive/OTP-%{version}-rc3/otp-OTP-%{version}-rc3.tar.gz
|
||||
Source0: https://github.com/erlang/otp/archive/OTP-%{version}/otp-OTP-%{version}.tar.gz
|
||||
Source5: epmd.service
|
||||
Source6: epmd.socket
|
||||
Source7: epmd@.service
|
||||
@ -712,7 +711,7 @@ Provides support for XML 1.0.
|
||||
### END OF AUTOGENERATED LIST ###
|
||||
|
||||
%prep
|
||||
%autosetup -p1 -n otp-OTP-%{version}-rc3
|
||||
%autosetup -p1 -n otp-OTP-%{version}
|
||||
|
||||
# FIXME we should come up with a better solution
|
||||
# remove shipped zlib sources
|
||||
@ -1954,6 +1953,9 @@ useradd -r -g epmd -d /dev/null -s /sbin/nologin \
|
||||
|
||||
|
||||
%changelog
|
||||
* Wed May 13 2020 Peter Lemenkov <lemenkov@gmail.com> - 23.0-1
|
||||
- Ver. 23.0
|
||||
|
||||
* Thu Apr 23 2020 Peter Lemenkov <lemenkov@gmail.com> - 23.0-0.2.rc3
|
||||
- Ver. 23.0-rc3
|
||||
|
||||
|
@ -6,10 +6,10 @@ Subject: [PATCH] Do not format man-pages and do not install miscellaneous
|
||||
Signed-off-by: Peter Lemenkov <lemenkov@gmail.com>
|
||||
|
||||
diff --git a/erts/etc/common/Makefile.in b/erts/etc/common/Makefile.in
|
||||
index ef40341c87..84e6c3cb2f 100644
|
||||
index 650ab1f6fe..fc9a200c3c 100644
|
||||
--- a/erts/etc/common/Makefile.in
|
||||
+++ b/erts/etc/common/Makefile.in
|
||||
@@ -501,10 +501,6 @@ endif
|
||||
@@ -521,10 +521,6 @@ endif
|
||||
ifneq ($(INSTALL_TOP_BIN),)
|
||||
$(INSTALL_PROGRAM) $(INSTALL_TOP_BIN) "$(RELEASE_PATH)"
|
||||
endif
|
||||
@ -21,10 +21,10 @@ index ef40341c87..84e6c3cb2f 100644
|
||||
$(INSTALL_DIR) "$(RELEASE_PATH)/erts-$(VSN)/src"
|
||||
$(INSTALL_DATA) $(INSTALL_SRC) "$(RELEASE_PATH)/erts-$(VSN)/src"
|
||||
diff --git a/erts/etc/unix/Install.src b/erts/etc/unix/Install.src
|
||||
index e4b842877c..382561821f 100644
|
||||
index 2dbf628972..5151f5130a 100644
|
||||
--- a/erts/etc/unix/Install.src
|
||||
+++ b/erts/etc/unix/Install.src
|
||||
@@ -141,14 +141,5 @@ cp -p ../releases/%I_SYSTEM_VSN%/start_*.boot .
|
||||
@@ -142,14 +142,5 @@ cp -p ../releases/%I_SYSTEM_VSN%/start_*.boot .
|
||||
cp -p ../releases/%I_SYSTEM_VSN%/no_dot_erlang.boot .
|
||||
cp -p $Name.boot start.boot
|
||||
cp -p ../releases/%I_SYSTEM_VSN%/$Name.script start.script
|
||||
|
@ -48,12 +48,12 @@ index c9d5a7064a..5f2dfb8e02 100644
|
||||
|
||||
release_docs_spec:
|
||||
diff --git a/lib/erl_interface/src/Makefile.in b/lib/erl_interface/src/Makefile.in
|
||||
index 5a07b5542a..dd16380160 100644
|
||||
index 7ff3f09abb..2b94ce7de0 100644
|
||||
--- a/lib/erl_interface/src/Makefile.in
|
||||
+++ b/lib/erl_interface/src/Makefile.in
|
||||
@@ -749,14 +749,13 @@ ifneq ($(EXE_TARGETS),)
|
||||
@@ -748,14 +748,13 @@ release: opt
|
||||
$(INSTALL_DATA) $(OBJ_TARGETS) "$(RELEASE_PATH)/usr/lib"
|
||||
$(INSTALL_PROGRAM) $(EXE_TARGETS) "$(RELSYSDIR)/bin"
|
||||
endif
|
||||
$(INSTALL_DATA) $(EXTRA) "$(RELSYSDIR)/src"
|
||||
- $(INSTALL_DATA) connect/*.[ch] "$(RELSYSDIR)/src/connect"
|
||||
- $(INSTALL_DATA) decode/*.[ch] "$(RELSYSDIR)/src/decode"
|
||||
|
@ -7,10 +7,10 @@ Patch allows one to use standard man path with erl -man command.
|
||||
as required by Debian policy.)
|
||||
|
||||
diff --git a/erts/etc/common/erlexec.c b/erts/etc/common/erlexec.c
|
||||
index 890a5b381a..9f84a16353 100644
|
||||
index 9a2488c93c..b0e46745db 100644
|
||||
--- a/erts/etc/common/erlexec.c
|
||||
+++ b/erts/etc/common/erlexec.c
|
||||
@@ -721,8 +721,10 @@ int main(int argc, char **argv)
|
||||
@@ -726,8 +726,10 @@ int main(int argc, char **argv)
|
||||
error("-man not supported on Windows");
|
||||
#else
|
||||
argv[i] = "man";
|
||||
|
2
sources
2
sources
@ -1 +1 @@
|
||||
SHA512 (otp-OTP-23.0-rc3.tar.gz) = 4b900016687c6b66570d9ed3a70859d91c9c5bdbb0deadd0c658c94ed1156816cd14bb57dbf2e9c9d984f643ef25842a248b10813b227ecb3e8dcdd29e8da1ed
|
||||
SHA512 (otp-OTP-23.0.tar.gz) = e5d1e4b52951234f8bd4f8db7bef59a330d2783aae317468e0b94ad23cd55a60afba5d3841efad49dfcda6d7ba0a51e60208bb6a950951683fd297df56636f83
|
||||
|
Loading…
Reference in New Issue
Block a user