Erlang ver. 26.2.5.1
Signed-off-by: Peter Lemenkov <lemenkov@gmail.com>
This commit is contained in:
parent
986d3f3ba7
commit
42618325e7
@ -1,89 +0,0 @@
|
||||
Configure changes to adjust to stricter C99 compilers: Avoid
|
||||
implicit function declarations, and define main as returning int.
|
||||
|
||||
Submitted upstream: <https://github.com/erlang/otp/pull/6504>
|
||||
|
||||
diff --git a/erts/configure b/erts/configure
|
||||
index 815428caaf61c914..7d057e69ae5e3a93 100755
|
||||
--- a/erts/configure
|
||||
+++ b/erts/configure
|
||||
@@ -20529,6 +20529,9 @@ else $as_nop
|
||||
#ifdef HAVE_MALLOC_H
|
||||
# include <malloc.h>
|
||||
#endif
|
||||
+#ifdef HAVE_UNISTD_H
|
||||
+# include <unistd.h>
|
||||
+#endif
|
||||
#if defined(HAVE_END_SYMBOL)
|
||||
extern char end;
|
||||
#elif defined(HAVE__END_SYMBOL)
|
||||
@@ -24437,10 +24440,13 @@ else $as_nop
|
||||
/* end confdefs.h. */
|
||||
|
||||
#include <poll.h>
|
||||
-main()
|
||||
+#ifdef HAVE_FCNTL_H
|
||||
+#include <fcntl.h>
|
||||
+#endif
|
||||
+int main()
|
||||
{
|
||||
#ifdef _POLL_EMUL_H_
|
||||
- exit(1); /* Implemented using select() -- fail */
|
||||
+ return 1; /* Implemented using select() -- fail */
|
||||
#else
|
||||
struct pollfd fds[1];
|
||||
int fd;
|
||||
@@ -24449,9 +24455,9 @@ main()
|
||||
fds[0].events = POLLIN;
|
||||
fds[0].revents = 0;
|
||||
if (poll(fds, 1, 0) < 0 || (fds[0].revents & POLLNVAL) != 0) {
|
||||
- exit(1); /* Does not work for devices -- fail */
|
||||
+ return 1; /* Does not work for devices -- fail */
|
||||
}
|
||||
- exit(0);
|
||||
+ return 0;
|
||||
#endif
|
||||
}
|
||||
|
||||
diff --git a/erts/configure.ac b/erts/configure.ac
|
||||
index ab2ee78acdca211e..f658b66e3c0e508a 100644
|
||||
--- a/erts/configure.ac
|
||||
+++ b/erts/configure.ac
|
||||
@@ -2436,6 +2436,9 @@ AC_CACHE_CHECK([if __after_morecore_hook can track malloc()s core memory use],
|
||||
#ifdef HAVE_MALLOC_H
|
||||
# include <malloc.h>
|
||||
#endif
|
||||
+#ifdef HAVE_UNISTD_H
|
||||
+# include <unistd.h>
|
||||
+#endif
|
||||
#if defined(HAVE_END_SYMBOL)
|
||||
extern char end;
|
||||
#elif defined(HAVE__END_SYMBOL)
|
||||
@@ -3033,10 +3036,13 @@ poll_works=no
|
||||
|
||||
AC_RUN_IFELSE([AC_LANG_SOURCE([[
|
||||
#include <poll.h>
|
||||
-main()
|
||||
+#ifdef HAVE_FCNTL_H
|
||||
+#include <fcntl.h>
|
||||
+#endif
|
||||
+int main()
|
||||
{
|
||||
#ifdef _POLL_EMUL_H_
|
||||
- exit(1); /* Implemented using select() -- fail */
|
||||
+ return 1; /* Implemented using select() -- fail */
|
||||
#else
|
||||
struct pollfd fds[1];
|
||||
int fd;
|
||||
@@ -3045,9 +3051,9 @@ main()
|
||||
fds[0].events = POLLIN;
|
||||
fds[0].revents = 0;
|
||||
if (poll(fds, 1, 0) < 0 || (fds[0].revents & POLLNVAL) != 0) {
|
||||
- exit(1); /* Does not work for devices -- fail */
|
||||
+ return 1; /* Does not work for devices -- fail */
|
||||
}
|
||||
- exit(0);
|
||||
+ return 0;
|
||||
#endif
|
||||
}
|
||||
]])],[poll_works=yes],[poll_works=no],[
|
@ -68,7 +68,7 @@
|
||||
|
||||
|
||||
Name: erlang
|
||||
Version: 26.2.5
|
||||
Version: 26.2.5.1
|
||||
Release: 1%{?dist}
|
||||
Summary: General-purpose programming language and runtime environment
|
||||
|
||||
@ -1969,6 +1969,9 @@ useradd -r -g epmd -d /dev/null -s /sbin/nologin \
|
||||
|
||||
|
||||
%changelog
|
||||
* Wed Jun 26 2024 Peter Lemenkov <lemenkov@gmail.com> - 26.2.5.1-1
|
||||
- Ver. 26.2.5.1
|
||||
|
||||
* Sat May 4 2024 Peter Lemenkov <lemenkov@gmail.com> - 26.2.5-1
|
||||
- Ver. 26.2.5
|
||||
|
||||
|
2
sources
2
sources
@ -1 +1 @@
|
||||
SHA512 (otp-OTP-26.2.5.tar.gz) = f06d34290c0d93609aa3efbdc97206e8d3ce17aa2c3f62b6c566c7631ee3a3d45a89b61ce0ace81604b5a94610d03ad98558f27ee888ca90ecdeeeb2759c0184
|
||||
SHA512 (otp-OTP-26.2.5.1.tar.gz) = fe7cf5c3a386123fa00e364c1f2e884adb46b8080cd4e84eee83c07531c4fca23c909e439516f0e0730735487c7d0384df9fd98ac68e29c6e05add6039ea18f4
|
||||
|
Loading…
x
Reference in New Issue
Block a user