Initial import (#1297281)

This commit is contained in:
Link Dupont 2016-10-31 22:25:49 -07:00
parent 6561ef3f47
commit 2e4809ee46
4 changed files with 173 additions and 0 deletions

1
.gitignore vendored
View File

@ -0,0 +1 @@
/endless-sky-0.9.4.tar.gz

View File

@ -0,0 +1,41 @@
diff -up ./SConstruct.orig ./SConstruct
--- ./SConstruct.orig 2016-01-11 20:28:45.250276511 -0800
+++ ./SConstruct 2016-01-11 20:29:13.778912624 -0800
@@ -43,7 +43,7 @@ sky = env.Program("endless-sky", Glob("b
# Install the binary:
-env.Install("$DESTDIR$PREFIX/games", sky)
+env.Install("$DESTDIR$PREFIX/bin", sky)
# Install the desktop file:
env.Install("$DESTDIR$PREFIX/share/applications", "endless-sky.desktop")
@@ -81,11 +81,11 @@ def RecursiveInstall(env, target, source
RecursiveInstall(env, os.path.join(target, name), node.abspath)
else:
env.Install(target, node)
-RecursiveInstall(env, "$DESTDIR$PREFIX/share/games/endless-sky/data", "data")
-RecursiveInstall(env, "$DESTDIR$PREFIX/share/games/endless-sky/images", "images")
-RecursiveInstall(env, "$DESTDIR$PREFIX/share/games/endless-sky/sounds", "sounds")
-env.Install("$DESTDIR$PREFIX/share/games/endless-sky", "credits.txt")
-env.Install("$DESTDIR$PREFIX/share/games/endless-sky", "keys.txt")
+RecursiveInstall(env, "$DESTDIR$PREFIX/share/endless-sky/data", "data")
+RecursiveInstall(env, "$DESTDIR$PREFIX/share/endless-sky/images", "images")
+RecursiveInstall(env, "$DESTDIR$PREFIX/share/endless-sky/sounds", "sounds")
+env.Install("$DESTDIR$PREFIX/share/endless-sky", "credits.txt")
+env.Install("$DESTDIR$PREFIX/share/endless-sky", "keys.txt")
# Make the word "install" in the command line do an installation.
env.Alias("install", "$DESTDIR$PREFIX")
diff -up ./source/Files.cpp.orig ./source/Files.cpp
--- ./source/Files.cpp.orig 2016-01-11 20:29:22.100806482 -0800
+++ ./source/Files.cpp 2016-01-11 20:29:35.419636593 -0800
@@ -115,7 +115,7 @@ void Files::Init(const char * const *arg
// the executable, but are under the same prefix (/usr or /usr/local).
static const string LOCAL_PATH = "/usr/local/";
static const string STANDARD_PATH = "/usr/";
- static const string RESOURCE_PATH = "share/games/endless-sky/";
+ static const string RESOURCE_PATH = "share/endless-sky/";
if(!resources.compare(0, LOCAL_PATH.length(), LOCAL_PATH))
resources = LOCAL_PATH + RESOURCE_PATH;
else if(!resources.compare(0, STANDARD_PATH.length(), STANDARD_PATH))

129
endless-sky.spec Normal file
View File

@ -0,0 +1,129 @@
%define gittag0 v0.9.4
Name: endless-sky
Version: 0.9.4
Release: 1%{?dist}
Summary: Space exploration, trading, and combat game
License: GPLv3
URL: https://%{name}.github.io
Source0: https://github.com/%{name}/%{name}/archive/%{gittag0}.tar.gz#/%{name}-%{version}.tar.gz
# Replace /usr/games with /usr/bin and /usr/share/games with /usr/share per
# https://fedoraproject.org/wiki/SIGs/Games/Packaging.
# Patch not submitted upstream. Upstream conforms to Debian packaging
# standards where the use of /usr/games is acceptable.
Patch0: endless-sky-0.8.10-remove-games-path.patch
Requires: %{name}-data = %{version}-%{release}
BuildRequires: scons
BuildRequires: gcc-c++
BuildRequires: SDL2-devel
BuildRequires: openal-soft-devel
BuildRequires: glew-devel
BuildRequires: libpng-devel
BuildRequires: libjpeg-turbo-devel
BuildRequires: libappstream-glib
BuildRequires: desktop-file-utils
%description
Explore other star systems. Earn money by trading, carrying passengers, or
completing missions. Use your earnings to buy a better ship or to upgrade the
weapons and engines on your current one. Blow up pirates. Take sides in a civil
war. Or leave human space behind and hope to find some friendly aliens whose
culture is more civilized than your own...
%package data
Summary: Game data for %{name}
# Sound and images appear to be a mix of Public Domain and CC-BY-SA licensing
# See copyright for details.
License: Public Domain and CC-BY-SA
BuildArch: noarch
%description data
Images, sound, and game data for %{name}.
%prep
%autosetup -p0
%build
scons PREFIX=%{_prefix}
%check
appstream-util validate-relax --nonet %{name}.appdata.xml
desktop-file-validate %{name}.desktop
%install
scons PREFIX=%{_prefix} DESTDIR=%{buildroot} install
install -m644 -D endless-sky.appdata.xml %{buildroot}%{_datadir}/appdata/%{name}.appdata.xml
%post
/bin/touch --no-create %{_datadir}/icons/hicolor &>/dev/null || :
%postun
if [ $1 -eq 0 ] ; then
/bin/touch --no-create %{_datadir}/icons/hicolor &>/dev/null
/usr/bin/gtk-update-icon-cache %{_datadir}/icons/hicolor &>/dev/null || :
fi
%posttrans
/usr/bin/gtk-update-icon-cache %{_datadir}/icons/hicolor &>/dev/null || :
%files
%doc README.md
%license license.txt
%{_bindir}/%{name}
%{_datadir}/icons/hicolor/16x16/apps/%{name}.png
%{_datadir}/icons/hicolor/22x22/apps/%{name}.png
%{_datadir}/icons/hicolor/24x24/apps/%{name}.png
%{_datadir}/icons/hicolor/32x32/apps/%{name}.png
%{_datadir}/icons/hicolor/48x48/apps/%{name}.png
%{_datadir}/icons/hicolor/256x256/apps/%{name}.png
%{_datadir}/applications/%{name}.desktop
%{_datadir}/appdata/%{name}.appdata.xml
%{_mandir}/man6/%{name}.6.gz
%files data
%license copyright
%{_datadir}/%{name}
%changelog
* Sat Oct 15 2016 Link Dupont <linkdupont@fedoraproject.org> - 0.9.4-1
- New upstream release
- Remove local appdata.xml file deferring to upstream
* Sat Aug 20 2016 Link Dupont <linkdupont@fedoraproject.org> - 0.9.2-1
- New upstream release
- Remove installation of 'extra' directory
* Sat Jan 16 2016 Link Dupont <linkdupont@fedoraproject.org> - 0.8.10-5
- Add strict version requirement to data package
- Document dual licensing characteristics of game data
- Add appdata validation
- Update icon cache on installation
* Mon Jan 11 2016 Link Dupont <linkdupont@fedoraproject.org> - 0.8.10-4
- Combine patches into single file
* Sun Jan 10 2016 Link Dupont <linkdupont@fedoraproject.org> - 0.8.10-3
- Patch game to load resources from /usr/share/endless-sky
* Sun Jan 10 2016 Link Dupont <linkdupont@fedoraproject.org> - 0.8.10-2
- Split data into separate package
- Patch game to avoid deprecated path /usr/games
* Sat Jan 9 2016 Link Dupont <linkdupont@fedoraproject.org> - 0.8.10-1
- New upstream release
- Added appdata.xml
* Sun Jan 3 2016 Link Dupont <linkdupont@fedoraproject.org> - 0.8.9-1
- Initial package

View File

@ -0,0 +1,2 @@
f807d2a56f42cb43f20fc94256d3c993 endless-sky-0.9.4.tar.gz
e840535fe4999eecad2f2a2f82f0d1a4 endless-sky-0.8.10-remove-games-path.patch