emacs/emacs-23.1-cpp.patch
Jonathan G. Underwood b9972d7223 - Add fix for BZ 53346
- Backport of bugfixes from F-12 branch (spec file changelog entries
    follow)
- Backport fixes for bugs 516391, 484830, 474958 from F-13 branch (Jonathan
    G. Underwood)
- Add cwd to load-path in byte-compile macro for add-on packaging (Jonathan
    G. Underwood)
- Add some commentary to spec file (Jonathan G. Underwood)
- Add patch to fix rhbz#547566 from Juanma Barranquero (Jonathan G.
    Underwood)
- Simpler fix for rhbz#517272 (Karel Klic)
- Fixed rhbz#545398 - ETags messes up filenames (Karel Klic)
- fix #543046 - Using scroll bar in emacs highlights/selects text (Daniel
    Novotny)
2010-03-30 22:04:38 +00:00

22 lines
1015 B
Diff
Raw Blame History

This file contains invisible Unicode characters

This file contains invisible Unicode characters that are indistinguishable to humans but may be processed differently by a computer. If you think that this is intentional, you can safely ignore this warning. Use the Escape button to reveal them.

diff -up emacs-23.1/configure.in.cpp emacs-23.1/configure.in
--- emacs-23.1/configure.in.cpp 2009-11-30 13:24:53.000000000 +0100
+++ emacs-23.1/configure.in 2009-11-30 13:25:45.000000000 +0100
@@ -2983,7 +2983,7 @@ echo creating lib-src/Makefile
sed -e '1,/start of cpp stuff/d'\
-e 's,/\*\*/#\(.*\)$,/* \1 */,' \
< Makefile.c > junk.c
- $CPP $cpp_undefs -I. -I$srcdir/src $CPPFLAGS junk.c | \
+ $CPP -P $cpp_undefs -I. -I$srcdir/src $CPPFLAGS junk.c | \
sed -e 's/^ / /' -e '/^#/d' -e '/^[ ]*$/d' > junk2.c
cat junk1.c junk2.c > Makefile.new
rm -f junk.c junk1.c junk2.c
@@ -2999,7 +2999,7 @@ echo creating src/Makefile
sed -e '1,/start of cpp stuff/d'\
-e 's,/\*\*/#\(.*\)$,/* \1 */,' \
< Makefile.c > junk.c
- $CPP $cpp_undefs -I. -I$srcdir/src $CPPFLAGS junk.c | \
+ $CPP -P $cpp_undefs -I. -I$srcdir/src $CPPFLAGS junk.c | \
sed -e 's/^ / /' -e '/^#/d' -e '/^[ ]*$/d' > junk2.c
cat junk1.c junk2.c > Makefile.new
rm -f junk.c junk1.c junk2.c