parent
3db109a18a
commit
f6258eb59a
1
.gitignore
vendored
1
.gitignore
vendored
@ -22,3 +22,4 @@
|
||||
/emacs-25.2.tar.xz
|
||||
/emacs-25.3.tar.xz
|
||||
/emacs-26.1.tar.xz
|
||||
/emacs-26.2.tar.xz
|
||||
|
@ -1,48 +0,0 @@
|
||||
commit 408bf21a8c8b5bf5a78785608255463ad1038871
|
||||
Author: Robert Pluim <rpluim@gmail.com>
|
||||
Date: Tue Apr 3 11:06:01 2018 +0200
|
||||
|
||||
Ignore color fonts when using Xft
|
||||
|
||||
* src/font.c (syms_of_font): New configuration variable
|
||||
xft-ignore-color-fonts, default t.
|
||||
* src/ftfont.c (ftfont_spec_pattern): Tell fontconfig to ignore
|
||||
color fonts if xft-ignore-color-fonts is t. (Bug#30874, Bug#30045)
|
||||
* etc/NEWS: Document xft-ignore-color-fonts.
|
||||
|
||||
diff --git a/src/font.c b/src/font.c
|
||||
index a6d3f5d479..ef3f92b594 100644
|
||||
--- a/src/font.c
|
||||
+++ b/src/font.c
|
||||
@@ -5473,6 +5473,13 @@ Disabling compaction of font caches might enlarge the Emacs memory
|
||||
footprint in sessions that use lots of different fonts. */);
|
||||
inhibit_compacting_font_caches = 0;
|
||||
|
||||
+ DEFVAR_BOOL ("xft-ignore-color-fonts",
|
||||
+ Vxft_ignore_color_fonts,
|
||||
+ doc: /*
|
||||
+Non-nil means don't query fontconfig for color fonts, since they often
|
||||
+cause Xft crashes. Only has an effect in Xft builds. */);
|
||||
+ Vxft_ignore_color_fonts = 1;
|
||||
+
|
||||
#ifdef HAVE_WINDOW_SYSTEM
|
||||
#ifdef HAVE_FREETYPE
|
||||
syms_of_ftfont ();
|
||||
diff --git a/src/ftfont.c b/src/ftfont.c
|
||||
index c2e093e633..24a92dd52e 100644
|
||||
--- a/src/ftfont.c
|
||||
+++ b/src/ftfont.c
|
||||
@@ -764,6 +764,13 @@ ftfont_spec_pattern (Lisp_Object spec, char *otlayout, struct OpenTypeSpec **ots
|
||||
if (scalable >= 0
|
||||
&& ! FcPatternAddBool (pattern, FC_SCALABLE, scalable ? FcTrue : FcFalse))
|
||||
goto err;
|
||||
+#ifdef HAVE_XFT
|
||||
+ /* We really don't like color fonts, they cause Xft crashes. See
|
||||
+ Bug#30874. */
|
||||
+ if (Vxft_ignore_color_fonts
|
||||
+ && ! FcPatternAddBool(pattern, FC_COLOR, FcFalse))
|
||||
+ goto err;
|
||||
+#endif
|
||||
|
||||
goto finish;
|
||||
|
22
emacs.spec
22
emacs.spec
@ -4,8 +4,8 @@
|
||||
Summary: GNU Emacs text editor
|
||||
Name: emacs
|
||||
Epoch: 1
|
||||
Version: 26.1
|
||||
Release: 8%{?dist}
|
||||
Version: 26.2
|
||||
Release: 1%{?dist}
|
||||
License: GPLv3+ and CC0-1.0
|
||||
URL: http://www.gnu.org/software/emacs/
|
||||
Source0: https://ftp.gnu.org/gnu/emacs/emacs-%{version}.tar.xz
|
||||
@ -21,8 +21,6 @@ Source9: %{name}.appdata.xml
|
||||
# rhbz#713600
|
||||
Patch1: emacs-spellchecker.patch
|
||||
Patch2: emacs-system-crypto-policies.patch
|
||||
# https://git.savannah.gnu.org/cgit/emacs.git/commit/?id=408bf21a8c8b5bf5a78785608255463ad1038871
|
||||
Patch3: emacs-xft-color-font-crash.patch
|
||||
|
||||
BuildRequires: gcc
|
||||
BuildRequires: atk-devel
|
||||
@ -73,6 +71,7 @@ BuildRequires: Xaw3d-devel
|
||||
BuildRequires: util-linux
|
||||
%endif
|
||||
|
||||
|
||||
# Emacs doesn't run without dejavu-sans-mono-fonts, rhbz#732422
|
||||
Requires: desktop-file-utils
|
||||
Requires: dejavu-sans-mono-fonts
|
||||
@ -167,12 +166,17 @@ BuildArch: noarch
|
||||
This package provides some directories which are required by other
|
||||
packages that add functionality to Emacs.
|
||||
|
||||
%package devel
|
||||
Summary: Development header files for Emacs
|
||||
|
||||
%description devel
|
||||
Development header files for Emacs.
|
||||
|
||||
%prep
|
||||
%setup -q
|
||||
|
||||
%patch1 -p1 -b .spellchecker
|
||||
%patch2 -p1 -b .system-crypto-policies
|
||||
%patch3 -p1
|
||||
autoconf
|
||||
|
||||
# We prefer our emacs.desktop file
|
||||
@ -325,6 +329,8 @@ install -p -m 0644 emacs.pc %{buildroot}/%{pkgconfig}
|
||||
# Install app data
|
||||
mkdir -p %{buildroot}/%{_datadir}/appdata
|
||||
cp -a %SOURCE9 %{buildroot}/%{_datadir}/appdata
|
||||
# Upstream ships its own appdata file, but it's quite terse.
|
||||
rm %{buildroot}/%{_datadir}/metainfo/emacs.appdata.xml
|
||||
|
||||
# Install rpm macro definition file
|
||||
mkdir -p %{buildroot}%{_rpmconfigdir}/macros.d
|
||||
@ -448,7 +454,13 @@ rm %{buildroot}%{_datadir}/icons/hicolor/scalable/mimetypes/emacs-document23.svg
|
||||
%dir %{_datadir}/emacs/site-lisp
|
||||
%dir %{_datadir}/emacs/site-lisp/site-start.d
|
||||
|
||||
%files devel
|
||||
%{_includedir}/emacs-module.h
|
||||
|
||||
%changelog
|
||||
* Wed Apr 17 2019 Jan Synáček <jsynacek@redhat.com> - 1:26.2-1
|
||||
- emacs-26.2 is available (#1699434)
|
||||
|
||||
* Thu Jan 31 2019 Fedora Release Engineering <releng@fedoraproject.org> - 1:26.1-8
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_30_Mass_Rebuild
|
||||
|
||||
|
2
sources
2
sources
@ -1 +1 @@
|
||||
SHA512 (emacs-26.1.tar.xz) = 537c2cfdd281151b360002419dde6280c313e07a937ed96405c67f754b3401ec5541091a3c0aa6690929bc33dd79e8e0d8844e7a6b014b7798c63cb15de210c2
|
||||
SHA512 (emacs-26.2.tar.xz) = c223ff5c51ca8bdf887bacb2dc37b08a637d39ed6f887cc24f67397e46fe5fdb68f33f21b97300b985c749f32aa09080d33103271637ed4ce5d9f2ea34ce9fe1
|
||||
|
Loading…
Reference in New Issue
Block a user