Merge remote-tracking branch 'up/main' into main-riscv64
Signed-off-by: David Abdurachmanov <davidlt@rivosinc.com>
This commit is contained in:
commit
f3f00165dc
86
0001-Pong-and-Tetris-are-excluded.patch
Normal file
86
0001-Pong-and-Tetris-are-excluded.patch
Normal file
@ -0,0 +1,86 @@
|
||||
From 6f29ac0393bb0bb70c8122d9f1bda0ae5d8cee24 Mon Sep 17 00:00:00 2001
|
||||
From: Peter Oliver <git@mavit.org.uk>
|
||||
Date: Thu, 26 Sep 2024 13:20:06 +0100
|
||||
Subject: [PATCH] Pong and Tetris are excluded.
|
||||
|
||||
---
|
||||
doc/emacs/ack.texi | 2 +-
|
||||
doc/emacs/misc.texi | 7 +------
|
||||
lisp/menu-bar.el | 6 ------
|
||||
test/src/doc-tests.el | 4 ++--
|
||||
4 files changed, 4 insertions(+), 15 deletions(-)
|
||||
|
||||
diff --git a/doc/emacs/ack.texi b/doc/emacs/ack.texi
|
||||
index 5ec5cd53fa6..26f174831ca 100644
|
||||
--- a/doc/emacs/ack.texi
|
||||
+++ b/doc/emacs/ack.texi
|
||||
@@ -228,7 +228,7 @@ Acknowledgments
|
||||
|
||||
@item
|
||||
Glynn Clements provided @file{gamegrid.el} and a couple of games that
|
||||
-use it, Snake and Tetris.
|
||||
+use it, including Snake.
|
||||
|
||||
@item
|
||||
Andrew Cohen wrote @file{spam-wash.el}, to decode and clean email before
|
||||
diff --git a/doc/emacs/misc.texi b/doc/emacs/misc.texi
|
||||
index 41e37fd094e..38e281bf59c 100644
|
||||
--- a/doc/emacs/misc.texi
|
||||
+++ b/doc/emacs/misc.texi
|
||||
@@ -3248,14 +3248,9 @@ Amusements
|
||||
nato-region} converts the text in the region to NATO phonetic
|
||||
alphabet; @kbd{M-x denato-region} converts it back.
|
||||
|
||||
-@findex pong
|
||||
-@cindex Pong game
|
||||
-@findex tetris
|
||||
-@cindex Tetris
|
||||
@findex snake
|
||||
@cindex Snake
|
||||
- @kbd{M-x pong}, @kbd{M-x snake} and @kbd{M-x tetris} are
|
||||
-implementations of the well-known Pong, Snake and Tetris games.
|
||||
+ @kbd{M-x snake} is an implementation of the well-known Snake game.
|
||||
|
||||
@findex solitaire
|
||||
@cindex solitaire
|
||||
diff --git a/lisp/menu-bar.el b/lisp/menu-bar.el
|
||||
index bcfa83cf8e4..1b0a0bce6a5 100644
|
||||
--- a/lisp/menu-bar.el
|
||||
+++ b/lisp/menu-bar.el
|
||||
@@ -1658,18 +1658,12 @@ menu-bar-games-menu
|
||||
(bindings--define-key menu [zone]
|
||||
'(menu-item "Zone Out" zone
|
||||
:help "Play tricks with Emacs display when Emacs is idle"))
|
||||
- (bindings--define-key menu [tetris]
|
||||
- '(menu-item "Tetris" tetris
|
||||
- :help "Falling blocks game"))
|
||||
(bindings--define-key menu [solitaire]
|
||||
'(menu-item "Solitaire" solitaire
|
||||
:help "Get rid of all the stones"))
|
||||
(bindings--define-key menu [snake]
|
||||
'(menu-item "Snake" snake
|
||||
:help "Move snake around avoiding collisions"))
|
||||
- (bindings--define-key menu [pong]
|
||||
- '(menu-item "Pong" pong
|
||||
- :help "Bounce the ball to your opponent"))
|
||||
(bindings--define-key menu [mult]
|
||||
'(menu-item "Multiplication Puzzle" mpuz
|
||||
:help "Exercise brain with multiplication"))
|
||||
diff --git a/test/src/doc-tests.el b/test/src/doc-tests.el
|
||||
index b41a7ac5fb6..24befb737bc 100644
|
||||
--- a/test/src/doc-tests.el
|
||||
+++ b/test/src/doc-tests.el
|
||||
@@ -34,8 +34,8 @@ doc-tests-documentation/autoloaded-macro
|
||||
|
||||
(ert-deftest doc-tests-documentation/autoloaded-defun ()
|
||||
(skip-unless noninteractive)
|
||||
- (should (autoloadp (symbol-function 'tetris)))
|
||||
- (should (stringp (documentation 'tetris)))) ; See Bug#52969.
|
||||
+ (should (autoloadp (symbol-function 'doctor)))
|
||||
+ (should (stringp (documentation 'doctor)))) ; See Bug#52969.
|
||||
|
||||
(ert-deftest doc-tests-quoting-style ()
|
||||
(should (memq (text-quoting-style) '(grave straight curve))))
|
||||
--
|
||||
2.46.1
|
||||
|
44
emacs.spec
44
emacs.spec
@ -3,11 +3,9 @@
|
||||
%bcond gpm %[!(0%{?rhel} >= 10)]
|
||||
%bcond webkit %[!(0%{?rhel} >= 10)]
|
||||
|
||||
%ifnarch riscv64
|
||||
%bcond_without gtkx11
|
||||
%bcond_without lucid
|
||||
%bcond_without nw
|
||||
%endif
|
||||
%bcond_with gtkx11
|
||||
%bcond_with lucid
|
||||
%bcond_with nw
|
||||
|
||||
Summary: GNU Emacs text editor
|
||||
Name: emacs
|
||||
@ -28,6 +26,9 @@ Source7: emacs-terminal.desktop
|
||||
Source8: emacs-terminal.sh
|
||||
Source9: emacs-desktop.sh
|
||||
|
||||
# Avoid trademark issues
|
||||
Patch: 0001-Pong-and-Tetris-are-excluded.patch
|
||||
|
||||
# rhbz#713600
|
||||
Patch: emacs-spellchecker.patch
|
||||
|
||||
@ -106,10 +107,6 @@ BuildRequires: zlib-devel
|
||||
BuildRequires: gpm-devel
|
||||
%endif
|
||||
|
||||
%if %{with webkit}
|
||||
BuildRequires: webkit2gtk4.1-devel
|
||||
%endif
|
||||
|
||||
%if %{with lucid} || %{with gtkx11}
|
||||
BuildRequires: libX11-devel
|
||||
BuildRequires: libXau-devel
|
||||
@ -246,14 +243,13 @@ Obsoletes: emacs-transient < 0.3.0-4
|
||||
|
||||
# https://github.com/tree-sitter/tree-sitter/issues/3296
|
||||
Requires: libtree-sitter >= 0.22.5
|
||||
Requires: libtree-sitter < 0.23
|
||||
|
||||
# Ideally, we'd package all tree-sitter parsers as RPMs, but, in the
|
||||
# meantime, we need the following packages for
|
||||
# treesit-install-language-grammar to be able to build the parsers for
|
||||
# us at runtime:
|
||||
Recommends: ((gcc and gcc-c++) or clang)
|
||||
Recommends: git
|
||||
Recommends: /usr/bin/git
|
||||
|
||||
Recommends: libtree-sitter-java
|
||||
|
||||
@ -288,18 +284,14 @@ Development header files for Emacs.
|
||||
cat '%{SOURCE2}' '%{SOURCE3}' > keyring
|
||||
%{gpgverify} --keyring=keyring --signature='%{SOURCE1}' --data='%{SOURCE0}'
|
||||
rm keyring
|
||||
|
||||
%autosetup -p1
|
||||
|
||||
autoconf
|
||||
|
||||
# Avoid trademark issues
|
||||
grep -v "tetris.elc" lisp/Makefile.in > lisp/Makefile.in.new \
|
||||
&& mv lisp/Makefile.in.new lisp/Makefile.in
|
||||
grep -v "pong.elc" lisp/Makefile.in > lisp/Makefile.in.new \
|
||||
&& mv lisp/Makefile.in.new lisp/Makefile.in
|
||||
rm -f lisp/play/tetris.el lisp/play/tetris.elc
|
||||
rm -f lisp/play/pong.el lisp/play/pong.elc
|
||||
sed -i "s/'tetris/'doctor/" test/src/doc-tests.el
|
||||
rm lisp/play/pong.el lisp/play/pong.elc \
|
||||
lisp/play/tetris.el lisp/play/tetris.elc
|
||||
|
||||
autoconf
|
||||
|
||||
%ifarch %{ix86}
|
||||
%define setarch setarch %{_arch} -R
|
||||
@ -321,8 +313,6 @@ export CFLAGS="-DMAIL_USE_LOCKF %{build_cflags}"
|
||||
mkdir build-lucid && cd build-lucid
|
||||
ln -s ../configure .
|
||||
|
||||
LDFLAGS=-Wl,-z,relro; export LDFLAGS;
|
||||
|
||||
%configure --with-cairo \
|
||||
--with-dbus \
|
||||
--with-gif \
|
||||
@ -372,8 +362,6 @@ cd ..
|
||||
mkdir build-gtk+x11 && cd build-gtk+x11
|
||||
ln -s ../configure .
|
||||
|
||||
LDFLAGS=-Wl,-z,relro; export LDFLAGS;
|
||||
|
||||
%configure --with-cairo \
|
||||
--with-dbus \
|
||||
--with-gif \
|
||||
@ -391,8 +379,7 @@ LDFLAGS=-Wl,-z,relro; export LDFLAGS;
|
||||
--with-webp \
|
||||
--with-x-toolkit=gtk3 \
|
||||
--with-xinput2 \
|
||||
--with-xpm \
|
||||
%{?with_webkit:--with-xwidgets}
|
||||
--with-xpm
|
||||
%{setarch} %make_build bootstrap
|
||||
%{setarch} %make_build
|
||||
rm src/emacs-%{version}.*
|
||||
@ -403,8 +390,6 @@ cd ..
|
||||
mkdir build-pgtk && cd build-pgtk
|
||||
ln -s ../configure .
|
||||
|
||||
LDFLAGS=-Wl,-z,relro; export LDFLAGS;
|
||||
|
||||
%configure --with-cairo \
|
||||
--with-dbus \
|
||||
--with-gif \
|
||||
@ -421,8 +406,7 @@ LDFLAGS=-Wl,-z,relro; export LDFLAGS;
|
||||
--with-tiff \
|
||||
--with-tree-sitter \
|
||||
--with-webp \
|
||||
--with-xpm \
|
||||
%{?with_webkit:--with-xwidgets}
|
||||
--with-xpm
|
||||
%{setarch} %make_build bootstrap
|
||||
%{setarch} %make_build
|
||||
rm src/emacs-%{version}.*
|
||||
|
Loading…
Reference in New Issue
Block a user