This commit is contained in:
Daniel Novotny 2009-08-31 09:59:41 +00:00
parent 0d8532b4f8
commit 8cf96151bd
2 changed files with 47 additions and 3 deletions

41
emacs-gtk.patch Normal file
View File

@ -0,0 +1,41 @@
--- emacs-23.1/configure.in.orig 2009-08-31 00:18:44.000000000 +0100
+++ emacs-23.1/configure.in 2009-08-31 00:18:47.000000000 +0100
@@ -1514,7 +1514,7 @@
HAVE_GTK=no
if test "${with_gtk}" = "yes" || test "$USE_X_TOOLKIT" = "maybe"; then
GLIB_REQUIRED=2.6
- GTK_REQUIRED=2.6
+ GTK_REQUIRED=2.17.9
GTK_MODULES="gtk+-2.0 >= $GTK_REQUIRED glib-2.0 >= $GLIB_REQUIRED"
dnl Checks for libraries.
--- emacs-23.1/src/xfns.c.orig 2009-08-31 00:03:02.000000000 +0100
+++ emacs-23.1/src/xfns.c 2009-08-31 00:21:39.000000000 +0100
@@ -468,8 +468,10 @@
if (!FRAME_X_P (f) || FRAME_X_DISPLAY_INFO (f) != dpyinfo)
continue;
x = f->output_data.x;
- /* Match if the window is this frame's menubar. */
#ifdef USE_GTK
+ /* Match if the window is this frame's window (button presses are no longer
+ caught by the menubar) or a menu in the menubar.
+ */
if (x->menubar_widget)
{
GtkWidget *gwdesc = xg_win_to_widget (dpyinfo->display, wdesc);
@@ -477,13 +479,14 @@
BLOCK_INPUT;
if (gwdesc != 0
- && (gwdesc == x->menubar_widget
+ && (gwdesc == gtk_widget_get_parent (gtk_widget_get_parent (x->menubar_widget))
|| gtk_widget_get_parent (gwdesc) == x->menubar_widget))
found = 1;
UNBLOCK_INPUT;
if (found) return f;
}
#else
+ /* Match if the window is in this frame's menubar */
if (x->menubar_widget
&& lw_window_is_in_menubar (wdesc, x->menubar_widget))
return f;

View File

@ -4,7 +4,7 @@ Summary: GNU Emacs text editor
Name: emacs
Epoch: 1
Version: 23.1
Release: 5%{?dist}
Release: 6%{?dist}
License: GPLv3+
URL: http://www.gnu.org/software/emacs/
Group: Applications/Editors
@ -26,7 +26,7 @@ Patch0: glibc-open-macro.patch
Patch1: rpm-spec-mode.patch
Patch2: po-mode-auto-replace-date-71264.patch
Patch3: rpm-spec-mode-utc.patch
#Patch4: emacsclient.patch
Patch4: emacs-gtk.patch
Buildroot: %{_tmppath}/%{name}-%{version}-root
BuildRequires: atk-devel, cairo-devel, desktop-file-utils, freetype-devel, fontconfig-devel, dbus-devel, giflib-devel, glibc-devel, gtk2-devel, libpng-devel
BuildRequires: libjpeg-devel, libtiff-devel, libX11-devel, libXau-devel, libXdmcp-devel, libXrender-devel, libXt-devel
@ -115,7 +115,7 @@ Emacs packages or see some elisp examples.
%prep
%setup -q
%patch0 -p1 -b .glibc-open-macro
#%%patch4 -p1
%patch4 -p1 -b .gtk
# install rest of site-lisp files
( cd site-lisp
@ -370,6 +370,9 @@ alternatives --install %{_bindir}/etags emacs.etags %{_bindir}/etags.emacs 80 \
%dir %{_datadir}/emacs/%{version}
%changelog
* Mon Aug 31 2009 Daniel Novotny <dnovotny@redhat.com> 1:23.1-6
- fixed buffer menu (#515722)
* Wed Aug 26 2009 Daniel Novotny <dnovotny@redhat.com> 1:23.1-5
- correct BuildRequires for libotf (#519151)