new upstream version 24.3

This commit is contained in:
Petr Hracek 2013-07-22 11:19:14 +02:00
commit 29fd17692e
10 changed files with 90 additions and 121 deletions

1
.gitignore vendored
View File

@ -8,3 +8,4 @@
/emacs-24.1-rc.tar.gz
/emacs-24.1.tar.bz2
/emacs-24.2.tar.xz
/emacs-24.3.tar.xz

View File

@ -0,0 +1,13 @@
diff --git a/lisp/textmodes/ispell.el b/lisp/textmodes/ispell.el
index 7167dc9..c8f2cd7 100644
--- a/lisp/textmodes/ispell.el
+++ b/lisp/textmodes/ispell.el
@@ -1177,7 +1177,7 @@ aspell is used along with Emacs).")
;; Unless default dict, re-add "-d" option with the mapped value
(if dict-name
(if dict-equiv
- (nconc ispell-args (list "-d" dict-equiv))
+ (setq ispell-args (nconc ispell-args (list "-d" dict-equiv)))
(message
"ispell-set-spellchecker-params: Missing hunspell equiv for \"%s\". Skipping."
dict-name)

View File

@ -1,7 +1,8 @@
diff -up emacs-24.2/lisp/textmodes/ispell.el.hunspell emacs-24.2/lisp/textmodes/ispell.el
--- emacs-24.2/lisp/textmodes/ispell.el.hunspell 2013-01-21 18:45:01.743335126 +0100
+++ emacs-24.2/lisp/textmodes/ispell.el 2013-01-21 18:51:02.082010837 +0100
@@ -572,6 +572,40 @@ re-start Emacs."
diff --git a/lisp/textmodes/ispell.el b/lisp/textmodes/ispell.el
index 1daec44..7167dc9 100644
--- a/lisp/textmodes/ispell.el
+++ b/lisp/textmodes/ispell.el
@@ -574,6 +574,40 @@ re-start Emacs."
(coding-system :tag "Coding System")))
:group 'ispell)
@ -41,8 +42,8 @@ diff -up emacs-24.2/lisp/textmodes/ispell.el.hunspell emacs-24.2/lisp/textmodes/
+ `ispell-dictionary-base-alist'.")
(defvar ispell-dictionary-base-alist
'((nil
@@ -1106,9 +1140,57 @@ aspell is used along with Emacs).")
'((nil ; default
@@ -1112,9 +1146,57 @@ aspell is used along with Emacs).")
ispell-encoding8-command)
ispell-aspell-dictionary-alist
nil))

View File

@ -1,8 +1,8 @@
diff --git a/configure.in b/configure.in
index 2b0b2f7..68459bc 100644
--- a/configure.in
+++ b/configure.in
@@ -1843,6 +1843,7 @@ if test "${HAVE_X11}" = "yes"; then
diff --git a/configure.ac b/configure.ac
index 62f53a3..a6f2f04 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1874,6 +1874,7 @@ if test "${HAVE_X11}" = "yes"; then
AC_MSG_RESULT($emacs_xkb)
if test $emacs_xkb = yes; then
AC_DEFINE(HAVE_XKBGETKEYBOARD, 1, [Define to 1 if you have the XkbGetKeyboard function.])
@ -11,12 +11,12 @@ index 2b0b2f7..68459bc 100644
AC_CHECK_FUNCS(XrmSetDatabase XScreenResourceString \
diff --git a/src/xterm.c b/src/xterm.c
index 9ce1668..67ad919 100644
index fb407c8..f47141d 100644
--- a/src/xterm.c
+++ b/src/xterm.c
@@ -139,6 +139,10 @@ extern void _XEditResCheckMessages (Widget, XtPointer, XEvent *, Boolean *);
#endif
#endif
@@ -130,6 +130,10 @@ extern void _XEditResCheckMessages (Widget, XtPointer, XEvent *, Boolean *);
#include "bitmaps/gray.xbm"
+#ifdef HAVE_XKB
+#include <X11/XKBlib.h>
@ -25,15 +25,15 @@ index 9ce1668..67ad919 100644
/* Default to using XIM if available. */
#ifdef USE_XIM
int use_xim = 1;
@@ -3238,7 +3242,11 @@ XTring_bell (struct frame *f)
#endif
@@ -3243,7 +3247,11 @@ XTring_bell (struct frame *f)
else
{
BLOCK_INPUT;
block_input ();
+#ifdef HAVE_XKB
+ XkbBell (FRAME_X_DISPLAY (f), None, 0, None);
+ XkbBell (FRAME_X_DISPLAY (f), None, 0, None);
+#else
XBell (FRAME_X_DISPLAY (f), 0);
+#endif
XFlush (FRAME_X_DISPLAY (f));
UNBLOCK_INPUT;
unblock_input ();
}

View File

@ -1,47 +0,0 @@
From: Sergio Durigan Junior <sergiodj@riseup.net>
Date: Tue, 02 Oct 2012 05:10:16 +0000
Subject: Bugfix for EUDCB-BBDB queries.
* net/eudcb-bbdb.el (eudc-bbdb-format-record-as-result): Fix
querying BBDB for entries without a last name.
2012-10-02 Sergio Durigan Junior <sergiodj@riseup.net>
* net/eudcb-bbdb.el (eudc-bbdb-format-record-as-result): Fix
querying BBDB for entries without a last name (Bug#11580).
Index: emacs-23.3/lisp/net/eudcb-bbdb.el
===================================================================
--- emacs-23.3.orig/lisp/net/eudcb-bbdb.el
+++ emacs-23.3/lisp/net/eudcb-bbdb.el
@@ -169,18 +169,18 @@ The record is filtered according to `eud
(symbol-name attr)))
'record))))
(t
- (setq val "Unknown BBDB attribute")))
- (if val
- (cond
- ((memq attr '(phones addresses))
- (setq eudc-rec (append val eudc-rec)))
- ((and (listp val)
- (= 1 (length val)))
- (setq eudc-rec (cons (cons attr (car val)) eudc-rec)))
- ((> (length val) 0)
- (setq eudc-rec (cons (cons attr val) eudc-rec)))
- (t
- (error "Unexpected attribute value")))))
+ (error "Unknown BBDB attribute")))
+ (cond
+ ((or (not val) (equal val ""))) ; do nothing
+ ((memq attr '(phones addresses))
+ (setq eudc-rec (append val eudc-rec)))
+ ((and (listp val)
+ (= 1 (length val)))
+ (setq eudc-rec (cons (cons attr (car val)) eudc-rec)))
+ ((> (length val) 0)
+ (setq eudc-rec (cons (cons attr val) eudc-rec)))
+ (t
+ (error "Unexpected attribute value"))))
(nreverse eudc-rec)))

View File

@ -1,12 +0,0 @@
diff -up emacs-24.1/lisp/org/org-exp-blocks.el.locate-library emacs-24.1/lisp/org/org-exp-blocks.el
--- emacs-24.1/lisp/org/org-exp-blocks.el.locate-library 2012-07-11 17:11:42.053056590 +0200
+++ emacs-24.1/lisp/org/org-exp-blocks.el 2012-07-11 17:11:47.716973793 +0200
@@ -240,7 +240,7 @@ which defaults to the value of `org-expo
(file-name-as-directory
(expand-file-name
"../contrib"
- (file-name-directory (find-library-name "org")))))))
+ (file-name-directory (locate-library "org")))))))
"Path to the ditaa jar executable."
:group 'org-babel
:type 'string)

View File

@ -1,15 +1,16 @@
qdiff -up emacs-23.3/lisp/textmodes/ispell.el.spellcheck emacs-23.3/lisp/textmodes/ispell.el
--- emacs-23.3/lisp/textmodes/ispell.el.spellcheck 2011-11-16 10:54:57.363513864 +0100
+++ emacs-23.3/lisp/textmodes/ispell.el 2011-11-16 10:55:17.209577635 +0100
@@ -348,9 +348,9 @@ Must be greater than 1."
diff --git a/lisp/textmodes/ispell.el b/lisp/textmodes/ispell.el
index 1d28de7..1daec44 100644
--- a/lisp/textmodes/ispell.el
+++ b/lisp/textmodes/ispell.el
@@ -351,9 +351,9 @@ Must be greater than 1."
:group 'ispell)
(defcustom ispell-program-name
- (or (locate-file "aspell" exec-path exec-suffixes 'file-executable-p)
+ (or (locate-file "hunspell" exec-path exec-suffixes 'file-executable-p)
+ (locate-file "aspell" exec-path exec-suffixes 'file-executable-p)
(locate-file "ispell" exec-path exec-suffixes 'file-executable-p)
- (locate-file "hunspell" exec-path exec-suffixes 'file-executable-p)
- (or (executable-find "aspell")
+ (or (executable-find "hunspell")
+ (executable-find "aspell")
(executable-find "ispell")
- (executable-find "hunspell")
"ispell")
"Program invoked by \\[ispell-word] and \\[ispell-region] commands."
:type 'string

View File

@ -1,8 +1,8 @@
diff --git a/src/gtkutil.c b/src/gtkutil.c
index 4dbef65..44f828c 100644
index e76b0a7..b3aa335 100644
--- a/src/gtkutil.c
+++ b/src/gtkutil.c
@@ -1050,7 +1050,9 @@ style_changed_cb (GObject *go,
@@ -1079,7 +1079,9 @@ style_changed_cb (GObject *go,
FOR_EACH_FRAME (rest, frame)
{
FRAME_PTR f = XFRAME (frame);

View File

@ -2,8 +2,8 @@
Summary: GNU Emacs text editor
Name: emacs
Epoch: 1
Version: 24.2
Release: 20%{?dist}
Version: 24.3
Release: 9%{?dist}
License: GPLv3+
URL: http://www.gnu.org/software/emacs/
Group: Applications/Editors
@ -19,21 +19,21 @@ Source7: emacs-terminal.sh
# rhbz#713600
Patch7: emacs-spellchecker.patch
# rhbz#830162, fixed in org-mode upstream
Patch8: emacs-locate-library.patch
#Patch8: emacs-locate-library.patch
# Fix for Emacs bug #111500.
Patch9: emacs-bz11580-eudc-bbdb.patch
#Patch9: emacs-bz11580-eudc-bbdb.patch
# Fix for emacs bug #922519
Patch10: emacs-style-change-cb.patch
# Fix for emacs bug #922519
# Fix for emacs bug #562719
Patch11: emacs-bell-dont-work.patch
# Fix for emacs bug #929353
Patch12: emacs-gtk-warning.patch
# Fix for emacs bug #948838
Patch13: emacs-help-update.patch
# Fix for emacs bug #13460.
Patch100: emacs-24.2-hunspell.patch
# Fix for emacs bug #827033.
Patch101: emacs-24.2-hunspell.2.patch
Patch100: emacs-24.3-hunspell.patch
# Fix for emacs bug #827033
Patch101: emacs-24.3-hunspell.2.patch
BuildRequires: atk-devel cairo-devel freetype-devel fontconfig-devel dbus-devel giflib-devel glibc-devel libpng-devel
BuildRequires: libjpeg-devel libtiff-devel libX11-devel libXau-devel libXdmcp-devel libXrender-devel libXt-devel
@ -52,6 +52,7 @@ BuildRequires: gtk3-devel python2-devel
BuildRequires: gtk3-devel python2-devel python3-devel
%endif
%endif
%ifarch %{ix86}
BuildRequires: util-linux
%endif
@ -167,8 +168,6 @@ packages that add functionality to Emacs.
%setup -q
%patch7 -p1 -b .spellchecker
%patch8 -p1 -b .locate-library
%patch9 -p1 -b .emacs-bz11580-eudc-bbdb
%patch10 -p1 -b .style-change-cb.patch
%patch11 -p1 -b .bell-dont-work.patch
@ -193,12 +192,15 @@ rm -f lisp/play/tetris.el lisp/play/tetris.elc
rm -f etc/sex.6 etc/condom.1 etc/celibacy.1 etc/COOKIES etc/future-bug etc/JOKES
%endif
%define info_files ada-mode auth autotype calc ccmode cl dbus dired-x ebrowse ede ediff edt eieio efaq eintr elisp emacs emacs-gnutls emacs-mime epa erc ert eshell eudc flymake forms gnus idlwave info mairix-el message mh-e newsticker nxml-mode org pcl-cvs pgg rcirc reftex remember sasl sc semantic ses sieve smtpmail speedbar tramp url vip viper widget woman
%define info_files ada-mode auth autotype bovine calc ccmode cl dbus dired-x ebrowse ede ediff edt efaq eieio eintr elisp emacs-gnutls emacs-mime emacs epa erc ert eshell eudc flymake forms gnus htmlfontify idlwave info mairix-el message mh-e newsticker nxml-mode org pcl-cvs pgg rcirc reftex remember sasl sc semantic ses sieve smtpmail speedbar srecode tramp url vip viper widget wisent woman
if test "$(perl -e 'while (<>) { if (/^INFO_FILES/) { s/.*=//; while (s/\\$//) { s/\\//; $_ .= <>; }; s/\s+/ /g; s/^ //; s/ $//; print; exit; } }' Makefile.in)" != "%info_files"; then
cd info
files=`echo $(ls *.info) | sed 's/\.info//'g | sort | tr -d '\n'`
if test "$files" != "%info_files"; then
echo Please update info_files >&2
exit 1
fi
cd ..
%ifarch %{ix86}
%define setarch setarch %{_arch} -R
@ -230,8 +232,7 @@ ln -s ../configure .
%endif
%configure --with-dbus --with-gif --with-jpeg --with-png --with-rsvg \
--with-tiff --with-xft --with-xpm --with-x-toolkit=%{toolkit} --with-gpm=no \
--with-wide-int
--with-tiff --with-xft --with-xpm --with-x-toolkit=%{toolkit} --with-gpm=no
make bootstrap
%{setarch} make %{?_smp_mflags}
cd ..
@ -298,6 +299,8 @@ mv %{buildroot}%{_bindir}/{etags,etags.emacs}
mv %{buildroot}%{_mandir}/man1/{ctags.1.gz,gctags.1.gz}
mv %{buildroot}%{_mandir}/man1/{etags.1.gz,etags.emacs.1.gz}
mv %{buildroot}%{_bindir}/{ctags,gctags}
# BZ 927996
mv %{buildroot}%{_infodir}/{info.info.gz,info.gz}
mkdir -p %{buildroot}%{site_lisp}/site-start.d
@ -413,7 +416,7 @@ update-desktop-database &> /dev/null || :
%{_datadir}/applications/emacs.desktop
%{_datadir}/applications/emacsclient.desktop
%{_datadir}/icons/hicolor/*/apps/emacs.png
%{_datadir}/icons/hicolor/*/apps/emacs22.png
#%{_datadir}/icons/hicolor/*/apps/emacs22.png
%{_datadir}/icons/hicolor/scalable/apps/emacs.svg
%{_datadir}/icons/hicolor/scalable/mimetypes/emacs-document.svg
@ -430,7 +433,7 @@ update-desktop-database &> /dev/null || :
%{_bindir}/etags.emacs
%{_bindir}/gctags
%{_bindir}/grep-changelog
%{_bindir}/rcs-checkin
#%{_bindir}/rcs-checkin
%{_mandir}/*/*
%{_infodir}/*
%dir %{_datadir}/emacs/%{version}
@ -455,30 +458,39 @@ update-desktop-database &> /dev/null || :
%dir %{_datadir}/emacs/site-lisp/site-start.d
%changelog
* Mon Jul 15 2013 Petr Hracek <phracek@redhat.com> - 1:24.2-20
- Bump the version (#981135) to 20
* Tue Apr 09 2013 Petr Hracek <phracek@redhat.com> - 1:24.3-9
- Help and man page corrections (#948838)
* Wed Apr 10 2013 Petr Hracek <phracek@redhat.com> - 1:24.2-18
- Help and manpage corrections (#948838)
* Tue Apr 09 2013 Petr Hracek <phracek@redhat.com> - 1:24.3-8
- Rebuild with new file package
* Mon Apr 08 2013 Petr Hracek <phracek@redhat.com> - 1:24.2-17
* Mon Apr 08 2013 Petr Hracek <phracek@redhat.com> - 1:24.3-7
- Spell checking broken by non-default dictionary (#827033)
* Thu Apr 04 2013 Petr Hracek <phracek@redhat.com> - 1:24.2-16
- Fix #929353: emacs gives gtk-warning
* Thu Apr 04 2013 Petr Hracek <phracek@redhat.com> - 1:24.3-6
- Rebuild with new ImageMagick
* Thu Mar 28 2013 Petr Hracek <phracek@redhat.com> - 1:24.2-15
* Thu Apr 04 2013 Petr Hracek <phracek@redhat.com> - 1:24.3-5
- Fix for Gtk-Warning (#929353)
* Wed Apr 03 2013 Petr Hracek <phracek@redhat.com> - 1:24.3-4
- Fix for info page. info.info.gz page was renamed to info.gz (#927996)
* Thu Mar 28 2013 Petr Hracek <phracek@redhat.com> - 1:24.3-3
- Fix for emacs bug 112144, style_changed_cb (#922519)
- Fix for emacs bug 112131, bell does not work (#526719)
- Fix for emacs bug 112131, bell does not work (#562719)
* Tue Mar 26 2013 Petr Hracek <phracek@redhat.com> - 1:24.2-14
- fixing distribution flags to rhel instead of el6:1
* Mon Mar 18 2013 Petr Hracek <phracek@redhat.com> - 1:24.3-2
- fix #927996 correcting bug. Info pages were not delivered
* Mon Mar 18 2013 Petr Hracek <phracek@redhat.com> - 1:24.2-13
* Mon Mar 18 2013 Petr Hracek <phracek@redhat.com> - 1:24.3-1
- Updated to the newest upstream release
- solved problem with distribution flag in case of rhel
- rcs-checking not availble anymore
- emacs22.png are not installed anymore
* Mon Mar 18 2013 Petr Hracek <phracek@redhat.com> - 1:24.2-12
- solved problem with distribution flag in case of rhel
* Mon Mar 18 2013 Rex Dieter <rdieter@fedoraproject.org> 1:24.2-12
- rebuild (ImageMagick)
* Fri Mar 08 2013 Ralf Corsépius <corsepiu@fedoraproject.org> - 1:24.2-11
- Remove %%config from %%{_sysconfdir}/rpm/macros.*

View File

@ -1 +1 @@
066f712b82f77c3c3c803e98bff2318b emacs-24.2.tar.xz
ea9ed000ca165280265aabb55b9afbd7 emacs-24.3.tar.xz