628963a739
drop obsolete openblas patch re-enable OpenMPI OpenMP builds enable papi on supported arches build and ship non-MPI version (without _onenode suffix) provide a man-link for openmp version of elpa2_print_kernels execstack is now available everywhere include and verify GPG signature conditionalize running tests and disable by default as they take too long
20 lines
713 B
Diff
20 lines
713 B
Diff
diff -up mpich/configure.ac.papi mpich/configure.ac
|
|
--- mpich/configure.ac.papi 2017-09-01 08:54:37.000000000 +0200
|
|
+++ mpich/configure.ac 2017-10-18 00:25:55.531438089 +0200
|
|
@@ -188,6 +188,7 @@ fi
|
|
AM_CONDITIONAL([HAVE_DETAILED_TIMINGS], [test x"$enable_timings" = x"yes"])
|
|
|
|
dnl PAPI for ftimings
|
|
+AC_LANG_PUSH([C])
|
|
AC_ARG_WITH([papi],
|
|
[AS_HELP_STRING([--with-papi],
|
|
[Use PAPI to also measure flop count in the detailed timing (--enable-timing), disabled by default])],
|
|
@@ -202,6 +203,7 @@ if test x"${enable_timings}" = x"yes"; t
|
|
AC_DEFINE([HAVE_LIBPAPI], [1], [Use the PAPI library])
|
|
fi
|
|
fi
|
|
+AC_LANG_POP([C])
|
|
|
|
save_FCFLAGS=$FCFLAGS
|
|
save_LDFLAGS=$LDFLAGS
|