fix build on epel-6-i386
Don't try to compile AVX intrinsics if SSE compilation failed.
This commit is contained in:
parent
cdfc38ca53
commit
81a8f43742
@ -1,6 +1,6 @@
|
|||||||
diff -up mpich/configure.ac.avx mpich/configure.ac
|
diff -up mpich/configure.ac.avx mpich/configure.ac
|
||||||
--- mpich/configure.ac.avx 2015-03-20 15:26:06.535080683 +0100
|
--- mpich/configure.ac.avx 2015-05-05 11:06:33.132304515 +0200
|
||||||
+++ mpich/configure.ac 2015-03-20 15:26:06.536080688 +0100
|
+++ mpich/configure.ac 2015-05-05 11:06:33.137304689 +0200
|
||||||
@@ -213,6 +213,11 @@ dnl first test failed: try again after u
|
@@ -213,6 +213,11 @@ dnl first test failed: try again after u
|
||||||
[can_compile_avx=yes],
|
[can_compile_avx=yes],
|
||||||
[can_compile_avx=no]
|
[can_compile_avx=no]
|
||||||
@ -22,9 +22,9 @@ diff -up mpich/configure.ac.avx mpich/configure.ac
|
|||||||
rm -rf modules/ .fortran_dependencies/
|
rm -rf modules/ .fortran_dependencies/
|
||||||
mkdir modules
|
mkdir modules
|
||||||
diff -up mpich/configure.avx mpich/configure
|
diff -up mpich/configure.avx mpich/configure
|
||||||
--- mpich/configure.avx 2015-03-18 10:49:42.000000000 +0100
|
--- mpich/configure.avx 2015-05-05 11:06:33.136304654 +0200
|
||||||
+++ mpich/configure 2015-05-04 12:03:18.861651356 +0200
|
+++ mpich/configure 2015-05-05 11:20:57.544768442 +0200
|
||||||
@@ -638,6 +638,7 @@
|
@@ -638,6 +638,7 @@ LTLIBOBJS
|
||||||
LIBOBJS
|
LIBOBJS
|
||||||
PKG_CONFIG_FILE
|
PKG_CONFIG_FILE
|
||||||
SUFFIX
|
SUFFIX
|
||||||
@ -32,7 +32,24 @@ diff -up mpich/configure.avx mpich/configure
|
|||||||
OPENMP_LDFLAGS
|
OPENMP_LDFLAGS
|
||||||
OPENMP_CFLAGS
|
OPENMP_CFLAGS
|
||||||
with_amd_bulldozer_kernel
|
with_amd_bulldozer_kernel
|
||||||
@@ -6076,6 +5965,11 @@
|
@@ -6049,14 +6050,14 @@ $as_echo_n "checking whether we can comp
|
||||||
|
}
|
||||||
|
|
||||||
|
_ACEOF
|
||||||
|
-if ac_fn_c_try_compile "$LINENO"; then :
|
||||||
|
+if test x"${can_compile_sse}" = x"yes" && ac_fn_c_try_compile "$LINENO" ; then
|
||||||
|
can_compile_avx=yes
|
||||||
|
else
|
||||||
|
can_compile_avx=no
|
||||||
|
|
||||||
|
fi
|
||||||
|
rm -f core conftest.err conftest.$ac_objext conftest.$ac_ext
|
||||||
|
- if test x"${can_compile_avx}" = x"no"; then
|
||||||
|
+ if test x"${can_compile_sse}" = x"yes" && test x"${can_compile_avx}" = x"no"; then
|
||||||
|
CFLAGS="$CFLAGS -mavx"
|
||||||
|
CXXFLAGS="$CXXFLAGS -mavx"
|
||||||
|
cat confdefs.h - <<_ACEOF >conftest.$ac_ext
|
||||||
|
@@ -6076,6 +6077,11 @@ else
|
||||||
|
|
||||||
fi
|
fi
|
||||||
rm -f core conftest.err conftest.$ac_objext conftest.$ac_ext
|
rm -f core conftest.err conftest.$ac_objext conftest.$ac_ext
|
||||||
@ -45,8 +62,8 @@ diff -up mpich/configure.avx mpich/configure
|
|||||||
{ $as_echo "$as_me:${as_lineno-$LINENO}: result: ${can_compile_avx}" >&5
|
{ $as_echo "$as_me:${as_lineno-$LINENO}: result: ${can_compile_avx}" >&5
|
||||||
$as_echo "${can_compile_avx}" >&6; }
|
$as_echo "${can_compile_avx}" >&6; }
|
||||||
diff -up mpich/Makefile.am.avx mpich/Makefile.am
|
diff -up mpich/Makefile.am.avx mpich/Makefile.am
|
||||||
--- mpich/Makefile.am.avx 2015-03-20 15:26:06.534080677 +0100
|
--- mpich/Makefile.am.avx 2015-05-05 11:06:33.131304480 +0200
|
||||||
+++ mpich/Makefile.am 2015-03-20 15:31:55.590089898 +0100
|
+++ mpich/Makefile.am 2015-05-05 11:06:33.141304828 +0200
|
||||||
@@ -8,6 +8,8 @@ AM_LDFLAGS = $(SCALAPACK_LDFLAGS)
|
@@ -8,6 +8,8 @@ AM_LDFLAGS = $(SCALAPACK_LDFLAGS)
|
||||||
# libelpa
|
# libelpa
|
||||||
lib_LTLIBRARIES = libelpa@SUFFIX@.la
|
lib_LTLIBRARIES = libelpa@SUFFIX@.la
|
||||||
@ -57,9 +74,9 @@ diff -up mpich/Makefile.am.avx mpich/Makefile.am
|
|||||||
libelpa@SUFFIX@_la_SOURCES = src/elpa_utilities.F90 \
|
libelpa@SUFFIX@_la_SOURCES = src/elpa_utilities.F90 \
|
||||||
src/elpa1.F90 \
|
src/elpa1.F90 \
|
||||||
diff -up mpich/Makefile.in.avx mpich/Makefile.in
|
diff -up mpich/Makefile.in.avx mpich/Makefile.in
|
||||||
--- mpich/Makefile.in.avx 2015-03-18 10:49:43.000000000 +0100
|
--- mpich/Makefile.in.avx 2015-05-05 11:06:33.131304480 +0200
|
||||||
+++ mpich/Makefile.in 2015-05-04 12:03:19.989659664 +0200
|
+++ mpich/Makefile.in 2015-05-05 11:06:33.141304828 +0200
|
||||||
@@ -774,6 +764,7 @@
|
@@ -774,6 +774,7 @@ AR = @AR@
|
||||||
AUTOCONF = @AUTOCONF@
|
AUTOCONF = @AUTOCONF@
|
||||||
AUTOHEADER = @AUTOHEADER@
|
AUTOHEADER = @AUTOHEADER@
|
||||||
AUTOMAKE = @AUTOMAKE@
|
AUTOMAKE = @AUTOMAKE@
|
||||||
@ -67,7 +84,7 @@ diff -up mpich/Makefile.in.avx mpich/Makefile.in
|
|||||||
AWK = @AWK@
|
AWK = @AWK@
|
||||||
CC = @CC@
|
CC = @CC@
|
||||||
CCAS = @CCAS@
|
CCAS = @CCAS@
|
||||||
@@ -918,6 +909,8 @@
|
@@ -918,6 +919,8 @@ AM_LDFLAGS = $(SCALAPACK_LDFLAGS)
|
||||||
# libelpa
|
# libelpa
|
||||||
lib_LTLIBRARIES = libelpa@SUFFIX@.la
|
lib_LTLIBRARIES = libelpa@SUFFIX@.la
|
||||||
libelpa@SUFFIX@_la_LINK = $(FCLINK) $(AM_LDFLAGS) -version-info $(ELPA_SO_VERSION) -lstdc++
|
libelpa@SUFFIX@_la_LINK = $(FCLINK) $(AM_LDFLAGS) -version-info $(ELPA_SO_VERSION) -lstdc++
|
||||||
|
Loading…
Reference in New Issue
Block a user