initial import on f20 branch
This commit is contained in:
parent
61aead22b4
commit
78a085cd54
@ -6,7 +6,7 @@ diff -up mpich/configure.ac.blacs mpich/configure.ac
|
||||
|
||||
dnl first check blas
|
||||
- AC_SEARCH_LIBS([dgemm],[blas],[can_link_with_blas=yes],[can_link_with_blas=no])
|
||||
+ AC_SEARCH_LIBS([dgemm],[satlas blas],[can_link_with_blas=yes],[can_link_with_blas=no])
|
||||
+ AC_SEARCH_LIBS([dgemm],[f77blas blas],[can_link_with_blas=yes],[can_link_with_blas=no],[-lf77blas -latlas])
|
||||
AC_MSG_CHECKING([whether we can link a program with a blas lib])
|
||||
AC_MSG_RESULT([${can_link_with_blas}])
|
||||
|
||||
|
21
elpa-blacs.patch
Normal file
21
elpa-blacs.patch
Normal file
@ -0,0 +1,21 @@
|
||||
diff -up mpich/configure.ac.blacs mpich/configure.ac
|
||||
--- mpich/configure.ac.blacs 2014-03-21 12:10:21.000000001 +0100
|
||||
+++ mpich/configure.ac 2014-06-29 22:47:36.214804126 +0200
|
||||
@@ -291,7 +291,7 @@ else
|
||||
fi
|
||||
|
||||
dnl now blacs
|
||||
- AC_SEARCH_LIBS([blacs_gridinit],[mpiblacs],[can_link_with_blacs=yes],[can_link_with_blacs=no])
|
||||
+ AC_SEARCH_LIBS([blacs_gridinit],[mpiblacs],[can_link_with_blacs=yes],[can_link_with_blacs=no],[-lmpiblacsF77init])
|
||||
AC_MSG_CHECKING([whether we can link a program with a blacs lib])
|
||||
AC_MSG_RESULT([${can_link_with_blacs}])
|
||||
|
||||
@@ -300,7 +300,7 @@ else
|
||||
fi
|
||||
|
||||
dnl now scalapack
|
||||
- AC_SEARCH_LIBS([pdtran],[mpiscalapack],[can_link_with_scalapack=yes],[can_link_with_scalapack=no])
|
||||
+ AC_SEARCH_LIBS([pdtran],[mpiscalapack scalapack],[can_link_with_scalapack=yes],[can_link_with_scalapack=no],[-lmpiblacsF77init])
|
||||
AC_MSG_CHECKING([whether we can link a program with a scalapack lib])
|
||||
AC_MSG_RESULT([${can_link_with_scalapack}])
|
||||
|
@ -1,12 +0,0 @@
|
||||
diff -up mpich/configure.ac.r mpich/configure.ac
|
||||
--- mpich/configure.ac.r 2014-05-19 22:31:26.000000000 +0200
|
||||
+++ mpich/configure.ac 2014-06-07 16:30:09.806374359 +0200
|
||||
@@ -300,7 +300,7 @@ else
|
||||
fi
|
||||
|
||||
dnl now scalapack
|
||||
- AC_SEARCH_LIBS([pdtran],[mpiscalapack],[can_link_with_scalapack=yes],[can_link_with_scalapack=no])
|
||||
+ AC_SEARCH_LIBS([pdtran],[scalapack],[can_link_with_scalapack=yes],[can_link_with_scalapack=no])
|
||||
AC_MSG_CHECKING([whether we can link a program with a scalapack lib])
|
||||
AC_MSG_RESULT([${can_link_with_scalapack}])
|
||||
|
@ -8,8 +8,8 @@ Release: 3.%{rel}%{?dist}
|
||||
URL: http://elpa.rzg.mpg.de/
|
||||
# http://elpa.rzg.mpg.de/elpa-tar-archive/elpa-2013-11.006/at_download/file
|
||||
Source0: ELPA_%{version}.%{rel}_%{snap}.tar.gz
|
||||
# fix scalapack detection on F21+
|
||||
Patch0: elpa-scalapack.patch
|
||||
# fix blacs/scalapack detection on <F21
|
||||
Patch0: elpa-blacs.patch
|
||||
# fix pkgconfig files and linking against mpi libraries
|
||||
Patch1: elpa-rpm.patch
|
||||
# build against atlas instead of reference blas
|
||||
@ -115,7 +115,7 @@ This package contains the development files for ELPA (OpenMPI version).
|
||||
%setup -q -c -T -a 0
|
||||
mv ELPA_%{version} mpich
|
||||
pushd mpich
|
||||
%patch0 -p1 -b .scalapack
|
||||
%patch0 -p1 -b .blacs
|
||||
%patch1 -p1 -b .r
|
||||
%patch2 -p1 -b .atlas
|
||||
autoreconf -vifs
|
||||
@ -126,6 +126,7 @@ cp -pr mpich openmpi _mt/
|
||||
|
||||
%build
|
||||
export LDFLAGS="-L%{_libdir}/atlas"
|
||||
export BLACS_LDFLAGS="-lmpiblacs -lmpiblacsF77init"
|
||||
export FCFLAGS=-ffree-line-length-none
|
||||
|
||||
%{_mpich_load}
|
||||
|
Loading…
Reference in New Issue
Block a user