Elixir ver. 1.6.6
Signed-off-by: Peter Lemenkov <lemenkov@gmail.com>
This commit is contained in:
parent
dc76852130
commit
7f4f1dd2b6
5
.gitignore
vendored
5
.gitignore
vendored
@ -1,4 +1,5 @@
|
||||
*.src.rpm
|
||||
/elixir-lang-elixir-*.tar.gz
|
||||
/elixir-*.tar.gz
|
||||
*~
|
||||
/elixir-*-doc.zip
|
||||
/elixir-*.tar.gz
|
||||
/elixir-lang-elixir-*.tar.gz
|
||||
|
@ -1,65 +0,0 @@
|
||||
--- lib/iex/test/iex/helpers_test.exs.orig 2018-05-07 12:36:01.000000000 +0200
|
||||
+++ lib/iex/test/iex/helpers_test.exs 2018-06-07 10:20:27.196176134 +0200
|
||||
@@ -195,30 +195,38 @@
|
||||
~r/#{@elixir_erl}:\d+$/
|
||||
end
|
||||
|
||||
- test "opens OTP lists module" do
|
||||
- assert capture_iex("open(:lists)") |> maybe_trim_quotes() =~ ~r/#{@lists_erl}:\d+$/
|
||||
- end
|
||||
-
|
||||
- test "opens OTP lists module.function" do
|
||||
- assert capture_iex("open(:lists.reverse)") |> maybe_trim_quotes() =~ ~r/#{@lists_erl}:\d+$/
|
||||
- end
|
||||
-
|
||||
- test "opens OTP lists module.function/arity" do
|
||||
- assert capture_iex("open(:lists.reverse/1)") |> maybe_trim_quotes() =~
|
||||
- ~r/#{@lists_erl}:\d+$/
|
||||
- end
|
||||
-
|
||||
- test "opens OTP httpc module" do
|
||||
- assert capture_iex("open(:httpc)") |> maybe_trim_quotes() =~ ~r/#{@httpc_erl}:\d+$/
|
||||
- end
|
||||
-
|
||||
- test "opens OTP httpc module.function" do
|
||||
- assert capture_iex("open(:httpc.request)") |> maybe_trim_quotes() =~ ~r/#{@httpc_erl}:\d+$/
|
||||
- end
|
||||
-
|
||||
- test "opens OTP httpc module.function/arity" do
|
||||
- assert capture_iex("open(:httpc.request/1)") |> maybe_trim_quotes() =~
|
||||
- ~r/#{@httpc_erl}:\d+$/
|
||||
+ # Some installations remove the source file once Erlang is compiled. See #7348.
|
||||
+ if File.regular?(@lists_erl) do
|
||||
+ test "opens OTP lists module" do
|
||||
+ assert capture_iex("open(:lists)") |> maybe_trim_quotes() =~ ~r/#{@lists_erl}:\d+$/
|
||||
+ end
|
||||
+
|
||||
+ test "opens OTP lists module.function" do
|
||||
+ assert capture_iex("open(:lists.reverse)") |> maybe_trim_quotes() =~
|
||||
+ ~r/#{@lists_erl}:\d+$/
|
||||
+ end
|
||||
+
|
||||
+ test "opens OTP lists module.function/arity" do
|
||||
+ assert capture_iex("open(:lists.reverse/1)") |> maybe_trim_quotes() =~
|
||||
+ ~r/#{@lists_erl}:\d+$/
|
||||
+ end
|
||||
+ end
|
||||
+
|
||||
+ # Some installations remove the source file once Erlang is compiled. See #7348.
|
||||
+ if File.regular?(@httpc_erl) do
|
||||
+ test "opens OTP httpc module" do
|
||||
+ assert capture_iex("open(:httpc)") |> maybe_trim_quotes() =~ ~r/#{@httpc_erl}:\d+$/
|
||||
+ end
|
||||
+
|
||||
+ test "opens OTP httpc module.function" do
|
||||
+ assert capture_iex("open(:httpc.request)") |> maybe_trim_quotes() =~
|
||||
+ ~r/#{@httpc_erl}:\d+$/
|
||||
+ end
|
||||
+
|
||||
+ test "opens OTP httpc module.function/arity" do
|
||||
+ assert capture_iex("open(:httpc.request/1)") |> maybe_trim_quotes() =~
|
||||
+ ~r/#{@httpc_erl}:\d+$/
|
||||
+ end
|
||||
end
|
||||
|
||||
test "errors OTP preloaded module" do
|
10
elixir.spec
10
elixir.spec
@ -1,8 +1,8 @@
|
||||
%global debug_package %{nil}
|
||||
|
||||
Name: elixir
|
||||
Version: 1.6.5
|
||||
Release: 3%{?dist}
|
||||
Version: 1.6.6
|
||||
Release: 1%{?dist}
|
||||
Summary: A modern approach to programming for the Erlang VM
|
||||
|
||||
Group: Development/Languages
|
||||
@ -11,9 +11,6 @@ URL: http://elixir-lang.org/
|
||||
|
||||
Source0: https://github.com/elixir-lang/%{name}/archive/v%{version}/%{name}-%{version}.tar.gz
|
||||
Source1: https://github.com/elixir-lang/%{name}/releases/download/v%{version}/Docs.zip#/%{name}-%{version}-doc.zip
|
||||
# Backported from upstream:
|
||||
# https://github.com/elixir-lang/elixir/pull/7711
|
||||
Patch0: elixir-1.6.5-disable_tests_on_erlang_sources_if_unavailable.patch
|
||||
#BuildArch: noarch
|
||||
BuildRequires: erlang-rebar
|
||||
BuildRequires: git
|
||||
@ -107,6 +104,9 @@ HTML documentation for eex, elixir, iex, logger and mix.
|
||||
%doc docs/doc/eex docs/doc/elixir docs/doc/iex docs/doc/logger docs/doc/mix
|
||||
|
||||
%changelog
|
||||
* Wed Jun 27 2018 Peter Lemenkov <lemenkov@gmail.com> - 1.6.6-1
|
||||
- New upstream release
|
||||
|
||||
* Wed Jun 20 2018 Timothée Floure <fnux@fedoraproject.org> - 1.6.5-3
|
||||
- Fix version-control-internal-file rpmlint errors
|
||||
- Fix hidden-file-or-dir rpmlint warnings
|
||||
|
4
sources
4
sources
@ -1,2 +1,2 @@
|
||||
SHA512 (elixir-1.6.5-doc.zip) = cc9473f556427a757e19a6e6edfa34aeb107aea5c2e33c740fdee8219ea25e63eddae0cb134d0d7287de23be5fb67041310159409f1945b8c112b466ac3a45af
|
||||
SHA512 (elixir-1.6.5.tar.gz) = e2cf9c2d9198da32cefb841cae4ce64bb52eb28239bbffb6d991916cfdee420b242773664efa7381eb4609c67438ab608f5f96ca2c403b54ecdd9bfdddf91a95
|
||||
SHA512 (elixir-1.6.6-doc.zip) = 8d873383f920664319f5a597708c9f934d820a6e21b0054895a198f3af906044f2214540f223a743805d1f01b29137b28528001cfc39d9555714527f712dffb1
|
||||
SHA512 (elixir-1.6.6.tar.gz) = 62010100274b99423bb6a660e34ef53a702250a09371ef4b49ec03a3afe8761611b3734aea31763afa361560eb74c6d23e022d4d9bc4453c1bdef36bb37f9b4d
|
||||
|
Loading…
Reference in New Issue
Block a user