Update to upstream 1.13.1
Signed-off-by: Peter Lemenkov <lemenkov@gmail.com>
This commit is contained in:
parent
ff02a1c768
commit
219fa80432
@ -1,26 +0,0 @@
|
||||
From: jendis <41624531+jendis@users.noreply.github.com>
|
||||
Date: Wed, 13 Oct 2021 23:48:14 +0200
|
||||
Subject: [PATCH] Fix elixir test assertion for erlang >=OTP-24.1 (#11309)
|
||||
|
||||
|
||||
diff --git a/lib/elixir/test/elixir/exception_test.exs b/lib/elixir/test/elixir/exception_test.exs
|
||||
index 6242194f7..c7d2f1a56 100644
|
||||
--- a/lib/elixir/test/elixir/exception_test.exs
|
||||
+++ b/lib/elixir/test/elixir/exception_test.exs
|
||||
@@ -470,11 +470,12 @@ test "annotates undefined function error with suggestions" do
|
||||
* min/1
|
||||
"""
|
||||
|
||||
- assert blame_message(:erlang, & &1.gt_cookie()) == """
|
||||
- function :erlang.gt_cookie/0 is undefined or private. Did you mean one of:
|
||||
+ assert blame_message(:erlang, & &1.hal()) == """
|
||||
+ function :erlang.hal/0 is undefined or private. Did you mean one of:
|
||||
|
||||
- * get_cookie/0
|
||||
- * set_cookie/2
|
||||
+ * halt/0
|
||||
+ * halt/1
|
||||
+ * halt/2
|
||||
"""
|
||||
end
|
||||
|
10
elixir.spec
10
elixir.spec
@ -4,8 +4,8 @@
|
||||
%global __with_rebar3 0
|
||||
|
||||
Name: elixir
|
||||
Version: 1.12.3
|
||||
Release: 3%{?dist}
|
||||
Version: 1.13.1
|
||||
Release: 1%{?dist}
|
||||
Summary: A modern approach to programming for the Erlang VM
|
||||
|
||||
License: ASL 2.0
|
||||
@ -13,7 +13,6 @@ URL: http://elixir-lang.org/
|
||||
|
||||
Source0: https://github.com/elixir-lang/%{name}/archive/v%{version}.tar.gz#/%{name}-%{version}.tar.gz
|
||||
Source1: https://github.com/elixir-lang/%{name}/releases/download/v%{version}/Docs.zip#/%{name}-%{version}-doc.zip
|
||||
Patch1: elixir-0001-Fix-elixir-test-assertion-for-erlang-OTP-24.1-11309.patch
|
||||
# See https://bugzilla.redhat.com/1470583
|
||||
#BuildArch: noarch
|
||||
BuildRequires: erlang-compiler
|
||||
@ -63,7 +62,7 @@ find -name ".build" -exec rm \{\} \;
|
||||
|
||||
# Unpack elixir itself (Source0)
|
||||
%setup -q -D
|
||||
%patch1 -p1
|
||||
#%patch1 -p1
|
||||
|
||||
# Remove windows-specific scripts
|
||||
find -name '*.bat' -exec rm \{\} \;
|
||||
@ -156,6 +155,9 @@ HTML documentation for eex, elixir, iex, logger and mix.
|
||||
%doc docs/doc/eex docs/doc/elixir docs/doc/iex docs/doc/logger docs/doc/mix
|
||||
|
||||
%changelog
|
||||
* Fri Dec 17 2021 Peter Lemenkov <lemenkov@gmail.com> - 1.13.1-1
|
||||
- New upstream release
|
||||
|
||||
* Sat Nov 6 2021 Peter Lemenkov <lemenkov@gmail.com> - 1.12.3-3
|
||||
- Fix FTBFS with Erlang 24.1 (see GH#11309)
|
||||
|
||||
|
4
sources
4
sources
@ -1,2 +1,2 @@
|
||||
SHA512 (elixir-1.12.3.tar.gz) = 945e33ca9c3e50015531f87630c1bc1b9966acc64bbf7d01c8c4f8cfc104ee1e08113f572f0ad6a9f5e8ee37e33144e58b2ac33dc0a2b01e1355fc5f8b1b9329
|
||||
SHA512 (elixir-1.12.3-doc.zip) = 3e3f2b39546025f25716bb265cc53861ab260db2598f2a91183da3389b9902e189cbd6b409e178a917e59e533c630e372d9d2c8721a8576951700ec8dbfa1d8f
|
||||
SHA512 (elixir-1.13.1.tar.gz) = 5783cf74c16541970504e24fe4454357f98f2a15b021fda5e514a67c096d000268dff15bccce268ac0d5364856df1ecf0284781fe095a089c542fb8100ea141d
|
||||
SHA512 (elixir-1.13.1-doc.zip) = 7c33c6208250a88646ffc2a2f74a944e7f1a9c69473791e9faaf054bd476876a1dd80d8c792a5c47b5bf350a77c0ba4ef191f3b4509b9e962d2514ef88bff9a3
|
||||
|
Loading…
Reference in New Issue
Block a user