Elixir ver. 1.17.2
Signed-off-by: Peter Lemenkov <lemenkov@gmail.com>
This commit is contained in:
parent
4d74467cab
commit
06676342a7
@ -1,59 +0,0 @@
|
||||
From: Peter Lemenkov <lemenkov@gmail.com>
|
||||
Date: Sun, 21 Jan 2024 12:31:05 +0100
|
||||
Subject: [PATCH] Workaround for failed tests in i686
|
||||
|
||||
I wish one day we just drop all i686 executables as more and more
|
||||
upstream projects did already.
|
||||
|
||||
Signed-off-by: Peter Lemenkov <lemenkov@gmail.com>
|
||||
|
||||
diff --git a/lib/iex/test/iex/helpers_test.exs b/lib/iex/test/iex/helpers_test.exs
|
||||
index 54f946516..f357e1145 100644
|
||||
--- a/lib/iex/test/iex/helpers_test.exs
|
||||
+++ b/lib/iex/test/iex/helpers_test.exs
|
||||
@@ -332,22 +332,6 @@ test "shows help" do
|
||||
assert help =~ "Welcome to Interactive Elixir"
|
||||
end
|
||||
|
||||
- test "prints Erlang module documentation" do
|
||||
- captured = capture_io(fn -> h(:timer) end)
|
||||
- assert captured =~ "This module provides useful functions related to time."
|
||||
- end
|
||||
-
|
||||
- test "prints Erlang module function specs" do
|
||||
- captured = capture_io(fn -> h(:timer.sleep() / 1) end)
|
||||
- assert captured =~ ":timer.sleep/1"
|
||||
- assert captured =~ "-spec sleep(Time) -> ok when Time :: timeout()."
|
||||
- end
|
||||
-
|
||||
- test "handles non-existing Erlang module function" do
|
||||
- captured = capture_io(fn -> h(:timer.baz() / 1) end)
|
||||
- assert captured =~ "No documentation for :timer.baz was found"
|
||||
- end
|
||||
-
|
||||
test "prints module documentation" do
|
||||
assert "\n IEx.Helpers\n\nWelcome to Interactive Elixir" <>
|
||||
_ = capture_io(fn -> h(IEx.Helpers) end)
|
||||
@@ -1008,22 +992,6 @@ defmodule TypeSample do
|
||||
cleanup_modules([TypeSample])
|
||||
end
|
||||
|
||||
- test "prints all types in erlang module" do
|
||||
- captured = capture_io(fn -> t(:queue) end)
|
||||
- assert captured =~ "-type queue() :: queue(_)"
|
||||
- assert captured =~ "-opaque queue(Item)"
|
||||
- end
|
||||
-
|
||||
- test "prints single type from erlang module" do
|
||||
- captured = capture_io(fn -> t(:erlang.iovec()) end)
|
||||
- assert captured =~ "-type iovec() :: [binary()]"
|
||||
- assert captured =~ "A list of binaries."
|
||||
-
|
||||
- captured = capture_io(fn -> t(:erlang.iovec() / 0) end)
|
||||
- assert captured =~ "-type iovec() :: [binary()]"
|
||||
- assert captured =~ "A list of binaries."
|
||||
- end
|
||||
-
|
||||
test "handles non-existing types from erlang module" do
|
||||
captured = capture_io(fn -> t(:erlang.foo()) end)
|
||||
assert captured =~ "No type information for :erlang.foo was found or :erlang.foo is private"
|
11
elixir.spec
11
elixir.spec
@ -2,21 +2,14 @@
|
||||
%global debug_package %{nil}
|
||||
|
||||
Name: elixir
|
||||
Version: 1.17.1
|
||||
Version: 1.17.2
|
||||
Release: %autorelease
|
||||
Summary: A modern approach to programming for the Erlang VM
|
||||
|
||||
# Automatically converted from old format: ASL 2.0 - review is highly recommended.
|
||||
License: Apache-2.0
|
||||
URL: https://elixir-lang.org/
|
||||
VCS: scm:git:https://github.com/%{upstream}/%{realname}.git
|
||||
VCS: git:https://github.com/%{upstream}/%{realname}.git
|
||||
Source0: https://github.com/%{upstream}/%{name}/archive/v%{version}/%{name}-%{version}.tar.gz
|
||||
Source1: https://github.com/%{upstream}/%{name}/releases/download/v%{version}/Docs.zip#/%{name}-%{version}-doc.zip
|
||||
%ifnarch %{java_arches}
|
||||
# erlang-doc is required for unit-testing but not strictly necessary for anything else
|
||||
# https://gitlab.alpinelinux.org/alpine/aports/-/issues/15654
|
||||
Patch1: elixir-0001-Workaround-for-failed-tests-in-i686.patch
|
||||
%endif
|
||||
# See https://bugzilla.redhat.com/1470583
|
||||
#BuildArch: noarch
|
||||
BuildRequires: erlang-compiler
|
||||
|
4
sources
4
sources
@ -1,2 +1,2 @@
|
||||
SHA512 (elixir-1.17.1.tar.gz) = ac8db93d4bff29b361fc40dbd01217726f7926cc60493abfbc9dcab5c2868156002589bfc1bcaba31ff86d29dd7e30060bb9baa5693845e366add4fc015d0495
|
||||
SHA512 (elixir-1.17.1-doc.zip) = bcfc4b628a610d6bdfbdba28da94bf6140ae336d0901ca829ee51a8d036466b70466fa2737237ab78b3c4606625af40df8cbd821ce45d6533db1bc764f97c1a1
|
||||
SHA512 (elixir-1.17.2.tar.gz) = f9d4983c3e7bd054a76bfe0dfa4aea483a4dd84ada432ae5a144167ff8d268499077704214eaaecfda84469c2f747a3594258ca95a7955bffde0c7b0f65985f2
|
||||
SHA512 (elixir-1.17.2-doc.zip) = 0503f7a5fb013219e9a43b011890ae427e1e4c615875aa79fdf13bb751d9f5bf3e435ee3158247d82975d4e1cb5dbaa4136af62c6e638a98dc32ebc97074348f
|
||||
|
Loading…
Reference in New Issue
Block a user