New upstream version 0.133

This commit is contained in:
roland 2008-03-01 21:20:41 +00:00
parent 1f1e72439b
commit fb2677a6f3
4 changed files with 100 additions and 30 deletions

View File

@ -1,3 +1,3 @@
testfile16.symtab.bz2
testfile16.symtab.debug.bz2
elfutils-0.132.tar.gz
elfutils-0.133.tar.gz

View File

@ -1,6 +1,6 @@
--- elfutils/backends/ChangeLog
+++ elfutils/backends/ChangeLog
@@ -258,6 +258,11 @@
@@ -281,6 +281,11 @@
* sparc_init.c: Likewise.
* x86_64_init.c: Likewise.
@ -12,7 +12,7 @@
2005-11-19 Roland McGrath <roland@redhat.com>
* ppc64_reloc.def: REL30 -> ADDR30.
@@ -280,6 +285,9 @@
@@ -303,6 +308,9 @@
* Makefile.am (uninstall): Don't try to remove $(pkgincludedir).
(CLEANFILES): Add libebl_$(m).so.
@ -297,7 +297,7 @@
AC_DEFINE_UNQUOTED(LOCALEDIR, "$LOCALEDIR")
--- elfutils/lib/ChangeLog
+++ elfutils/lib/ChangeLog
@@ -16,6 +16,11 @@
@@ -30,6 +30,11 @@
* Makefile.am (libeu_a_SOURCES): Add it.
* system.h: Declare crc32_file.
@ -328,7 +328,7 @@
noinst_LIBRARIES = libeu.a
--- elfutils/lib/Makefile.in
+++ elfutils/lib/Makefile.in
@@ -92,6 +92,7 @@ INSTALL_PROGRAM = @INSTALL_PROGRAM@
@@ -93,6 +93,7 @@ INSTALL_PROGRAM = @INSTALL_PROGRAM@
INSTALL_SCRIPT = @INSTALL_SCRIPT@
INSTALL_STRIP_PROGRAM = @INSTALL_STRIP_PROGRAM@
LDFLAGS = @LDFLAGS@
@ -336,7 +336,7 @@
LEX = @LEX@
LEXLIB = @LEXLIB@
LEX_OUTPUT_ROOT = @LEX_OUTPUT_ROOT@
@@ -121,6 +122,7 @@ SHELL = @SHELL@
@@ -122,6 +123,7 @@ SHELL = @SHELL@
STRIP = @STRIP@
USE_NLS = @USE_NLS@
VERSION = @VERSION@
@ -344,7 +344,7 @@
XGETTEXT = @XGETTEXT@
XGETTEXT_015 = @XGETTEXT_015@
YACC = @YACC@
@@ -176,9 +178,9 @@ target_alias = @target_alias@
@@ -177,9 +179,9 @@ target_alias = @target_alias@
top_builddir = @top_builddir@
top_srcdir = @top_srcdir@
@MUDFLAP_FALSE@AM_CFLAGS = -fpic -Wall -Wshadow -Werror -Wunused \
@ -419,7 +419,7 @@
-I$(top_srcdir)/lib
--- elfutils/libcpu/ChangeLog
+++ elfutils/libcpu/ChangeLog
@@ -262,6 +262,11 @@
@@ -265,6 +265,11 @@
* defs/i386.doc: New file.
* defs/x86_64: New file.
@ -477,7 +477,7 @@
INCLUDES = -I$(srcdir) -I$(srcdir)/../lib -I$(srcdir)/../libelf \
--- elfutils/libdw/ChangeLog
+++ elfutils/libdw/ChangeLog
@@ -482,6 +482,11 @@
@@ -490,6 +490,11 @@
2005-05-31 Roland McGrath <roland@redhat.com>
@ -541,7 +541,17 @@
$(COMPILE)))
--- elfutils/libdwfl/ChangeLog
+++ elfutils/libdwfl/ChangeLog
@@ -744,6 +744,11 @@
@@ -1,3 +1,9 @@
+2008-03-01 Roland McGrath <roland@redhat.com>
+
+ * libdwflP.h (__libdwfl_seterrno): Remove parameter name from
+ prototype to avoid older compiler's complaint about reuse of the name.
+ (__libdwfl_canon_error): Likewise.
+
2008-02-19 Roland McGrath <roland@redhat.com>
* relocate.c (relocate_section): Check for an unhandled relocation
@@ -760,6 +766,11 @@
2005-07-21 Roland McGrath <roland@redhat.com>
@ -553,6 +563,26 @@
* Makefile.am (noinst_HEADERS): Add loc2c.c.
* test2.c (main): Check sscanf result to quiet warning.
--- elfutils/libdwfl/libdwflP.h
+++ elfutils/libdwfl/libdwflP.h
@@ -1,5 +1,5 @@
/* Internal definitions for libdwfl.
- Copyright (C) 2005, 2006, 2007 Red Hat, Inc.
+ Copyright (C) 2005, 2006, 2007, 2008 Red Hat, Inc.
This file is part of Red Hat elfutils.
Red Hat elfutils is free software; you can redistribute it and/or modify
@@ -99,8 +99,8 @@ typedef enum { DWFL_ERRORS DWFL_E_NUM }
#define OTHER_ERROR(name) ((unsigned int) DWFL_E_##name << 16)
#define DWFL_E(name, errno) (OTHER_ERROR (name) | (errno))
-extern int __libdwfl_canon_error (Dwfl_Error error) internal_function;
-extern void __libdwfl_seterrno (Dwfl_Error error) internal_function;
+extern int __libdwfl_canon_error (Dwfl_Error) internal_function;
+extern void __libdwfl_seterrno (Dwfl_Error) internal_function;
struct Dwfl
{
--- elfutils/libdwfl/Makefile.am
+++ elfutils/libdwfl/Makefile.am
@@ -27,12 +27,13 @@
@ -602,7 +632,7 @@
--- elfutils/libebl/ChangeLog
+++ elfutils/libebl/ChangeLog
@@ -505,6 +505,11 @@
@@ -527,6 +527,11 @@
* Makefile.am (libebl_*_so_SOURCES): Set to $(*_SRCS) so dependency
tracking works right.
@ -633,7 +663,7 @@
INCLUDES = -I$(srcdir) -I$(top_srcdir)/libelf -I$(top_srcdir)/libdw \
--- elfutils/libebl/Makefile.in
+++ elfutils/libebl/Makefile.in
@@ -121,6 +121,7 @@ INSTALL_PROGRAM = @INSTALL_PROGRAM@
@@ -122,6 +122,7 @@ INSTALL_PROGRAM = @INSTALL_PROGRAM@
INSTALL_SCRIPT = @INSTALL_SCRIPT@
INSTALL_STRIP_PROGRAM = @INSTALL_STRIP_PROGRAM@
LDFLAGS = @LDFLAGS@
@ -641,7 +671,7 @@
LEX = @LEX@
LEXLIB = @LEXLIB@
LEX_OUTPUT_ROOT = @LEX_OUTPUT_ROOT@
@@ -150,6 +151,7 @@ SHELL = @SHELL@
@@ -151,6 +152,7 @@ SHELL = @SHELL@
STRIP = @STRIP@
USE_NLS = @USE_NLS@
VERSION = 1
@ -649,7 +679,7 @@
XGETTEXT = @XGETTEXT@
XGETTEXT_015 = @XGETTEXT_015@
YACC = @YACC@
@@ -205,9 +207,9 @@ target_alias = @target_alias@
@@ -206,9 +208,9 @@ target_alias = @target_alias@
top_builddir = @top_builddir@
top_srcdir = @top_srcdir@
@MUDFLAP_FALSE@AM_CFLAGS = -fpic -Wall -Wshadow -Werror -Wunused \
@ -663,7 +693,7 @@
--- elfutils/libelf/ChangeLog
+++ elfutils/libelf/ChangeLog
@@ -333,6 +333,11 @@
@@ -355,6 +355,11 @@
If section content hasn't been read yet, do it before looking for the
block size. If no section data present, infer size of section header.
@ -795,7 +825,16 @@
YACC = @YACC@
--- elfutils/src/ChangeLog
+++ elfutils/src/ChangeLog
@@ -126,6 +126,8 @@
@@ -1,3 +1,8 @@
+2008-03-01 Roland McGrath <roland@redhat.com>
+
+ * readelf.c (dump_archive_index): Tweak portability hack
+ to match [__GNUC__ < 4] too.
+
2008-02-29 Roland McGrath <roland@redhat.com>
* readelf.c (print_attributes): Add a cast.
@@ -249,6 +254,8 @@
* readelf.c (hex_dump): Fix rounding error in whitespace calculation.
@ -804,7 +843,7 @@
2007-10-15 Roland McGrath <roland@redhat.com>
* make-debug-archive.in: New file.
@@ -565,6 +567,10 @@
@@ -688,6 +695,10 @@
* elflint.c (valid_e_machine): Add EM_ALPHA.
Reported by Christian Aichinger <Greek0@gmx.net>.
@ -815,7 +854,7 @@
2006-08-08 Ulrich Drepper <drepper@redhat.com>
* elflint.c (check_dynamic): Don't require DT_HASH for DT_SYMTAB.
@@ -641,6 +647,10 @@
@@ -764,6 +775,10 @@
* Makefile.am: Add hacks to create dependency files for non-generic
linker.
@ -826,7 +865,7 @@
2006-06-12 Ulrich Drepper <drepper@redhat.com>
* ldgeneric.c (ld_generic_generate_sections): Don't create .interp
@@ -989,6 +999,11 @@
@@ -1112,6 +1127,11 @@
* readelf.c (print_debug_loc_section): Fix indentation for larger
address size.
@ -926,6 +965,17 @@
readelf_LDADD = $(libdw) $(libebl) $(libelf) $(libeu) $(libmudflap) -ldl
nm_LDADD = $(libdw) $(libebl) $(libelf) $(libeu) $(libmudflap) -ldl
size_LDADD = $(libelf) $(libeu) $(libmudflap)
--- elfutils/src/readelf.c
+++ elfutils/src/readelf.c
@@ -6340,7 +6340,7 @@ dump_archive_index (Elf *elf, const char
if (unlikely (elf_rand (elf, as_off) == 0)
|| unlikely ((subelf = elf_begin (-1, ELF_C_READ_MMAP, elf))
== NULL))
-#if __GLIBC__ < 2 || (__GLIBC__ == 2 && __GLIBC_MINOR__ < 7)
+#if __GLIBC__ < 2 || (__GLIBC__ == 2 && __GLIBC_MINOR__ < 7) || __GNUC__ < 4
while (1)
#endif
error (EXIT_FAILURE, 0,
--- elfutils/src/strings.c
+++ elfutils/src/strings.c
@@ -51,6 +51,10 @@
@ -1007,7 +1057,16 @@
cannot set access and modification date of '%s'"), fname);
--- elfutils/tests/ChangeLog
+++ elfutils/tests/ChangeLog
@@ -703,6 +703,11 @@
@@ -21,6 +21,8 @@
2008-01-21 Roland McGrath <roland@redhat.com>
+ * line2addr.c (main): Revert last change.
+
* testfile45.S.bz2: Add tests for cltq, cqto.
* testfile45.expect.bz2: Adjust.
@@ -729,6 +731,11 @@
* Makefile.am (TESTS): Add run-elflint-test.sh.
(EXTRA_DIST): Add run-elflint-test.sh and testfile18.bz2.
@ -1019,6 +1078,17 @@
2005-05-24 Ulrich Drepper <drepper@redhat.com>
* get-files.c (main): Use correct format specifier.
--- elfutils/tests/line2addr.c
+++ elfutils/tests/line2addr.c
@@ -132,7 +132,7 @@ main (int argc, char *argv[])
{
struct args a = { .arg = argv[cnt] };
- switch (sscanf (a.arg, "%m[^:]:%d", &a.file, &a.line))
+ switch (sscanf (a.arg, "%a[^:]:%d", &a.file, &a.line))
{
default:
case 0:
--- elfutils/tests/Makefile.am
+++ elfutils/tests/Makefile.am
@@ -25,12 +25,13 @@
@ -1039,7 +1109,7 @@
endif
--- elfutils/tests/Makefile.in
+++ elfutils/tests/Makefile.in
@@ -325,6 +325,7 @@ INSTALL_PROGRAM = @INSTALL_PROGRAM@
@@ -330,6 +330,7 @@ INSTALL_PROGRAM = @INSTALL_PROGRAM@
INSTALL_SCRIPT = @INSTALL_SCRIPT@
INSTALL_STRIP_PROGRAM = @INSTALL_STRIP_PROGRAM@
LDFLAGS = @LDFLAGS@
@ -1047,7 +1117,7 @@
LEX = @LEX@
LEXLIB = @LEXLIB@
LEX_OUTPUT_ROOT = @LEX_OUTPUT_ROOT@
@@ -354,6 +355,7 @@ SHELL = @SHELL@
@@ -359,6 +360,7 @@ SHELL = @SHELL@
STRIP = @STRIP@
USE_NLS = @USE_NLS@
VERSION = @VERSION@
@ -1055,7 +1125,7 @@
XGETTEXT = @XGETTEXT@
XGETTEXT_015 = @XGETTEXT_015@
YACC = @YACC@
@@ -408,10 +410,10 @@ sysconfdir = @sysconfdir@
@@ -413,10 +415,10 @@ sysconfdir = @sysconfdir@
target_alias = @target_alias@
top_builddir = @top_builddir@
top_srcdir = @top_srcdir@

View File

@ -1,5 +1,5 @@
%define eu_version 0.132
%define eu_release 4
%define eu_version 0.133
%define eu_release 1
%if %{?_with_compat:1}%{!?_with_compat:0}
%define compat 1
@ -192,7 +192,6 @@ chmod +x ${RPM_BUILD_ROOT}%{_prefix}/%{_lib}/elfutils/lib*.so*
# XXX Nuke unpackaged files
{ cd ${RPM_BUILD_ROOT}
rm -f .%{_bindir}/eu-ld
rm -f .%{_bindir}/eu-objdump
rm -f .%{_includedir}/elfutils/libasm.h
rm -f .%{_libdir}/libasm-%{version}.so
rm -f .%{_libdir}/libasm.so*
@ -222,7 +221,7 @@ rm -rf ${RPM_BUILD_ROOT}
%{_bindir}/eu-elflint
%{_bindir}/eu-findtextrel
%{_bindir}/eu-nm
#%{_bindir}/eu-objdump
%{_bindir}/eu-objdump
%{_bindir}/eu-ranlib
%{_bindir}/eu-readelf
%{_bindir}/eu-size
@ -274,8 +273,9 @@ rm -rf ${RPM_BUILD_ROOT}
%{_libdir}/libelf.a
%changelog
* Wed Feb 20 2008 Jesse Keating <jkeating@redhat.com> - 0.132-4
- Rebuild for GCC 4.3
* Fri Feb 29 2008 Roland McGrath <roland@redhat.com> - 0.133-1
- Update to 0.133
- Install eu-objdump, now has limited disassembler support.
* Mon Jan 21 2008 Roland McGrath <roland@redhat.com> - 0.132-3
- Update to 0.132

View File

@ -1,3 +1,3 @@
07a924423a05b1bf6d0f9fe8b35dbe6b testfile16.symtab.bz2
bd40d1aaca8eaf1c7aea54bf4b29bda2 testfile16.symtab.debug.bz2
73603ebe9bff4e5c7295c6e683436940 elfutils-0.132.tar.gz
f6c69d0dec7431f4d933bf2ba33a9aff elfutils-0.133.tar.gz