Update to 0.138
This commit is contained in:
parent
69a951ae90
commit
ef465d1d34
@ -1 +1 @@
|
||||
elfutils-0.137.tar.gz
|
||||
elfutils-0.138.tar.bz2
|
||||
|
4
Makefile
4
Makefile
@ -4,7 +4,7 @@ NAME := elfutils
|
||||
SPECFILE = elfutils.spec
|
||||
|
||||
UPSTREAM_CHECKS := sig
|
||||
UPSTREAM_FILES = $(NAME)-$(VERSION).tar.gz
|
||||
UPSTREAM_FILES = $(NAME)-$(VERSION).tar.bz2
|
||||
upstream:;
|
||||
|
||||
define find-makefile-common
|
||||
@ -53,7 +53,7 @@ portable-r = 0.$(subst $(DIST),,$(RELEASE))
|
||||
portable-vr = $(VERSION)-$(portable-r)
|
||||
portable.srpm = elfutils-$(portable-vr).src.rpm
|
||||
$(portable.srpm): elfutils-portable.spec elfutils-portability.patch \
|
||||
elfutils-$(VERSION).tar.gz
|
||||
elfutils-$(VERSION).tar.bz2
|
||||
$(RPM_WITH_DIRS) --nodeps -bs $<
|
||||
|
||||
portable-srpm: $(portable.srpm)
|
||||
|
Binary file not shown.
@ -1,174 +0,0 @@
|
||||
--- elfutils-0.137/libdwfl/ChangeLog
|
||||
+++ elfutils-0.137/libdwfl/ChangeLog
|
||||
@@ -1,3 +1,17 @@
|
||||
+2008-09-29 Roland McGrath <roland@redhat.com>
|
||||
+
|
||||
+ * segment.c (insert): Must realloc DWFL->lookup_module here too.
|
||||
+ (dwfl_report_segment): Clear DWFL->lookup_module before insert calls.
|
||||
+
|
||||
+2008-08-28 Roland McGrath <roland@redhat.com>
|
||||
+
|
||||
+ * segment.c (reify_segments): Fix last change.
|
||||
+
|
||||
+2008-08-27 Roland McGrath <roland@redhat.com>
|
||||
+
|
||||
+ * linux-proc-maps.c (read_proc_memory): Return 0 for EINVAL or EPERM
|
||||
+ failure from pread64.
|
||||
+
|
||||
2008-08-26 Roland McGrath <roland@redhat.com>
|
||||
|
||||
* segment.c (reify_segments): Insert a trailing segment for a module
|
||||
--- elfutils-0.137/libdwfl/linux-proc-maps.c
|
||||
+++ elfutils-0.137/libdwfl/linux-proc-maps.c
|
||||
@@ -267,6 +267,9 @@ read_proc_memory (void *arg, void *data,
|
||||
{
|
||||
const int fd = *(const int *) arg;
|
||||
ssize_t nread = pread64 (fd, data, maxread, (off64_t) address);
|
||||
+ /* Some kernels don't actually let us do this read, ignore those errors. */
|
||||
+ if (nread < 0 && (errno == EINVAL || errno == EPERM))
|
||||
+ return 0;
|
||||
if (nread > 0 && (size_t) nread < minread)
|
||||
nread = 0;
|
||||
return nread;
|
||||
--- elfutils-0.137/libdwfl/segment.c
|
||||
+++ elfutils-0.137/libdwfl/segment.c
|
||||
@@ -83,12 +83,26 @@ insert (Dwfl *dwfl, size_t i, GElf_Addr
|
||||
int *nsegndx = realloc (dwfl->lookup_segndx, sizeof nsegndx[0] * n);
|
||||
if (unlikely (nsegndx == NULL))
|
||||
{
|
||||
- free (naddr);
|
||||
+ if (naddr != dwfl->lookup_addr)
|
||||
+ free (naddr);
|
||||
return true;
|
||||
}
|
||||
dwfl->lookup_alloc = n;
|
||||
dwfl->lookup_addr = naddr;
|
||||
dwfl->lookup_segndx = nsegndx;
|
||||
+
|
||||
+ if (dwfl->lookup_module != NULL)
|
||||
+ {
|
||||
+ /* Make sure this array is big enough too. */
|
||||
+ Dwfl_Module **old = dwfl->lookup_module;
|
||||
+ dwfl->lookup_module = realloc (dwfl->lookup_module,
|
||||
+ sizeof dwfl->lookup_module[0] * n);
|
||||
+ if (unlikely (dwfl->lookup_module == NULL))
|
||||
+ {
|
||||
+ free (old);
|
||||
+ return true;
|
||||
+ }
|
||||
+ }
|
||||
}
|
||||
|
||||
if (unlikely (i < dwfl->lookup_elts))
|
||||
@@ -175,9 +189,17 @@ reify_segments (Dwfl *dwfl)
|
||||
return true;
|
||||
++idx;
|
||||
}
|
||||
+ else if (dwfl->lookup_addr[idx] < start)
|
||||
+ {
|
||||
+ /* The module starts past the end of this segment.
|
||||
+ Add a new one. */
|
||||
+ if (unlikely (insert (dwfl, idx + 1, start, end, -1)))
|
||||
+ return true;
|
||||
+ ++idx;
|
||||
+ }
|
||||
|
||||
- if (((size_t) idx + 1 == dwfl->lookup_elts
|
||||
- || end < dwfl->lookup_addr[idx + 1])
|
||||
+ if ((size_t) idx + 1 < dwfl->lookup_elts
|
||||
+ && end < dwfl->lookup_addr[idx + 1]
|
||||
/* The module ends in the middle of this segment. Split it. */
|
||||
&& unlikely (insert (dwfl, idx + 1,
|
||||
end, dwfl->lookup_addr[idx + 1], -1)))
|
||||
@@ -261,6 +283,12 @@ dwfl_report_segment (Dwfl *dwfl, int ndx
|
||||
phdr->p_align < dwfl->segment_align))
|
||||
dwfl->segment_align = phdr->p_align;
|
||||
|
||||
+ if (unlikely (dwfl->lookup_module != NULL))
|
||||
+ {
|
||||
+ free (dwfl->lookup_module);
|
||||
+ dwfl->lookup_module = NULL;
|
||||
+ }
|
||||
+
|
||||
GElf_Addr start = segment_start (dwfl, bias + phdr->p_vaddr);
|
||||
GElf_Addr end = segment_end (dwfl, bias + phdr->p_vaddr + phdr->p_memsz);
|
||||
|
||||
@@ -289,12 +317,6 @@ dwfl_report_segment (Dwfl *dwfl, int ndx
|
||||
dwfl->lookup_tail_offset = end - bias - phdr->p_vaddr + phdr->p_offset;
|
||||
dwfl->lookup_tail_ndx = ndx + 1;
|
||||
|
||||
- if (unlikely (dwfl->lookup_module != NULL))
|
||||
- {
|
||||
- free (dwfl->lookup_module);
|
||||
- dwfl->lookup_module = NULL;
|
||||
- }
|
||||
-
|
||||
return ndx;
|
||||
}
|
||||
INTDEF (dwfl_report_segment)
|
||||
--- elfutils-0.137/libelf/ChangeLog
|
||||
+++ elfutils-0.137/libelf/ChangeLog
|
||||
@@ -1,3 +1,9 @@
|
||||
+2008-08-27 Roland McGrath <roland@redhat.com>
|
||||
+
|
||||
+ * elf_begin.c (get_shnum): Avoid misaligned reads for matching endian.
|
||||
+
|
||||
+ * libelfP.h [!ALLOW_UNALIGNED] (__libelf_type_align): Fix CLASS index.
|
||||
+
|
||||
2008-08-25 Roland McGrath <roland@redhat.com>
|
||||
|
||||
* Makefile.am (libelf_so_LDLIBS): New variable.
|
||||
--- elfutils-0.137/libelf/elf_begin.c
|
||||
+++ elfutils-0.137/libelf/elf_begin.c
|
||||
@@ -111,7 +111,11 @@ get_shnum (void *map_address, unsigned c
|
||||
bool is32 = e_ident[EI_CLASS] == ELFCLASS32;
|
||||
|
||||
/* Make the ELF header available. */
|
||||
- if (e_ident[EI_DATA] == MY_ELFDATA)
|
||||
+ if (e_ident[EI_DATA] == MY_ELFDATA
|
||||
+ && (ALLOW_UNALIGNED
|
||||
+ || (((size_t) e_ident
|
||||
+ & ((is32 ? __alignof__ (Elf32_Ehdr) : __alignof__ (Elf64_Ehdr))
|
||||
+ - 1)) == 0)))
|
||||
ehdr.p = e_ident;
|
||||
else
|
||||
{
|
||||
@@ -130,8 +134,11 @@ get_shnum (void *map_address, unsigned c
|
||||
else
|
||||
memcpy (&ehdr_mem, e_ident, sizeof (Elf32_Ehdr));
|
||||
|
||||
- CONVERT (ehdr_mem.e32.e_shnum);
|
||||
- CONVERT (ehdr_mem.e32.e_shoff);
|
||||
+ if (e_ident[EI_DATA] != MY_ELFDATA)
|
||||
+ {
|
||||
+ CONVERT (ehdr_mem.e32.e_shnum);
|
||||
+ CONVERT (ehdr_mem.e32.e_shoff);
|
||||
+ }
|
||||
}
|
||||
else
|
||||
{
|
||||
@@ -143,8 +150,11 @@ get_shnum (void *map_address, unsigned c
|
||||
else
|
||||
memcpy (&ehdr_mem, e_ident, sizeof (Elf64_Ehdr));
|
||||
|
||||
- CONVERT (ehdr_mem.e64.e_shnum);
|
||||
- CONVERT (ehdr_mem.e64.e_shoff);
|
||||
+ if (e_ident[EI_DATA] != MY_ELFDATA)
|
||||
+ {
|
||||
+ CONVERT (ehdr_mem.e64.e_shnum);
|
||||
+ CONVERT (ehdr_mem.e64.e_shoff);
|
||||
+ }
|
||||
}
|
||||
}
|
||||
|
||||
--- elfutils-0.137/libelf/libelfP.h
|
||||
+++ elfutils-0.137/libelf/libelfP.h
|
||||
@@ -460,7 +460,7 @@ extern const uint_fast8_t __libelf_type_
|
||||
version, binary class, and type. */
|
||||
extern const uint_fast8_t __libelf_type_aligns[EV_NUM - 1][ELFCLASSNUM - 1][ELF_T_NUM] attribute_hidden;
|
||||
# define __libelf_type_align(class, type) \
|
||||
- (__libelf_type_aligns[LIBELF_EV_IDX][class][type] ?: 1)
|
||||
+ (__libelf_type_aligns[LIBELF_EV_IDX][class - 1][type] ?: 1)
|
||||
#else
|
||||
# define __libelf_type_align(class, type) 1
|
||||
#endif
|
Binary file not shown.
BIN
elfutils-0.138.tar.bz2.sig
Normal file
BIN
elfutils-0.138.tar.bz2.sig
Normal file
Binary file not shown.
@ -1,6 +1,6 @@
|
||||
--- elfutils/backends/ChangeLog
|
||||
+++ elfutils/backends/ChangeLog
|
||||
@@ -315,6 +315,11 @@
|
||||
@@ -325,6 +325,11 @@
|
||||
* sparc_init.c: Likewise.
|
||||
* x86_64_init.c: Likewise.
|
||||
|
||||
@ -12,7 +12,7 @@
|
||||
2005-11-19 Roland McGrath <roland@redhat.com>
|
||||
|
||||
* ppc64_reloc.def: REL30 -> ADDR30.
|
||||
@@ -337,6 +342,9 @@
|
||||
@@ -347,6 +352,9 @@
|
||||
* Makefile.am (uninstall): Don't try to remove $(pkgincludedir).
|
||||
(CLEANFILES): Add libebl_$(m).so.
|
||||
|
||||
@ -66,7 +66,7 @@
|
||||
XGETTEXT = @XGETTEXT@
|
||||
XGETTEXT_015 = @XGETTEXT_015@
|
||||
YACC = @YACC@
|
||||
@@ -239,9 +241,9 @@ target_alias = @target_alias@
|
||||
@@ -241,9 +243,9 @@ top_build_prefix = @top_build_prefix@
|
||||
top_builddir = @top_builddir@
|
||||
top_srcdir = @top_srcdir@
|
||||
@MUDFLAP_FALSE@AM_CFLAGS = -fpic -Wall -Wshadow -Werror -Wunused \
|
||||
@ -80,7 +80,7 @@
|
||||
-I$(top_srcdir)/lib -I..
|
||||
--- elfutils/ChangeLog
|
||||
+++ elfutils/ChangeLog
|
||||
@@ -39,6 +39,10 @@
|
||||
@@ -54,6 +54,10 @@
|
||||
* configure.ac: Add dummy automake conditional to get dependencies
|
||||
for non-generic linker right. See src/Makefile.am.
|
||||
|
||||
@ -91,7 +91,7 @@
|
||||
2005-11-18 Roland McGrath <roland@redhat.com>
|
||||
|
||||
* Makefile.am (DISTCHECK_CONFIGURE_FLAGS): New variable.
|
||||
@@ -86,6 +90,17 @@
|
||||
@@ -101,6 +105,17 @@
|
||||
* Makefile.am (all_SUBDIRS): Add libdwfl.
|
||||
* configure.ac: Write libdwfl/Makefile.
|
||||
|
||||
@ -99,12 +99,12 @@
|
||||
+
|
||||
+ * configure.ac (WEXTRA): Check for -Wextra and set this substitution.
|
||||
+
|
||||
+ * configure.ac: Check for struct stat st_?tim members.
|
||||
+ * src/strip.c (process_file): Use st_?time if st_?tim are not there.
|
||||
+ * configure.ac: Check for struct stat st_?tim members.
|
||||
+ * src/strip.c (process_file): Use st_?time if st_?tim are not there.
|
||||
+
|
||||
+ * configure.ac: Check for futimes function.
|
||||
+ * src/strip.c (handle_elf) [! HAVE_FUTIMES]: Use utimes instead.
|
||||
+ (handle_ar) [! HAVE_FUTIMES]: Likewise.
|
||||
+ * configure.ac: Check for futimes function.
|
||||
+ * src/strip.c (handle_elf) [! HAVE_FUTIMES]: Use utimes instead.
|
||||
+ (handle_ar) [! HAVE_FUTIMES]: Likewise.
|
||||
+
|
||||
2005-05-19 Roland McGrath <roland@redhat.com>
|
||||
|
||||
@ -129,23 +129,23 @@
|
||||
YACC = @YACC@
|
||||
--- elfutils/configure
|
||||
+++ elfutils/configure
|
||||
@@ -676,6 +676,8 @@ YFLAGS
|
||||
LEX
|
||||
LEX_OUTPUT_ROOT
|
||||
LEXLIB
|
||||
+WEXTRA
|
||||
+LD_AS_NEEDED
|
||||
LOCALEDIR
|
||||
DATADIRNAME
|
||||
@@ -637,6 +637,8 @@ NATIVE_LD_FALSE
|
||||
NATIVE_LD_TRUE
|
||||
@@ -3894,6 +3896,88 @@ echo "$as_me: error: gcc with C99 suppor
|
||||
DATADIRNAME
|
||||
LOCALEDIR
|
||||
+LD_AS_NEEDED
|
||||
+WEXTRA
|
||||
LEXLIB
|
||||
LEX_OUTPUT_ROOT
|
||||
LEX
|
||||
@@ -4028,6 +4030,89 @@ $as_echo "$as_me: error: gcc with C99 su
|
||||
fi
|
||||
|
||||
|
||||
+{ echo "$as_me:$LINENO: checking for -Wextra option to $CC" >&5
|
||||
+echo $ECHO_N "checking for -Wextra option to $CC... $ECHO_C" >&6; }
|
||||
+{ $as_echo "$as_me:$LINENO: checking for -Wextra option to $CC" >&5
|
||||
+$as_echo_n "checking for -Wextra option to $CC... " >&6; }
|
||||
+if test "${ac_cv_cc_wextra+set}" = set; then
|
||||
+ echo $ECHO_N "(cached) $ECHO_C" >&6
|
||||
+ $as_echo_n "(cached) " >&6
|
||||
+else
|
||||
+ old_CFLAGS="$CFLAGS"
|
||||
+CFLAGS="$CFLAGS -Wextra"
|
||||
@ -158,20 +158,21 @@
|
||||
+ *\"* | *\`* | *\\*) ac_try_echo=\$ac_try;;
|
||||
+ *) ac_try_echo=$ac_try;;
|
||||
+esac
|
||||
+eval "echo \"\$as_me:$LINENO: $ac_try_echo\"") >&5
|
||||
+eval ac_try_echo="\"\$as_me:$LINENO: $ac_try_echo\""
|
||||
+$as_echo "$ac_try_echo") >&5
|
||||
+ (eval "$ac_compile") 2>conftest.er1
|
||||
+ ac_status=$?
|
||||
+ grep -v '^ *+' conftest.er1 >conftest.err
|
||||
+ rm -f conftest.er1
|
||||
+ cat conftest.err >&5
|
||||
+ echo "$as_me:$LINENO: \$? = $ac_status" >&5
|
||||
+ $as_echo "$as_me:$LINENO: \$? = $ac_status" >&5
|
||||
+ (exit $ac_status); } && {
|
||||
+ test -z "$ac_c_werror_flag" ||
|
||||
+ test ! -s conftest.err
|
||||
+ } && test -s conftest.$ac_objext; then
|
||||
+ ac_cv_cc_wextra=yes
|
||||
+else
|
||||
+ echo "$as_me: failed program was:" >&5
|
||||
+ $as_echo "$as_me: failed program was:" >&5
|
||||
+sed 's/^/| /' conftest.$ac_ext >&5
|
||||
+
|
||||
+ ac_cv_cc_wextra=no
|
||||
@ -180,8 +181,8 @@
|
||||
+rm -f core conftest.err conftest.$ac_objext conftest.$ac_ext
|
||||
+CFLAGS="$old_CFLAGS"
|
||||
+fi
|
||||
+{ echo "$as_me:$LINENO: result: $ac_cv_cc_wextra" >&5
|
||||
+echo "${ECHO_T}$ac_cv_cc_wextra" >&6; }
|
||||
+{ $as_echo "$as_me:$LINENO: result: $ac_cv_cc_wextra" >&5
|
||||
+$as_echo "$ac_cv_cc_wextra" >&6; }
|
||||
+
|
||||
+if test "x$ac_cv_cc_wextra" = xyes; then
|
||||
+ WEXTRA=-Wextra
|
||||
@ -190,10 +191,10 @@
|
||||
+fi
|
||||
+
|
||||
+
|
||||
+{ echo "$as_me:$LINENO: checking for --as-needed linker option" >&5
|
||||
+echo $ECHO_N "checking for --as-needed linker option... $ECHO_C" >&6; }
|
||||
+{ $as_echo "$as_me:$LINENO: checking for --as-needed linker option" >&5
|
||||
+$as_echo_n "checking for --as-needed linker option... " >&6; }
|
||||
+if test "${ac_cv_as_needed+set}" = set; then
|
||||
+ echo $ECHO_N "(cached) $ECHO_C" >&6
|
||||
+ $as_echo_n "(cached) " >&6
|
||||
+else
|
||||
+ cat > conftest.c <<EOF
|
||||
+int main (void) { return 0; }
|
||||
@ -204,7 +205,7 @@
|
||||
+ { (eval echo "$as_me:$LINENO: \"$ac_try\"") >&5
|
||||
+ (eval $ac_try) 2>&5
|
||||
+ ac_status=$?
|
||||
+ echo "$as_me:$LINENO: \$? = $ac_status" >&5
|
||||
+ $as_echo "$as_me:$LINENO: \$? = $ac_status" >&5
|
||||
+ (exit $ac_status); }; }
|
||||
+then
|
||||
+ ac_cv_as_needed=yes
|
||||
@ -213,8 +214,8 @@
|
||||
+fi
|
||||
+rm -f conftest*
|
||||
+fi
|
||||
+{ echo "$as_me:$LINENO: result: $ac_cv_as_needed" >&5
|
||||
+echo "${ECHO_T}$ac_cv_as_needed" >&6; }
|
||||
+{ $as_echo "$as_me:$LINENO: result: $ac_cv_as_needed" >&5
|
||||
+$as_echo "$ac_cv_as_needed" >&6; }
|
||||
+if test "x$ac_cv_as_needed" = xyes; then
|
||||
+ LD_AS_NEEDED=-Wl,--as-needed
|
||||
+else
|
||||
@ -227,35 +228,6 @@
|
||||
LOCALEDIR=$datadir
|
||||
|
||||
cat >>confdefs.h <<_ACEOF
|
||||
@@ -5646,8 +5730,8 @@ YFLAGS!$YFLAGS$ac_delim
|
||||
LEX!$LEX$ac_delim
|
||||
LEX_OUTPUT_ROOT!$LEX_OUTPUT_ROOT$ac_delim
|
||||
LEXLIB!$LEXLIB$ac_delim
|
||||
-LOCALEDIR!$LOCALEDIR$ac_delim
|
||||
-DATADIRNAME!$DATADIRNAME$ac_delim
|
||||
+WEXTRA!$WEXTRA$ac_delim
|
||||
+LD_AS_NEEDED!$LD_AS_NEEDED$ac_delim
|
||||
_ACEOF
|
||||
|
||||
if test `sed -n "s/.*$ac_delim\$/X/p" conf$$subs.sed | grep -c X` = 97; then
|
||||
@@ -5689,6 +5773,8 @@ _ACEOF
|
||||
ac_delim='%!_!# '
|
||||
for ac_last_try in false false false false false :; do
|
||||
cat >conf$$subs.sed <<_ACEOF
|
||||
+LOCALEDIR!$LOCALEDIR$ac_delim
|
||||
+DATADIRNAME!$DATADIRNAME$ac_delim
|
||||
NATIVE_LD_TRUE!$NATIVE_LD_TRUE$ac_delim
|
||||
NATIVE_LD_FALSE!$NATIVE_LD_FALSE$ac_delim
|
||||
base_cpu!$base_cpu$ac_delim
|
||||
@@ -5722,7 +5808,7 @@ LIBOBJS!$LIBOBJS$ac_delim
|
||||
LTLIBOBJS!$LTLIBOBJS$ac_delim
|
||||
_ACEOF
|
||||
|
||||
- if test `sed -n "s/.*$ac_delim\$/X/p" conf$$subs.sed | grep -c X` = 31; then
|
||||
+ if test `sed -n "s/.*$ac_delim\$/X/p" conf$$subs.sed | grep -c X` = 33; then
|
||||
break
|
||||
elif $ac_last_try; then
|
||||
{ { echo "$as_me:$LINENO: error: could not make $CONFIG_STATUS" >&5
|
||||
--- elfutils/configure.ac
|
||||
+++ elfutils/configure.ac
|
||||
@@ -74,6 +74,34 @@ CFLAGS="$old_CFLAGS"])
|
||||
@ -342,7 +314,7 @@
|
||||
XGETTEXT = @XGETTEXT@
|
||||
XGETTEXT_015 = @XGETTEXT_015@
|
||||
YACC = @YACC@
|
||||
@@ -177,9 +179,9 @@ target_alias = @target_alias@
|
||||
@@ -179,9 +181,9 @@ top_build_prefix = @top_build_prefix@
|
||||
top_builddir = @top_builddir@
|
||||
top_srcdir = @top_srcdir@
|
||||
@MUDFLAP_FALSE@AM_CFLAGS = -fpic -Wall -Wshadow -Werror -Wunused \
|
||||
@ -356,7 +328,7 @@
|
||||
libeu_a_SOURCES = xstrndup.c xmalloc.c next_prime.c \
|
||||
--- elfutils/libasm/ChangeLog
|
||||
+++ elfutils/libasm/ChangeLog
|
||||
@@ -54,6 +54,11 @@
|
||||
@@ -58,6 +58,11 @@
|
||||
* asm_error.c: Add new error ASM_E_IOERROR.
|
||||
* libasmP.h: Add ASM_E_IOERROR definition.
|
||||
|
||||
@ -387,7 +359,7 @@
|
||||
-I$(top_srcdir)/lib
|
||||
--- elfutils/libasm/Makefile.in
|
||||
+++ elfutils/libasm/Makefile.in
|
||||
@@ -126,6 +126,7 @@ INSTALL_PROGRAM = @INSTALL_PROGRAM@
|
||||
@@ -127,6 +127,7 @@ INSTALL_PROGRAM = @INSTALL_PROGRAM@
|
||||
INSTALL_SCRIPT = @INSTALL_SCRIPT@
|
||||
INSTALL_STRIP_PROGRAM = @INSTALL_STRIP_PROGRAM@
|
||||
LDFLAGS = @LDFLAGS@
|
||||
@ -395,7 +367,7 @@
|
||||
LEX = @LEX@
|
||||
LEXLIB = @LEXLIB@
|
||||
LEX_OUTPUT_ROOT = @LEX_OUTPUT_ROOT@
|
||||
@@ -155,6 +156,7 @@ SHELL = @SHELL@
|
||||
@@ -156,6 +157,7 @@ SHELL = @SHELL@
|
||||
STRIP = @STRIP@
|
||||
USE_NLS = @USE_NLS@
|
||||
VERSION = 1
|
||||
@ -403,7 +375,7 @@
|
||||
XGETTEXT = @XGETTEXT@
|
||||
XGETTEXT_015 = @XGETTEXT_015@
|
||||
YACC = @YACC@
|
||||
@@ -210,9 +212,9 @@ target_alias = @target_alias@
|
||||
@@ -213,9 +215,9 @@ top_build_prefix = @top_build_prefix@
|
||||
top_builddir = @top_builddir@
|
||||
top_srcdir = @top_srcdir@
|
||||
@MUDFLAP_FALSE@AM_CFLAGS = -std=gnu99 -Wall -Wshadow -Werror -Wunused \
|
||||
@ -417,7 +389,7 @@
|
||||
-I$(top_srcdir)/lib
|
||||
--- elfutils/libcpu/ChangeLog
|
||||
+++ elfutils/libcpu/ChangeLog
|
||||
@@ -265,6 +265,11 @@
|
||||
@@ -307,6 +307,11 @@
|
||||
* defs/i386.doc: New file.
|
||||
* defs/x86_64: New file.
|
||||
|
||||
@ -459,8 +431,8 @@
|
||||
XGETTEXT = @XGETTEXT@
|
||||
XGETTEXT_015 = @XGETTEXT_015@
|
||||
YACC = @YACC@
|
||||
@@ -192,10 +194,10 @@ sysconfdir = @sysconfdir@
|
||||
target_alias = @target_alias@
|
||||
@@ -194,10 +196,10 @@ target_alias = @target_alias@
|
||||
top_build_prefix = @top_build_prefix@
|
||||
top_builddir = @top_builddir@
|
||||
top_srcdir = @top_srcdir@
|
||||
-@MUDFLAP_FALSE@AM_CFLAGS = -Wall -Wshadow -Wunused -Wextra -std=gnu99 \
|
||||
@ -524,7 +496,7 @@
|
||||
XGETTEXT = @XGETTEXT@
|
||||
XGETTEXT_015 = @XGETTEXT_015@
|
||||
YACC = @YACC@
|
||||
@@ -248,9 +250,10 @@ target_alias = @target_alias@
|
||||
@@ -250,9 +252,10 @@ top_build_prefix = @top_build_prefix@
|
||||
top_builddir = @top_builddir@
|
||||
top_srcdir = @top_srcdir@
|
||||
@MUDFLAP_FALSE@AM_CFLAGS = $(am__append_1) -Wall -Werror -Wshadow \
|
||||
@ -539,7 +511,7 @@
|
||||
$(COMPILE)))
|
||||
--- elfutils/libdwfl/ChangeLog
|
||||
+++ elfutils/libdwfl/ChangeLog
|
||||
@@ -885,6 +885,11 @@
|
||||
@@ -936,6 +936,11 @@
|
||||
|
||||
2005-07-21 Roland McGrath <roland@redhat.com>
|
||||
|
||||
@ -586,7 +558,7 @@
|
||||
XGETTEXT = @XGETTEXT@
|
||||
XGETTEXT_015 = @XGETTEXT_015@
|
||||
YACC = @YACC@
|
||||
@@ -215,9 +217,9 @@ target_alias = @target_alias@
|
||||
@@ -217,9 +219,9 @@ top_build_prefix = @top_build_prefix@
|
||||
top_builddir = @top_builddir@
|
||||
top_srcdir = @top_srcdir@
|
||||
@MUDFLAP_FALSE@AM_CFLAGS = -Wall -Werror -Wshadow -Wunused -Wformat=2 \
|
||||
@ -600,7 +572,7 @@
|
||||
|
||||
--- elfutils/libebl/ChangeLog
|
||||
+++ elfutils/libebl/ChangeLog
|
||||
@@ -554,6 +554,11 @@
|
||||
@@ -558,6 +558,11 @@
|
||||
* Makefile.am (libebl_*_so_SOURCES): Set to $(*_SRCS) so dependency
|
||||
tracking works right.
|
||||
|
||||
@ -647,7 +619,7 @@
|
||||
XGETTEXT = @XGETTEXT@
|
||||
XGETTEXT_015 = @XGETTEXT_015@
|
||||
YACC = @YACC@
|
||||
@@ -207,9 +209,9 @@ target_alias = @target_alias@
|
||||
@@ -209,9 +211,9 @@ top_build_prefix = @top_build_prefix@
|
||||
top_builddir = @top_builddir@
|
||||
top_srcdir = @top_srcdir@
|
||||
@MUDFLAP_FALSE@AM_CFLAGS = -fpic -Wall -Wshadow -Werror -Wunused \
|
||||
@ -661,7 +633,7 @@
|
||||
|
||||
--- elfutils/libelf/ChangeLog
|
||||
+++ elfutils/libelf/ChangeLog
|
||||
@@ -408,6 +408,11 @@
|
||||
@@ -477,6 +477,11 @@
|
||||
If section content hasn't been read yet, do it before looking for the
|
||||
block size. If no section data present, infer size of section header.
|
||||
|
||||
@ -730,7 +702,7 @@
|
||||
XGETTEXT = @XGETTEXT@
|
||||
XGETTEXT_015 = @XGETTEXT_015@
|
||||
YACC = @YACC@
|
||||
@@ -255,10 +257,10 @@ target_alias = @target_alias@
|
||||
@@ -257,10 +259,10 @@ top_build_prefix = @top_build_prefix@
|
||||
top_builddir = @top_builddir@
|
||||
top_srcdir = @top_srcdir@
|
||||
@MUDFLAP_FALSE@AM_CFLAGS = $(am__append_1) -Wall -Wshadow -Werror \
|
||||
@ -763,7 +735,7 @@
|
||||
YACC = @YACC@
|
||||
--- elfutils/Makefile.in
|
||||
+++ elfutils/Makefile.in
|
||||
@@ -98,6 +98,7 @@ INSTALL_PROGRAM = @INSTALL_PROGRAM@
|
||||
@@ -109,6 +109,7 @@ INSTALL_PROGRAM = @INSTALL_PROGRAM@
|
||||
INSTALL_SCRIPT = @INSTALL_SCRIPT@
|
||||
INSTALL_STRIP_PROGRAM = @INSTALL_STRIP_PROGRAM@
|
||||
LDFLAGS = @LDFLAGS@
|
||||
@ -771,7 +743,7 @@
|
||||
LEX = @LEX@
|
||||
LEXLIB = @LEXLIB@
|
||||
LEX_OUTPUT_ROOT = @LEX_OUTPUT_ROOT@
|
||||
@@ -127,6 +128,7 @@ SHELL = @SHELL@
|
||||
@@ -138,6 +139,7 @@ SHELL = @SHELL@
|
||||
STRIP = @STRIP@
|
||||
USE_NLS = @USE_NLS@
|
||||
VERSION = @VERSION@
|
||||
@ -781,7 +753,7 @@
|
||||
YACC = @YACC@
|
||||
--- elfutils/src/ChangeLog
|
||||
+++ elfutils/src/ChangeLog
|
||||
@@ -61,6 +61,11 @@
|
||||
@@ -76,6 +76,11 @@
|
||||
that matches its PT_LOAD's p_flags &~ PF_W. On sparc, PF_X really
|
||||
is valid in RELRO.
|
||||
|
||||
@ -793,7 +765,7 @@
|
||||
2008-02-29 Roland McGrath <roland@redhat.com>
|
||||
|
||||
* readelf.c (print_attributes): Add a cast.
|
||||
@@ -312,6 +317,8 @@
|
||||
@@ -327,6 +332,8 @@
|
||||
|
||||
* readelf.c (hex_dump): Fix rounding error in whitespace calculation.
|
||||
|
||||
@ -802,7 +774,7 @@
|
||||
2007-10-15 Roland McGrath <roland@redhat.com>
|
||||
|
||||
* make-debug-archive.in: New file.
|
||||
@@ -751,6 +758,10 @@
|
||||
@@ -766,6 +773,10 @@
|
||||
* elflint.c (valid_e_machine): Add EM_ALPHA.
|
||||
Reported by Christian Aichinger <Greek0@gmx.net>.
|
||||
|
||||
@ -813,7 +785,7 @@
|
||||
2006-08-08 Ulrich Drepper <drepper@redhat.com>
|
||||
|
||||
* elflint.c (check_dynamic): Don't require DT_HASH for DT_SYMTAB.
|
||||
@@ -827,6 +838,10 @@
|
||||
@@ -842,6 +853,10 @@
|
||||
* Makefile.am: Add hacks to create dependency files for non-generic
|
||||
linker.
|
||||
|
||||
@ -824,7 +796,7 @@
|
||||
2006-06-12 Ulrich Drepper <drepper@redhat.com>
|
||||
|
||||
* ldgeneric.c (ld_generic_generate_sections): Don't create .interp
|
||||
@@ -1175,6 +1190,11 @@
|
||||
@@ -1190,6 +1205,11 @@
|
||||
* readelf.c (print_debug_loc_section): Fix indentation for larger
|
||||
address size.
|
||||
|
||||
@ -898,7 +870,7 @@
|
||||
XGETTEXT = @XGETTEXT@
|
||||
XGETTEXT_015 = @XGETTEXT_015@
|
||||
YACC = @YACC@ -d
|
||||
@@ -287,13 +289,13 @@ top_srcdir = @top_srcdir@
|
||||
@@ -289,13 +291,13 @@ top_srcdir = @top_srcdir@
|
||||
@MUDFLAP_FALSE@AM_CFLAGS = -Wall -Wshadow -std=gnu99 \
|
||||
@MUDFLAP_FALSE@ $(native_ld_cflags) $(if \
|
||||
@MUDFLAP_FALSE@ $($(*F)_no_Werror),,-Werror) $(if \
|
||||
@ -914,7 +886,7 @@
|
||||
@MUDFLAP_TRUE@ $($(*F)_no_Wformat),,-Wformat=2) $(CFLAGS_$(*F))
|
||||
INCLUDES = -I$(srcdir) -I$(srcdir)/../libelf -I$(srcdir)/../libebl \
|
||||
-I$(srcdir)/../libdw -I$(srcdir)/../libdwfl \
|
||||
@@ -337,6 +339,9 @@ size_no_Wformat = yes
|
||||
@@ -339,6 +341,9 @@ size_no_Wformat = yes
|
||||
strings_no_Wformat = yes
|
||||
# XXX While the file is not finished, don't warn about this
|
||||
ldgeneric_no_Wunused = yes
|
||||
@ -926,7 +898,7 @@
|
||||
size_LDADD = $(libelf) $(libeu) $(libmudflap)
|
||||
--- elfutils/src/readelf.c
|
||||
+++ elfutils/src/readelf.c
|
||||
@@ -6419,7 +6419,7 @@ dump_archive_index (Elf *elf, const char
|
||||
@@ -6424,7 +6424,7 @@ dump_archive_index (Elf *elf, const char
|
||||
if (unlikely (elf_rand (elf, as_off) == 0)
|
||||
|| unlikely ((subelf = elf_begin (-1, ELF_C_READ_MMAP, elf))
|
||||
== NULL))
|
||||
@ -1016,7 +988,7 @@
|
||||
cannot set access and modification date of '%s'"), fname);
|
||||
--- elfutils/tests/ChangeLog
|
||||
+++ elfutils/tests/ChangeLog
|
||||
@@ -51,6 +51,8 @@
|
||||
@@ -84,6 +84,8 @@
|
||||
|
||||
2008-01-21 Roland McGrath <roland@redhat.com>
|
||||
|
||||
@ -1025,7 +997,7 @@
|
||||
* testfile45.S.bz2: Add tests for cltq, cqto.
|
||||
* testfile45.expect.bz2: Adjust.
|
||||
|
||||
@@ -759,6 +761,11 @@
|
||||
@@ -792,6 +794,11 @@
|
||||
* Makefile.am (TESTS): Add run-elflint-test.sh.
|
||||
(EXTRA_DIST): Add run-elflint-test.sh and testfile18.bz2.
|
||||
|
||||
@ -1068,7 +1040,7 @@
|
||||
endif
|
||||
--- elfutils/tests/Makefile.in
|
||||
+++ elfutils/tests/Makefile.in
|
||||
@@ -335,6 +335,7 @@ INSTALL_PROGRAM = @INSTALL_PROGRAM@
|
||||
@@ -341,6 +341,7 @@ INSTALL_PROGRAM = @INSTALL_PROGRAM@
|
||||
INSTALL_SCRIPT = @INSTALL_SCRIPT@
|
||||
INSTALL_STRIP_PROGRAM = @INSTALL_STRIP_PROGRAM@
|
||||
LDFLAGS = @LDFLAGS@
|
||||
@ -1076,7 +1048,7 @@
|
||||
LEX = @LEX@
|
||||
LEXLIB = @LEXLIB@
|
||||
LEX_OUTPUT_ROOT = @LEX_OUTPUT_ROOT@
|
||||
@@ -364,6 +365,7 @@ SHELL = @SHELL@
|
||||
@@ -370,6 +371,7 @@ SHELL = @SHELL@
|
||||
STRIP = @STRIP@
|
||||
USE_NLS = @USE_NLS@
|
||||
VERSION = @VERSION@
|
||||
@ -1084,8 +1056,8 @@
|
||||
XGETTEXT = @XGETTEXT@
|
||||
XGETTEXT_015 = @XGETTEXT_015@
|
||||
YACC = @YACC@
|
||||
@@ -418,10 +420,10 @@ sysconfdir = @sysconfdir@
|
||||
target_alias = @target_alias@
|
||||
@@ -426,10 +428,10 @@ target_alias = @target_alias@
|
||||
top_build_prefix = @top_build_prefix@
|
||||
top_builddir = @top_builddir@
|
||||
top_srcdir = @top_srcdir@
|
||||
-@MUDFLAP_FALSE@AM_CFLAGS = -Wall -Werror -Wextra -std=gnu99 \
|
||||
|
@ -1,5 +1,5 @@
|
||||
%define eu_version 0.137
|
||||
%define eu_release 3
|
||||
%define eu_version 0.138
|
||||
%define eu_release 1
|
||||
|
||||
%if %{?_with_compat:1}%{!?_with_compat:0}
|
||||
%define compat 1
|
||||
@ -32,10 +32,9 @@ Release: 0.%{eu_release}
|
||||
License: GPLv2 with exceptions
|
||||
Group: Development/Tools
|
||||
URL: https://fedorahosted.org/elfutils/
|
||||
Source: http://fedorahosted.org/releases/e/l/elfutils/%{name}-%{version}.tar.gz
|
||||
Source: http://fedorahosted.org/releases/e/l/elfutils/%{name}-%{version}.tar.bz2
|
||||
Patch1: elfutils-portability.patch
|
||||
Patch2: elfutils-robustify.patch
|
||||
Patch3: elfutils-0.137-fixes.patch
|
||||
Requires: elfutils-libelf-%{_arch} = %{version}-%{release}
|
||||
Requires: elfutils-libs-%{_arch} = %{version}-%{release}
|
||||
|
||||
@ -157,8 +156,6 @@ find . \( -name configure -o -name config.h.in \) -print | xargs touch
|
||||
|
||||
%patch2 -p1 -b .robustify
|
||||
|
||||
%patch3 -p1 -b .fixes
|
||||
|
||||
find . -name \*.sh ! -perm -0100 -print | xargs chmod +x
|
||||
|
||||
%build
|
||||
@ -239,6 +236,7 @@ rm -rf ${RPM_BUILD_ROOT}
|
||||
%{_includedir}/elfutils/libebl.h
|
||||
%{_includedir}/elfutils/libdw.h
|
||||
%{_includedir}/elfutils/libdwfl.h
|
||||
%{_includedir}/elfutils/version.h
|
||||
%{_libdir}/libebl.a
|
||||
%{_libdir}/libasm.so
|
||||
%{_libdir}/libdw.so
|
||||
@ -265,6 +263,16 @@ rm -rf ${RPM_BUILD_ROOT}
|
||||
%{_libdir}/libelf.a
|
||||
|
||||
%changelog
|
||||
* Wed Dec 31 2008 Roland McGrath <roland@redhat.com> - 0.138-1
|
||||
- Update to 0.138
|
||||
- Install <elfutils/version.h> header file for applications to use in
|
||||
source version compatibility checks.
|
||||
- libebl: backend fixes for i386 TLS relocs; backend support for NT_386_IOPERM
|
||||
- libcpu: disassembler fixes (#469739)
|
||||
- libdwfl: bug fixes (#465878)
|
||||
- libelf: bug fixes
|
||||
- eu-nm: bug fixes for handling corrupt input files (#476136)
|
||||
|
||||
* Wed Oct 1 2008 Roland McGrath <roland@redhat.com> - 0.137-3
|
||||
- fix libdwfl regression (#462689)
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user