Update to 0.107

This commit is contained in:
roland 2005-05-08 22:43:51 +00:00
parent f59968ee2c
commit 76905ff5ba
5 changed files with 106 additions and 76 deletions

View File

@ -1 +1 @@
elfutils-0.106.tar.gz
elfutils-0.107.tar.gz

View File

@ -1,6 +1,17 @@
# Makefile for source rpm: elfutils
# $Id$
# $Id: Makefile,v 1.1 2004/09/09 04:28:54 cvsdist Exp $
NAME := elfutils
SPECFILE = $(firstword $(wildcard *.spec))
include ../common/Makefile.common
elfutils-portability.patch: elfutils-$(VERSION).tar.gz portable.patch
rm -rf elfutils-$(VERSION) elfutils-$(VERSION).orig
tar xzf $<
mv elfutils-$(VERSION) elfutils-$(VERSION).orig
tar xzf $<
patch -p1 -d elfutils-$(VERSION) < portable.patch
cd elfutils-$(VERSION); autoreconf
diff -rpu elfutils-$(VERSION).orig elfutils-$(VERSION) | \
filterdiff --remove-timestamps > $@.new
mv $@.new $@

View File

@ -1,5 +1,5 @@
--- elfutils/ChangeLog
+++ elfutils/ChangeLog
--- elfutils-0.107.orig/ChangeLog
+++ elfutils-0.107/ChangeLog
@@ -1,3 +1,16 @@
+2005-02-07 Roland McGrath <roland@frob.com>
+
@ -17,8 +17,8 @@
2005-02-22 Ulrich Drepper <drepper@redhat.com>
* Makefile.am (all_SUBDIRS): Don't add doc subdir for now.
--- elfutils/Makefile.in
+++ elfutils/Makefile.in
--- elfutils-0.107.orig/Makefile.in
+++ elfutils-0.107/Makefile.in
@@ -127,6 +127,7 @@ SHELL = @SHELL@
STRIP = @STRIP@
USE_NLS = @USE_NLS@
@ -27,8 +27,8 @@
XGETTEXT = @XGETTEXT@
YACC = @YACC@
ac_ct_CC = @ac_ct_CC@
--- elfutils/config/Makefile.in
+++ elfutils/config/Makefile.in
--- elfutils-0.107.orig/config/Makefile.in
+++ elfutils-0.107/config/Makefile.in
@@ -105,6 +105,7 @@ SHELL = @SHELL@
STRIP = @STRIP@
USE_NLS = @USE_NLS@
@ -37,9 +37,9 @@
XGETTEXT = @XGETTEXT@
YACC = @YACC@
ac_ct_CC = @ac_ct_CC@
--- elfutils/configure
+++ elfutils/configure
@@ -277,7 +277,7 @@ PACKAGE_STRING='Red Hat elfutils 0.106'
--- elfutils-0.107.orig/configure
+++ elfutils-0.107/configure
@@ -277,7 +277,7 @@ PACKAGE_STRING='Red Hat elfutils 0.107'
PACKAGE_BUGREPORT='http://bugzilla.redhat.com/bugzilla/'
ac_unique_file="libelf/libelf.h"
@ -115,8 +115,8 @@
s,@LOCALEDIR@,$LOCALEDIR,;t t
s,@DATADIRNAME@,$DATADIRNAME,;t t
s,@NATIVE_LD_TRUE@,$NATIVE_LD_TRUE,;t t
--- elfutils/configure.ac
+++ elfutils/configure.ac
--- elfutils-0.107.orig/configure.ac
+++ elfutils-0.107/configure.ac
@@ -64,6 +64,15 @@ CFLAGS="$old_CFLAGS"])
AS_IF([test "x$ac_cv_c99" != xyes],
AC_MSG_ERROR([gcc with C99 support required]))
@ -133,19 +133,22 @@
LOCALEDIR=$datadir
AC_SUBST(LOCALEDIR)
AC_DEFINE_UNQUOTED(LOCALEDIR, "$LOCALEDIR")
--- elfutils/lib/ChangeLog
+++ elfutils/lib/ChangeLog
@@ -1,3 +1,8 @@
--- elfutils-0.107.orig/lib/ChangeLog
+++ elfutils-0.107/lib/ChangeLog
@@ -4,6 +4,11 @@
* Makefile.am (libeu_a_SOURCES): Add it.
* system.h: Declare crc32_file.
+2005-02-07 Roland McGrath <roland@redhat.com>
+
+ * Makefile.am (WEXTRA): New variable, substituted by configure.
+ (AM_CFLAGS): Use it in place of -Wextra.
+
2005-02-15 Ulrich Drepper <drepper@redhat.com>
2005-04-30 Ulrich Drepper <drepper@redhat.com>
* dynamicsizehash.c (lookup): Mark val parameter as possibly unused.
--- elfutils/lib/Makefile.am
+++ elfutils/lib/Makefile.am
* Makefile.am: Use -ffunction-sections for xmalloc.c.
--- elfutils-0.107.orig/lib/Makefile.am
+++ elfutils-0.107/lib/Makefile.am
@@ -16,12 +16,13 @@
## Inc., 59 Temple Place - Suite 330, Boston, MA 02111-1307, USA.
##
@ -161,9 +164,9 @@
INCLUDES = -I$(srcdir)/../libelf -I..
noinst_LIBRARIES = libeu.a
--- elfutils/lib/Makefile.in
+++ elfutils/lib/Makefile.in
@@ -126,6 +126,7 @@ SHELL = @SHELL@
--- elfutils-0.107.orig/lib/Makefile.in
+++ elfutils-0.107/lib/Makefile.in
@@ -127,6 +127,7 @@ SHELL = @SHELL@
STRIP = @STRIP@
USE_NLS = @USE_NLS@
VERSION = @VERSION@
@ -171,7 +174,7 @@
XGETTEXT = @XGETTEXT@
YACC = @YACC@
ac_ct_CC = @ac_ct_CC@
@@ -168,9 +169,9 @@ sharedstatedir = @sharedstatedir@
@@ -169,9 +170,9 @@ sharedstatedir = @sharedstatedir@
sysconfdir = @sysconfdir@
target_alias = @target_alias@
@MUDFLAP_FALSE@AM_CFLAGS = -fpic -Wall -Wshadow -Werror -Wunused \
@ -182,9 +185,9 @@
+@MUDFLAP_TRUE@ -Wunused $(WEXTRA) $($(*F)_CFLAGS)
INCLUDES = -I$(srcdir)/../libelf -I..
noinst_LIBRARIES = libeu.a
libeu_a_SOURCES = xstrdup.c xstrndup.c xmalloc.c next_prime.c crc32.c
--- elfutils/libasm/Makefile.am
+++ elfutils/libasm/Makefile.am
libeu_a_SOURCES = xstrdup.c xstrndup.c xmalloc.c next_prime.c \
--- elfutils-0.107.orig/libasm/Makefile.am
+++ elfutils-0.107/libasm/Makefile.am
@@ -13,12 +13,13 @@
## 3001 King Ranch Road, Ukiah, CA 95482.
##
@ -200,8 +203,8 @@
INCLUDES = -I. -I$(srcdir) -I.. -I$(top_srcdir)/libelf -I$(top_srcdir)/libebl \
-I$(top_srcdir)/lib
GCC_INCLUDE = -I$(shell $(CC) -print-file-name=include)
--- elfutils/libasm/Makefile.in
+++ elfutils/libasm/Makefile.in
--- elfutils-0.107.orig/libasm/Makefile.in
+++ elfutils-0.107/libasm/Makefile.in
@@ -159,6 +159,7 @@ SHELL = @SHELL@
STRIP = @STRIP@
USE_NLS = @USE_NLS@
@ -223,8 +226,8 @@
INCLUDES = -I. -I$(srcdir) -I.. -I$(top_srcdir)/libelf -I$(top_srcdir)/libebl \
-I$(top_srcdir)/lib
--- elfutils/libcpu/ChangeLog
+++ elfutils/libcpu/ChangeLog
--- elfutils-0.107.orig/libcpu/ChangeLog
+++ elfutils-0.107/libcpu/ChangeLog
@@ -1,3 +1,8 @@
+2005-04-04 Roland McGrath <roland@redhat.com>
+
@ -234,8 +237,8 @@
2005-02-15 Ulrich Drepper <drepper@redhat.com>
* Makefile (AM_CFLAGS): Add -Wunused -Wextra -Wformat=2.
--- elfutils/libcpu/Makefile.am
+++ elfutils/libcpu/Makefile.am
--- elfutils-0.107.orig/libcpu/Makefile.am
+++ elfutils-0.107/libcpu/Makefile.am
@@ -13,7 +13,8 @@
## 3001 King Ranch Road, Ukiah, CA 95482.
##
@ -246,8 +249,8 @@
INCLUDES = -I$(srcdir)
noinst_LIBRARIES = libcpu_i386.a
--- elfutils/libcpu/Makefile.in
+++ elfutils/libcpu/Makefile.in
--- elfutils-0.107.orig/libcpu/Makefile.in
+++ elfutils-0.107/libcpu/Makefile.in
@@ -122,6 +122,7 @@ SHELL = @SHELL@
STRIP = @STRIP@
USE_NLS = @USE_NLS@
@ -265,8 +268,8 @@
INCLUDES = -I$(srcdir)
noinst_LIBRARIES = libcpu_i386.a
libcpu_i386_a_SOURCES = i386_dis.c
--- elfutils/libdw/Makefile.am
+++ elfutils/libdw/Makefile.am
--- elfutils-0.107.orig/libdw/Makefile.am
+++ elfutils-0.107/libdw/Makefile.am
@@ -13,12 +13,13 @@
## 3001 King Ranch Road, Ukiah, CA 95482.
##
@ -282,8 +285,8 @@
INCLUDES = -I. -I$(srcdir) -I$(srcdir)/../libelf -I.. -I$(srcdir)/../lib
VERSION = 1
--- elfutils/libdw/Makefile.in
+++ elfutils/libdw/Makefile.in
--- elfutils-0.107.orig/libdw/Makefile.in
+++ elfutils-0.107/libdw/Makefile.in
@@ -190,6 +190,7 @@ SHELL = @SHELL@
STRIP = @STRIP@
USE_NLS = @USE_NLS@
@ -304,8 +307,8 @@
INCLUDES = -I. -I$(srcdir) -I$(srcdir)/../libelf -I.. -I$(srcdir)/../lib
lib_LIBRARIES = libdw.a
@MUDFLAP_FALSE@noinst_LIBRARIES = libdw_pic.a
--- elfutils/libebl/Makefile.am
+++ elfutils/libebl/Makefile.am
--- elfutils-0.107.orig/libebl/Makefile.am
+++ elfutils-0.107/libebl/Makefile.am
@@ -13,12 +13,13 @@
## 3001 King Ranch Road, Ukiah, CA 95482.
##
@ -321,8 +324,8 @@
-std=gnu99
INCLUDES = -I$(srcdir) -I$(top_srcdir)/libelf -I$(top_srcdir)/lib -I..
--- elfutils/libebl/Makefile.in
+++ elfutils/libebl/Makefile.in
--- elfutils-0.107.orig/libebl/Makefile.in
+++ elfutils-0.107/libebl/Makefile.in
@@ -236,6 +236,7 @@ SHELL = @SHELL@
STRIP = @STRIP@
USE_NLS = @USE_NLS@
@ -343,8 +346,8 @@
INCLUDES = -I$(srcdir) -I$(top_srcdir)/libelf -I$(top_srcdir)/lib -I..
lib_LIBRARIES = libebl.a
modules = i386 sh mips x86_64 ia64 alpha arm sparc ppc ppc64
--- elfutils/libelf/Makefile.am
+++ elfutils/libelf/Makefile.am
--- elfutils-0.107.orig/libelf/Makefile.am
+++ elfutils-0.107/libelf/Makefile.am
@@ -16,12 +16,13 @@
## Inc., 59 Temple Place - Suite 330, Boston, MA 02111-1307, USA.
##
@ -360,8 +363,8 @@
$($(*F)_CFLAGS)
INCLUDES = -I$(srcdir) -I$(top_srcdir)/lib -I..
GCC_INCLUDE = -I$(shell $(CC) -print-file-name=include)
--- elfutils/libelf/Makefile.in
+++ elfutils/libelf/Makefile.in
--- elfutils-0.107.orig/libelf/Makefile.in
+++ elfutils-0.107/libelf/Makefile.in
@@ -199,6 +199,7 @@ SHELL = @SHELL@
STRIP = @STRIP@
USE_NLS = @USE_NLS@
@ -383,8 +386,8 @@
@MUDFLAP_TRUE@ $($(*F)_CFLAGS)
INCLUDES = -I$(srcdir) -I$(top_srcdir)/lib -I..
GCC_INCLUDE = -I$(shell $(CC) -print-file-name=include)
--- elfutils/m4/Makefile.in
+++ elfutils/m4/Makefile.in
--- elfutils-0.107.orig/m4/Makefile.in
+++ elfutils-0.107/m4/Makefile.in
@@ -103,6 +103,7 @@ SHELL = @SHELL@
STRIP = @STRIP@
USE_NLS = @USE_NLS@
@ -393,8 +396,8 @@
XGETTEXT = @XGETTEXT@
YACC = @YACC@
ac_ct_CC = @ac_ct_CC@
--- elfutils/src/Makefile.am
+++ elfutils/src/Makefile.am
--- elfutils-0.107.orig/src/Makefile.am
+++ elfutils-0.107/src/Makefile.am
@@ -14,14 +14,15 @@
##
DEFS = -D_GNU_SOURCE -DHAVE_CONFIG_H $(YYDEBUG) \
@ -413,9 +416,9 @@
$(if $($(*F)_no_Wformat),,-Wformat=2)
endif
if MUDFLAP
--- elfutils/src/Makefile.in
+++ elfutils/src/Makefile.in
@@ -192,6 +192,7 @@ SHELL = @SHELL@
--- elfutils-0.107.orig/src/Makefile.in
+++ elfutils-0.107/src/Makefile.in
@@ -194,6 +194,7 @@ SHELL = @SHELL@
STRIP = @STRIP@
USE_NLS = @USE_NLS@
VERSION = @VERSION@
@ -423,7 +426,7 @@
XGETTEXT = @XGETTEXT@
YACC = @YACC@ -d
ac_ct_CC = @ac_ct_CC@
@@ -235,10 +236,10 @@ sysconfdir = @sysconfdir@
@@ -237,10 +238,10 @@ sysconfdir = @sysconfdir@
target_alias = @target_alias@
@MUDFLAP_FALSE@AM_CFLAGS = -Wall -Wshadow -std=gnu99 $(native_ld_cflags) \
@MUDFLAP_FALSE@ $(if $($(*F)_no_Werror),,-Werror) \
@ -436,8 +439,23 @@
@MUDFLAP_TRUE@ $(native_ld_cflags) $(if $($(*F)_no_Wunused),,-Wunused) \
@MUDFLAP_TRUE@ $(if $($(*F)_no_Wformat),,-Wformat=2)
--- elfutils/src/strip.c
+++ elfutils/src/strip.c
--- elfutils-0.107.orig/src/findtextrel.c
+++ elfutils-0.107/src/findtextrel.c
@@ -476,7 +476,11 @@ ptrcompare (const void *p1, const void *
static void
-check_rel (size_t nsegments, struct segments segments[nsegments],
+check_rel (size_t nsegments, struct segments segments[
+#if __GNUC__ >= 4
+ nsegments
+#endif
+ ],
GElf_Addr addr, Elf *elf, Elf_Scn *symscn, Dwarf *dw,
const char *fname, bool more_than_one, void **knownsrcs)
{
--- elfutils-0.107.orig/src/strip.c
+++ elfutils-0.107/src/strip.c
@@ -40,6 +40,12 @@
#include <libebl.h>
#include <system.h>
@ -451,7 +469,7 @@
/* Name and version of program. */
static void print_version (FILE *stream, struct argp_state *state);
@@ -245,8 +251,18 @@ process_file (const char *fname)
@@ -269,8 +275,18 @@ process_file (const char *fname)
/* If we have to preserve the timestamp, we need it in the
format utimes() understands. */
@ -470,7 +488,7 @@
}
/* Open the file. */
@@ -1677,7 +1693,7 @@ handle_elf (int fd, Elf *elf, const char
@@ -1702,7 +1718,7 @@ handle_elf (int fd, Elf *elf, const char
/* If requested, preserve the timestamp. */
if (tvp != NULL)
{
@ -478,8 +496,8 @@
+ if (FUTIMES (fd, output_fname, tvp) != 0)
{
error (0, errno, gettext ("\
cannot set access and modification date of \"%s\""),
@@ -1734,7 +1750,7 @@ handle_ar (int fd, Elf *elf, const char
cannot set access and modification date of '%s'"),
@@ -1759,7 +1775,7 @@ handle_ar (int fd, Elf *elf, const char
if (tvp != NULL)
{
@ -487,9 +505,9 @@
+ if (unlikely (FUTIMES (fd, fname, tvp) != 0))
{
error (0, errno, gettext ("\
cannot set access and modification date of \"%s\""), fname);
--- elfutils/tests/Makefile.in
+++ elfutils/tests/Makefile.in
cannot set access and modification date of '%s'"), fname);
--- elfutils-0.107.orig/tests/Makefile.in
+++ elfutils-0.107/tests/Makefile.in
@@ -266,6 +266,7 @@ SHELL = @SHELL@
STRIP = @STRIP@
USE_NLS = @USE_NLS@

View File

@ -1,5 +1,5 @@
%define version 0.106
%define release 3
%define version 0.107
%define release 1
%define gpl 0
%if %{?_with_compat:1}%{!?_with_compat:0}
@ -24,11 +24,8 @@ License: OSL
Group: Development/Tools
#URL: file://home/devel/drepper/
Source: elfutils-%{version}.tar.gz
Patch1: elfutils-0.106-libdw-compile.patch
%if %{compat}
Patch100: elfutils-portability.patch
Patch101: elfutils-bswap.patch
%endif
Patch1: elfutils-portability.patch
Patch2: elfutils-bswap.patch
Obsoletes: libelf libelf-devel
Requires: elfutils-libelf = %{version}-%{release}
%if %{gpl}
@ -110,11 +107,9 @@ different sections of an ELF file.
%prep
%setup -q
%patch1 -p1
%if %{compat}
%patch100 -p1
%patch101 -p1
%patch1 -p1
%patch2 -p1
sleep 1
find . \( -name Makefile.in -o -name aclocal.m4 \) -print | xargs touch
sleep 1
@ -224,6 +219,12 @@ rm -rf ${RPM_BUILD_ROOT}
%{_libdir}/libelf.so
%changelog
* Sun May 8 2005 Roland McGrath <roland@redhat.com> - 0.107-1
- update to 0.107
- readelf: improve DWARF output format
- elflint: -d option to support checking separate debuginfo files
- strip: fix ET_REL debuginfo files (#156341)
* Mon Apr 4 2005 Roland McGrath <roland@redhat.com> - 0.106-3
- fix some bugs in new code, reenable make check

View File

@ -1 +1 @@
6b4a7b0e3a3f274f91095a9d95cfa635 elfutils-0.106.tar.gz
0ea806a7cc170faa225f8fc1b36dd3da elfutils-0.107.tar.gz