Update to 0.127

This commit is contained in:
roland 2007-04-19 16:28:12 +00:00
parent 53174e299e
commit 6b412c1d39
4 changed files with 1051 additions and 1057 deletions

View File

@ -11,8 +11,8 @@ elfutils-portability.patch: elfutils-$(VERSION).tar.gz
@rm -rf elfutils-master elfutils-portable @rm -rf elfutils-master elfutils-portable
$(MONOTONE) checkout -b com.redhat.elfutils elfutils-master $(MONOTONE) checkout -b com.redhat.elfutils elfutils-master
$(MONOTONE) checkout -b com.redhat.elfutils.portable elfutils-portable $(MONOTONE) checkout -b com.redhat.elfutils.portable elfutils-portable
cd elfutils-master; autoreconf; rm -rf autom4te.cache _MTN cd elfutils-master; autoreconf -i; rm -rf autom4te.cache _MTN
cd elfutils-portable; autoreconf; rm -rf autom4te.cache _MTN cd elfutils-portable; autoreconf -i; rm -rf autom4te.cache _MTN
diff -rpu elfutils-master elfutils-portable | \ diff -rpu elfutils-master elfutils-portable | \
filterdiff --remove-timestamps --strip=1 --addprefix=elfutils/ > $@.new filterdiff --remove-timestamps --strip=1 --addprefix=elfutils/ > $@.new
mv $@.new $@ mv $@.new $@

View File

@ -1,6 +1,6 @@
--- elfutils/backends/ChangeLog --- elfutils/backends/ChangeLog
+++ elfutils/backends/ChangeLog +++ elfutils/backends/ChangeLog
@@ -130,6 +130,11 @@ @@ -135,6 +135,11 @@
* sparc_init.c: Likewise. * sparc_init.c: Likewise.
* x86_64_init.c: Likewise. * x86_64_init.c: Likewise.
@ -12,7 +12,7 @@
2005-11-19 Roland McGrath <roland@redhat.com> 2005-11-19 Roland McGrath <roland@redhat.com>
* ppc64_reloc.def: REL30 -> ADDR30. * ppc64_reloc.def: REL30 -> ADDR30.
@@ -152,6 +157,9 @@ @@ -157,6 +162,9 @@
* Makefile.am (uninstall): Don't try to remove $(pkgincludedir). * Makefile.am (uninstall): Don't try to remove $(pkgincludedir).
(CLEANFILES): Add libebl_$(m).so. (CLEANFILES): Add libebl_$(m).so.
@ -121,7 +121,7 @@
* configure.ac [AH_BOTTOM] (INTDECL, _INTDECL): New macros. * configure.ac [AH_BOTTOM] (INTDECL, _INTDECL): New macros.
--- elfutils/config/Makefile.in --- elfutils/config/Makefile.in
+++ elfutils/config/Makefile.in +++ elfutils/config/Makefile.in
@@ -84,6 +84,7 @@ INSTALL_PROGRAM = @INSTALL_PROGRAM@ @@ -83,6 +83,7 @@ INSTALL_PROGRAM = @INSTALL_PROGRAM@
INSTALL_SCRIPT = @INSTALL_SCRIPT@ INSTALL_SCRIPT = @INSTALL_SCRIPT@
INSTALL_STRIP_PROGRAM = @INSTALL_STRIP_PROGRAM@ INSTALL_STRIP_PROGRAM = @INSTALL_STRIP_PROGRAM@
LDFLAGS = @LDFLAGS@ LDFLAGS = @LDFLAGS@
@ -129,7 +129,7 @@
LEX = @LEX@ LEX = @LEX@
LEXLIB = @LEXLIB@ LEXLIB = @LEXLIB@
LEX_OUTPUT_ROOT = @LEX_OUTPUT_ROOT@ LEX_OUTPUT_ROOT = @LEX_OUTPUT_ROOT@
@@ -124,6 +125,7 @@ TESTS_RPATH_FALSE = @TESTS_RPATH_FALSE@ @@ -123,6 +124,7 @@ TESTS_RPATH_FALSE = @TESTS_RPATH_FALSE@
TESTS_RPATH_TRUE = @TESTS_RPATH_TRUE@ TESTS_RPATH_TRUE = @TESTS_RPATH_TRUE@
USE_NLS = @USE_NLS@ USE_NLS = @USE_NLS@
VERSION = @VERSION@ VERSION = @VERSION@
@ -139,7 +139,7 @@
ac_ct_CC = @ac_ct_CC@ ac_ct_CC = @ac_ct_CC@
--- elfutils/configure --- elfutils/configure
+++ elfutils/configure +++ elfutils/configure
@@ -276,7 +276,7 @@ PACKAGE_STRING='Red Hat elfutils 0.126' @@ -276,7 +276,7 @@ PACKAGE_STRING='Red Hat elfutils 0.127'
PACKAGE_BUGREPORT='http://bugzilla.redhat.com/bugzilla/' PACKAGE_BUGREPORT='http://bugzilla.redhat.com/bugzilla/'
ac_unique_file="libelf/libelf.h" ac_unique_file="libelf/libelf.h"
@ -461,7 +461,7 @@
libcpu_i386_a_SOURCES = i386_dis.c libcpu_i386_a_SOURCES = i386_dis.c
--- elfutils/libdw/ChangeLog --- elfutils/libdw/ChangeLog
+++ elfutils/libdw/ChangeLog +++ elfutils/libdw/ChangeLog
@@ -329,6 +329,11 @@ @@ -370,6 +370,11 @@
2005-05-31 Roland McGrath <roland@redhat.com> 2005-05-31 Roland McGrath <roland@redhat.com>
@ -525,7 +525,7 @@
$(COMPILE))) $(COMPILE)))
--- elfutils/libdwfl/ChangeLog --- elfutils/libdwfl/ChangeLog
+++ elfutils/libdwfl/ChangeLog +++ elfutils/libdwfl/ChangeLog
@@ -409,6 +409,11 @@ @@ -474,6 +474,11 @@
2005-07-21 Roland McGrath <roland@redhat.com> 2005-07-21 Roland McGrath <roland@redhat.com>
@ -586,7 +586,7 @@
--- elfutils/libebl/ChangeLog --- elfutils/libebl/ChangeLog
+++ elfutils/libebl/ChangeLog +++ elfutils/libebl/ChangeLog
@@ -460,6 +460,11 @@ @@ -465,6 +465,11 @@
* Makefile.am (libebl_*_so_SOURCES): Set to $(*_SRCS) so dependency * Makefile.am (libebl_*_so_SOURCES): Set to $(*_SRCS) so dependency
tracking works right. tracking works right.
@ -647,7 +647,7 @@
--- elfutils/libelf/ChangeLog --- elfutils/libelf/ChangeLog
+++ elfutils/libelf/ChangeLog +++ elfutils/libelf/ChangeLog
@@ -206,6 +206,11 @@ @@ -221,6 +221,11 @@
If section content hasn't been read yet, do it before looking for the If section content hasn't been read yet, do it before looking for the
block size. If no section data present, infer size of section header. block size. If no section data present, infer size of section header.
@ -779,7 +779,7 @@
ac_ct_CC = @ac_ct_CC@ ac_ct_CC = @ac_ct_CC@
--- elfutils/src/ChangeLog --- elfutils/src/ChangeLog
+++ elfutils/src/ChangeLog +++ elfutils/src/ChangeLog
@@ -76,6 +76,10 @@ @@ -87,6 +87,10 @@
* elflint.c (valid_e_machine): Add EM_ALPHA. * elflint.c (valid_e_machine): Add EM_ALPHA.
Reported by Christian Aichinger <Greek0@gmx.net>. Reported by Christian Aichinger <Greek0@gmx.net>.
@ -790,7 +790,7 @@
2006-08-08 Ulrich Drepper <drepper@redhat.com> 2006-08-08 Ulrich Drepper <drepper@redhat.com>
* elflint.c (check_dynamic): Don't require DT_HASH for DT_SYMTAB. * elflint.c (check_dynamic): Don't require DT_HASH for DT_SYMTAB.
@@ -152,6 +156,10 @@ @@ -163,6 +167,10 @@
* Makefile.am: Add hacks to create dependency files for non-generic * Makefile.am: Add hacks to create dependency files for non-generic
linker. linker.
@ -801,7 +801,7 @@
2006-06-12 Ulrich Drepper <drepper@redhat.com> 2006-06-12 Ulrich Drepper <drepper@redhat.com>
* ldgeneric.c (ld_generic_generate_sections): Don't create .interp * ldgeneric.c (ld_generic_generate_sections): Don't create .interp
@@ -500,6 +508,11 @@ @@ -511,6 +519,11 @@
* readelf.c (print_debug_loc_section): Fix indentation for larger * readelf.c (print_debug_loc_section): Fix indentation for larger
address size. address size.
@ -962,7 +962,7 @@
cannot set access and modification date of '%s'"), fname); cannot set access and modification date of '%s'"), fname);
--- elfutils/tests/ChangeLog --- elfutils/tests/ChangeLog
+++ elfutils/tests/ChangeLog +++ elfutils/tests/ChangeLog
@@ -449,6 +449,11 @@ @@ -473,6 +473,11 @@
* Makefile.am (TESTS): Add run-elflint-test.sh. * Makefile.am (TESTS): Add run-elflint-test.sh.
(EXTRA_DIST): Add run-elflint-test.sh and testfile18.bz2. (EXTRA_DIST): Add run-elflint-test.sh and testfile18.bz2.
@ -994,7 +994,7 @@
endif endif
--- elfutils/tests/Makefile.in --- elfutils/tests/Makefile.in
+++ elfutils/tests/Makefile.in +++ elfutils/tests/Makefile.in
@@ -297,6 +297,7 @@ INSTALL_PROGRAM = @INSTALL_PROGRAM@ @@ -310,6 +310,7 @@ INSTALL_PROGRAM = @INSTALL_PROGRAM@
INSTALL_SCRIPT = @INSTALL_SCRIPT@ INSTALL_SCRIPT = @INSTALL_SCRIPT@
INSTALL_STRIP_PROGRAM = @INSTALL_STRIP_PROGRAM@ INSTALL_STRIP_PROGRAM = @INSTALL_STRIP_PROGRAM@
LDFLAGS = @LDFLAGS@ LDFLAGS = @LDFLAGS@
@ -1002,7 +1002,7 @@
LEX = @LEX@ LEX = @LEX@
LEXLIB = @LEXLIB@ LEXLIB = @LEXLIB@
LEX_OUTPUT_ROOT = @LEX_OUTPUT_ROOT@ LEX_OUTPUT_ROOT = @LEX_OUTPUT_ROOT@
@@ -337,6 +338,7 @@ TESTS_RPATH_FALSE = @TESTS_RPATH_FALSE@ @@ -350,6 +351,7 @@ TESTS_RPATH_FALSE = @TESTS_RPATH_FALSE@
TESTS_RPATH_TRUE = @TESTS_RPATH_TRUE@ TESTS_RPATH_TRUE = @TESTS_RPATH_TRUE@
USE_NLS = @USE_NLS@ USE_NLS = @USE_NLS@
VERSION = @VERSION@ VERSION = @VERSION@
@ -1010,7 +1010,7 @@
XGETTEXT = @XGETTEXT@ XGETTEXT = @XGETTEXT@
YACC = @YACC@ YACC = @YACC@
ac_ct_CC = @ac_ct_CC@ ac_ct_CC = @ac_ct_CC@
@@ -378,10 +380,10 @@ sbindir = @sbindir@ @@ -391,10 +393,10 @@ sbindir = @sbindir@
sharedstatedir = @sharedstatedir@ sharedstatedir = @sharedstatedir@
sysconfdir = @sysconfdir@ sysconfdir = @sysconfdir@
target_alias = @target_alias@ target_alias = @target_alias@

File diff suppressed because it is too large Load Diff

View File

@ -1,4 +1,4 @@
%define eu_version 0.126 %define eu_version 0.127
%define eu_release 1 %define eu_release 1
%if %{?_with_compat:1}%{!?_with_compat:0} %if %{?_with_compat:1}%{!?_with_compat:0}
@ -14,7 +14,7 @@
%define separate_devel_static 1 %define separate_devel_static 1
%endif %endif
Summary: A collection of utilities and DSOs to handle compiled objects. Summary: A collection of utilities and DSOs to handle compiled objects
Name: elfutils Name: elfutils
Version: %{eu_version} Version: %{eu_version}
%if !%{compat} %if !%{compat}
@ -35,9 +35,7 @@ Patch0: elfutils-strip-copy-symtab.patch
Source2: testfile16.symtab.bz2 Source2: testfile16.symtab.bz2
Source3: testfile16.symtab.debug.bz2 Source3: testfile16.symtab.debug.bz2
# ExcludeArch: xxx BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
BuildRoot: %{_tmppath}/%{name}-root
BuildRequires: bison >= 1.875 BuildRequires: bison >= 1.875
BuildRequires: flex >= 2.5.4a BuildRequires: flex >= 2.5.4a
BuildRequires: bzip2 BuildRequires: bzip2
@ -146,8 +144,8 @@ Conflicts: elfutils-libelf-devel < %{version}-%{release}
Conflicts: elfutils-libelf-devel > %{version}-%{release} Conflicts: elfutils-libelf-devel > %{version}-%{release}
%description libelf-devel-static %description libelf-devel-static
The elfutils-libelf-devel-static package contains The elfutils-libelf-static package contains the static archive
the static archive for libelf. for libelf.
%prep %prep
%setup -q %setup -q
@ -182,9 +180,7 @@ make -s %{?_smp_mflags}
%install %install
rm -rf ${RPM_BUILD_ROOT} rm -rf ${RPM_BUILD_ROOT}
mkdir -p ${RPM_BUILD_ROOT}%{_prefix} make -s install DESTDIR=${RPM_BUILD_ROOT}
%makeinstall
chmod +x ${RPM_BUILD_ROOT}%{_prefix}/%{_lib}/lib*.so* chmod +x ${RPM_BUILD_ROOT}%{_prefix}/%{_lib}/lib*.so*
chmod +x ${RPM_BUILD_ROOT}%{_prefix}/%{_lib}/elfutils/lib*.so* chmod +x ${RPM_BUILD_ROOT}%{_prefix}/%{_lib}/elfutils/lib*.so*
@ -200,7 +196,7 @@ chmod +x ${RPM_BUILD_ROOT}%{_prefix}/%{_lib}/elfutils/lib*.so*
} }
%check %check
make check make -s check
%clean %clean
rm -rf ${RPM_BUILD_ROOT} rm -rf ${RPM_BUILD_ROOT}
@ -271,6 +267,12 @@ rm -rf ${RPM_BUILD_ROOT}
%{_libdir}/libelf.a %{_libdir}/libelf.a
%changelog %changelog
* Wed Apr 18 2007 Roland McGrath <roland@redhat.com> - 0.127-1
- Update to 0.127
- libdw: new function dwarf_getsrcdirs
- libdwfl: new functions dwfl_module_addrsym, dwfl_report_begin_add,
dwfl_module_address_section
* Mon Feb 5 2007 Roland McGrath <roland@redhat.com> - 0.126-1 * Mon Feb 5 2007 Roland McGrath <roland@redhat.com> - 0.126-1
- Update to 0.126 - Update to 0.126
- New program eu-ar. - New program eu-ar.