New upstream version 0.117

This commit is contained in:
roland 2005-11-22 19:43:54 +00:00
parent 7a7abf842b
commit 418cfd0655
2 changed files with 325 additions and 189 deletions

View File

@ -1,6 +1,57 @@
--- elfutils/backends/ChangeLog
+++ elfutils/backends/ChangeLog
@@ -20,6 +20,9 @@
* Makefile.am (uninstall): Don't try to remove $(pkgincludedir).
(CLEANFILES): Add libebl_$(m).so.
+ * Makefile.am (WEXTRA): New variable, substituted by configure.
+ (AM_CFLAGS): Use it in place of -Wextra.
+
* ppc_reloc.def: Update bits per Alan Modra <amodra@bigpond.net.au>.
* ppc64_reloc.def: Likewise.
--- elfutils/backends/Makefile.am
+++ elfutils/backends/Makefile.am
@@ -13,12 +13,13 @@
## 3001 King Ranch Road, Ukiah, CA 95482.
##
DEFS = -D_GNU_SOURCE -DHAVE_CONFIG_H -DOBJDIR=\"$(shell pwd)\"
+WEXTRA = @WEXTRA@
if MUDFLAP
AM_CFLAGS = -fmudflap
else
AM_CFLAGS =
endif
-AM_CFLAGS += -fpic -Wall -Wshadow -Werror -Wunused -Wextra -Wformat=2 \
+AM_CFLAGS += -fpic -Wall -Wshadow -Werror -Wunused $(WEXTRA) -Wformat=2 \
-std=gnu99
INCLUDES = -I$(srcdir) -I$(top_srcdir)/libebl \
-I$(top_srcdir)/libelf -I$(top_srcdir)/libdw \
--- elfutils/backends/Makefile.in
+++ elfutils/backends/Makefile.in
@@ -191,6 +191,7 @@ TESTS_RPATH_FALSE = @TESTS_RPATH_FALSE@
TESTS_RPATH_TRUE = @TESTS_RPATH_TRUE@
USE_NLS = @USE_NLS@
VERSION = @VERSION@
+WEXTRA = @WEXTRA@
XGETTEXT = @XGETTEXT@
YACC = @YACC@
ac_ct_CC = @ac_ct_CC@
@@ -233,9 +234,9 @@ sharedstatedir = @sharedstatedir@
sysconfdir = @sysconfdir@
target_alias = @target_alias@
@MUDFLAP_FALSE@AM_CFLAGS = -fpic -Wall -Wshadow -Werror -Wunused \
-@MUDFLAP_FALSE@ -Wextra -Wformat=2 -std=gnu99
+@MUDFLAP_FALSE@ $(WEXTRA) -Wformat=2 -std=gnu99
@MUDFLAP_TRUE@AM_CFLAGS = -fmudflap -fpic -Wall -Wshadow -Werror \
-@MUDFLAP_TRUE@ -Wunused -Wextra -Wformat=2 -std=gnu99
+@MUDFLAP_TRUE@ -Wunused $(WEXTRA) -Wformat=2 -std=gnu99
INCLUDES = -I$(srcdir) -I$(top_srcdir)/libebl \
-I$(top_srcdir)/libelf -I$(top_srcdir)/libdw \
-I$(top_srcdir)/lib -I..
--- elfutils/ChangeLog
+++ elfutils/ChangeLog
@@ -29,6 +29,17 @@
@@ -45,6 +45,17 @@
* Makefile.am (all_SUBDIRS): Add libdwfl.
* configure.ac: Write libdwfl/Makefile.
@ -20,8 +71,8 @@
* configure.ac [AH_BOTTOM] (INTDECL, _INTDECL): New macros.
--- elfutils/config/Makefile.in
+++ elfutils/config/Makefile.in
@@ -113,6 +113,7 @@ SHELL = @SHELL@
STRIP = @STRIP@
@@ -119,6 +119,7 @@ TESTS_RPATH_FALSE = @TESTS_RPATH_FALSE@
TESTS_RPATH_TRUE = @TESTS_RPATH_TRUE@
USE_NLS = @USE_NLS@
VERSION = @VERSION@
+WEXTRA = @WEXTRA@
@ -30,16 +81,16 @@
ac_ct_CC = @ac_ct_CC@
--- elfutils/configure
+++ elfutils/configure
@@ -276,7 +276,7 @@ PACKAGE_STRING='Red Hat elfutils 0.115'
@@ -276,7 +276,7 @@ PACKAGE_STRING='Red Hat elfutils 0.117'
PACKAGE_BUGREPORT='http://bugzilla.redhat.com/bugzilla/'
ac_unique_file="libelf/libelf.h"
-ac_subst_vars='SHELL PATH_SEPARATOR PACKAGE_NAME PACKAGE_TARNAME PACKAGE_VERSION PACKAGE_STRING PACKAGE_BUGREPORT exec_prefix prefix program_transform_name bindir sbindir libexecdir datadir sysconfdir sharedstatedir localstatedir libdir includedir oldincludedir infodir mandir build_alias host_alias target_alias DEFS ECHO_C ECHO_N ECHO_T LIBS INSTALL_PROGRAM INSTALL_SCRIPT INSTALL_DATA CYGPATH_W PACKAGE VERSION ACLOCAL AUTOCONF AUTOMAKE AUTOHEADER MAKEINFO install_sh STRIP ac_ct_STRIP INSTALL_STRIP_PROGRAM mkdir_p AWK SET_MAKE am__leading_dot AMTAR am__tar am__untar MODVERSION build build_cpu build_vendor build_os host host_cpu host_vendor host_os CC CFLAGS LDFLAGS CPPFLAGS ac_ct_CC EXEEXT OBJEXT DEPDIR am__include am__quote AMDEP_TRUE AMDEP_FALSE AMDEPBACKSLASH CCDEPMODE am__fastdepCC_TRUE am__fastdepCC_FALSE RANLIB ac_ct_RANLIB YACC LEX LEXLIB LEX_OUTPUT_ROOT LOCALEDIR DATADIRNAME NATIVE_LD_TRUE NATIVE_LD_FALSE base_cpu MUDFLAP_TRUE MUDFLAP_FALSE GPROF_TRUE GPROF_FALSE GCOV_TRUE GCOV_FALSE BUILD_STATIC_TRUE BUILD_STATIC_FALSE LIBEBL_SUBDIR USE_NLS MKINSTALLDIRS MSGFMT GMSGFMT XGETTEXT MSGMERGE LIBOBJS LTLIBOBJS'
+ac_subst_vars='SHELL PATH_SEPARATOR PACKAGE_NAME PACKAGE_TARNAME PACKAGE_VERSION PACKAGE_STRING PACKAGE_BUGREPORT exec_prefix prefix program_transform_name bindir sbindir libexecdir datadir sysconfdir sharedstatedir localstatedir libdir includedir oldincludedir infodir mandir build_alias host_alias target_alias DEFS ECHO_C ECHO_N ECHO_T LIBS INSTALL_PROGRAM INSTALL_SCRIPT INSTALL_DATA CYGPATH_W PACKAGE VERSION ACLOCAL AUTOCONF AUTOMAKE AUTOHEADER MAKEINFO install_sh STRIP ac_ct_STRIP INSTALL_STRIP_PROGRAM mkdir_p AWK SET_MAKE am__leading_dot AMTAR am__tar am__untar MODVERSION build build_cpu build_vendor build_os host host_cpu host_vendor host_os CC CFLAGS LDFLAGS CPPFLAGS ac_ct_CC EXEEXT OBJEXT DEPDIR am__include am__quote AMDEP_TRUE AMDEP_FALSE AMDEPBACKSLASH CCDEPMODE am__fastdepCC_TRUE am__fastdepCC_FALSE RANLIB ac_ct_RANLIB YACC LEX LEXLIB LEX_OUTPUT_ROOT WEXTRA LOCALEDIR DATADIRNAME NATIVE_LD_TRUE NATIVE_LD_FALSE base_cpu MUDFLAP_TRUE MUDFLAP_FALSE GPROF_TRUE GPROF_FALSE GCOV_TRUE GCOV_FALSE BUILD_STATIC_TRUE BUILD_STATIC_FALSE LIBEBL_SUBDIR USE_NLS MKINSTALLDIRS MSGFMT GMSGFMT XGETTEXT MSGMERGE LIBOBJS LTLIBOBJS'
-ac_subst_vars='SHELL PATH_SEPARATOR PACKAGE_NAME PACKAGE_TARNAME PACKAGE_VERSION PACKAGE_STRING PACKAGE_BUGREPORT exec_prefix prefix program_transform_name bindir sbindir libexecdir datadir sysconfdir sharedstatedir localstatedir libdir includedir oldincludedir infodir mandir build_alias host_alias target_alias DEFS ECHO_C ECHO_N ECHO_T LIBS INSTALL_PROGRAM INSTALL_SCRIPT INSTALL_DATA CYGPATH_W PACKAGE VERSION ACLOCAL AUTOCONF AUTOMAKE AUTOHEADER MAKEINFO install_sh STRIP ac_ct_STRIP INSTALL_STRIP_PROGRAM mkdir_p AWK SET_MAKE am__leading_dot AMTAR am__tar am__untar MODVERSION build build_cpu build_vendor build_os host host_cpu host_vendor host_os CC CFLAGS LDFLAGS CPPFLAGS ac_ct_CC EXEEXT OBJEXT DEPDIR am__include am__quote AMDEP_TRUE AMDEP_FALSE AMDEPBACKSLASH CCDEPMODE am__fastdepCC_TRUE am__fastdepCC_FALSE RANLIB ac_ct_RANLIB YACC LEX LEXLIB LEX_OUTPUT_ROOT LOCALEDIR DATADIRNAME NATIVE_LD_TRUE NATIVE_LD_FALSE base_cpu MUDFLAP_TRUE MUDFLAP_FALSE GPROF_TRUE GPROF_FALSE GCOV_TRUE GCOV_FALSE BUILD_STATIC_TRUE BUILD_STATIC_FALSE TESTS_RPATH_TRUE TESTS_RPATH_FALSE LIBEBL_SUBDIR HAVE_LIBASM_TRUE HAVE_LIBASM_FALSE STANDALONE_TRUE STANDALONE_FALSE USE_NLS MKINSTALLDIRS MSGFMT GMSGFMT XGETTEXT MSGMERGE LIBOBJS LTLIBOBJS'
+ac_subst_vars='SHELL PATH_SEPARATOR PACKAGE_NAME PACKAGE_TARNAME PACKAGE_VERSION PACKAGE_STRING PACKAGE_BUGREPORT exec_prefix prefix program_transform_name bindir sbindir libexecdir datadir sysconfdir sharedstatedir localstatedir libdir includedir oldincludedir infodir mandir build_alias host_alias target_alias DEFS ECHO_C ECHO_N ECHO_T LIBS INSTALL_PROGRAM INSTALL_SCRIPT INSTALL_DATA CYGPATH_W PACKAGE VERSION ACLOCAL AUTOCONF AUTOMAKE AUTOHEADER MAKEINFO install_sh STRIP ac_ct_STRIP INSTALL_STRIP_PROGRAM mkdir_p AWK SET_MAKE am__leading_dot AMTAR am__tar am__untar MODVERSION build build_cpu build_vendor build_os host host_cpu host_vendor host_os CC CFLAGS LDFLAGS CPPFLAGS ac_ct_CC EXEEXT OBJEXT DEPDIR am__include am__quote AMDEP_TRUE AMDEP_FALSE AMDEPBACKSLASH CCDEPMODE am__fastdepCC_TRUE am__fastdepCC_FALSE RANLIB ac_ct_RANLIB YACC LEX LEXLIB LEX_OUTPUT_ROOT WEXTRA LOCALEDIR DATADIRNAME NATIVE_LD_TRUE NATIVE_LD_FALSE base_cpu MUDFLAP_TRUE MUDFLAP_FALSE GPROF_TRUE GPROF_FALSE GCOV_TRUE GCOV_FALSE BUILD_STATIC_TRUE BUILD_STATIC_FALSE TESTS_RPATH_TRUE TESTS_RPATH_FALSE LIBEBL_SUBDIR HAVE_LIBASM_TRUE HAVE_LIBASM_FALSE STANDALONE_TRUE STANDALONE_FALSE USE_NLS MKINSTALLDIRS MSGFMT GMSGFMT XGETTEXT MSGMERGE LIBOBJS LTLIBOBJS'
ac_subst_files=''
# Initialize some variables set by options.
@@ -3384,6 +3384,58 @@ echo "$as_me: error: gcc with C99 suppor
@@ -3385,6 +3385,58 @@ echo "$as_me: error: gcc with C99 suppor
fi
@ -98,7 +149,7 @@
LOCALEDIR=$datadir
cat >>confdefs.h <<_ACEOF
@@ -4925,6 +4977,7 @@ s,@YACC@,$YACC,;t t
@@ -4987,6 +5039,7 @@ s,@YACC@,$YACC,;t t
s,@LEX@,$LEX,;t t
s,@LEXLIB@,$LEXLIB,;t t
s,@LEX_OUTPUT_ROOT@,$LEX_OUTPUT_ROOT,;t t
@ -157,15 +208,15 @@
noinst_LIBRARIES = libeu.a
--- elfutils/lib/Makefile.in
+++ elfutils/lib/Makefile.in
@@ -135,6 +135,7 @@ SHELL = @SHELL@
STRIP = @STRIP@
@@ -141,6 +141,7 @@ TESTS_RPATH_FALSE = @TESTS_RPATH_FALSE@
TESTS_RPATH_TRUE = @TESTS_RPATH_TRUE@
USE_NLS = @USE_NLS@
VERSION = @VERSION@
+WEXTRA = @WEXTRA@
XGETTEXT = @XGETTEXT@
YACC = @YACC@
ac_ct_CC = @ac_ct_CC@
@@ -177,9 +178,9 @@ sharedstatedir = @sharedstatedir@
@@ -183,9 +184,9 @@ sharedstatedir = @sharedstatedir@
sysconfdir = @sysconfdir@
target_alias = @target_alias@
@MUDFLAP_FALSE@AM_CFLAGS = -fpic -Wall -Wshadow -Werror -Wunused \
@ -179,7 +230,7 @@
libeu_a_SOURCES = xstrdup.c xstrndup.c xmalloc.c next_prime.c \
--- elfutils/libasm/ChangeLog
+++ elfutils/libasm/ChangeLog
@@ -24,6 +24,11 @@
@@ -28,6 +28,11 @@
* asm_error.c: Add new error ASM_E_IOERROR.
* libasmP.h: Add ASM_E_IOERROR definition.
@ -205,20 +256,20 @@
endif
-AM_CFLAGS += -std=gnu99 -Wall -Wshadow -Werror -Wunused -Wextra -Wformat=2
+AM_CFLAGS += -std=gnu99 -Wall -Wshadow -Werror -Wunused $(WEXTRA) -Wformat=2
INCLUDES = -I. -I$(srcdir) -I.. -I$(top_srcdir)/libelf -I$(top_srcdir)/libebl \
INCLUDES = -I. -I$(srcdir) -I.. \
-I$(top_srcdir)/libelf -I$(top_srcdir)/libebl -I$(top_srcdir)/libdw\
-I$(top_srcdir)/lib
GCC_INCLUDE = -I$(shell $(CC) -print-file-name=include)
--- elfutils/libasm/Makefile.in
+++ elfutils/libasm/Makefile.in
@@ -167,6 +167,7 @@ SHELL = @SHELL@
STRIP = @STRIP@
@@ -173,6 +173,7 @@ TESTS_RPATH_FALSE = @TESTS_RPATH_FALSE@
TESTS_RPATH_TRUE = @TESTS_RPATH_TRUE@
USE_NLS = @USE_NLS@
VERSION = 1
+WEXTRA = @WEXTRA@
XGETTEXT = @XGETTEXT@
YACC = @YACC@
ac_ct_CC = @ac_ct_CC@
@@ -209,9 +210,9 @@ sharedstatedir = @sharedstatedir@
@@ -215,9 +216,9 @@ sharedstatedir = @sharedstatedir@
sysconfdir = @sysconfdir@
target_alias = @target_alias@
@MUDFLAP_FALSE@AM_CFLAGS = -std=gnu99 -Wall -Wshadow -Werror -Wunused \
@ -227,9 +278,9 @@
@MUDFLAP_TRUE@AM_CFLAGS = -fmudflap -std=gnu99 -Wall -Wshadow -Werror \
-@MUDFLAP_TRUE@ -Wunused -Wextra -Wformat=2
+@MUDFLAP_TRUE@ -Wunused $(WEXTRA) -Wformat=2
INCLUDES = -I. -I$(srcdir) -I.. -I$(top_srcdir)/libelf -I$(top_srcdir)/libebl \
INCLUDES = -I. -I$(srcdir) -I.. \
-I$(top_srcdir)/libelf -I$(top_srcdir)/libebl -I$(top_srcdir)/libdw\
-I$(top_srcdir)/lib
--- elfutils/libcpu/ChangeLog
+++ elfutils/libcpu/ChangeLog
@@ -1,3 +1,8 @@
@ -255,15 +306,15 @@
noinst_LIBRARIES = libcpu_i386.a
--- elfutils/libcpu/Makefile.in
+++ elfutils/libcpu/Makefile.in
@@ -130,6 +130,7 @@ SHELL = @SHELL@
STRIP = @STRIP@
@@ -136,6 +136,7 @@ TESTS_RPATH_FALSE = @TESTS_RPATH_FALSE@
TESTS_RPATH_TRUE = @TESTS_RPATH_TRUE@
USE_NLS = @USE_NLS@
VERSION = @VERSION@
+WEXTRA = @WEXTRA@
XGETTEXT = @XGETTEXT@
YACC = @YACC@
ac_ct_CC = @ac_ct_CC@
@@ -171,7 +172,7 @@ sbindir = @sbindir@
@@ -177,7 +178,7 @@ sbindir = @sbindir@
sharedstatedir = @sharedstatedir@
sysconfdir = @sysconfdir@
target_alias = @target_alias@
@ -274,7 +325,7 @@
libcpu_i386_a_SOURCES = i386_dis.c
--- elfutils/libdw/ChangeLog
+++ elfutils/libdw/ChangeLog
@@ -239,6 +239,11 @@
@@ -247,6 +247,11 @@
2005-05-31 Roland McGrath <roland@redhat.com>
@ -288,7 +339,7 @@
--- elfutils/libdw/Makefile.am
+++ elfutils/libdw/Makefile.am
@@ -13,12 +13,13 @@
@@ -13,6 +13,7 @@
## 3001 King Ranch Road, Ukiah, CA 95482.
##
DEFS = -D_GNU_SOURCE -DHAVE_CONFIG_H -DIS_LIBDW
@ -296,7 +347,9 @@
if MUDFLAP
AM_CFLAGS = -fmudflap
else
AM_CFLAGS =
@@ -21,7 +22,7 @@ endif
if BUILD_STATIC
AM_CFLAGS += -fpic
endif
-AM_CFLAGS += -Wall -Werror -Wshadow -Wunused -Wformat=2 -Wextra -std=gnu99
+AM_CFLAGS += -Wall -Werror -Wshadow -Wunused -Wformat=2 $(WEXTRA) -std=gnu99
@ -305,29 +358,30 @@
--- elfutils/libdw/Makefile.in
+++ elfutils/libdw/Makefile.in
@@ -206,6 +206,7 @@ SHELL = @SHELL@
STRIP = @STRIP@
@@ -213,6 +213,7 @@ TESTS_RPATH_FALSE = @TESTS_RPATH_FALSE@
TESTS_RPATH_TRUE = @TESTS_RPATH_TRUE@
USE_NLS = @USE_NLS@
VERSION = 1
+WEXTRA = @WEXTRA@
XGETTEXT = @XGETTEXT@
YACC = @YACC@
ac_ct_CC = @ac_ct_CC@
@@ -248,9 +249,9 @@ sharedstatedir = @sharedstatedir@
@@ -255,9 +256,10 @@ sharedstatedir = @sharedstatedir@
sysconfdir = @sysconfdir@
target_alias = @target_alias@
@MUDFLAP_FALSE@AM_CFLAGS = -Wall -Werror -Wshadow -Wunused -Wformat=2 \
-@MUDFLAP_FALSE@ -Wextra -std=gnu99
+@MUDFLAP_FALSE@ $(WEXTRA) -std=gnu99
@MUDFLAP_TRUE@AM_CFLAGS = -fmudflap -Wall -Werror -Wshadow -Wunused \
-@MUDFLAP_TRUE@ -Wformat=2 -Wextra -std=gnu99
+@MUDFLAP_TRUE@ -Wformat=2 $(WEXTRA) -std=gnu99
@MUDFLAP_FALSE@AM_CFLAGS = $(am__append_1) -Wall -Werror -Wshadow \
-@MUDFLAP_FALSE@ -Wunused -Wformat=2 -Wextra -std=gnu99
+@MUDFLAP_FALSE@ -Wunused -Wformat=2 $(WEXTRA) -std=gnu99
@MUDFLAP_TRUE@AM_CFLAGS = -fmudflap $(am__append_1) -Wall -Werror \
-@MUDFLAP_TRUE@ -Wshadow -Wunused -Wformat=2 -Wextra -std=gnu99
+@MUDFLAP_TRUE@ -Wshadow -Wunused -Wformat=2 $(WEXTRA) \
+@MUDFLAP_TRUE@ -std=gnu99
INCLUDES = -I. -I$(srcdir) -I$(srcdir)/../libelf -I.. -I$(srcdir)/../lib
COMPILE.os = $(filter-out -fprofile-arcs, $(filter-out -ftest-coverage, \
$(COMPILE)))
--- elfutils/libdwfl/ChangeLog
+++ elfutils/libdwfl/ChangeLog
@@ -210,6 +210,11 @@
@@ -223,6 +223,11 @@
2005-07-21 Roland McGrath <roland@redhat.com>
@ -358,15 +412,15 @@
VERSION = 1
--- elfutils/libdwfl/Makefile.in
+++ elfutils/libdwfl/Makefile.in
@@ -163,6 +163,7 @@ SHELL = @SHELL@
STRIP = @STRIP@
@@ -170,6 +170,7 @@ TESTS_RPATH_FALSE = @TESTS_RPATH_FALSE@
TESTS_RPATH_TRUE = @TESTS_RPATH_TRUE@
USE_NLS = @USE_NLS@
VERSION = 1
+WEXTRA = @WEXTRA@
XGETTEXT = @XGETTEXT@
YACC = @YACC@
ac_ct_CC = @ac_ct_CC@
@@ -205,9 +206,9 @@ sharedstatedir = @sharedstatedir@
@@ -212,9 +213,9 @@ sharedstatedir = @sharedstatedir@
sysconfdir = @sysconfdir@
target_alias = @target_alias@
@MUDFLAP_FALSE@AM_CFLAGS = -Wall -Werror -Wshadow -Wunused -Wformat=2 \
@ -380,7 +434,7 @@
--- elfutils/libebl/ChangeLog
+++ elfutils/libebl/ChangeLog
@@ -152,6 +152,11 @@
@@ -391,6 +391,11 @@
* Makefile.am (libebl_*_so_SOURCES): Set to $(*_SRCS) so dependency
tracking works right.
@ -408,18 +462,18 @@
+AM_CFLAGS += -fpic -Wall -Wshadow -Werror -Wunused $(WEXTRA) -Wformat=2 \
-std=gnu99
INCLUDES = -I$(srcdir) -I$(top_srcdir)/libelf -I$(top_srcdir)/lib -I..
INCLUDES = -I$(srcdir) -I$(top_srcdir)/libelf -I$(top_srcdir)/libdw \
--- elfutils/libebl/Makefile.in
+++ elfutils/libebl/Makefile.in
@@ -258,6 +258,7 @@ SHELL = @SHELL@
STRIP = @STRIP@
@@ -166,6 +166,7 @@ TESTS_RPATH_FALSE = @TESTS_RPATH_FALSE@
TESTS_RPATH_TRUE = @TESTS_RPATH_TRUE@
USE_NLS = @USE_NLS@
VERSION = 1
+WEXTRA = @WEXTRA@
XGETTEXT = @XGETTEXT@
YACC = @YACC@
ac_ct_CC = @ac_ct_CC@
@@ -300,9 +301,9 @@ sharedstatedir = @sharedstatedir@
@@ -208,9 +209,9 @@ sharedstatedir = @sharedstatedir@
sysconfdir = @sysconfdir@
target_alias = @target_alias@
@MUDFLAP_FALSE@AM_CFLAGS = -fpic -Wall -Wshadow -Werror -Wunused \
@ -428,12 +482,12 @@
@MUDFLAP_TRUE@AM_CFLAGS = -fmudflap -fpic -Wall -Wshadow -Werror \
-@MUDFLAP_TRUE@ -Wunused -Wextra -Wformat=2 -std=gnu99
+@MUDFLAP_TRUE@ -Wunused $(WEXTRA) -Wformat=2 -std=gnu99
INCLUDES = -I$(srcdir) -I$(top_srcdir)/libelf -I$(top_srcdir)/lib -I..
lib_LIBRARIES = libebl.a
modules = i386 sh x86_64 ia64 alpha arm sparc ppc ppc64
INCLUDES = -I$(srcdir) -I$(top_srcdir)/libelf -I$(top_srcdir)/libdw \
-I$(top_srcdir)/lib -I..
--- elfutils/libelf/ChangeLog
+++ elfutils/libelf/ChangeLog
@@ -91,6 +91,11 @@
@@ -103,6 +103,11 @@
If section content hasn't been read yet, do it before looking for the
block size. If no section data present, infer size of section header.
@ -498,15 +552,15 @@
@MUDFLAP_FALSE@noinst_PROGRAMS = $(am__EXEEXT_1)
@MUDFLAP_TRUE@am_libelf_pic_a_OBJECTS =
subdir = libelf
@@ -210,6 +210,7 @@ SHELL = @SHELL@
STRIP = @STRIP@
@@ -216,6 +216,7 @@ TESTS_RPATH_FALSE = @TESTS_RPATH_FALSE@
TESTS_RPATH_TRUE = @TESTS_RPATH_TRUE@
USE_NLS = @USE_NLS@
VERSION = 1
+WEXTRA = @WEXTRA@
XGETTEXT = @XGETTEXT@
YACC = @YACC@
ac_ct_CC = @ac_ct_CC@
@@ -252,10 +253,10 @@ sharedstatedir = @sharedstatedir@
@@ -258,10 +259,10 @@ sharedstatedir = @sharedstatedir@
sysconfdir = @sysconfdir@
target_alias = @target_alias@
@MUDFLAP_FALSE@AM_CFLAGS = $(am__append_1) -Wall -Wshadow -Werror \
@ -521,8 +575,8 @@
GCC_INCLUDE = -I$(shell $(CC) -print-file-name=include)
--- elfutils/m4/Makefile.in
+++ elfutils/m4/Makefile.in
@@ -111,6 +111,7 @@ SHELL = @SHELL@
STRIP = @STRIP@
@@ -117,6 +117,7 @@ TESTS_RPATH_FALSE = @TESTS_RPATH_FALSE@
TESTS_RPATH_TRUE = @TESTS_RPATH_TRUE@
USE_NLS = @USE_NLS@
VERSION = @VERSION@
+WEXTRA = @WEXTRA@
@ -531,8 +585,8 @@
ac_ct_CC = @ac_ct_CC@
--- elfutils/Makefile.in
+++ elfutils/Makefile.in
@@ -135,6 +135,7 @@ SHELL = @SHELL@
STRIP = @STRIP@
@@ -141,6 +141,7 @@ TESTS_RPATH_FALSE = @TESTS_RPATH_FALSE@
TESTS_RPATH_TRUE = @TESTS_RPATH_TRUE@
USE_NLS = @USE_NLS@
VERSION = @VERSION@
+WEXTRA = @WEXTRA@
@ -589,15 +643,15 @@
INCLUDES = -I$(srcdir) -I$(srcdir)/../libelf -I$(srcdir)/../libebl \
--- elfutils/src/Makefile.in
+++ elfutils/src/Makefile.in
@@ -221,6 +221,7 @@ SHELL = @SHELL@
STRIP = @STRIP@
@@ -227,6 +227,7 @@ TESTS_RPATH_FALSE = @TESTS_RPATH_FALSE@
TESTS_RPATH_TRUE = @TESTS_RPATH_TRUE@
USE_NLS = @USE_NLS@
VERSION = @VERSION@
+WEXTRA = @WEXTRA@
XGETTEXT = @XGETTEXT@
YACC = @YACC@ -d
ac_ct_CC = @ac_ct_CC@
@@ -265,12 +266,12 @@ target_alias = @target_alias@
@@ -271,12 +272,12 @@ target_alias = @target_alias@
@MUDFLAP_FALSE@AM_CFLAGS = -Wall -Wshadow -std=gnu99 \
@MUDFLAP_FALSE@ $(native_ld_cflags) $(if \
@MUDFLAP_FALSE@ $($(*F)_no_Werror),,-Werror) $(if \
@ -666,7 +720,7 @@
cannot set access and modification date of '%s'"), fname);
--- elfutils/tests/ChangeLog
+++ elfutils/tests/ChangeLog
@@ -181,6 +181,11 @@
@@ -295,6 +295,11 @@
* Makefile.am (TESTS): Add run-elflint-test.sh.
(EXTRA_DIST): Add run-elflint-test.sh and testfile18.bz2.
@ -689,24 +743,24 @@
-AM_CFLAGS = -Wall -Werror -Wextra -std=gnu99 -fmudflap\
+AM_CFLAGS = -Wall -Werror $(WEXTRA) -std=gnu99 -fmudflap\
$(if $($(*F)_no_Wformat),-Wno-format,-Wformat=2)
AM_LDFLAGS = -Wl,-rpath,\$$ORIGIN/../libebl
BUILD_RPATH = \$$ORIGIN/../backends
else
-AM_CFLAGS = -Wall -Werror -Wextra -std=gnu99 \
+AM_CFLAGS = -Wall -Werror $(WEXTRA) -std=gnu99 \
$(if $($(*F)_no_Wformat),-Wno-format,-Wformat=2)
AM_LDFLAGS = -Wl,-rpath,\$$ORIGIN/../libasm:\$$ORIGIN/../libdw:\$$ORIGIN/../libebl:\$$ORIGIN/../libelf
BUILT_RPATH = \$$ORIGIN/../libasm:\$$ORIGIN/../libdw:\$$ORIGIN/../backends:\$$ORIGIN/../libelf
endif
--- elfutils/tests/Makefile.in
+++ elfutils/tests/Makefile.in
@@ -291,6 +291,7 @@ SHELL = @SHELL@
STRIP = @STRIP@
@@ -315,6 +315,7 @@ TESTS_RPATH_FALSE = @TESTS_RPATH_FALSE@
TESTS_RPATH_TRUE = @TESTS_RPATH_TRUE@
USE_NLS = @USE_NLS@
VERSION = @VERSION@
+WEXTRA = @WEXTRA@
XGETTEXT = @XGETTEXT@
YACC = @YACC@
ac_ct_CC = @ac_ct_CC@
@@ -332,10 +333,10 @@ sbindir = @sbindir@
@@ -356,10 +357,10 @@ sbindir = @sbindir@
sharedstatedir = @sharedstatedir@
sysconfdir = @sysconfdir@
target_alias = @target_alias@
@ -718,4 +772,4 @@
+@MUDFLAP_TRUE@AM_CFLAGS = -Wall -Werror $(WEXTRA) -std=gnu99 -fmudflap\
@MUDFLAP_TRUE@ $(if $($(*F)_no_Wformat),-Wno-format,-Wformat=2)
@MUDFLAP_FALSE@AM_LDFLAGS = -Wl,-rpath,\$$ORIGIN/../libasm:\$$ORIGIN/../libdw:\$$ORIGIN/../libebl:\$$ORIGIN/../libelf
@MUDFLAP_TRUE@BUILD_RPATH = \$$ORIGIN/../backends

View File

@ -1,53 +1,89 @@
# -*- rpm-spec-*-
%define fake 0
%define version 0.117
%define release 1
%define gpl 0
%if %{?_with_compat:1}%{!?_with_compat:0}
%define compat 1
%else
%define compat 0
%endif
Summary: A collection of utilities and DSOs to handle compiled objects.
Name: elfutils
Version: 0.117
Release: 1
%if %{fake}
Version: %{version}
%if !%{compat}
Release: %{release}
%else
Release: 0.%{release}
%endif
%if %{gpl}
License: GPL
%else
License: OSL
%endif
Group: Development/Tools
#URL: file://home/devel/drepper/
Source: elfutils-%{version}.tar.gz
Patch1: elfutils-portability.patch
Patch2: elfutils-robustify.patch
Obsoletes: libelf libelf-devel
Requires: elfutils-libelf = %{version}-%{release}
%if %{fake}
Requires: elfutils-libs = %{version}-%{release}
%if %{gpl}
Requires: binutils >= 2.14.90.0.4-26.2
%endif
Requires: glibc >= 2.3.1-2
# ExcludeArch: xxx
BuildRoot: %{_tmppath}/%{name}-root
BuildRequires: gcc >= 3.4
BuildRequires: bison >= 1.875
BuildRequires: flex >= 2.5.4a
BuildRequires: bzip2
%if !%{compat}
BuildRequires: gcc >= 3.4
# Need <byteswap.h> that gives unsigned bswap_16 etc.
BuildRequires: glibc-headers >= 2.3.4-11
%else
BuildRequires: gcc >= 3.2
%endif
%define _gnu %{nil}
%define _programprefix eu-
%define _program_prefix eu-
%description
Elfutils is a collection of utilities, including ld (a linker),
nm (for listing symbols from object files), size (for listing the
section sizes of an object or archive file), strip (for discarding
symbols), readelf (to see the raw ELF file structures), and elflint
(to check for well-formed ELF files). Also included are numerous
helper libraries which implement DWARF, ELF, and machine-specific ELF
handling.
(to check for well-formed ELF files).
%if !%{gpl}
%package libs
Summary: Libraries to handle compiled objects.
Group: Development/Tools
License: OSL
Requires: elfutils-libelf = %{version}-%{release}
Conflicts: elfutils < %{version}-%{release}
Conflicts: elfutils > %{version}-%{release}
Conflicts: elfutils-devel < %{version}-%{release}
Conflicts: elfutils-devel > %{version}-%{release}
%description libs
The elfutils-libs package contains libraries which implement DWARF, ELF,
and machine-specific ELF handling. These libraries are used by the programs
in the elfutils package. The elfutils-devel package enables building
other programs using these libraries.
%endif
%package devel
Summary: Development libraries to handle compiled objects.
Group: Development/Tools
%if %{fake}
%if %{gpl}
License: GPL
%else
License: OSL
%endif
Requires: elfutils = %{version}-%{release}
Requires: elfutils-libs = %{version}-%{release}
Requires: elfutils-libelf-devel = %{version}-%{release}
%description devel
@ -60,9 +96,15 @@ assembler interface.
%package libelf
Summary: Library to read and write ELF files.
Group: Development/Tools
%if %{fake}
%if %{gpl}
License: GPL
%endif
Conflicts: elfutils < %{version}-%{release}
Conflicts: elfutils > %{version}-%{release}
Conflicts: elfutils-libs < %{version}-%{release}
Conflicts: elfutils-libs > %{version}-%{release}
Conflicts: elfutils-libelf-devel < %{version}-%{release}
Conflicts: elfutils-libelf-devel > %{version}-%{release}
%description libelf
The elfutils-libelf package provides a DSO which allows reading and
@ -75,7 +117,7 @@ Summary: Development support for libelf
Group: Development/Tools
Requires: elfutils-libelf = %{version}-%{release}
Conflicts: libelf-devel
%if %{fake}
%if %{gpl}
License: GPL
%endif
@ -88,9 +130,24 @@ different sections of an ELF file.
%prep
%setup -q
%if %{compat}
%patch1 -p1
sleep 1
find . \( -name Makefile.in -o -name aclocal.m4 \) -print | xargs touch
sleep 1
find . \( -name configure -o -name config.h.in \) -print | xargs touch
%endif
%patch2 -p1
%build
%configure --program-prefix=%{_programprefix}
make
# Remove -Wall from default flags. The makefiles enable enough warnings
# themselves, and they use -Werror. Appending -Wall defeats the cases where
# the makefiles disable some specific warnings for specific code.
RPM_OPT_FLAGS=${RPM_OPT_FLAGS/-Wall/}
%configure CFLAGS="$RPM_OPT_FLAGS"
make %{?_smp_mflags}
%install
rm -rf ${RPM_BUILD_ROOT}
@ -99,31 +156,32 @@ mkdir -p ${RPM_BUILD_ROOT}%{_prefix}
%makeinstall
chmod +x ${RPM_BUILD_ROOT}%{_prefix}/%{_lib}/lib*.so*
%if !%{fake}
%if !%{gpl}
chmod +x ${RPM_BUILD_ROOT}%{_prefix}/%{_lib}/elfutils/lib*.so*
%endif
%if !%{fake}
%if !%{gpl}
# XXX Nuke unpackaged files
{ cd ${RPM_BUILD_ROOT}
rm -f .%{_bindir}/eu-ld
rm -f .%{_bindir}/eu-objdump
rm -f .%{_includedir}/elfutils/libasm.h
rm -f .%{_libdir}/libasm-%{version}.so
rm -f .%{_libdir}/libasm.so.*
rm -f .%{_libdir}/libasm.so
rm -f .%{_libdir}/libasm.so*
rm -f .%{_libdir}/libasm.a
}
%endif
%check
make check
# XXX elflint not happy on ia64
make check || :
%clean
rm -rf ${RPM_BUILD_ROOT}
%post -p /sbin/ldconfig
%post libs -p /sbin/ldconfig
%postun -p /sbin/ldconfig
%postun libs -p /sbin/ldconfig
%post libelf -p /sbin/ldconfig
@ -132,22 +190,26 @@ rm -rf ${RPM_BUILD_ROOT}
%files
%defattr(-,root,root)
%doc README TODO
%if %{fake}
%if %{gpl}
%doc fake-src/FULL
%endif
%{_bindir}/eu-elflint
%{_bindir}/eu-nm
%{_bindir}/eu-readelf
%{_bindir}/eu-size
%{_bindir}/eu-strip
%{_bindir}/eu-findtextrel
%{_bindir}/eu-addr2line
%{_bindir}/eu-elfcmp
%{_bindir}/eu-elflint
%{_bindir}/eu-findtextrel
%{_bindir}/eu-nm
%{_bindir}/eu-ranlib
%{_bindir}/eu-readelf
%{_bindir}/eu-size
%{_bindir}/eu-strings
%if !%{fake}
%{_bindir}/eu-strip
%if !%{gpl}
#%{_bindir}/eu-ld
#%{_libdir}/libasm-%{version}.so
%endif
%if !%{gpl}
%files libs
%defattr(-,root,root)
%{_libdir}/libdw-%{version}.so
#%{_libdir}/libasm.so.*
%{_libdir}/libdw.so.*
@ -160,7 +222,7 @@ rm -rf ${RPM_BUILD_ROOT}
%{_includedir}/dwarf.h
%dir %{_includedir}/elfutils
%{_includedir}/elfutils/elf-knowledge.h
%if !%{fake}
%if !%{gpl}
%{_includedir}/elfutils/libebl.h
%{_includedir}/elfutils/libdw.h
%{_includedir}/elfutils/libdwfl.h
@ -185,115 +247,135 @@ rm -rf ${RPM_BUILD_ROOT}
%{_libdir}/libelf.so
%changelog
* Thu Nov 17 2005 Ulrich Drepper <drepper@redhat.com> 0.117-1
- libdwfl: New function dwfl_module_return_value_location.
- libebl: Backend improvements for several CPUs.
* Tue Nov 22 2005 Roland McGrath <roland@redhat.com> - 0.117-1
- update to 0.117
- libdwfl: New function dwfl_module_return_value_location (#166118)
- libebl: Backend improvements for several CPUs
* Mon Oct 31 2005 Ulrich Drepper <drepper@redhat.com> 0.116-1
- libdw: New functions dwarf_ranges, dwarf_entrypc, dwarf_diecu, d
warf_entry_breakpoints. Removed Dwarf_Func type and functions d
warf_func_name, dwarf_func_lowpc, dwarf_func_highpc, dwarf_func_
entrypc, dwarf_func_die; dwarf_getfuncs callback now uses Dwarf_
Die, and dwarf_func_file, dwarf_func_line, dwarf_func_col replac
ed by dwarf_decl_file, dwarf_decl_line, dwarf_decl_column; dwarf
_func_inline, dwarf_func_inline_instances now take Dwarf_Die. Ty
pe Dwarf_Loc renamed to Dwarf_Op; dwarf_getloclist, dwarf_addrlo
clists renamed dwarf_getlocation, dwarf_getlocation_addr.
* Mon Oct 31 2005 Roland McGrath <roland@redhat.com> - 0.116-1
- update to 0.116
- libdw fixes, API changes and additions
- libdwfl fixes (#169672)
- eu-strip/libelf fix to preserve setuid/setgid permission bits (#167745)
* Fri Sep 2 2005 Ulrich Drepper <drepper@redhat.com> 0.115-1
- libelf: speed-ups of non-mmap reading.
- strings: New program.
- Implement --enable-gcov option for configure.
- libdw: New function dwarf_getscopes_die.
* Fri Sep 9 2005 Roland McGrath <roland@redhat.com> - 0.115-3
- Update requires/conflicts for better biarch update behavior.
* Wed Aug 24 2005 Ulrich Drepper <drepper@redhat.com> 0.114-1
- libelf: new function elf_getaroff
- libdw: Added dwarf_func_die, dwarf_func_inline, dwarf_func_inline_inst
ances.
- libdwfl: New functions dwfl_report_offline, dwfl_offline_section_addre
ss, dwfl_linux_kernel_report_offline.
- ranlib: new program
* Mon Sep 5 2005 Roland McGrath <roland@redhat.com> - 0.115-2
- update to 0.115
- New program eu-strings.
- libdw: New function dwarf_getscopes_die.
- libelf: speed-ups of non-mmap reading.
- Implement --enable-gcov option for configure.
* Mon Aug 15 2005 Ulrich Drepper <drepper@redhat.com> 0.114-1
- libelf: new function elf_getaroff
- ranlib: new program
* Wed Aug 24 2005 Roland McGrath <roland@redhat.com> - 0.114-1
- update to 0.114
- new program eu-ranlib
- libdw: new calls for inlines
- libdwfl: new calls for offline modules
* Wed Aug 10 2005 Ulrich Drepper <@redhat.com> 0.113-1
- elflint: relax a bit. Allow version definitions for defined symbols ag
ainstDSO versions also for symbols in nobits sections. Allow .rodata
sectionto have STRINGS and MERGE flag set.
- strip: add some more compatibility with binutils.
* Sat Aug 13 2005 Roland McGrath <roland@redhat.com> - 0.113-2
- update to 0.113
- elflint: relax a bit. Allow version definitions for defined symbols
against DSO versions also for symbols in nobits sections.
Allow .rodata section to have STRINGS and MERGE flag set.
- strip: add some more compatibility with binutils.
- libdwfl: bug fixes.
- Separate libdw et al into elfutils-libs subpackage.
* Sat Aug 6 2005 Ulrich Drepper <@redhat.com> 0.113-1
- elflint: relax a bit. Allow version definitions for defined symbols ag
ainstDSO versions also for symbols in nobits sections. Allow .rodata
sectionto have STRINGS and MERGE flag set.
* Sat Aug 6 2005 Roland McGrath <roland@redhat.com> - 0.112-1
- update to 0.112
- elfcmp: some more relaxation.
- elflint: many more tests, especially regarding to symbol versioning.
- libelf: Add elfXX_offscn and gelf_offscn.
- libasm: asm_begin interface changes.
- libebl: Add three new interfaces to directly access machine, class,
and data encoding information.
* Sat Aug 6 2005 Ulrich Drepper <@redhat.com> 0.113-1
- elflint: relax a bit. Allow version definitions for defined symbols ag
ainstDSO versions also for symbols in nobits sections.
* Fri Jul 29 2005 Roland McGrath <roland@redhat.com> - 0.111-2
- update portability patch
* Fri Aug 5 2005 Ulrich Drepper <@redhat.com> 0.112-1
- elfcmp: some more relaxation.
- elflint: many more tests, especially regarding to symbol versioning.
- libelf: Add elfXX_offscn and gelf_offscn.
- libasm: asm_begin interface changes.
- libebl: Add three new interfaces to directly access machine, class, an
ddata encoding information.
- objdump: New program. Just the beginning.
* Thu Jul 28 2005 Roland McGrath <roland@redhat.com> - 0.111-1
- update to 0.111
- libdwfl library now merged into libdw
* Thu Jul 28 2005 Ulrich Drepper <@redhat.com> 0.111-1
- libdw: now contains all of libdwfl. The latter is not installed anymore.
- elfcmp: little usability tweak, name and index of differing section is
printed.
* Sun Jul 24 2005 Roland McGrath <roland@redhat.com> - 0.110-1
- update to 0.110
* Sun Jul 24 2005 Ulrich Drepper <@redhat.com> 0.110-1
- libelf: fix a numbe rof problems with elf_update
- elfcmp: fix a few bugs. Compare gaps.
- Fix a few PLT problems and mudflap build issues.
- libebl: Don't expose Ebl structure definition in libebl.h. It's now p
rivate.
* Fri Jul 22 2005 Roland McGrath <roland@redhat.com> - 0.109-2
- update to 0.109
- verify that libebl modules are from the same build
- new eu-elflint checks on copy relocations
- new program eu-elfcmp
- new experimental libdwfl library
* Thu Jul 21 2005 Ulrich Drepper <@redhat.com> 0.109-1
- libebl: Check for matching modules.
- elflint: Check that copy relocations only happen for OBJECT or NOTYPE
symbols.
- elfcmp: New program.
- libdwfl: New library.
* Thu Jun 9 2005 Roland McGrath <roland@redhat.com> - 0.108-5
- robustification of eu-strip and eu-readelf
* Mon May 9 2005 Ulrich Drepper <@redhat.com> 0.108-1
- strip: fix bug introduced in last change
- libdw: records returned by dwarf_getsrclines are now sorted by address
* Wed May 25 2005 Roland McGrath <roland@redhat.com> - 0.108-3
- more robustification
* Sun May 8 2005 Ulrich Drepper <@redhat.com> 0.108-1
- strip: fix bug introduced in last change
* Mon May 16 2005 Roland McGrath <roland@redhat.com> - 0.108-2
- robustification
* Sun May 8 2005 Ulrich Drepper <@redhat.com> 0.107-1
- readelf: improve DWARF output format
- strip: support Linux kernel modules
* Mon May 9 2005 Roland McGrath <roland@redhat.com> - 0.108-1
- update to 0.108
- merge strip fixes
- sort records in dwarf_getsrclines, fix dwarf_getsrc_die searching
- update elf.h from glibc
* Fri Apr 29 2005 Ulrich Drepper <drepper@redhat.com> 0.107-1
- readelf: improve DWARF output format
* Sun May 8 2005 Roland McGrath <roland@redhat.com> - 0.107-2
- fix strip -f byte-swapping bug
* Mon Apr 4 2005 Ulrich Drepper <drepper@redhat.com> 0.106-1
- libdw: Updated dwarf.h from DWARF3 speclibdw: add new funtions dwarf_f
unc_entrypc, dwarf_func_file, dwarf_func_line,dwarf_func_col, dwarf_ge
tsrc_file
* Sun May 8 2005 Roland McGrath <roland@redhat.com> - 0.107-1
- update to 0.107
- readelf: improve DWARF output format
- elflint: -d option to support checking separate debuginfo files
- strip: fix ET_REL debuginfo files (#156341)
* Fri Apr 1 2005 Ulrich Drepper <drepper@redhat.com> 0.105-1
- addr2line: New program
- libdw: add new functions: dwarf_addrdie, dwarf_macro_*, dwarf_getfuncs
,dwarf_func_*.
- findtextrel: use dwarf_addrdie
* Mon Apr 4 2005 Roland McGrath <roland@redhat.com> - 0.106-3
- fix some bugs in new code, reenable make check
* Mon Mar 28 2005 Ulrich Drepper <drepper@redhat.com> 0.104-1
- findtextrel: New program.
* Mon Apr 4 2005 Roland McGrath <roland@redhat.com> - 0.106-2
- disable make check for most arches, for now
* Mon Mar 21 2005 Ulrich Drepper <drepper@redhat.com> 0.103-1
- libdw: Fix using libdw.h with gcc < 4 and C++ code. Compiler bug.
* Mon Apr 4 2005 Roland McGrath <roland@redhat.com> - 0.106-1
- update to 0.106
* Tue Feb 22 2005 Ulrich Drepper <drepper@redhat.com> 0.102-1
- More Makefile and spec file cleanups.
* Mon Mar 28 2005 Roland McGrath <roland@redhat.com> - 0.104-2
- update to 0.104
* Wed Mar 23 2005 Jakub Jelinek <jakub@redhat.com> 0.103-2
- update to 0.103
* Wed Feb 16 2005 Jakub Jelinek <jakub@redhat.com> 0.101-2
- update to 0.101.
- use %%configure macro to get CFLAGS etc. right
* Sat Feb 5 2005 Jeff Johnson <jbj@redhat.com> 0.99-2
- upgrade to 0.99.
* Sun Sep 26 2004 Jeff Johnson <jbj@redhat.com> 0.97-3
- upgrade to 0.97.
* Tue Aug 17 2004 Jakub Jelinek <jakub@redhat.com> 0.95-5
- upgrade to 0.96.
* Mon Jul 5 2004 Jakub Jelinek <jakub@redhat.com> 0.95-4
- rebuilt with GCC 3.4.x, workaround VLA + alloca mixing
warning
* Tue Jun 15 2004 Elliot Lee <sopwith@redhat.com>
- rebuilt
* Fri Apr 2 2004 Jeff Johnson <jbj@redhat.com> 0.95-2
- upgrade to 0.95.
* Tue Mar 02 2004 Elliot Lee <sopwith@redhat.com>
- rebuilt
* Fri Feb 13 2004 Elliot Lee <sopwith@redhat.com>
- rebuilt
* Fri Jan 16 2004 Jakub Jelinek <jakub@redhat.com> 0.94-1
- upgrade to 0.94