Portability updates.

This commit is contained in:
roland 2005-07-29 20:18:25 +00:00
parent 10316ee7f3
commit 2728103090
3 changed files with 30 additions and 33 deletions

View File

@ -1,5 +1,5 @@
# Makefile for source rpm: elfutils
# $Id: Makefile,v 1.6 2005/07/29 00:12:10 roland Exp $
# $Id: Makefile,v 1.7 2005/07/29 01:56:30 roland Exp $
NAME := elfutils
SPECFILE = $(firstword $(wildcard *.spec))
@ -16,3 +16,13 @@ elfutils-portability.patch: elfutils-$(VERSION).tar.gz
diff -rpu elfutils-master elfutils-portable | \
filterdiff --remove-timestamps --strip=1 --addprefix=elfutils/ > $@.new
mv $@.new $@
elfutils-portable.spec: elfutils.spec
(echo '%define _with_compat 1'; cat $<) > $@.new
mv -f $@.new $@
portable: elfutils-$(VERSION)-0.$(RELEASE).src.rpm
elfutils-$(VERSION)-0.$(RELEASE).src.rpm: elfutils-portable.spec \
elfutils-portability.patch \
sources
$(RPM_WITH_DIRS) --nodeps -bs $<

View File

@ -1,6 +1,6 @@
--- elfutils/ChangeLog
+++ elfutils/ChangeLog
@@ -7,6 +7,17 @@
@@ -11,6 +11,17 @@
* Makefile.am (all_SUBDIRS): Add libdwfl.
* configure.ac: Write libdwfl/Makefile.
@ -30,14 +30,7 @@
ac_ct_CC = @ac_ct_CC@
--- elfutils/configure
+++ elfutils/configure
@@ -1,5 +1,5 @@
#! /bin/sh
-# From configure.ac Revision: 1.50 .
+# From configure.ac Revision: 1.47.2.5 .
# Guess values for system-dependent variables and create Makefiles.
# Generated by GNU Autoconf 2.59 for Red Hat elfutils 0.110.
#
@@ -277,7 +277,7 @@ PACKAGE_STRING='Red Hat elfutils 0.110'
@@ -276,7 +276,7 @@ PACKAGE_STRING='Red Hat elfutils 0.111'
PACKAGE_BUGREPORT='http://bugzilla.redhat.com/bugzilla/'
ac_unique_file="libelf/libelf.h"
@ -46,7 +39,7 @@
ac_subst_files=''
# Initialize some variables set by options.
@@ -3384,6 +3384,58 @@ echo "$as_me: error: gcc with C99 suppor
@@ -3382,6 +3382,58 @@ echo "$as_me: error: gcc with C99 suppor
fi
@ -105,7 +98,7 @@
LOCALEDIR=$datadir
cat >>confdefs.h <<_ACEOF
@@ -4847,6 +4899,7 @@ s,@YACC@,$YACC,;t t
@@ -4845,6 +4897,7 @@ s,@YACC@,$YACC,;t t
s,@LEX@,$LEX,;t t
s,@LEXLIB@,$LEXLIB,;t t
s,@LEX_OUTPUT_ROOT@,$LEX_OUTPUT_ROOT,;t t
@ -115,16 +108,7 @@
s,@NATIVE_LD_TRUE@,$NATIVE_LD_TRUE,;t t
--- elfutils/configure.ac
+++ elfutils/configure.ac
@@ -23,7 +23,7 @@ AC_CONFIG_AUX_DIR([config])
AC_CONFIG_FILES([config/Makefile])
AC_COPYRIGHT([Copyright (C) 1996-2003, 2004, 2005 Red Hat, Inc.])
-AC_REVISION($Revision: 1.9 $)
+AC_REVISION($Revision: 1.9 $)
AC_PREREQ(2.59) dnl Minimum Autoconf version required.
AM_INIT_AUTOMAKE([gnits 1.7])
@@ -70,6 +70,15 @@ CFLAGS="$old_CFLAGS"])
@@ -69,6 +69,15 @@ CFLAGS="$old_CFLAGS"])
AS_IF([test "x$ac_cv_c99" != xyes],
AC_MSG_ERROR([gcc with C99 support required]))
@ -288,7 +272,7 @@
libcpu_i386_a_SOURCES = i386_dis.c
--- elfutils/libdw/ChangeLog
+++ elfutils/libdw/ChangeLog
@@ -44,6 +44,11 @@
@@ -60,6 +60,11 @@
2005-05-31 Roland McGrath <roland@redhat.com>
@ -319,7 +303,7 @@
--- elfutils/libdw/Makefile.in
+++ elfutils/libdw/Makefile.in
@@ -196,6 +196,7 @@ SHELL = @SHELL@
@@ -198,6 +198,7 @@ SHELL = @SHELL@
STRIP = @STRIP@
USE_NLS = @USE_NLS@
VERSION = 1
@ -327,7 +311,7 @@
XGETTEXT = @XGETTEXT@
YACC = @YACC@
ac_ct_CC = @ac_ct_CC@
@@ -238,9 +239,9 @@ sharedstatedir = @sharedstatedir@
@@ -240,9 +241,9 @@ sharedstatedir = @sharedstatedir@
sysconfdir = @sysconfdir@
target_alias = @target_alias@
@MUDFLAP_FALSE@AM_CFLAGS = -Wall -Werror -Wshadow -Wunused -Wformat=2 \
@ -341,7 +325,7 @@
@MUDFLAP_FALSE@noinst_LIBRARIES = libdw_pic.a
--- elfutils/libdwfl/ChangeLog
+++ elfutils/libdwfl/ChangeLog
@@ -4,6 +4,11 @@
@@ -32,6 +32,11 @@
2005-07-21 Roland McGrath <roland@redhat.com>
@ -372,7 +356,7 @@
VERSION = 1
--- elfutils/libdwfl/Makefile.in
+++ elfutils/libdwfl/Makefile.in
@@ -184,6 +184,7 @@ SHELL = @SHELL@
@@ -155,6 +155,7 @@ SHELL = @SHELL@
STRIP = @STRIP@
USE_NLS = @USE_NLS@
VERSION = 1
@ -380,7 +364,7 @@
XGETTEXT = @XGETTEXT@
YACC = @YACC@
ac_ct_CC = @ac_ct_CC@
@@ -226,9 +227,9 @@ sharedstatedir = @sharedstatedir@
@@ -197,9 +198,9 @@ sharedstatedir = @sharedstatedir@
sysconfdir = @sysconfdir@
target_alias = @target_alias@
@MUDFLAP_FALSE@AM_CFLAGS = -Wall -Werror -Wshadow -Wunused -Wformat=2 \
@ -541,7 +525,7 @@
ac_ct_CC = @ac_ct_CC@
--- elfutils/src/ChangeLog
+++ elfutils/src/ChangeLog
@@ -44,6 +44,11 @@
@@ -52,6 +52,11 @@
* readelf.c (print_debug_loc_section): Fix indentation for larger
address size.
@ -665,7 +649,7 @@
cannot set access and modification date of '%s'"), fname);
--- elfutils/tests/ChangeLog
+++ elfutils/tests/ChangeLog
@@ -5,6 +5,11 @@
@@ -16,6 +16,11 @@
* Makefile.am (TESTS): Add run-elflint-test.sh.
(EXTRA_DIST): Add run-elflint-test.sh and testfile18.bz2.
@ -696,7 +680,7 @@
endif
--- elfutils/tests/Makefile.in
+++ elfutils/tests/Makefile.in
@@ -268,6 +268,7 @@ SHELL = @SHELL@
@@ -272,6 +272,7 @@ SHELL = @SHELL@
STRIP = @STRIP@
USE_NLS = @USE_NLS@
VERSION = @VERSION@
@ -704,7 +688,7 @@
XGETTEXT = @XGETTEXT@
YACC = @YACC@
ac_ct_CC = @ac_ct_CC@
@@ -309,10 +310,10 @@ sbindir = @sbindir@
@@ -313,10 +314,10 @@ sbindir = @sbindir@
sharedstatedir = @sharedstatedir@
sysconfdir = @sysconfdir@
target_alias = @target_alias@

View File

@ -1,5 +1,5 @@
%define version 0.111
%define release 1
%define release 2
%define gpl 0
%if %{?_with_compat:1}%{!?_with_compat:0}
@ -222,6 +222,9 @@ rm -rf ${RPM_BUILD_ROOT}
%{_libdir}/libelf.so
%changelog
* Fri Jul 29 2005 Roland McGrath <roland@redhat.com> - 0.111-2
- update portability patch
* Thu Jul 28 2005 Roland McGrath <roland@redhat.com> - 0.111-1
- update to 0.111
- libdwfl library now merged into libdw