Update to 0.148

This commit is contained in:
roland 2010-06-28 21:17:28 +00:00
parent 72e901990f
commit 0f58b0c8b8
5 changed files with 136 additions and 206 deletions

View File

@ -1 +1 @@
elfutils-0.147.tar.bz2
elfutils-0.148.tar.bz2

View File

@ -54,7 +54,7 @@
LEX = @LEX@
LEXLIB = @LEXLIB@
LEX_OUTPUT_ROOT = @LEX_OUTPUT_ROOT@
@@ -193,6 +194,7 @@ SHELL = @SHELL@
@@ -194,6 +195,7 @@ SHELL = @SHELL@
STRIP = @STRIP@
USE_NLS = @USE_NLS@
VERSION = @VERSION@
@ -62,7 +62,7 @@
XGETTEXT = @XGETTEXT@
XGETTEXT_015 = @XGETTEXT_015@
XGETTEXT_EXTRA_OPTIONS = @XGETTEXT_EXTRA_OPTIONS@
@@ -256,7 +258,7 @@ INCLUDES = -I. -I$(srcdir) -I$(top_srcdi
@@ -257,7 +259,7 @@ INCLUDES = -I. -I$(srcdir) -I$(top_srcdi
-I$(top_srcdir)/libelf -I$(top_srcdir)/libdw
AM_CFLAGS = -std=gnu99 -Wall -Wshadow $(if \
$($(*F)_no_Werror),,-Werror) $(if \
@ -71,7 +71,7 @@
$($(*F)_no_Wformat),-Wno-format,-Wformat=2) $($(*F)_CFLAGS) \
$(am__append_1)
@MUDFLAP_FALSE@libmudflap =
@@ -697,7 +699,7 @@ libebl_%.so libebl_%.map: libebl_%_pic.a
@@ -698,7 +700,7 @@ libebl_%.so libebl_%.map: libebl_%_pic.a
$(LINK) -shared -o $(@:.map=.so) \
-Wl,--whole-archive $< $(cpu_$*) -Wl,--no-whole-archive \
-Wl,--version-script,$(@:.so=.map) \
@ -170,7 +170,7 @@
LEX = @LEX@
LEXLIB = @LEXLIB@
LEX_OUTPUT_ROOT = @LEX_OUTPUT_ROOT@
@@ -104,6 +105,7 @@ SHELL = @SHELL@
@@ -105,6 +106,7 @@ SHELL = @SHELL@
STRIP = @STRIP@
USE_NLS = @USE_NLS@
VERSION = @VERSION@
@ -189,7 +189,7 @@
/* $libdir subdirectory containing libebl modules. */
#undef LIBEBL_SUBDIR
@@ -52,4 +55,7 @@
@@ -55,4 +58,7 @@
/* Define for large files, on AIX-style hosts. */
#undef _LARGE_FILES
@ -199,7 +199,7 @@
#include <eu-config.h>
--- elfutils/configure
+++ elfutils/configure
@@ -646,6 +646,8 @@ NEVER_TRUE
@@ -602,6 +602,8 @@ NEVER_TRUE
base_cpu
NATIVE_LD_FALSE
NATIVE_LD_TRUE
@ -208,67 +208,47 @@
LEXLIB
LEX_OUTPUT_ROOT
LEX
@@ -4098,6 +4100,205 @@ $as_echo "$as_me: error: gcc with C99 su
@@ -3852,6 +3854,130 @@ if test "x$ac_cv_c99" != xyes; then :
as_fn_error "gcc with C99 support required" "$LINENO" 5
fi
+{ $as_echo "$as_me:$LINENO: checking for -Wextra option to $CC" >&5
+{ $as_echo "$as_me:${as_lineno-$LINENO}: checking for -Wextra option to $CC" >&5
+$as_echo_n "checking for -Wextra option to $CC... " >&6; }
+if test "${ac_cv_cc_wextra+set}" = set; then
+if test "${ac_cv_cc_wextra+set}" = set; then :
+ $as_echo_n "(cached) " >&6
+else
+ old_CFLAGS="$CFLAGS"
+CFLAGS="$CFLAGS -Wextra"
+cat >conftest.$ac_ext <<_ACEOF
+cat confdefs.h - <<_ACEOF >conftest.$ac_ext
+/* end confdefs.h. */
+void foo (void) { }
+_ACEOF
+rm -f conftest.$ac_objext
+if { (ac_try="$ac_compile"
+case "(($ac_try" in
+ *\"* | *\`* | *\\*) ac_try_echo=\$ac_try;;
+ *) ac_try_echo=$ac_try;;
+esac
+eval ac_try_echo="\"\$as_me:$LINENO: $ac_try_echo\""
+$as_echo "$ac_try_echo") >&5
+ (eval "$ac_compile") 2>conftest.er1
+ ac_status=$?
+ grep -v '^ *+' conftest.er1 >conftest.err
+ rm -f conftest.er1
+ cat conftest.err >&5
+ $as_echo "$as_me:$LINENO: \$? = $ac_status" >&5
+ (exit $ac_status); } && {
+ test -z "$ac_c_werror_flag" ||
+ test ! -s conftest.err
+ } && test -s conftest.$ac_objext; then
+if ac_fn_c_try_compile "$LINENO"; then :
+ ac_cv_cc_wextra=yes
+else
+ $as_echo "$as_me: failed program was:" >&5
+sed 's/^/| /' conftest.$ac_ext >&5
+
+ ac_cv_cc_wextra=no
+ ac_cv_cc_wextra=no
+fi
+
+rm -f core conftest.err conftest.$ac_objext conftest.$ac_ext
+CFLAGS="$old_CFLAGS"
+fi
+{ $as_echo "$as_me:$LINENO: result: $ac_cv_cc_wextra" >&5
+{ $as_echo "$as_me:${as_lineno-$LINENO}: result: $ac_cv_cc_wextra" >&5
+$as_echo "$ac_cv_cc_wextra" >&6; }
+
+if test "x$ac_cv_cc_wextra" = xyes; then
+if test "x$ac_cv_cc_wextra" = xyes; then :
+ WEXTRA=-Wextra
+else
+ WEXTRA=-W
+fi
+
+
+{ $as_echo "$as_me:$LINENO: checking for -fgnu89-inline option to $CC" >&5
+{ $as_echo "$as_me:${as_lineno-$LINENO}: checking for -fgnu89-inline option to $CC" >&5
+$as_echo_n "checking for -fgnu89-inline option to $CC... " >&6; }
+if test "${ac_cv_cc_gnu89_inline+set}" = set; then
+if test "${ac_cv_cc_gnu89_inline+set}" = set; then :
+ $as_echo_n "(cached) " >&6
+else
+ old_CFLAGS="$CFLAGS"
+CFLAGS="$CFLAGS -fgnu89-inline -Werror"
+cat >conftest.$ac_ext <<_ACEOF
+cat confdefs.h - <<_ACEOF >conftest.$ac_ext
+/* end confdefs.h. */
+
+void foo (void)
+{
@ -278,45 +258,23 @@
+extern inline void baz (void) {}
+
+_ACEOF
+rm -f conftest.$ac_objext
+if { (ac_try="$ac_compile"
+case "(($ac_try" in
+ *\"* | *\`* | *\\*) ac_try_echo=\$ac_try;;
+ *) ac_try_echo=$ac_try;;
+esac
+eval ac_try_echo="\"\$as_me:$LINENO: $ac_try_echo\""
+$as_echo "$ac_try_echo") >&5
+ (eval "$ac_compile") 2>conftest.er1
+ ac_status=$?
+ grep -v '^ *+' conftest.er1 >conftest.err
+ rm -f conftest.er1
+ cat conftest.err >&5
+ $as_echo "$as_me:$LINENO: \$? = $ac_status" >&5
+ (exit $ac_status); } && {
+ test -z "$ac_c_werror_flag" ||
+ test ! -s conftest.err
+ } && test -s conftest.$ac_objext; then
+if ac_fn_c_try_compile "$LINENO"; then :
+ ac_cv_cc_gnu89_inline=yes
+else
+ $as_echo "$as_me: failed program was:" >&5
+sed 's/^/| /' conftest.$ac_ext >&5
+
+ ac_cv_cc_gnu89_inline=no
+ ac_cv_cc_gnu89_inline=no
+fi
+
+rm -f core conftest.err conftest.$ac_objext conftest.$ac_ext
+CFLAGS="$old_CFLAGS"
+fi
+{ $as_echo "$as_me:$LINENO: result: $ac_cv_cc_gnu89_inline" >&5
+{ $as_echo "$as_me:${as_lineno-$LINENO}: result: $ac_cv_cc_gnu89_inline" >&5
+$as_echo "$ac_cv_cc_gnu89_inline" >&6; }
+if test "x$ac_cv_cc_gnu89_inline" = xyes; then
+if test "x$ac_cv_cc_gnu89_inline" = xyes; then :
+ WEXTRA="${WEXTRA:+$WEXTRA }-fgnu89-inline"
+fi
+
+
+{ $as_echo "$as_me:$LINENO: checking for --as-needed linker option" >&5
+{ $as_echo "$as_me:${as_lineno-$LINENO}: checking for --as-needed linker option" >&5
+$as_echo_n "checking for --as-needed linker option... " >&6; }
+if test "${ac_cv_as_needed+set}" = set; then
+if test "${ac_cv_as_needed+set}" = set; then :
+ $as_echo_n "(cached) " >&6
+else
+ cat > conftest.c <<EOF
@ -325,11 +283,11 @@
+if { ac_try='${CC-cc} $CFLAGS $CPPFLAGS $LDFLAGS
+ -fPIC -shared -o conftest.so conftest.c
+ -Wl,--as-needed 1>&5'
+ { (eval echo "$as_me:$LINENO: \"$ac_try\"") >&5
+ { { eval echo "\"\$as_me\":${as_lineno-$LINENO}: \"$ac_try\""; } >&5
+ (eval $ac_try) 2>&5
+ ac_status=$?
+ $as_echo "$as_me:$LINENO: \$? = $ac_status" >&5
+ (exit $ac_status); }; }
+ $as_echo "$as_me:${as_lineno-$LINENO}: \$? = $ac_status" >&5
+ test $ac_status = 0; }; }
+then
+ ac_cv_as_needed=yes
+else
@ -337,26 +295,21 @@
+fi
+rm -f conftest*
+fi
+{ $as_echo "$as_me:$LINENO: result: $ac_cv_as_needed" >&5
+{ $as_echo "$as_me:${as_lineno-$LINENO}: result: $ac_cv_as_needed" >&5
+$as_echo "$ac_cv_as_needed" >&6; }
+if test "x$ac_cv_as_needed" = xyes; then
+if test "x$ac_cv_as_needed" = xyes; then :
+ LD_AS_NEEDED=-Wl,--as-needed
+else
+ LD_AS_NEEDED=
+fi
+
+
+
+{ $as_echo "$as_me:$LINENO: checking for __builtin_popcount" >&5
+{ $as_echo "$as_me:${as_lineno-$LINENO}: checking for __builtin_popcount" >&5
+$as_echo_n "checking for __builtin_popcount... " >&6; }
+if test "${ac_cv_popcount+set}" = set; then
+if test "${ac_cv_popcount+set}" = set; then :
+ $as_echo_n "(cached) " >&6
+else
+ cat >conftest.$ac_ext <<_ACEOF
+/* confdefs.h. */
+_ACEOF
+cat confdefs.h >>conftest.$ac_ext
+cat >>conftest.$ac_ext <<_ACEOF
+ cat confdefs.h - <<_ACEOF >conftest.$ac_ext
+/* end confdefs.h. */
+
+int
@ -367,84 +320,50 @@
+ return 0;
+}
+_ACEOF
+rm -f conftest.$ac_objext conftest$ac_exeext
+if { (ac_try="$ac_link"
+case "(($ac_try" in
+ *\"* | *\`* | *\\*) ac_try_echo=\$ac_try;;
+ *) ac_try_echo=$ac_try;;
+esac
+eval ac_try_echo="\"\$as_me:$LINENO: $ac_try_echo\""
+$as_echo "$ac_try_echo") >&5
+ (eval "$ac_link") 2>conftest.er1
+ ac_status=$?
+ grep -v '^ *+' conftest.er1 >conftest.err
+ rm -f conftest.er1
+ cat conftest.err >&5
+ $as_echo "$as_me:$LINENO: \$? = $ac_status" >&5
+ (exit $ac_status); } && {
+ test -z "$ac_c_werror_flag" ||
+ test ! -s conftest.err
+ } && test -s conftest$ac_exeext && {
+ test "$cross_compiling" = yes ||
+ $as_test_x conftest$ac_exeext
+ }; then
+if ac_fn_c_try_link "$LINENO"; then :
+ ac_cv_popcount=yes
+else
+ $as_echo "$as_me: failed program was:" >&5
+sed 's/^/| /' conftest.$ac_ext >&5
+
+ ac_cv_popcount=no
+ ac_cv_popcount=no
+fi
+
+rm -rf conftest.dSYM
+rm -f core conftest.err conftest.$ac_objext conftest_ipa8_conftest.oo \
+ conftest$ac_exeext conftest.$ac_ext
+rm -f core conftest.err conftest.$ac_objext \
+ conftest$ac_exeext conftest.$ac_ext
+fi
+{ $as_echo "$as_me:$LINENO: result: $ac_cv_popcount" >&5
+{ $as_echo "$as_me:${as_lineno-$LINENO}: result: $ac_cv_popcount" >&5
+$as_echo "$ac_cv_popcount" >&6; }
+if test "x$ac_cv_popcount" = xyes; then
+if test "x$ac_cv_popcount" = xyes; then :
+
+cat >>confdefs.h <<\_ACEOF
+#define HAVE_BUILTIN_POPCOUNT 1
+_ACEOF
+$as_echo "#define HAVE_BUILTIN_POPCOUNT 1" >>confdefs.h
+
+fi
+
+
{ $as_echo "$as_me:$LINENO: checking for __thread support" >&5
{ $as_echo "$as_me:${as_lineno-$LINENO}: checking for __thread support" >&5
$as_echo_n "checking for __thread support... " >&6; }
if test "${ac_cv_tls+set}" = set; then
@@ -4163,9 +4364,18 @@ fi
{ $as_echo "$as_me:$LINENO: result: $ac_cv_tls" >&5
if test "${ac_cv_tls+set}" = set; then :
@@ -3888,7 +4014,13 @@ fi
{ $as_echo "$as_me:${as_lineno-$LINENO}: result: $ac_cv_tls" >&5
$as_echo "$ac_cv_tls" >&6; }
if test "x$ac_cv_tls" != xyes; then
- { { $as_echo "$as_me:$LINENO: error: __thread support required" >&5
-$as_echo "$as_me: error: __thread support required" >&2;}
+ if test "$use_locks" = yes; then
+ { { $as_echo "$as_me:$LINENO: error: --enable-thread-safety requires __thread support" >&5
+$as_echo "$as_me: error: --enable-thread-safety requires __thread support" >&2;}
{ (exit 1); exit 1; }; }
if test "x$ac_cv_tls" != xyes; then :
- as_fn_error "__thread support required" "$LINENO" 5
+ if test "$use_locks" = yes; then :
+ as_fn_error "--enable-thread-safety requires __thread support" "$LINENO" 5
+else
+
+cat >>confdefs.h <<\_ACEOF
+#define __thread /* empty: no multi-thread support */
+_ACEOF
+$as_echo "#define __thread /* empty: no multi-thread support */" >>confdefs.h
+
+fi
+
fi
@@ -5454,7 +5664,7 @@ ac_config_files="$ac_config_files versio
# Check whether --enable-largefile was given.
@@ -4874,7 +5006,7 @@ ac_config_files="$ac_config_files versio
# 1.234<whatever> -> 1234<whatever>
case "$PACKAGE_VERSION" in
-[0-9].*) eu_version="${PACKAGE_VERSION/./}" ;;
+[0-9].*) eu_version=`echo "$PACKAGE_VERSION" | sed 's@\.@@'` ;;
*) { { $as_echo "$as_me:$LINENO: error: confused by version number '$PACKAGE_VERSION'" >&5
$as_echo "$as_me: error: confused by version number '$PACKAGE_VERSION'" >&2;}
{ (exit 1); exit 1; }; } ;;
@@ -5489,7 +5699,7 @@ $as_echo "$as_me: error: confused by ver
*) as_fn_error "confused by version number '$PACKAGE_VERSION'" "$LINENO" 5 ;;
esac
case "$eu_version" in
@@ -4903,7 +5035,7 @@ case "$eu_version" in
esac
# Round up to the next release API (x.y) version.
@ -541,7 +460,7 @@
AC_OUTPUT
--- elfutils/lib/ChangeLog
+++ elfutils/lib/ChangeLog
@@ -8,6 +8,9 @@
@@ -14,6 +14,9 @@
2009-01-23 Roland McGrath <roland@redhat.com>
@ -551,7 +470,7 @@
* eu-config.h: Add multiple inclusion protection.
2009-01-17 Ulrich Drepper <drepper@redhat.com>
@@ -64,6 +67,11 @@
@@ -70,6 +73,11 @@
* Makefile.am (libeu_a_SOURCES): Add it.
* system.h: Declare crc32_file.
@ -593,7 +512,7 @@
LEX = @LEX@
LEXLIB = @LEXLIB@
LEX_OUTPUT_ROOT = @LEX_OUTPUT_ROOT@
@@ -127,6 +128,7 @@ SHELL = @SHELL@
@@ -128,6 +129,7 @@ SHELL = @SHELL@
STRIP = @STRIP@
USE_NLS = @USE_NLS@
VERSION = @VERSION@
@ -601,7 +520,7 @@
XGETTEXT = @XGETTEXT@
XGETTEXT_015 = @XGETTEXT_015@
XGETTEXT_EXTRA_OPTIONS = @XGETTEXT_EXTRA_OPTIONS@
@@ -189,7 +191,7 @@ INCLUDES = -I. -I$(srcdir) -I$(top_srcdi
@@ -190,7 +192,7 @@ INCLUDES = -I. -I$(srcdir) -I$(top_srcdi
-I$(srcdir)/../libelf
AM_CFLAGS = -std=gnu99 -Wall -Wshadow $(if \
$($(*F)_no_Werror),,-Werror) $(if \
@ -634,7 +553,7 @@
LEX = @LEX@
LEXLIB = @LEXLIB@
LEX_OUTPUT_ROOT = @LEX_OUTPUT_ROOT@
@@ -175,6 +176,7 @@ SHELL = @SHELL@
@@ -176,6 +177,7 @@ SHELL = @SHELL@
STRIP = @STRIP@
USE_NLS = @USE_NLS@
VERSION = 1
@ -642,7 +561,7 @@
XGETTEXT = @XGETTEXT@
XGETTEXT_015 = @XGETTEXT_015@
XGETTEXT_EXTRA_OPTIONS = @XGETTEXT_EXTRA_OPTIONS@
@@ -238,7 +240,7 @@ INCLUDES = -I. -I$(srcdir) -I$(top_srcdi
@@ -239,7 +241,7 @@ INCLUDES = -I. -I$(srcdir) -I$(top_srcdi
-I$(top_srcdir)/libdw
AM_CFLAGS = -std=gnu99 -Wall -Wshadow $(if \
$($(*F)_no_Werror),,-Werror) $(if \
@ -695,7 +614,7 @@
LEX = @LEX@
LEXLIB = @LEXLIB@
LEX_OUTPUT_ROOT = lex.$(<F:lex.l=)
@@ -144,6 +145,7 @@ SHELL = @SHELL@
@@ -145,6 +146,7 @@ SHELL = @SHELL@
STRIP = @STRIP@
USE_NLS = @USE_NLS@
VERSION = @VERSION@
@ -703,7 +622,7 @@
XGETTEXT = @XGETTEXT@
XGETTEXT_015 = @XGETTEXT_015@
XGETTEXT_EXTRA_OPTIONS = @XGETTEXT_EXTRA_OPTIONS@
@@ -207,7 +209,7 @@ INCLUDES = -I. -I$(srcdir) -I$(top_srcdi
@@ -208,7 +210,7 @@ INCLUDES = -I. -I$(srcdir) -I$(top_srcdi
-I$(srcdir)/../libdw -I$(srcdir)/../libasm
AM_CFLAGS = -std=gnu99 -Wall -Wshadow $(if \
$($(*F)_no_Werror),,-Werror) $(if \
@ -714,7 +633,7 @@
@MUDFLAP_FALSE@libmudflap =
--- elfutils/libdw/ChangeLog
+++ elfutils/libdw/ChangeLog
@@ -82,6 +82,10 @@
@@ -276,6 +276,10 @@
* dwarf_hasattr_integrate.c: Integrate DW_AT_specification too.
@ -725,7 +644,7 @@
2009-08-10 Roland McGrath <roland@redhat.com>
* dwarf_getscopevar.c: Use dwarf_diename.
@@ -850,6 +854,11 @@
@@ -1044,6 +1048,11 @@
2005-05-31 Roland McGrath <roland@redhat.com>
@ -739,7 +658,7 @@
--- elfutils/libdw/libdw.h
+++ elfutils/libdw/libdw.h
@@ -814,7 +814,7 @@ extern Dwarf_OOM dwarf_new_oom_handler (
@@ -842,7 +842,7 @@ extern Dwarf_OOM dwarf_new_oom_handler (
/* Inline optimizations. */
@ -750,7 +669,7 @@
dwarf_whatattr (Dwarf_Attribute *attr)
--- elfutils/libdw/Makefile.in
+++ elfutils/libdw/Makefile.in
@@ -189,6 +189,7 @@ INSTALL_PROGRAM = @INSTALL_PROGRAM@
@@ -191,6 +191,7 @@ INSTALL_PROGRAM = @INSTALL_PROGRAM@
INSTALL_SCRIPT = @INSTALL_SCRIPT@
INSTALL_STRIP_PROGRAM = @INSTALL_STRIP_PROGRAM@
LDFLAGS = @LDFLAGS@
@ -758,7 +677,7 @@
LEX = @LEX@
LEXLIB = @LEXLIB@
LEX_OUTPUT_ROOT = @LEX_OUTPUT_ROOT@
@@ -217,6 +218,7 @@ SHELL = @SHELL@
@@ -220,6 +221,7 @@ SHELL = @SHELL@
STRIP = @STRIP@
USE_NLS = @USE_NLS@
VERSION = 1
@ -766,7 +685,7 @@
XGETTEXT = @XGETTEXT@
XGETTEXT_015 = @XGETTEXT_015@
XGETTEXT_EXTRA_OPTIONS = @XGETTEXT_EXTRA_OPTIONS@
@@ -279,7 +281,7 @@ INCLUDES = -I. -I$(srcdir) -I$(top_srcdi
@@ -282,7 +284,7 @@ INCLUDES = -I. -I$(srcdir) -I$(top_srcdi
-I$(srcdir)/../libelf
AM_CFLAGS = -std=gnu99 -Wall -Wshadow $(if \
$($(*F)_no_Werror),,-Werror) $(if \
@ -777,7 +696,7 @@
@MUDFLAP_FALSE@libmudflap =
--- elfutils/libdwfl/ChangeLog
+++ elfutils/libdwfl/ChangeLog
@@ -1207,6 +1207,11 @@
@@ -1265,6 +1265,11 @@
2005-07-21 Roland McGrath <roland@redhat.com>
@ -799,7 +718,7 @@
LEX = @LEX@
LEXLIB = @LEXLIB@
LEX_OUTPUT_ROOT = @LEX_OUTPUT_ROOT@
@@ -209,6 +210,7 @@ SHELL = @SHELL@
@@ -210,6 +211,7 @@ SHELL = @SHELL@
STRIP = @STRIP@
USE_NLS = @USE_NLS@
VERSION = 1
@ -807,7 +726,7 @@
XGETTEXT = @XGETTEXT@
XGETTEXT_015 = @XGETTEXT_015@
XGETTEXT_EXTRA_OPTIONS = @XGETTEXT_EXTRA_OPTIONS@
@@ -272,7 +274,7 @@ INCLUDES = -I. -I$(srcdir) -I$(top_srcdi
@@ -273,7 +275,7 @@ INCLUDES = -I. -I$(srcdir) -I$(top_srcdi
-I$(srcdir)/../libdw
AM_CFLAGS = -std=gnu99 -Wall -Wshadow $(if \
$($(*F)_no_Werror),,-Werror) $(if \
@ -840,7 +759,7 @@
LEX = @LEX@
LEXLIB = @LEXLIB@
LEX_OUTPUT_ROOT = @LEX_OUTPUT_ROOT@
@@ -171,6 +172,7 @@ SHELL = @SHELL@
@@ -172,6 +173,7 @@ SHELL = @SHELL@
STRIP = @STRIP@
USE_NLS = @USE_NLS@
VERSION = 1
@ -848,7 +767,7 @@
XGETTEXT = @XGETTEXT@
XGETTEXT_015 = @XGETTEXT_015@
XGETTEXT_EXTRA_OPTIONS = @XGETTEXT_EXTRA_OPTIONS@
@@ -234,7 +236,7 @@ INCLUDES = -I. -I$(srcdir) -I$(top_srcdi
@@ -235,7 +237,7 @@ INCLUDES = -I. -I$(srcdir) -I$(top_srcdi
-I$(srcdir)/../libasm
AM_CFLAGS = -std=gnu99 -Wall -Wshadow $(if \
$($(*F)_no_Werror),,-Werror) $(if \
@ -859,7 +778,7 @@
@MUDFLAP_FALSE@libmudflap =
--- elfutils/libelf/ChangeLog
+++ elfutils/libelf/ChangeLog
@@ -651,6 +651,11 @@
@@ -657,6 +657,11 @@
* elf.h: Update from glibc.
@ -901,7 +820,7 @@
LEX = @LEX@
LEXLIB = @LEXLIB@
LEX_OUTPUT_ROOT = @LEX_OUTPUT_ROOT@
@@ -217,6 +218,7 @@ SHELL = @SHELL@
@@ -218,6 +219,7 @@ SHELL = @SHELL@
STRIP = @STRIP@
USE_NLS = @USE_NLS@
VERSION = 1
@ -909,7 +828,7 @@
XGETTEXT = @XGETTEXT@
XGETTEXT_015 = @XGETTEXT_015@
XGETTEXT_EXTRA_OPTIONS = @XGETTEXT_EXTRA_OPTIONS@
@@ -278,7 +280,7 @@ zip_LIBS = @zip_LIBS@
@@ -279,7 +281,7 @@ zip_LIBS = @zip_LIBS@
INCLUDES = -I. -I$(srcdir) -I$(top_srcdir)/lib -I..
AM_CFLAGS = -std=gnu99 -Wall -Wshadow $(if \
$($(*F)_no_Werror),,-Werror) $(if \
@ -928,7 +847,7 @@
LEX = @LEX@
LEXLIB = @LEXLIB@
LEX_OUTPUT_ROOT = @LEX_OUTPUT_ROOT@
@@ -103,6 +104,7 @@ SHELL = @SHELL@
@@ -104,6 +105,7 @@ SHELL = @SHELL@
STRIP = @STRIP@
USE_NLS = @USE_NLS@
VERSION = @VERSION@
@ -946,7 +865,7 @@
LEX = @LEX@
LEXLIB = @LEXLIB@
LEX_OUTPUT_ROOT = @LEX_OUTPUT_ROOT@
@@ -183,6 +184,7 @@ SHELL = @SHELL@
@@ -184,6 +185,7 @@ SHELL = @SHELL@
STRIP = @STRIP@
USE_NLS = @USE_NLS@
VERSION = @VERSION@
@ -958,20 +877,20 @@
+++ elfutils/src/addr2line.c
@@ -447,10 +447,10 @@ handle_address (const char *string, Dwfl
bool parsed = false;
int n;
int i, j;
char *name = NULL;
- if (sscanf (string, "(%m[^)])%" PRIiMAX "%n", &name, &addr, &n) == 2
+ if (sscanf (string, "(%a[^)])%" PRIiMAX "%n", &name, &addr, &n) == 2
&& string[n] == '\0')
- if (sscanf (string, "(%m[^)])%" PRIiMAX "%n", &name, &addr, &i) == 2
+ if (sscanf (string, "(%a[^)])%" PRIiMAX "%n", &name, &addr, &i) == 2
&& string[i] == '\0')
parsed = adjust_to_section (name, &addr, dwfl);
- else if (sscanf (string, "%m[^-+]%" PRIiMAX "%n", &name, &addr, &n) == 2
+ else if (sscanf (string, "%a[^-+]%" PRIiMAX "%n", &name, &addr, &n) == 2
&& string[n] == '\0')
- switch (sscanf (string, "%m[^-+]%n%" PRIiMAX "%n", &name, &i, &addr, &j))
+ switch (sscanf (string, "%a[^-+]%n%" PRIiMAX "%n", &name, &i, &addr, &j))
{
/* It was symbol+offset. */
default:
break;
--- elfutils/src/ChangeLog
+++ elfutils/src/ChangeLog
@@ -98,8 +98,16 @@
@@ -165,8 +165,16 @@
* readelf.c (attr_callback): Use print_block only when we don't use
print_ops.
@ -988,7 +907,7 @@
* ar.c (do_oper_extract): Use pathconf instead of statfs.
2009-08-01 Ulrich Drepper <drepper@redhat.com>
@@ -263,6 +271,8 @@
@@ -330,6 +338,8 @@
* readelf.c (print_debug_frame_section): Use t instead of j formats
for ptrdiff_t OFFSET.
@ -997,7 +916,7 @@
2009-01-21 Ulrich Drepper <drepper@redhat.com>
* elflint.c (check_program_header): Fix typo in .eh_frame_hdr section
@@ -446,6 +456,11 @@
@@ -513,6 +523,11 @@
that matches its PT_LOAD's p_flags &~ PF_W. On sparc, PF_X really
is valid in RELRO.
@ -1009,7 +928,7 @@
2008-02-29 Roland McGrath <roland@redhat.com>
* readelf.c (print_attributes): Add a cast.
@@ -697,6 +712,8 @@
@@ -764,6 +779,8 @@
* readelf.c (hex_dump): Fix rounding error in whitespace calculation.
@ -1018,7 +937,7 @@
2007-10-15 Roland McGrath <roland@redhat.com>
* make-debug-archive.in: New file.
@@ -1136,6 +1153,10 @@
@@ -1203,6 +1220,10 @@
* elflint.c (valid_e_machine): Add EM_ALPHA.
Reported by Christian Aichinger <Greek0@gmx.net>.
@ -1029,7 +948,7 @@
2006-08-08 Ulrich Drepper <drepper@redhat.com>
* elflint.c (check_dynamic): Don't require DT_HASH for DT_SYMTAB.
@@ -1212,6 +1233,10 @@
@@ -1279,6 +1300,10 @@
* Makefile.am: Add hacks to create dependency files for non-generic
linker.
@ -1040,7 +959,7 @@
2006-06-12 Ulrich Drepper <drepper@redhat.com>
* ldgeneric.c (ld_generic_generate_sections): Don't create .interp
@@ -1560,6 +1585,11 @@
@@ -1627,6 +1652,11 @@
* readelf.c (print_debug_loc_section): Fix indentation for larger
address size.
@ -1106,7 +1025,7 @@
LEX = @LEX@
LEXLIB = @LEXLIB@
LEX_OUTPUT_ROOT = @LEX_OUTPUT_ROOT@
@@ -256,6 +257,7 @@ SHELL = @SHELL@
@@ -257,6 +258,7 @@ SHELL = @SHELL@
STRIP = @STRIP@
USE_NLS = @USE_NLS@
VERSION = @VERSION@
@ -1114,7 +1033,7 @@
XGETTEXT = @XGETTEXT@
XGETTEXT_015 = @XGETTEXT_015@
XGETTEXT_EXTRA_OPTIONS = @XGETTEXT_EXTRA_OPTIONS@
@@ -320,7 +322,7 @@ INCLUDES = -I. -I$(srcdir) -I$(top_srcdi
@@ -321,7 +323,7 @@ INCLUDES = -I. -I$(srcdir) -I$(top_srcdi
-I$(srcdir)/../libasm
AM_CFLAGS = -std=gnu99 -Wall -Wshadow $(if \
$($(*F)_no_Werror),,-Werror) $(if \
@ -1123,7 +1042,7 @@
$($(*F)_no_Wformat),-Wno-format,-Wformat=2) $($(*F)_CFLAGS) \
$(am__append_1)
@MUDFLAP_FALSE@libmudflap =
@@ -367,6 +369,9 @@ strings_no_Wformat = yes
@@ -368,6 +370,9 @@ strings_no_Wformat = yes
addr2line_no_Wformat = yes
# XXX While the file is not finished, don't warn about this
ldgeneric_no_Wunused = yes
@ -1135,7 +1054,7 @@
size_LDADD = $(libelf) $(libeu) $(libmudflap)
--- elfutils/src/readelf.c
+++ elfutils/src/readelf.c
@@ -7655,7 +7655,7 @@ dump_archive_index (Elf *elf, const char
@@ -7845,7 +7845,7 @@ dump_archive_index (Elf *elf, const char
if (unlikely (elf_rand (elf, as_off) == 0)
|| unlikely ((subelf = elf_begin (-1, ELF_C_READ_MMAP, elf))
== NULL))
@ -1237,7 +1156,7 @@
cannot set access and modification date of '%s'"), fname);
--- elfutils/tests/ChangeLog
+++ elfutils/tests/ChangeLog
@@ -150,6 +150,8 @@
@@ -154,6 +154,8 @@
2008-01-21 Roland McGrath <roland@redhat.com>
@ -1246,7 +1165,7 @@
* testfile45.S.bz2: Add tests for cltq, cqto.
* testfile45.expect.bz2: Adjust.
@@ -858,6 +860,11 @@
@@ -862,6 +864,11 @@
* Makefile.am (TESTS): Add run-elflint-test.sh.
(EXTRA_DIST): Add run-elflint-test.sh and testfile18.bz2.
@ -1279,7 +1198,7 @@
LEX = @LEX@
LEXLIB = @LEXLIB@
LEX_OUTPUT_ROOT = @LEX_OUTPUT_ROOT@
@@ -400,6 +401,7 @@ SHELL = @SHELL@
@@ -401,6 +402,7 @@ SHELL = @SHELL@
STRIP = @STRIP@
USE_NLS = @USE_NLS@
VERSION = @VERSION@
@ -1287,7 +1206,7 @@
XGETTEXT = @XGETTEXT@
XGETTEXT_015 = @XGETTEXT_015@
XGETTEXT_EXTRA_OPTIONS = @XGETTEXT_EXTRA_OPTIONS@
@@ -461,7 +463,7 @@ zip_LIBS = @zip_LIBS@
@@ -462,7 +464,7 @@ zip_LIBS = @zip_LIBS@
INCLUDES = -I. -I$(srcdir) -I$(top_srcdir)/lib -I.. $(am__append_2)
AM_CFLAGS = -std=gnu99 -Wall -Wshadow $(if \
$($(*F)_no_Werror),,-Werror) $(if \

View File

@ -1,6 +1,6 @@
--- elfutils/libelf/ChangeLog
+++ elfutils/libelf/ChangeLog
@@ -643,10 +643,53 @@
@@ -649,10 +649,53 @@
If section content hasn't been read yet, do it before looking for the
block size. If no section data present, infer size of section header.
@ -865,7 +865,7 @@
#endif /* libelfP.h */
--- elfutils/src/ChangeLog
+++ elfutils/src/ChangeLog
@@ -1548,6 +1548,16 @@
@@ -1615,6 +1615,16 @@
object symbols or symbols with unknown type.
(check_rel): Likewise.
@ -882,7 +882,7 @@
2005-06-08 Roland McGrath <roland@redhat.com>
* readelf.c (print_ops): Add consts.
@@ -1593,6 +1603,19 @@
@@ -1660,6 +1670,19 @@
* readelf.c (dwarf_tag_string): Add new tags.
@ -1179,7 +1179,7 @@
idx, section_name (ebl, idx),
--- elfutils/src/readelf.c
+++ elfutils/src/readelf.c
@@ -1171,6 +1171,8 @@ handle_scngrp (Ebl *ebl, Elf_Scn *scn, G
@@ -1172,6 +1172,8 @@ handle_scngrp (Ebl *ebl, Elf_Scn *scn, G
Elf32_Word *grpref = (Elf32_Word *) data->d_buf;
GElf_Sym sym_mem;
@ -1188,7 +1188,7 @@
printf ((grpref[0] & GRP_COMDAT)
? ngettext ("\
\nCOMDAT section group [%2zu] '%s' with signature '%s' contains %zu entry:\n",
@@ -1183,8 +1185,8 @@ handle_scngrp (Ebl *ebl, Elf_Scn *scn, G
@@ -1184,8 +1186,8 @@ handle_scngrp (Ebl *ebl, Elf_Scn *scn, G
data->d_size / sizeof (Elf32_Word) - 1),
elf_ndxscn (scn),
elf_strptr (ebl->elf, shstrndx, shdr->sh_name),
@ -1199,7 +1199,7 @@
?: gettext ("<INVALID SYMBOL>"),
data->d_size / sizeof (Elf32_Word) - 1);
@@ -1335,7 +1337,8 @@ static void
@@ -1336,7 +1338,8 @@ static void
handle_dynamic (Ebl *ebl, Elf_Scn *scn, GElf_Shdr *shdr)
{
int class = gelf_getclass (ebl->elf);
@ -1209,7 +1209,7 @@
Elf_Data *data;
size_t cnt;
size_t shstrndx;
@@ -1350,6 +1353,11 @@ handle_dynamic (Ebl *ebl, Elf_Scn *scn,
@@ -1351,6 +1354,11 @@ handle_dynamic (Ebl *ebl, Elf_Scn *scn,
error (EXIT_FAILURE, 0,
gettext ("cannot get section header string table index"));
@ -1221,7 +1221,7 @@
printf (ngettext ("\
\nDynamic segment contains %lu entry:\n Addr: %#0*" PRIx64 " Offset: %#08" PRIx64 " Link to section: [%2u] '%s'\n",
"\
@@ -1359,9 +1367,7 @@ handle_dynamic (Ebl *ebl, Elf_Scn *scn,
@@ -1360,9 +1368,7 @@ handle_dynamic (Ebl *ebl, Elf_Scn *scn,
class == ELFCLASS32 ? 10 : 18, shdr->sh_addr,
shdr->sh_offset,
(int) shdr->sh_link,
@ -1232,7 +1232,7 @@
fputs_unlocked (gettext (" Type Value\n"), stdout);
for (cnt = 0; cnt < shdr->sh_size / shdr->sh_entsize; ++cnt)
@@ -1944,6 +1950,13 @@ handle_symtab (Ebl *ebl, Elf_Scn *scn, G
@@ -1945,6 +1951,13 @@ handle_symtab (Ebl *ebl, Elf_Scn *scn, G
error (EXIT_FAILURE, 0,
gettext ("cannot get section header string table index"));
@ -1246,7 +1246,7 @@
/* Now we can compute the number of entries in the section. */
unsigned int nsyms = data->d_size / (class == ELFCLASS32
? sizeof (Elf32_Sym)
@@ -1954,15 +1967,12 @@ handle_symtab (Ebl *ebl, Elf_Scn *scn, G
@@ -1955,15 +1968,12 @@ handle_symtab (Ebl *ebl, Elf_Scn *scn, G
nsyms),
(unsigned int) elf_ndxscn (scn),
elf_strptr (ebl->elf, shstrndx, shdr->sh_name), nsyms);
@ -1263,7 +1263,7 @@
fputs_unlocked (class == ELFCLASS32
? gettext ("\
@@ -2198,7 +2208,13 @@ handle_verneed (Ebl *ebl, Elf_Scn *scn,
@@ -2199,7 +2209,13 @@ handle_verneed (Ebl *ebl, Elf_Scn *scn,
error (EXIT_FAILURE, 0,
gettext ("cannot get section header string table index"));
@ -1278,7 +1278,7 @@
printf (ngettext ("\
\nVersion needs section [%2u] '%s' contains %d entry:\n Addr: %#0*" PRIx64 " Offset: %#08" PRIx64 " Link to section: [%2u] '%s'\n",
"\
@@ -2209,9 +2225,7 @@ handle_verneed (Ebl *ebl, Elf_Scn *scn,
@@ -2210,9 +2226,7 @@ handle_verneed (Ebl *ebl, Elf_Scn *scn,
class == ELFCLASS32 ? 10 : 18, shdr->sh_addr,
shdr->sh_offset,
(unsigned int) shdr->sh_link,
@ -1289,7 +1289,7 @@
unsigned int offset = 0;
for (int cnt = shdr->sh_info; --cnt >= 0; )
@@ -2264,8 +2278,14 @@ handle_verdef (Ebl *ebl, Elf_Scn *scn, G
@@ -2265,8 +2279,14 @@ handle_verdef (Ebl *ebl, Elf_Scn *scn, G
error (EXIT_FAILURE, 0,
gettext ("cannot get section header string table index"));
@ -1305,7 +1305,7 @@
printf (ngettext ("\
\nVersion definition section [%2u] '%s' contains %d entry:\n Addr: %#0*" PRIx64 " Offset: %#08" PRIx64 " Link to section: [%2u] '%s'\n",
"\
@@ -2277,9 +2297,7 @@ handle_verdef (Ebl *ebl, Elf_Scn *scn, G
@@ -2278,9 +2298,7 @@ handle_verdef (Ebl *ebl, Elf_Scn *scn, G
class == ELFCLASS32 ? 10 : 18, shdr->sh_addr,
shdr->sh_offset,
(unsigned int) shdr->sh_link,
@ -1316,7 +1316,7 @@
unsigned int offset = 0;
for (int cnt = shdr->sh_info; --cnt >= 0; )
@@ -2541,8 +2559,14 @@ handle_versym (Ebl *ebl, Elf_Scn *scn, G
@@ -2542,8 +2560,14 @@ handle_versym (Ebl *ebl, Elf_Scn *scn, G
filename = NULL;
}
@ -1332,7 +1332,7 @@
printf (ngettext ("\
\nVersion symbols section [%2u] '%s' contains %d entry:\n Addr: %#0*" PRIx64 " Offset: %#08" PRIx64 " Link to section: [%2u] '%s'",
"\
@@ -2554,9 +2578,7 @@ handle_versym (Ebl *ebl, Elf_Scn *scn, G
@@ -2555,9 +2579,7 @@ handle_versym (Ebl *ebl, Elf_Scn *scn, G
class == ELFCLASS32 ? 10 : 18, shdr->sh_addr,
shdr->sh_offset,
(unsigned int) shdr->sh_link,
@ -1343,7 +1343,7 @@
/* Now we can finally look at the actual contents of this section. */
for (unsigned int cnt = 0; cnt < shdr->sh_size / shdr->sh_entsize; ++cnt)
@@ -2608,7 +2630,17 @@ print_hash_info (Ebl *ebl, Elf_Scn *scn,
@@ -2609,7 +2631,17 @@ print_hash_info (Ebl *ebl, Elf_Scn *scn,
for (Elf32_Word cnt = 0; cnt < nbucket; ++cnt)
++counts[lengths[cnt]];
@ -1362,7 +1362,7 @@
printf (ngettext ("\
\nHistogram for bucket list length in section [%2u] '%s' (total of %d bucket):\n Addr: %#0*" PRIx64 " Offset: %#08" PRIx64 " Link to section: [%2u] '%s'\n",
"\
@@ -2621,9 +2653,7 @@ print_hash_info (Ebl *ebl, Elf_Scn *scn,
@@ -2622,9 +2654,7 @@ print_hash_info (Ebl *ebl, Elf_Scn *scn,
shdr->sh_addr,
shdr->sh_offset,
(unsigned int) shdr->sh_link,
@ -1373,7 +1373,7 @@
if (extrastr != NULL)
fputs (extrastr, stdout);
@@ -4265,6 +4295,16 @@ print_debug_aranges_section (Dwfl_Module
@@ -4312,6 +4342,16 @@ print_debug_aranges_section (Dwfl_Module
return;
}

View File

@ -1,4 +1,4 @@
%global eu_version 0.147
%global eu_version 0.148
%global eu_release 1
%if %{?_with_compat:1}%{!?_with_compat:0}
@ -317,6 +317,17 @@ rm -rf ${RPM_BUILD_ROOT}
%{_libdir}/libelf.a
%changelog
* Mon Jun 28 2010 Roland McGrath <roland@redhat.com> - 0.148-1
- Update to 0.148
- libdw: Accept DWARF 4 format: new functions dwarf_next_unit,
dwarf_offdie_types.
New functions dwarf_lineisa, dwarf_linediscriminator,
dwarf_lineop_index.
- libdwfl: Fixes in core-file handling, support cores from PIEs. (#588818)
When working from build IDs, don't open a named file
that mismatches.
- readelf: Handle DWARF 4 formats.
* Mon May 3 2010 Roland McGrath <roland@redhat.com> - 0.147-1
- Update to 0.147

View File

@ -1 +1 @@
ccb6bba1d96c096f1b5dbd34444554a3 elfutils-0.147.tar.bz2
a0bed1130135f17ad27533b0034dba8d elfutils-0.148.tar.bz2