disable neon on armv7hl, let aarch64 try with luajit again
This commit is contained in:
parent
c416770d4c
commit
b22639095b
16
efl-1.23.1-no-neon.patch
Normal file
16
efl-1.23.1-no-neon.patch
Normal file
@ -0,0 +1,16 @@
|
||||
diff -up efl-1.23.1/meson.build.noneon efl-1.23.1/meson.build
|
||||
--- efl-1.23.1/meson.build.noneon 2019-10-16 17:24:32.291167994 -0400
|
||||
+++ efl-1.23.1/meson.build 2019-10-16 17:24:51.001778207 -0400
|
||||
@@ -169,12 +169,6 @@ if get_option('native-arch-optimization'
|
||||
config_h.set10('BUILD_SSE3', true)
|
||||
native_arch_opt_c_args = [ '-msse3' ]
|
||||
message('x86 build - MMX + SSE3 enabled')
|
||||
- elif host_machine.cpu_family() == 'arm'
|
||||
- cpu_neon = true
|
||||
- config_h.set10('BUILD_NEON', true)
|
||||
- add_global_arguments('-mfpu=neon', language: 'c')
|
||||
- add_global_arguments('-ftree-vectorize', language: 'c')
|
||||
- message('ARM build - NEON enabled')
|
||||
elif host_machine.cpu_family() == 'aarch64'
|
||||
cpu_neon = true
|
||||
cpu_neon_intrinsics = true
|
9
efl.spec
9
efl.spec
@ -6,9 +6,9 @@
|
||||
%endif
|
||||
# PANIC: unprotected error in call to Lua API (bad light userdata pointer)
|
||||
# Disabling luajit for aarch64
|
||||
%ifarch aarch64
|
||||
%global has_luajit 0
|
||||
%endif
|
||||
# %%ifarch aarch64
|
||||
# %%global has_luajit 0
|
||||
# %%endif
|
||||
|
||||
# Look, you probably don't want this. scim is so 2012. ibus is the new hotness.
|
||||
# Enabling this means you'll almost certainly need to pass ECORE_IMF_MODULE=xim
|
||||
@ -36,6 +36,8 @@ Source0: http://download.enlightenment.org/rel/libs/efl/efl-%{version}.tar.xz
|
||||
Patch1: efl-1.17.1-old-nomodifier-in-drm_mode_fb_cmd2.patch
|
||||
# If luaL_reg is not defined, define it.
|
||||
Patch2: efl-1.23.1-luajitfix.patch
|
||||
# Our armv7 builds do not use neon
|
||||
Patch3: efl-1.23.1-no-neon.patch
|
||||
|
||||
%ifnarch s390 s390x
|
||||
BuildRequires: libunwind-devel
|
||||
@ -192,6 +194,7 @@ Development files for EFL.
|
||||
%patch1 -p1 -b .old
|
||||
%endif
|
||||
%patch2 -p1 -b .luajitfix
|
||||
%patch3 -p1 -b .noneon
|
||||
|
||||
# This is why hardcoding paths is bad.
|
||||
# sed -i -e 's|/opt/efl-%{version}/share/|%{_datadir}/|' \
|
||||
|
Loading…
Reference in New Issue
Block a user