Allow Lua 5.4

Fedora 33 has Lua 5.4.1

Signed-off-by: David Abdurachmanov <david.abdurachmanov@sifive.com>
This commit is contained in:
David Abdurachmanov 2020-12-04 16:31:38 +02:00
parent 8e007b21f9
commit 3008d6f019
Signed by: davidlt
GPG Key ID: 8B7F1DA0E2C9FDBB
2 changed files with 17 additions and 0 deletions

13
allow-lua-54.patch Normal file
View File

@ -0,0 +1,13 @@
diff --git a/meson.build b/meson.build
index 91ddfdc..a9d5262 100644
--- a/meson.build
+++ b/meson.build
@@ -256,7 +256,7 @@ ecore_evas_wayland_engine_include_dir = []
evas_static_list = []
luaold_interpreters = [
- ['lua', ['>=5.1.0', '<5.3.0']],
+ ['lua', ['>=5.1.0', '<5.5.0']],
['lua51', ['>=5.1.0', '<5.2.0']],
['lua-5.1', ['>=5.1.0', '<5.2.0']],
['lua5.1', ['>=5.1.0', '<5.2.0']],

View File

@ -46,6 +46,8 @@ Patch3: efl-1.25.0-no-neon.patch
# Upstream efl probably needs to rework how they use check in their C tests
Patch4: efl-1.25.0-check-fix.patch
Patch10: allow-lua-54.patch
%ifnarch s390 s390x riscv64
BuildRequires: libunwind-devel
%endif
@ -206,6 +208,8 @@ Development files for EFL.
%patch3 -p1 -b .noneon
%patch4 -p1 -b .checkfix
%patch10 -p1 -b .lua54
# This is why hardcoding paths is bad.
# sed -i -e 's|/opt/efl-%{version}/share/|%{_datadir}/|' \
# data/libeo.so.%{version}-gdb.py