This commit is contained in:
Tom Callaway 2020-09-22 16:02:32 -04:00
parent c02d0b6fd2
commit 1d1e47f1aa
5 changed files with 15 additions and 34 deletions

1
.gitignore vendored
View File

@ -31,3 +31,4 @@
/efl-1.23.3.tar.xz
/efl-1.24.2.tar.xz
/efl-1.24.3.tar.xz
/efl-1.25.0.tar.xz

View File

@ -1,16 +0,0 @@
diff -up efl-1.23.1/meson.build.noneon efl-1.23.1/meson.build
--- efl-1.23.1/meson.build.noneon 2019-10-16 17:24:32.291167994 -0400
+++ efl-1.23.1/meson.build 2019-10-16 17:24:51.001778207 -0400
@@ -169,12 +169,6 @@ if get_option('native-arch-optimization'
config_h.set10('BUILD_SSE3', true)
native_arch_opt_c_args = [ '-msse3' ]
message('x86 build - MMX + SSE3 enabled')
- elif host_machine.cpu_family() == 'arm'
- cpu_neon = true
- config_h.set10('BUILD_NEON', true)
- add_global_arguments('-mfpu=neon', language: 'c')
- add_global_arguments('-ftree-vectorize', language: 'c')
- message('ARM build - NEON enabled')
elif host_machine.cpu_family() == 'aarch64'
cpu_neon = true
cpu_neon_intrinsics = true

View File

@ -1,6 +1,6 @@
diff -up efl-1.24.3/src/tests/eldbus/eldbus_fake_server.c.checkfix efl-1.24.3/src/tests/eldbus/eldbus_fake_server.c
--- efl-1.24.3/src/tests/eldbus/eldbus_fake_server.c.checkfix 2020-08-05 11:47:06.340045747 -0400
+++ efl-1.24.3/src/tests/eldbus/eldbus_fake_server.c 2020-08-05 11:47:27.437985789 -0400
diff -up efl-1.25.0/src/tests/eldbus/eldbus_fake_server.c.checkfix efl-1.25.0/src/tests/eldbus/eldbus_fake_server.c
--- efl-1.25.0/src/tests/eldbus/eldbus_fake_server.c.checkfix 2020-09-22 13:54:51.000000000 -0400
+++ efl-1.25.0/src/tests/eldbus/eldbus_fake_server.c 2020-09-22 15:24:41.384828189 -0400
@@ -170,11 +170,11 @@ _fake_server_name_request_cb(void *data
{
const char *name, *text;
@ -15,12 +15,3 @@ diff -up efl-1.24.3/src/tests/eldbus/eldbus_fake_server.c.checkfix efl-1.24.3/sr
if (ELDBUS_NAME_REQUEST_REPLY_PRIMARY_OWNER != reply)
{
@@ -196,7 +196,7 @@ _fake_server_name_request_cb(void *data
}
snprintf(errmsg, sizeof(errmsg), "Failed to start fake server: %s (%u)",
errcode, reply);
- ck_abort_msg(errmsg);
+ fail(errmsg);
}
ecore_main_loop_quit();

View File

@ -25,8 +25,8 @@
Name: efl
Version: 1.24.3
Release: 4%{?dist}
Version: 1.25.0
Release: 1%{?dist}
Summary: Collection of Enlightenment libraries
License: BSD and LGPLv2+ and GPLv2 and zlib
URL: http://enlightenment.org/
@ -37,10 +37,10 @@ Source0: http://download.enlightenment.org/rel/libs/efl/efl-%{version}.tar.xz
# If luaL_reg is not defined, define it.
#Patch2: efl-1.23.1-luajitfix.patch
# Our armv7 builds do not use neon
Patch3: efl-1.23.1-no-neon.patch
Patch3: efl-1.25.0-no-neon.patch
# This is hacky, but it gets us building in rawhide again.
# Upstream efl probably needs to rework how they use check in their C tests
Patch4: efl-1.24.3-check-fix.patch
Patch4: efl-1.25.0-check-fix.patch
%ifnarch s390 s390x
BuildRequires: libunwind-devel
@ -62,6 +62,7 @@ BuildRequires: pkgconfig(poppler-cpp) >= 0.12
BuildRequires: pkgconfig(libspectre) pkgconfig(libraw)
BuildRequires: pkgconfig(librsvg-2.0) >= 2.14.0
BuildRequires: pkgconfig(cairo) >= 1.0.0
BuildRequires: pkgconfig(libavif)
%if %{with_scim}
BuildRequires: scim-devel
%endif
@ -227,8 +228,9 @@ Development files for EFL.
-Ddrm=true \
-Dinstall-eo-files=true \
%if 0%{?has_luajit}
-Dbindings=luajit,cxx \
-Dbindings=lua,cxx \
-Dlua-interpreter=luajit \
-Delua=true \
%else
-Dbindings=cxx \
-Dlua-interpreter=lua \
@ -564,6 +566,9 @@ find %{buildroot} -name '*.la' -exec rm -f {} ';'
%{_libdir}/libexactness*.so
%changelog
* Tue Sep 22 2020 Tom Callaway <spot@fedoraproject.org> - 1.25.0-1
- update to 1.25.0
* Wed Aug 5 2020 Tom Callaway <spot@fedoraproject.org> - 1.24.3-4
- fix build against check in rawhide

View File

@ -1 +1 @@
SHA512 (efl-1.24.3.tar.xz) = 3791955c588bc1b2ca55caa19dc0fb351c9f6c681791bfe76a435255edd55257c9c5ab2f16d0d91ec2d55113bd9d24d45c0f9026ae72d9f6afbddfd093975089
SHA512 (efl-1.25.0.tar.xz) = 1362e46399d4f22bd16abd5356fc57da0eb3d92dde36413cf671c1279ca6ff24ba91b358e2cff7158fa0dc9646ed83282f952e2a23e1fd92d3e37c03ba47cf1f